View Single Post
      06-08-2012, 06:20 AM   #41
340driver
Enlisted Member
Singapore
0

 
Drives: F30 335i Sport Highline
Join Date: Feb 2012
Location: Singapore


Posts: 38
iTrader: (0)

Problem after 50km

Well, my car (335i 8ATs) developed a pretty serious issue within 3 hrs of leaving the dealership... collected at 27kms and by 53kms as I pulled out of a gas station...

there was a clunk from the rear followed by (on the screen & HUD)

1. transmission failure
2. drivetrain fault
3. clutch overheat
4. transmission overheat
5. tyre press monitoring fault

Car went into limp home mode. so pulled over, shut off, waited a few minutes and started 'er up again (on the advise of BMW teleservice). All seemed good with the exception of "transmission overheat, leave engine running to cool and wait a few minutes". So waited the 5 minutes till everything reset and shut off and restarted car again. All seemed ok, so drove home. BMW tech came by and said couldn't fault anything, no leaks, no unusual noises and nothing on the diagnostics.

The next morning drove to the dealership to get the car thoroughly examined. When the techs drove it same faults as the previous evening started appearing. After a day, they reckon it's "corrupted software" and they're waiting for some sort of software/key or version from BMW AG to reload.

My first Bimmer and tell ya what, worst experience thus far... Had my car a grand total of 12hrs and it's back in the shop till Monday. Only remote upside is the dealership's been pretty good thus far 'cept they could only get me a loaner X1 s18i.

All this in Singapore too where the 335i costs the equivalent of USD $220,000!

Here's hoping the claimed software fix fixes things. Somehow, I'd rather the wheel vibration issue.....