F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics > Idrive random reboots
Post Reply
 
Thread Tools Search this Thread
      06-10-2012, 07:16 PM   #1
xugator
New Member
 
Drives: BMW
Join Date: Jun 2012
Location: Ohio

Posts: 13
iTrader: (0)

Idrive random reboots

It seems like every couple of days, the idrive in my brand new F30 will just randomly reboot. Each time it has happened, I have been listening to mp3s from a flash drive in the center console. When this happens, the song will stop playing and the idrive will go completely black. About 10 seconds later, the song will pick up right where it left off, the bmw splash screen will show and then it will be back to normal.

I have reformatted the flash drive and updated the software on the idrive to the current version and that did not help. I dont even know if its even related to the music. I also have my bluetooth phone connected which also I suppose could cause an issue

Anyone have any ideas other than just taking this to the dealer? I have a feeling this will be difficult for them to diagnose and in my experience, many times after a dealer service for something like this, new problems occur.

If anyone has any ideas I would appreciate them.
xugator is offline  
0
Reply With Quote
      06-11-2012, 06:23 AM   #2
micknugget
Second Lieutenant
 
Drives: 2012 F30 328 Red
Join Date: Apr 2012
Location: Detroit

Posts: 215
iTrader: (0)

Quote:
Originally Posted by xugator View Post
It seems like every couple of days, the idrive in my brand new F30 will just randomly reboot. Each time it has happened, I have been listening to mp3s from a flash drive in the center console. When this happens, the song will stop playing and the idrive will go completely black. About 10 seconds later, the song will pick up right where it left off, the bmw splash screen will show and then it will be back to normal.

I have reformatted the flash drive and updated the software on the idrive to the current version and that did not help. I dont even know if its even related to the music. I also have my bluetooth phone connected which also I suppose could cause an issue

Anyone have any ideas other than just taking this to the dealer? I have a feeling this will be difficult for them to diagnose and in my experience, many times after a dealer service for something like this, new problems occur.

If anyone has any ideas I would appreciate them.
I haven't had this issue but I think that this is one that you need to self diagnose as it would be hard for the dealer since it's intermittent. I would buy a new flash drive (they are cheap) and try that. If the issue continues then it has to be the iDrive or the phone. You can search the internet and see if ither peoiple are having problems with iDrive and your brand/model of phone. It's just going to take some detecive work ruling out one thing at a time.
__________________
2012 328i Base, Auto, Melbourne Red
micknugget is offline  
0
Reply With Quote
      06-11-2012, 07:04 AM   #3
aarslan
Private First Class
 
Drives: BMW 3.20i 2012
Join Date: Apr 2012
Location: Turkey

Posts: 173
iTrader: (0)

Same happens to me and I have talked about it in several other threads. I am almost sure that it is about the type of mp3 you are listening, but I haven't made a controlled experiment. It may also be relevant to the number of files in the folder where mp3's are being played. Shall be tried and seen.
aarslan is offline   Turkey
0
Reply With Quote
      06-11-2012, 09:30 AM   #4
LAnderson23
Lieutenant
 
Drives: 2012 328i MG Sportline
Join Date: May 2012
Location: Ohio

Posts: 506
iTrader: (0)

Quote:
Originally Posted by aarslan
Same happens to me and I have talked about it in several other threads. I am almost sure that it is about the type of mp3 you are listening, but I haven't made a controlled experiment. It may also be relevant to the number of files in the folder where mp3's are being played. Shall be tried and seen.
Is this only when listening via thumb drive, or does it affect iPod too?
LAnderson23 is offline   United_States
0
Reply With Quote
      06-11-2012, 09:43 AM   #5
aarslan
Private First Class
 
Drives: BMW 3.20i 2012
Join Date: Apr 2012
Location: Turkey

Posts: 173
iTrader: (0)

Quote:
Originally Posted by LAnderson23 View Post
Is this only when listening via thumb drive, or does it affect iPod too?
I don't know ipod, I don't have one.
aarslan is offline   Turkey
0
Reply With Quote
      06-11-2012, 09:43 AM   #6
The X Men
Lieutenant Colonel
 
Drives: 2012 535xi 2013 X3 35i
Join Date: Mar 2012
Location: MA

Posts: 1,937
iTrader: (0)

This use to happen on my Audi, I found out that it was related to a particular song, it must have been a corrupted file.
The X Men is offline  
0
Reply With Quote
      06-11-2012, 11:08 AM   #7
xugator
New Member
 
Drives: BMW
Join Date: Jun 2012
Location: Ohio

Posts: 13
iTrader: (0)

MP3

This has happened on several different songs so I dont think they are corrupt. Its the same flash drive I have used in my other car and have had no problems

Maybe it has to do with bluetooth on the phone. My phone is a Samsung Epic 4G

BMW doesnt have it on the supported list but it still works just fine

Definitely not easy to diagnose because it happens randomly
xugator is offline  
0
Reply With Quote
      06-11-2012, 01:14 PM   #8
HairTooLongToo
New Member
 
Drives: f30 328 sportline
Join Date: Apr 2012
Location: canada

Posts: 20
iTrader: (0)

It has happened to me once sp far. It was on the info screen with the radio on but muted (since you can't turn off music it seems). Screen just went blank and started back up with the logo and legal.
HairTooLongToo is offline  
0
Reply With Quote
      06-28-2012, 11:09 AM   #9
ozanyener
New Member
 
Drives: 2012 3.20i
Join Date: Jun 2012
Location: Istanbul

Posts: 5
iTrader: (0)

Hi xugator,

It's exactly what happens to me. I took my car to the dealer. They couldn't find any diagnostic record. I left the car. A couple of days later they said something very stupid : We found virus in your usb medium! They've formatted my usb stick and put 10 or 15 tracks instead. Yes, that much songs can be played. When I full my medium with other songs it started again. Nothing has solved!

PS 1 : In manual I saw that tracks should be max 256kbps. Most of my tracks are 320
kbps.
PS 2 : I didn't test enough my iphone but it seems ok.
PS 3 : I didn't use my car for two weeks. Today I've noticed that my radio stations are
all gone. And seat belt warning doesn't work.

I'm very UNHAPPY with my new car
ozanyener is offline  
0
Reply With Quote
      07-05-2012, 08:38 AM   #10
ozanyener
New Member
 
Drives: 2012 3.20i
Join Date: Jun 2012
Location: Istanbul

Posts: 5
iTrader: (0)

Quote:
Originally Posted by aarslan View Post
Same happens to me and I have talked about it in several other threads. I am almost sure that it is about the type of mp3 you are listening, but I haven't made a controlled experiment. It may also be relevant to the number of files in the folder where mp3's are being played. Shall be tried and seen.
Hi aarslan,
Which dealer have you taken your car? I've taken mine to Avcılar Borusan. They've surprised when they hear such a problem(idrive reboot caused by usb). They couldn't fix it so far...
ozanyener is offline  
0
Reply With Quote
      07-05-2012, 09:02 AM   #11
aarslan
Private First Class
 
Drives: BMW 3.20i 2012
Join Date: Apr 2012
Location: Turkey

Posts: 173
iTrader: (0)

Quote:
Originally Posted by ozanyener View Post
Hi aarslan,
Which dealer have you taken your car? I've taken mine to Avcılar Borusan. They've surprised when they hear such a problem(idrive reboot caused by usb). They couldn't fix it so far...
Ozan I am in Ankara. I take the car to Borusan Birlik.

These folks did not understand the technological thing I guess. This has nothing to do with a virus. After all those viruses in our memory sticks (even if they are there) are intended to affect Windows OS. This iDrive is an embedded system, probably not executing a Windows clone.

Anyways, I believe there are bugs in the mp3 player which is causing the reset. If you can systematically reproduce the problem under certain conditions, this shall somehow be communicated to BMW SW development crew - and I don't know if this is really possible.

Now, regarding the seat belt warning; my car doesn't have a seat belt warning for passenger and rear seats. Only for the driver seat activates this warning, and IMHO this is lame! When I check the EuroNCAP tests, 3 series has full points for seat belt alerts. Where are those alerts in my car?
aarslan is offline   Turkey
0
Reply With Quote
      07-07-2012, 12:34 PM   #12
Foreigner
New Member
 
Drives: F3x
Join Date: Mar 2012
Location: L.A.

Posts: 13
iTrader: (0)

I have seen issues in the past were big ID3 tags (several MB with some 20 pictures in them) have caused combox resets.
Do you have the CIC/Nav or the Entry Headunit w/ or w/o combox?
Have you tried using completely different MP3s and see if the same happens?
Foreigner is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:52 PM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST