F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Wheels and Tires > PICTURE: KW Variant 2 on my 335i
Extreme Power House
Post Reply
 
Thread Tools Search this Thread
      09-29-2012, 02:14 PM   #45
Rossifumi
Lieutenant Colonel
Rossifumi's Avatar
No_Country
35
Rep
1,667
Posts

 
Drives: Some BMW
Join Date: Feb 2007
Location: Sweden

iTrader: (0)

Quote:
Originally Posted by Tremolo View Post
I want out because, they are not worth $2k. Since i received the kit, I've had suspicions that KW totally half ass'd it on the coilovers for the F30, but dealing with the tech dept has all but confirmed it. Sure they might have the a suspension dyno and they have a great rep with previous kits and professional kits, but it's obvious that this particular kit is not up to snuff. That plus the way they treated me is enough to make me never use one of their products ever again in my life.
I understand that you are dissapointed. But isn't it a bit premature to base your opinion of the kit (handling and driving) on its current state with the wrong springs?

Or what did KW tell you to make you draw these conclusions?

It sucks though that they sent you the wrong parts and how they seam to have treated you.
Appreciate 0
      09-30-2012, 01:00 AM   #46
Number
Number's Avatar
32
Rep
1,235
Posts

 
Drives: ✚
Join Date: Feb 2012
Location: ✚ ✚

iTrader: (1)

Quote:
Originally Posted by Rossifumi View Post
I understand that you are dissapointed. But isn't it a bit premature to base your opinion of the kit (handling and driving) on its current state with the wrong springs?

Or what did KW tell you to make you draw these conclusions?

It sucks though that they sent you the wrong parts and how they seam to have treated you.
The only conclusion I've drawn is that I don't like the way KW treats their customers (or maybe just me). That is enough for me to leave the brand. The suspicion of half ass'n the coilovers for the F30 was confirmed by KW USA to me over the phone. He said that they got the word from straight from KW Germany. This was also confirmed by the shop I got the kit from (finally got a call back). They confirmed it with their KW rep.

Other reasons that lead me to believe it was half ass'd...

- The rear struts are painted black. Not stainless steel like the E90 kits.

- The perches for the rears are too shallow, and from an engineering standpoint, cheaply made.

- There is no allen key slot at the bottom of the coil to counter the perch turns... Even though they had these on other KW kits. To adjust the height, you have to unbolt the strut, and completely take out the control arm bolt. Then take out the spring and perch. Adjust the perch and very carefully seat the spring back in, and put it all back together. Hopefully, you didn't touch the perch wrong and cause it to spin while putting it back in. Other brands allow you to lock the perch heights.

- They made absolutely no attempt to make the damping of the rear struts easily adjustable. You have to take off the wheel, unbolt the strut to access the adjuster. Other companies have put the damping knob outside of the strut tower requiring you to only jack up the car and reach your hand in.

I DO know that KW is a reputable brand. They make awesome kits for cars. But anyone who compares this F30 kit with previous BMW kits will immediately notice the difference in build quality and engineering. And I've made no attempt to steer people away from KW. I've only documented my experience. But I would hope that people won't buy this kit for their F30s until they issue a fix... that is, unless you like rolling slammed. Which is not necessarily a bad thing... just not for me.
Appreciate 0
      09-30-2012, 03:04 AM   #47
Rossifumi
Lieutenant Colonel
Rossifumi's Avatar
No_Country
35
Rep
1,667
Posts

 
Drives: Some BMW
Join Date: Feb 2007
Location: Sweden

iTrader: (0)

Thanks for clarifying. I was thinking about the KW or the Bilsteins, so maybe it's just best to stick with the Bilsteins.
Appreciate 0
      09-30-2012, 07:09 AM   #48
PGT
Second Lieutenant
4
Rep
281
Posts

 
Drives: 328i M-Sport in Estoril Blue
Join Date: Sep 2012
Location: Leesburg, VA

iTrader: (0)

many companies beta test on paying customers. Its wrong.
__________________
| '13 328i M Sport - Estoril Blue | '12 300C SRT8 | '12 Wrangler Rubi Unlimited - COD MW3 Edition|
Appreciate 0
      10-02-2012, 12:17 AM   #49
RollingLower42
Lieutenant
RollingLower42's Avatar
11
Rep
541
Posts

 
Drives: 2012 BMW 335I
Join Date: May 2012
Location: Los Angeles

iTrader: (0)

Garage List
I recently got a set of KW V2's this past weekend through LTMW.

Thanks to LTMW, Long, Phillip, Long's cousin (I think) who did the install, and everyone else that works there and helps out.

I am not sure if this is going to work or not; I am trying to upload 4 pictures for everyone to see how it looks. Just cell phone camera, nothing fancy. Definitely is low, but it rides really smooth and straight I have to say.
Attached Images
    
Appreciate 0
      10-02-2012, 12:28 AM   #50
tiltmode43
I plead the 5th.
tiltmode43's Avatar
United_States
27
Rep
645
Posts

 
Drives: AW F30 328i & IB E85 Z4M
Join Date: Oct 2009
Location: SoCal

iTrader: (7)

Send a message via AIM to tiltmode43
Damn Tremolo, serious bummer. I would not have expected this from KW! Sounds like a crappy situation in which there is no real happy ending :/

Drop me a PM if you decide to sell. I would be interested in playing around with some springs I've got to possibly salvage these.
__________________
Appreciate 0
      10-02-2012, 06:27 AM   #51
remmib
General
remmib's Avatar
Norway
356
Rep
26,266
Posts

 
Drives: 2013 F10 520d M-Sport
Join Date: Feb 2006
Location: Norway

iTrader: (0)

Quote:
Originally Posted by RollingHard28 View Post
I recently got a set of KW V2's this past weekend through LTMW.

Thanks to LTMW, Long, Phillip, Long's cousin (I think) who did the install, and everyone else that works there and helps out.

I am not sure if this is going to work or not; I am trying to upload 4 pictures for everyone to see how it looks. Just cell phone camera, nothing fancy. Definitely is low, but it rides really smooth and straight I have to say.
Looks great.

Do you know if you got the wrong (too short) springs as Tremolo?
__________________

F10 520d M-Sport Alpine White | HRE P43SC 20x9+20x11 | Michelin PSS 255/35+295/30 | KW V3 Coilover | M5 Front Sway Bar + M550d Rear Sway Bar | 3D Design Front Lip | BMW M Performance CF Spoiler | BMW M Performance Diffuser | BMW M Performance Black Grills | BMW M Performance Pedals |
Appreciate 0
      10-02-2012, 04:51 PM   #52
RollingLower42
Lieutenant
RollingLower42's Avatar
11
Rep
541
Posts

 
Drives: 2012 BMW 335I
Join Date: May 2012
Location: Los Angeles

iTrader: (0)

Garage List
Quote:
Originally Posted by remmib View Post
Looks great.

Do you know if you got the wrong (too short) springs as Tremolo?
I am not 100% sure, but I do know Tremolo was talking about his backs as being too low and a problem..It still is low but I do not have any clearance issues in the back or rubbing at all, so I am guessing not. I do have to go real slow over speed bumps, dips, driveways and what not, if i take it too fast I will scrape, but for how low it is now, it still drives really smooth.

The fronts seem like the wheel wells are pretty close to the tire, but there is no real major rubbing. I did kind of feel what I thought was a small grinding feel when I turn my wheel to the left or right real hard. I took it back to LTMW and the one mechanic didn't think there was anything wrong, although the thing I thought was grinding, he believes has something to do with the steering column..But if you look at all my tires, everything is in tact so I think I am fine..
Appreciate 0
      10-02-2012, 09:08 PM   #53
Rossifumi
Lieutenant Colonel
Rossifumi's Avatar
No_Country
35
Rep
1,667
Posts

 
Drives: Some BMW
Join Date: Feb 2007
Location: Sweden

iTrader: (0)

Quote:
Originally Posted by RollingHard28 View Post
I am not 100% sure, but I do know Tremolo was talking about his backs as being too low and a problem..It still is low but I do not have any clearance issues in the back or rubbing at all, so I am guessing not. I do have to go real slow over speed bumps, dips, driveways and what not, if i take it too fast I will scrape, but for how low it is now, it still drives really smooth.

The fronts seem like the wheel wells are pretty close to the tire, but there is no real major rubbing. I did kind of feel what I thought was a small grinding feel when I turn my wheel to the left or right real hard. I took it back to LTMW and the one mechanic didn't think there was anything wrong, although the thing I thought was grinding, he believes has something to do with the steering column..But if you look at all my tires, everything is in tact so I think I am fine..
If that is the highest setting you have on the pictures above I'm guessing you have the wrong springs too. That car would be undrivable over here.
Appreciate 0
      10-02-2012, 10:39 PM   #54
RollingLower42
Lieutenant
RollingLower42's Avatar
11
Rep
541
Posts

 
Drives: 2012 BMW 335I
Join Date: May 2012
Location: Los Angeles

iTrader: (0)

Garage List
Quote:
Originally Posted by Tremolo View Post
UPDATE: Got a call from KW. They confirmed the springs are wrong. Part number is stamped correctly but they QC'd the wrong spring. This applies to all F30 KW coilovers. No idea when a fix is coming.

I want out of these coilovers due to it being a defect. But the shop won't call me back. I'm going to give them one more try before outting them here. I'm not a happy camper.
Hey Tremolo,

Any updates from KW? I figure since you said it applies to all F30 KW coilovers, then I have the same short springs. Let m know what you find out, as I will need that fix/upgrade when it as available as well.
Appreciate 0
      10-02-2012, 11:51 PM   #55
Number
Number's Avatar
32
Rep
1,235
Posts

 
Drives: ✚
Join Date: Feb 2012
Location: ✚ ✚

iTrader: (1)

Quote:
Originally Posted by RollingHard28 View Post
Hey Tremolo,

Any updates from KW? I figure since you said it applies to all F30 KW coilovers, then I have the same short springs. Let m know what you find out, as I will need that fix/upgrade when it as available as well.
According to KW, you do indeed have the short springs. Try jacking up one side of your front wheel. No need to take off the wheel. Just check the perch and how high it is. It will probably at the top or close to it. I'm sure your ride is fine for now. But after a week or two, it'll settle and you will immediately notice how much worse the ride will be. Some people don't mind the ride quality being diminished, but I'm a real stickler for ride quality.

The original pic in my post is the when the perch was about 3/4 inch from the top. However, if you read on, I raised it all the way up. This raised the car about 1/2 an inch. The ride quality was really good. But after a week, the front settled again to the same height as the original pic. That's how short/soft the springs are.

My car right now is about the height of your car. The ride quality isn't unbearable and it honestly looks pretty nice. But the fact that it's the highest it can go is just not right. It is not the product they advertised and it's not what I paid for. Ironically, they would deny you warranty on your shocks since it's too low.

KW has a good rep. But I judge a company by how they handle the situation when they have a "miss". Some research will show that most fans of KW probably had no problems with their KW products. But read about the bad experiences. They echo the experience I had.
Appreciate 0
      10-03-2012, 04:25 PM   #56
RollingLower42
Lieutenant
RollingLower42's Avatar
11
Rep
541
Posts

 
Drives: 2012 BMW 335I
Join Date: May 2012
Location: Los Angeles

iTrader: (0)

Garage List
Quote:
Originally Posted by Tremolo View Post
According to KW, you do indeed have the short springs. Try jacking up one side of your front wheel. No need to take off the wheel. Just check the perch and how high it is. It will probably at the top or close to it. I'm sure your ride is fine for now. But after a week or two, it'll settle and you will immediately notice how much worse the ride will be. Some people don't mind the ride quality being diminished, but I'm a real stickler for ride quality.

The original pic in my post is the when the perch was about 3/4 inch from the top. However, if you read on, I raised it all the way up. This raised the car about 1/2 an inch. The ride quality was really good. But after a week, the front settled again to the same height as the original pic. That's how short/soft the springs are.

My car right now is about the height of your car. The ride quality isn't unbearable and it honestly looks pretty nice. But the fact that it's the highest it can go is just not right. It is not the product they advertised and it's not what I paid for. Ironically, they would deny you warranty on your shocks since it's too low.

KW has a good rep. But I judge a company by how they handle the situation when they have a "miss". Some research will show that most fans of KW probably had no problems with their KW products. But read about the bad experiences. They echo the experience I had.
Hi Again tremolo,

Another question for you; since you have had the KW's on, has your check engine light come on for any reason?

I woke up today, and noticed my check engine light was on. I took it to BMW since there is one right near where I live and they didn't think it was a big deal and told me to come back in a couple of days if it doesn't go away. The guy didn't think the new c/o system would have anything to do with it.

I mentioned that a day before, I got a message on my car telling me to "fasten the gas cap", so I went, it already was fastened, unfastened it, then restarted the car and it was good and cleared.

BMW worker thinks that maybe my wheel bumped the wheel well in the back and triggered the gas cap message like that, and thinks it may clear in a couple of days. I am probably going to take it back to LTMW after work and have them check that code out..

Also, tremolo, have you noticed or felt any grinding at all in the front? I feel a slight grind once and awhile while turning, especially on dips; although LTMW said after looking it all again, everything was clearing with no rubbing, but thought maybe it was something to do with my steering column, have you had anything similar?
Appreciate 0
      10-03-2012, 05:13 PM   #57
Number
Number's Avatar
32
Rep
1,235
Posts

 
Drives: ✚
Join Date: Feb 2012
Location: ✚ ✚

iTrader: (1)

Quote:
Originally Posted by RollingHard28 View Post
Hi Again tremolo,

Another question for you; since you have had the KW's on, has your check engine light come on for any reason?

I woke up today, and noticed my check engine light was on. I took it to BMW since there is one right near where I live and they didn't think it was a big deal and told me to come back in a couple of days if it doesn't go away. The guy didn't think the new c/o system would have anything to do with it.

I mentioned that a day before, I got a message on my car telling me to "fasten the gas cap", so I went, it already was fastened, unfastened it, then restarted the car and it was good and cleared.

BMW worker thinks that maybe my wheel bumped the wheel well in the back and triggered the gas cap message like that, and thinks it may clear in a couple of days. I am probably going to take it back to LTMW after work and have them check that code out..

Also, tremolo, have you noticed or felt any grinding at all in the front? I feel a slight grind once and awhile while turning, especially on dips; although LTMW said after looking it all again, everything was clearing with no rubbing, but thought maybe it was something to do with my steering column, have you had anything similar?
I haven't had any of the problems you've mentioned. I did rub my tire on the fender once while going up my driveway at an angle. My wheel was turned almost all the way. It wasn't a bad rub. It only rubbed because I hit the driveway a little bit fast and the car bounced a tiny bit. My iDrive said my oil is at Min... but I think that's different from the check engine light. I've had no issues with the gas cap. My brakes grind and squeal, but I dont' think that has anything to do with the suspension.
Appreciate 0
      10-03-2012, 11:31 PM   #58
RollingLower42
Lieutenant
RollingLower42's Avatar
11
Rep
541
Posts

 
Drives: 2012 BMW 335I
Join Date: May 2012
Location: Los Angeles

iTrader: (0)

Garage List
Quote:
Originally Posted by Tremolo View Post
I haven't had any of the problems you've mentioned. I did rub my tire on the fender once while going up my driveway at an angle. My wheel was turned almost all the way. It wasn't a bad rub. It only rubbed because I hit the driveway a little bit fast and the car bounced a tiny bit. My iDrive said my oil is at Min... but I think that's different from the check engine light. I've had no issues with the gas cap. My brakes grind and squeal, but I dont' think that has anything to do with the suspension.
Thanks for the info. Went to LTMW and they confirmed the code had to do with the gas cap. He reset it and it is gone now.

Do you find it harder to stop now that you have it lower? Seems to me like the breaks are working harder than before when I come to a stop..
Appreciate 0
      10-04-2012, 12:49 AM   #59
Number
Number's Avatar
32
Rep
1,235
Posts

 
Drives: ✚
Join Date: Feb 2012
Location: ✚ ✚

iTrader: (1)

Quote:
Originally Posted by RollingHard28 View Post
Thanks for the info. Went to LTMW and they confirmed the code had to do with the gas cap. He reset it and it is gone now.

Do you find it harder to stop now that you have it lower? Seems to me like the breaks are working harder than before when I come to a stop..
No. My brakes work fine. Just noisy. I think there's some debris stuck in between the pad and rotor on my front brake. It's starting to make a groove on the rotor.
Appreciate 0
      10-04-2012, 02:16 AM   #60
AWMSPORT
1ST CLASS AWMSPORT
AWMSPORT's Avatar
United_States
10
Rep
748
Posts

 
Drives: 13' 328 MSPORT
Join Date: Sep 2006
Location: South Fla

iTrader: (0)

Garage List
i like the drop. Front a tad to low ...but Was hoping you can help! I am going to be getting a 328 Msport. I want to get the Super sport springs but don't know if it will be to low in the front. I called H n R today and he told me that they just came out with an app for Msport, that puts the front to 1.6' and the rear to 1". Does anyone have any pics or some ways i can figure this out??

Thanks in advance.
__________________
'13 328i MSport, AW, Black Dakota leather, Premium Pkg, xenons, ///M Perf, side skirts,Front Lip, Fully coded, CF roundels, Matt Black Grillz, Painted reflectors (front & rear) Smoked tail lights, Plazma l.E.D White PY27W front turn signal,trunk spoiler, Matt Black roof, 8K D1S HID,Custom Exhaust,!
Soon:
JB4,DP,H&R sports,rear diff,!
Appreciate 0
      10-11-2012, 01:46 AM   #61
RollingLower42
Lieutenant
RollingLower42's Avatar
11
Rep
541
Posts

 
Drives: 2012 BMW 335I
Join Date: May 2012
Location: Los Angeles

iTrader: (0)

Garage List
So it's been 2 weeks almost now, and it definitely settled real low. I think I am going to go get it lifted a little bit Saturday morning. But I do have to say again, for as low as it is, it is still a amazing smooth ride (except over speedbumps and driveways). But is Tits besides that
Attached Images
  
Appreciate 0
      10-11-2012, 10:25 PM   #62
Number
Number's Avatar
32
Rep
1,235
Posts

 
Drives: ✚
Join Date: Feb 2012
Location: ✚ ✚

iTrader: (1)

Update for me. There is none. After being promised a solution and a call with directions on how they're going to make it right, there has been no response. I even called to check on the status of the fix. The tech supervisor went on vacation and didn't talk to anyone about it. The other tech guys can't do anything because they have zero decision making powers. They said they will contact the supervisor on vacation because he should still read his emails. However, no word since then. That was a week ago.

Rollinghard28: I'm glad you like the ride quality. Maybe you're more forgiving than I am. But in my opinion, the ride is literally crap. There is no way anyone can take a bumpy corner confidently with this ride quality. The other night I hit what should've been a mild bump and it rattled the car so badly it felt like the car's bones broke (figurative). The noise was so loud I thought my rims were dented. now I have these popping and pinging sounds when I drive.
Appreciate 0
      10-11-2012, 10:59 PM   #63
Jackson743
Lieutenant
9
Rep
475
Posts

 
Drives: 335i M-Sport/EBII/ED 12/5
Join Date: Aug 2012
Location: Los Angeles, CA

iTrader: (0)

I just ordered my 335i M-Sport with adaptive suspension. At this point, I'll be putting on the 19" M355 replicas. Clearly, I won't be using KW's if I want a very modest drop. I'm shocked they just didn't refund you.
Appreciate 0
      10-14-2012, 09:30 PM   #64
ocso1606
Lieutenant
ocso1606's Avatar
United_States
13
Rep
531
Posts

 
Drives: 2013 335i M
Join Date: Aug 2012
Location: Syracuse,NY

iTrader: (0)

Garage List
2007 BMW 525xi  [0.00]
2010 Volvo  [0.00]
2013 BMW 335i M-Sport  [0.00]
doesnt it bottom out with it so low
__________________
2013 335i M-Sport, Alpine White, Red Coral Leather, 6SP M/T, 403m 19" wheels, M- Suspension, CWP, M-Performance Exhaust, M-Performance Power Pack!
Appreciate 0
      10-15-2012, 06:20 AM   #65
F555
Captain
F555's Avatar
Indonesia
12
Rep
653
Posts

 
Drives: F30 - 335i
Join Date: Jul 2012
Location: Indonesia

iTrader: (0)

Was thinking of getting KW ver2 , but after all u had been through, might have to wait till KW solve this problem over time.
Appreciate 0
      10-15-2012, 12:06 PM   #66
MMOTION
Lieutenant Colonel
MMOTION's Avatar
24
Rep
1,723
Posts

 
Drives: like you'll never drive again
Join Date: Feb 2009
Location: uptown

iTrader: (21)

Really sorry to hear about your situation with the KW coilovers. Looks like we'll have to wait until a better solution is available for F30's.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:17 AM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST