F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > F30 DIYs and Coding Discussions > BMW F30 3 Series Coding DIY - Code Auto Start Stop, DVD, Folding Mirrors, Etc.
European Auto Source
Post Reply
 
Thread Tools Search this Thread
      10-26-2012, 01:26 PM   #1145
rolandleth
Enlisted Member
 
Drives: F30 328i
Join Date: Sep 2012
Location: Bucharest

Posts: 45
iTrader: (0)

Quote:
Originally Posted by shawnsheridan View Post
Yes, you will know because after the dealer update, the ECU CAFD file name will be newer.
Right. Thanks! I will come back with an error report when trying to "Code" the FEM_BODY module.
rolandleth is offline  
0
Reply With Quote
      10-26-2012, 01:55 PM   #1146
demge01
Private First Class
 
demge01's Avatar
 
Drives: F30 320ed
Join Date: May 2012
Location: United Kingdom

Posts: 145
iTrader: (0)

Garage List
MDRIVE

Today I switched on the MDRIVE to aktiv in the HU folders.
Got rather excited at first as it appears that you can customise:
DSC (off, DTC, DSC)
STEERING (comfort, sport, sport+)
THROTTLE (comfort, sport, sport+)
You can have any combination of the above.
However I couldn't get any changes to register.
Anyone?
demge01 is offline  
0
Reply With Quote
      10-26-2012, 02:27 PM   #1147
rolandleth
Enlisted Member
 
Drives: F30 328i
Join Date: Sep 2012
Location: Bucharest

Posts: 45
iTrader: (0)

That's what it says in the cheat sheet, as well, you shouldn't have gotten excited, hehe:
Shows M Drive menu in iDrive, cannot seem to select settings, needs testing.

Would be nice indeed if anyone tested it further, though.
rolandleth is offline  
0
Reply With Quote
      10-26-2012, 02:48 PM   #1148
demge01
Private First Class
 
demge01's Avatar
 
Drives: F30 320ed
Join Date: May 2012
Location: United Kingdom

Posts: 145
iTrader: (0)

Garage List
Quote:
Originally Posted by rolandleth
That's what it says in the cheat sheet, as well, you shouldn't have gotten excited, hehe:
Shows M Drive menu in iDrive, cannot seem to select settings, needs testing.

Would be nice indeed if anyone tested it further, though.
Ah yes I see it now.
demge01 is offline  
0
Reply With Quote
      10-26-2012, 05:25 PM   #1149
rolandleth
Enlisted Member
 
Drives: F30 328i
Join Date: Sep 2012
Location: Bucharest

Posts: 45
iTrader: (0)

Update for high beam assistant:

The F10 code for auto highbeam assistant is FLA_AUTO_AKTIV in the FRM module.

The F30 has no FRM module, so I searched in the FEM_BODY for "FLA_" and I found FLA_AKTIVIERUNG, which has Kommentar: "Fernlicht Assistent:0 - FLA (oder KAFAS) nicht verbaut1 - FLA (oder KAFAS) verbaut; Aktivierung bei Lichtschalter in Stellung A (Auto) moglish 2 - FLA (oder KAFAS) verbaut; Aktivierung bei Lichtschalter in Stellung A (Auto) ODER 2 moglich"
There are 3 values for it: LDS_IN_A_oder_2, nicht_aktiv, LDS_in_A (was the default one, I changed it to oder_2 one).

Then I went in the HU_CIC and found HIGH_BEAM_ASSISTANT (Kommentar: Light Settings High Beam Assistant (Fernlichtassistent) and changed it to aktiv. Now i have a checkbox under setings-lights named Highbeam Assistant.

Still no high beam assistant auto start, the checkbox does nothing. Anyone that has more knowledge than me can give his oppinion on my findings, please?
rolandleth is offline  
0
Reply With Quote
      10-26-2012, 08:31 PM   #1150
sudyawi
Registered
 
Drives: 320i Luxury Line
Join Date: Oct 2012
Location: Jakarta Indonesia

Posts: 4
iTrader: (0)

link request

Greetings from Indonesia!!
I was wondering if anyone would be kind enough to share the download links to e-sys software and data files? Since i am nubie with zero post, had to trouble u by sending them to my email address, sudyawi@gmail.com

Many thanks and hope i can contribute more in the future.

Awi
sudyawi is offline  
0
Reply With Quote
      10-26-2012, 08:48 PM   #1151
shawnsheridan
Brigadier General
 
shawnsheridan's Avatar
 
Drives: 2011 535i M-Sport
Join Date: Feb 2010
Location: Houston, TX

Posts: 4,248
iTrader: (0)

Garage List
Quote:
Originally Posted by sudyawi View Post
Greetings from Indonesia!!
I was wondering if anyone would be kind enough to share the download links to e-sys software and data files? Since i am nubie with zero post, had to trouble u by sending them to my email address, sudyawi@gmail.com

Many thanks and hope i can contribute more in the future.

Awi
PM Sent.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
shawnsheridan is online now   United_States
0
Reply With Quote
      10-26-2012, 11:56 PM   #1152
clarence
Lieutenant Colonel
 
Drives: F30 328i M-Sport
Join Date: Mar 2006
Location: Hong Kong

Posts: 1,544
iTrader: (0)

Quote:
Originally Posted by rolandleth View Post
Still no high beam assistant auto start, the checkbox does nothing. Anyone that has more knowledge than me can give his oppinion on my findings, please?
I think it requires additonal hardware which only exist if u spec with adaptive bi-xenons.
clarence is offline  
0
Reply With Quote
      10-26-2012, 11:58 PM   #1153
clarence
Lieutenant Colonel
 
Drives: F30 328i M-Sport
Join Date: Mar 2006
Location: Hong Kong

Posts: 1,544
iTrader: (0)

Quote:
Originally Posted by demge01 View Post
Today I switched on the MDRIVE to aktiv in the HU folders.
Maybe it only works on M-cars.
clarence is offline  
0
Reply With Quote
      10-27-2012, 12:23 AM   #1154
demge01
Private First Class
 
demge01's Avatar
 
Drives: F30 320ed
Join Date: May 2012
Location: United Kingdom

Posts: 145
iTrader: (0)

Garage List
Quote:
Originally Posted by clarence
Quote:
Originally Posted by demge01 View Post
Today I switched on the MDRIVE to aktiv in the HU folders.
Maybe it only works on M-cars.
Yes maybe. However the different drive modes (comfort, sport etc) are only really selecting predetermined settings of what is possible to customise in MDRIVE.
I can't see it being a hardware thing.
demge01 is offline  
0
Reply With Quote
      10-27-2012, 02:04 AM   #1155
mokwai
Registered
 
Drives: 116
Join Date: Aug 2012
Location: Singapore

Posts: 2
iTrader: (0)

Thanks shawn for the email.
mokwai is offline  
0
Reply With Quote
      10-27-2012, 04:47 AM   #1156
rolandleth
Enlisted Member
 
Drives: F30 328i
Join Date: Sep 2012
Location: Bucharest

Posts: 45
iTrader: (0)

Quote:
Originally Posted by clarence
I think it requires additonal hardware which only exist if u spec with adaptive bi-xenons.
And I do have adaptive bixenons. So that's not it
I DO have high beam assistant, I just want it to auto start when starting the car.
rolandleth is offline  
0
Reply With Quote
      10-27-2012, 08:49 AM   #1157
shawnsheridan
Brigadier General
 
shawnsheridan's Avatar
 
Drives: 2011 535i M-Sport
Join Date: Feb 2010
Location: Houston, TX

Posts: 4,248
iTrader: (0)

Garage List
Quote:
Originally Posted by rolandleth View Post
And I do have adaptive bixenons. So that's not it
I DO have high beam assistant, I just want it to auto start when starting the car.
On the F10's, with older firmware, FRM/3050/FLA_AUTO_AKTIV could be set to "aktiv"; which worked perfectly.

For reasons unknown, on newer firmware it was changed from "aktiv" to "automatik".

With "automatik", FLA automatically turns on when switching on the lights (manually) or if they automatically come on. However, High Beam Assistant is not active when starting the car in the dark (i.e. when the lights automatically turn on with the engine).

Maybe on the F30 it can still be set to "aktiv".
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
shawnsheridan is online now   United_States
0
Reply With Quote
      10-27-2012, 11:33 AM   #1158
rolandleth
Enlisted Member
 
Drives: F30 328i
Join Date: Sep 2012
Location: Bucharest

Posts: 45
iTrader: (0)

Quote:
With "automatik", FLA automatically turns on when switching on the lights (manually) or if they automatically come on.
Well, you're right; this is what i want as well, I didn't express myself properly, sorry. Of course the assistant won't start during daylight and with dipped beams off, only when I manually turn them on (or they auto start by keeping lights on (A)). However, this does not happen after changing the above FLA_AKTIVIERUNG.

On the F30 there is no FRM module, nor a FLA_AUTO_AKTIV anywhere else, just the
FEM_BODY/3060(i think?)/FLA_AKTIVIERUNG which only has LDS_IN_A_oder_2, nicht_aktiv, LDS_in_A as values (I wrote a few posts above its Kommentar which I can not really translate).

Quote:
However, High Beam Assistant is not active when starting the car in the dark (i.e. when the lights automatically turn on with the engine).
Aww, that's plain silly, if the car can detect the dipped have to stay on because it's dark, it should be possible to auto turn HBA on as well. Yea, I'm lazy, haha

Last edited by rolandleth; 10-27-2012 at 11:43 AM.
rolandleth is offline  
0
Reply With Quote
      10-27-2012, 01:21 PM   #1159
martinf79
Captain
 
martinf79's Avatar
 
Drives: F30 335i M Sport
Join Date: May 2012
Location: Toronto, Canada

Posts: 640
iTrader: (0)

Sorry .. finally decided I would give this "coding" thing a try.

I disabled my wifi connection - I then connected the cable to my ethernet port, then to the car (car off), nothing, couldn't get a connection.

Tried again (this time w/ the car on). Still nothing.

Tried to run "ZGW_Search.exe". Get an error (given I don't have a connection).

Any thoughts??? What am I doing wrong?
__________________

2013 335i ///M-Sport | MPPK ON ORDER | AW | BD Leather | 19 M3 ZCP Wheels | M-Sport Brakes | Adaptive M-Suspension | Variable Sport Steering | Premium Package | Enhanced Bluetooth | Sirius | BMW Apps | Heads Up Display | Speed Limit Info | M Performance Grill | Front/Rear Painted Reflectors | Coded
martinf79 is offline  
0
Reply With Quote
      10-27-2012, 01:24 PM   #1160
shawnsheridan
Brigadier General
 
shawnsheridan's Avatar
 
Drives: 2011 535i M-Sport
Join Date: Feb 2010
Location: Houston, TX

Posts: 4,248
iTrader: (0)

Garage List
Quote:
Originally Posted by martinf79 View Post
Sorry .. finally decided I would give this "coding" thing a try.

I disabled my wifi connection - I then connected the cable to my ethernet port, then to the car (car off), nothing, couldn't get a connection.

Tried again (this time w/ the car on). Still nothing.

Tried to run "ZGW_Search.exe". Get an error (given I don't have a connection).

Any thoughts??? What am I doing wrong?
Is the car ignition turned on?

Where did you get your ENET cable?

Is you LAN Adapter settings set for Auto IP etc.?

What is the laptop OS?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
shawnsheridan is online now   United_States
0
Reply With Quote
      10-27-2012, 01:30 PM   #1161
martinf79
Captain
 
martinf79's Avatar
 
Drives: F30 335i M Sport
Join Date: May 2012
Location: Toronto, Canada

Posts: 640
iTrader: (0)

Quote:
Originally Posted by shawnsheridan View Post
Is the car ignition turned on?

Where did you get your ENET cable?

Is you LAN Adapter settings set for Auto IP etc.?

What is the laptop OS?
Ignition is on (actually tried w/ car off, ignition on, car on)

I bought the cable off of another forum user (Raspartan)

Not sure how to check LAN Adaper settings? Please advise and I will check.

Running Windows 7
__________________

2013 335i ///M-Sport | MPPK ON ORDER | AW | BD Leather | 19 M3 ZCP Wheels | M-Sport Brakes | Adaptive M-Suspension | Variable Sport Steering | Premium Package | Enhanced Bluetooth | Sirius | BMW Apps | Heads Up Display | Speed Limit Info | M Performance Grill | Front/Rear Painted Reflectors | Coded

Last edited by martinf79; 10-27-2012 at 01:35 PM.
martinf79 is offline  
0
Reply With Quote
      10-27-2012, 01:37 PM   #1162
shawnsheridan
Brigadier General
 
shawnsheridan's Avatar
 
Drives: 2011 535i M-Sport
Join Date: Feb 2010
Location: Houston, TX

Posts: 4,248
iTrader: (0)

Garage List
Quote:
Originally Posted by martinf79 View Post
Ignition is on (actually tried w/ car off, ignition on, car on)

I bought the cable off of another forum user.

Not sure how to check LAN Adaper settings? Please advise and I will check.

Running Windows 7
Change TCP/IP settings:

http://windows.microsoft.com/en-US/w...CP-IP-settings

Make sure IP and DNS are set to Auto.

Win7 32-Bit or 64-Bit?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
shawnsheridan is online now   United_States
0
Reply With Quote
      10-27-2012, 01:43 PM   #1163
martinf79
Captain
 
martinf79's Avatar
 
Drives: F30 335i M Sport
Join Date: May 2012
Location: Toronto, Canada

Posts: 640
iTrader: (0)

Quote:
Originally Posted by shawnsheridan View Post
Change TCP/IP settings:

http://windows.microsoft.com/en-US/w...CP-IP-settings

Make sure IP and DNS are set to Auto.

Win7 32-Bit or 64-Bit?
Both set to auto.

64 bit
__________________

2013 335i ///M-Sport | MPPK ON ORDER | AW | BD Leather | 19 M3 ZCP Wheels | M-Sport Brakes | Adaptive M-Suspension | Variable Sport Steering | Premium Package | Enhanced Bluetooth | Sirius | BMW Apps | Heads Up Display | Speed Limit Info | M Performance Grill | Front/Rear Painted Reflectors | Coded
martinf79 is offline  
0
Reply With Quote
      10-27-2012, 01:47 PM   #1164
shawnsheridan
Brigadier General
 
shawnsheridan's Avatar
 
Drives: 2011 535i M-Sport
Join Date: Feb 2010
Location: Houston, TX

Posts: 4,248
iTrader: (0)

Garage List
Quote:
Originally Posted by martinf79 View Post
Both set to auto.

64 bit
Let's start there. ZGW_Search.exe will not run on 64-Bit OS. Right-click on it, go to properties, and set it to run in the XP SP2 Compatibility mode.

Launch ZGW_Search.exe, and give it a few minutes to populate.

ZGW_Search.exe though is an informational tool only, and is not needed at all for E-Sys to fucntion. So, regardless of ZGW_Search.exe working or not, launch E-Sys, and see if you can connect to the car.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
shawnsheridan is online now   United_States
0
Reply With Quote
      10-27-2012, 02:06 PM   #1165
martinf79
Captain
 
martinf79's Avatar
 
Drives: F30 335i M Sport
Join Date: May 2012
Location: Toronto, Canada

Posts: 640
iTrader: (0)

Quote:
Originally Posted by shawnsheridan View Post
Let's start there. ZGW_Search.exe will not run on 64-Bit OS. Right-click on it, go to properties, and set it to run in the XP SP2 Compatibility mode.

Launch ZGW_Search.exe, and give it a few minutes to populate.

ZGW_Search.exe though is an informational tool only, and is not needed at all for E-Sys to fucntion. So, regardless of ZGW_Search.exe working or not, launch E-Sys, and see if you can connect to the car.
it worked! Thanks!

Got ZGW_Search to work. Tried running E-Sys, and was able to connect. Now only problem is, I don't see F30 as a Target option?? lol

You must be getting annoyed by now (apologies, but new at this). lol
__________________

2013 335i ///M-Sport | MPPK ON ORDER | AW | BD Leather | 19 M3 ZCP Wheels | M-Sport Brakes | Adaptive M-Suspension | Variable Sport Steering | Premium Package | Enhanced Bluetooth | Sirius | BMW Apps | Heads Up Display | Speed Limit Info | M Performance Grill | Front/Rear Painted Reflectors | Coded
martinf79 is offline  
0
Reply With Quote
      10-27-2012, 02:07 PM   #1166
shawnsheridan
Brigadier General
 
shawnsheridan's Avatar
 
Drives: 2011 535i M-Sport
Join Date: Feb 2010
Location: Houston, TX

Posts: 4,248
iTrader: (0)

Garage List
Quote:
Originally Posted by martinf79 View Post
it worked! Thanks!

Got ZGW_Search to work. Tried running E-Sys, and was able to connect. Now only problem is, I don't see F30 as a Target option?? lol

You must be getting annoyed by now (apologies, but new at this). lol
F020 psdzdata covers the F20 1-series and F30 3-series.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
shawnsheridan is online now   United_States
0
Reply With Quote
Post Reply

Bookmarks

Tags
3 series coding, 3 series f30, 3 series f30 coding, 3 series f30 forum, 3 series forum, 3-series forum, 5 series f10 coding, ass, ass disable, auto start stop, auto start stop disable, bmw 3 series coding, bmw 3 series f30, bmw 3 series forum, bmw 3-series f30, bmw 3-series forum, bmw 5 series coding, bmw auto start stop disable, bmw auto start stop disabling, bmw coding, bmw coding directions, bmw coding diy, bmw coding instructions, bmw diy, bmw diy forum, bmw f10 coding, bmw f30, bmw f30 3 series, bmw f30 3-series, bmw f30 coding, bmw f30 forum, coding 3 series, coding f30, coding f30 3 series, disable ass, disable auto start stop, disable bmw auto start stop, disabling auto start stop, disabling bmw auto start stop, f10 5 series coding, f10 coding, f30 3 series, f30 3 series coding, f30 3 series forum, f30 3-series, f30 3-series forum, f30 coding, f30 forum, f30 forums

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:27 AM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST