F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Mechanical Maintenance and TSBs: Break-in / Oil & Fluids / Servicing / TSBs and Service Bulletin > Coolant Light Keep Coming On After Replacement of Sensor
MINHS Auto Care Center
Post Reply
 
Thread Tools Search this Thread
      01-22-2013, 08:27 AM   #1
legaleye3000
First Lieutenant
 
Drives: 328i 2014
Join Date: Sep 2012
Location: South FL

Posts: 328
iTrader: (0)

Coolant Light Keep Coming On After Replacement of Sensor

I just had my car in the shop. They replaced the coolant tank that has the sensor on it. After testing, they said that the replacement was bad. Then they replaced it again and now my coolant light keeps coming on.

Any ideas?
legaleye3000 is offline   United_States
0
Reply With Quote
      01-22-2013, 12:53 PM   #2
shivj
New Member
 
Drives: 2012 F30
Join Date: Jan 2013
Location: WNY

Posts: 15
iTrader: (0)

Misunderstood, but the tank was replaced twice or the sensor was? When you turn the heat on does it get hot? Any issues with overheating at all?
shivj is offline  
0
Reply With Quote
      01-22-2013, 01:23 PM   #3
legaleye3000
First Lieutenant
 
Drives: 328i 2014
Join Date: Sep 2012
Location: South FL

Posts: 328
iTrader: (0)

They said they replaced the tank twice (during the same visit to the dealership; not to different visits). No overheating issues... I haven't turned the heat on since I'm in south FL and need the a/c
legaleye3000 is offline   United_States
0
Reply With Quote
      01-22-2013, 01:41 PM   #4
shivj
New Member
 
Drives: 2012 F30
Join Date: Jan 2013
Location: WNY

Posts: 15
iTrader: (0)

Ah my mistake, missed the location. Well if cooling system is functioning properly, perhaps there is some sort of a short on the sensor lead. Sorry I can't be of more help. Still getting used to how nearly every aspect of these cars is computer controlled. Another trip to the dealer perhaps? Best of luck!
shivj is offline  
0
Reply With Quote
      01-22-2013, 01:42 PM   #5
legaleye3000
First Lieutenant
 
Drives: 328i 2014
Join Date: Sep 2012
Location: South FL

Posts: 328
iTrader: (0)

If a sensor is replaced, is a sensor lead also replaced? Thanks!
legaleye3000 is offline   United_States
0
Reply With Quote
      01-22-2013, 01:57 PM   #6
shivj
New Member
 
Drives: 2012 F30
Join Date: Jan 2013
Location: WNY

Posts: 15
iTrader: (0)

Not entirely sure on bmw's, but on my s2000 the same lead would be reused and just the sensor at the end replaced. Looking at the previous generation 3 series it is similar, so I imagine the F30 would be as well. However, I have seen that a few people with F30's have had faulty coolant sensors, which were of course replaced by the dealer. That's the only thing that pops into my head regarding the light coming on
shivj is offline  
0
Reply With Quote
      02-02-2013, 03:22 PM   #7
Hilbe
New Member
 
Drives: F30 320 2013
Join Date: Dec 2012
Location: Mexico

Posts: 6
iTrader: (0)

What color is your coolant? Service repulaced it and now the temperature goes up.

Now the coolant is blue but i think it was pink when i got the car
Hilbe is offline  
0
Reply With Quote
      02-02-2013, 07:52 PM   #8
Robz_328i
Enlisted Member
 
Drives: Bmw 328i 2012 Luxury Executive
Join Date: Aug 2012
Location: Montreal

Posts: 33
iTrader: (0)

By the way a question like this, I live in montreal canada which is pretty cold. Do someone experience this but it takes about 10mins for the car heat to get hot? Sorry i was driving a volvo before and it became hot pretty quick. My 328i seems to take time though but might be normal ???
Robz_328i is offline  
0
Reply With Quote
      02-02-2013, 07:53 PM   #9
Robz_328i
Enlisted Member
 
Drives: Bmw 328i 2012 Luxury Executive
Join Date: Aug 2012
Location: Montreal

Posts: 33
iTrader: (0)

+ my coolant did came up too. However when i went to bmw, they added some more and it eventually did better than before. Never saw the smg again.
Robz_328i is offline  
0
Reply With Quote
      02-02-2013, 09:51 PM   #10
legaleye3000
First Lieutenant
 
Drives: 328i 2014
Join Date: Sep 2012
Location: South FL

Posts: 328
iTrader: (0)

I found out that the dealership didn't secure the hose that connects the tank to the engine so a couple hours later it fell off of the tank and all the coolant spilled out causing my car to overheat!
legaleye3000 is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:07 PM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST