F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics > iPod current Song Info won't update
Post Reply
 
Thread Tools Search this Thread
      02-25-2013, 03:55 AM   #1
AntBabeee
Lieutenant
 
Drives: 2013 BMW 335i
Join Date: Sep 2012
Location: Bay Area, CA

Posts: 570
iTrader: (2)

Garage List
2013 BMW 335i  [0.00]
iPod current Song Info won't update

I have an iPod touch 4th on 6.1 hooked up via USB. When I select songs on it through idrive it'll play but when I skip a song and go next. Sometimes idrive doesn't update the song info to the new song that playing its still stuck on the previous song. Sometimes stuck for a while. It happens more often if I use the steering wheel scroll button to change song. Apparently 6.1 allows me to change the song and select song on the iPod at the same time it's connected to car through USB. Doesn't show the accessory screen that blocks are controls.

Anyone else have this problem?
What did you do to fix it?
__________________
F30 BMW 335i M-Sport: Estoril Blue II, 19" Rims, Sports Auto, Premium, Technology, Harmon Kardon, Heated Front Seats, Driver Assistance...
AntBabeee is offline   United_States
0
Reply With Quote
      02-25-2013, 04:49 PM   #2
AntBabeee
Lieutenant
 
Drives: 2013 BMW 335i
Join Date: Sep 2012
Location: Bay Area, CA

Posts: 570
iTrader: (2)

Garage List
2013 BMW 335i  [0.00]
bump...
__________________
F30 BMW 335i M-Sport: Estoril Blue II, 19" Rims, Sports Auto, Premium, Technology, Harmon Kardon, Heated Front Seats, Driver Assistance...
AntBabeee is offline   United_States
0
Reply With Quote
      02-28-2013, 04:30 AM   #3
AntBabeee
Lieutenant
 
Drives: 2013 BMW 335i
Join Date: Sep 2012
Location: Bay Area, CA

Posts: 570
iTrader: (2)

Garage List
2013 BMW 335i  [0.00]
Anyone?
__________________
F30 BMW 335i M-Sport: Estoril Blue II, 19" Rims, Sports Auto, Premium, Technology, Harmon Kardon, Heated Front Seats, Driver Assistance...
AntBabeee is offline   United_States
0
Reply With Quote
      02-28-2013, 07:31 AM   #4
Axman85
Private First Class
 
Drives: 335i x-Drive M-Sport Min. Grey
Join Date: Dec 2012
Location: MA

Posts: 158
iTrader: (0)

Have the same issue with iPhone 4S. The other quirky thing is that the radio doesn't know what station it was last on when the car is turned on after being off a few hours. The radio station will be the same as the last one played except there won't be a check next to it in the display. Quite annoying when you don't know the stations call sign or nick name. The screen also doesn't update when using one of the eight memory buttons to recall a station.

Will ask my dealer about it when it goes in. Probably going to have to live with it.
Axman85 is offline  
0
Reply With Quote
      02-28-2013, 04:07 PM   #5
AntBabeee
Lieutenant
 
Drives: 2013 BMW 335i
Join Date: Sep 2012
Location: Bay Area, CA

Posts: 570
iTrader: (2)

Garage List
2013 BMW 335i  [0.00]
Quote:
Originally Posted by Axman85 View Post
Have the same issue with iPhone 4S. The other quirky thing is that the radio doesn't know what station it was last on when the car is turned on after being off a few hours. The radio station will be the same as the last one played except there won't be a check next to it in the display. Quite annoying when you don't know the stations call sign or nick name. The screen also doesn't update when using one of the eight memory buttons to recall a station.

Will ask my dealer about it when it goes in. Probably going to have to live with it.
i tried restarting drive and doesnt work completely. I just restored my ipod touch, lets see if it continues again. I happens on my iphone 5 too. Dont recall it happening when i was on 6.0 for my iPod...
__________________
F30 BMW 335i M-Sport: Estoril Blue II, 19" Rims, Sports Auto, Premium, Technology, Harmon Kardon, Heated Front Seats, Driver Assistance...
AntBabeee is offline   United_States
0
Reply With Quote
      02-28-2013, 05:07 PM   #6
ScarecrowBoat
Zooombie attaaack!!
 
ScarecrowBoat's Avatar
 
Drives: 2012 328i
Join Date: Mar 2011
Location: NEB

Posts: 882
iTrader: (2)

Garage List
2012 BMW  [0.00]
Happens to me occasionally. The album art will be correct but the song doesn't update. It has to do with the iPod, not the car. Knowing Apple, they'll never fix it.
__________________
12 BMW 328i
08 Range Rover Sport SC
ScarecrowBoat is offline   United_States
0
Reply With Quote
      02-28-2013, 07:42 PM   #7
awizon
New Member
 
Drives: 2010 BMW 328i Coupe
Join Date: Dec 2012
Location: Basking Ridge, NJ

Posts: 29
iTrader: (0)

I think there are a few software issues with the iPod interface. Besides the long delay mentioned above, I found that with my 7th gen iPod, if I'm playing a playlist and go back to look at playlists, it always starts at my first playlist, not the one I'm currently playing. I'm pretty sure my previous 3-series (2010) did the later. Maybe people don't mind that behavior, but I like the system to keep the playlist position when I go to search again.

Also, there is definitely processor lag with current version iDrive. That is one thing that will be much better in next version. System is still great, but wish they had released the next version already.
awizon is offline  
0
Reply With Quote
      03-01-2013, 07:35 PM   #8
Axman85
Private First Class
 
Drives: 335i x-Drive M-Sport Min. Grey
Join Date: Dec 2012
Location: MA

Posts: 158
iTrader: (0)

Album art. Don't even get that.
Axman85 is offline  
0
Reply With Quote
      03-04-2013, 10:49 AM   #9
ScarecrowBoat
Zooombie attaaack!!
 
ScarecrowBoat's Avatar
 
Drives: 2012 328i
Join Date: Mar 2011
Location: NEB

Posts: 882
iTrader: (2)

Garage List
2012 BMW  [0.00]
Quote:
Originally Posted by Axman85 View Post
Album art. Don't even get that.
Is there a confirmed issue with album art or are you speculating
__________________
12 BMW 328i
08 Range Rover Sport SC
ScarecrowBoat is offline   United_States
0
Reply With Quote
      03-04-2013, 01:47 PM   #10
AntBabeee
Lieutenant
 
Drives: 2013 BMW 335i
Join Date: Sep 2012
Location: Bay Area, CA

Posts: 570
iTrader: (2)

Garage List
2013 BMW 335i  [0.00]
Quote:
Originally Posted by Axman85 View Post
Album art. Don't even get that.
I get album art. it just the song info dont change. I actually want to know is there a way to disable album art all together. haha
__________________
F30 BMW 335i M-Sport: Estoril Blue II, 19" Rims, Sports Auto, Premium, Technology, Harmon Kardon, Heated Front Seats, Driver Assistance...
AntBabeee is offline   United_States
0
Reply With Quote
      03-04-2013, 02:51 PM   #11
Axman85
Private First Class
 
Drives: 335i x-Drive M-Sport Min. Grey
Join Date: Dec 2012
Location: MA

Posts: 158
iTrader: (0)

I don't get album art.
Axman85 is offline  
0
Reply With Quote
      04-03-2013, 07:10 AM   #12
Rajput
New Member
 
Drives: BMW F30 320d 2012
Join Date: Dec 2012
Location: SW, UK

Posts: 19
iTrader: (0)

I have the base system and am using a 160gb 7th gen ipod classic.

I don't get any kind of album art.

I have smart playlists set up in iTunes, e.g. play all songs where the playcount is <10 (and therefore if >10 remove from playlist). This way I get to listen to all of my music over time, and not just my favourites.

If I start off with a song in a playlist on my ipod, and then connect it to the usb/ipod interface, the screen displays only the name of the current playing song. It's not possible to see what's coming up next, but, the title is always correct for whatever is playing.

If on the other hand I choose a playlist via iDrive i.e. after the ipod has been connected, then I can see the name of the "current" playing song, as well as what's coming up next. Effectively iDrive has read the contents of the playlist, so if you have say 100 songs in the playlist, it will display all 100 songs as potential plays. HOWEVER, as the ipod plays songs it effectively updates the smart playlist i.e. if I start out with 100 songs and play 3 of them, then there are only 97 songs remaining to play. Unfortunately, iDrive can't handle this as it thinks there are still 100 songs in the playlist, when in reality there are now only 97. iDrive doesn't update exactly at the end of a song, to say the song has finished, and this time lag is an issue, because by now a new song could have started playing. Hence it ends up displaying the wrong song title.

It's the fact that iDrive reads playlist contents in advance which is the problem.

I haven't tried playing a "static" playlist, to see if the same problem arises, or a smart playlist where none of the songs are removed from the list e.g. all songs by the same artist". Will have to try it out later to see if the song info updates properly or not. I can't remember if the playing via USB has the same problem, as playlist contents don't change - unlike with the latest ipod. I'm also going to disable the smart playlist update feature when I next update my ipod and see if i get the wrong song info if i select a playlist via iDrive.
Rajput is offline   United Kingdom
0
Reply With Quote
      04-03-2013, 08:17 AM   #13
narlus
Private
 
Drives: 2013 335xi
Join Date: Apr 2013
Location: United States

Posts: 80
iTrader: (0)

somewhat related...does anyone have a problem w/ their iPod freezing up? i have had to do a hard reset at least a dozen times in the ~4 weeks I've had my car...it's getting annoying.

The occurrence is not predictable either. it can happen during song skips, searches, or even during playback. all of a sudden, the music stops and the iPod option on the screen is grayed out as unavailable. the iPod screen itself will say 'OK to disconnect'

is this an iPod issue, a BMW connectivity issue, or both? for the record, i am in a 2013 335xi and am using the latest generation iPod 160GB model (almost filled).


as a side note, i do like seeing album art (virtually all my mp3s are tagged correctly, with album art) but the screen resolution is rather dodgy...why couldn't have BMW spec'd a slightly nicer screen so the image isn't pixelated?
narlus is offline  
0
Reply With Quote
      04-03-2013, 09:36 AM   #14
chriskd
Private
 
Drives: 2013 335i M Sport
Join Date: Sep 2012
Location: Bay Area, CA

Posts: 60
iTrader: (0)

Others have complained about ipod classics freezing up. Might be related to them using traditional platter hard drives (http://www.f30post.com/forums/showthread.php?t=817605). Try one of the ipods that use flash memory instead - I use an ipod touch and it never freezes.

As for screen resolution for album art, again my ipod touch was a better choice due to its screen resolution. The album art from my ipod classic was pretty crappy (http://www.f30post.com/forums/showthread.php?t=816572)
chriskd is offline  
0
Reply With Quote
      04-03-2013, 10:57 AM   #15
ghettodefendant
Private First Class
 
ghettodefendant's Avatar
 
Drives: F30 328i Sportline
Join Date: Feb 2013
Location: Melbourne, VIC

Posts: 105
iTrader: (0)

Garage List
2012 BMW 328i  [0.00]
Quote:
Originally Posted by narlus View Post
as a side note, i do like seeing album art (virtually all my mp3s are tagged correctly, with album art) but the screen resolution is rather dodgy...why couldn't have BMW spec'd a slightly nicer screen so the image isn't pixelated?
I'm pretty sure the iPod classic album art is stored in a lower resolution then that of an iPhone or touch. That would be why it's pixelated.
ghettodefendant is offline   Australia
0
Reply With Quote
      04-03-2013, 11:39 AM   #16
diesel86
Private First Class
 
Drives: 2012 BMW 328i Sportline
Join Date: Aug 2012
Location: Phoenix, AZ

Posts: 195
iTrader: (0)

I would agree that it is most likely an iPod malfunction vs. an iDrive issue. Our 4Runner has an aftermarket Pioneer navigation system with iPod integration. Every so often, the on-screen song data is blank or just plain wrong. Everytime that has happened, it's been an iPod issue. When that happens, the iPod usually freezes and requires a restart. The restart always fixes the issue in my case. Based on the fact that it lives permanently in my glove box...and I live in Phoenix, I'm surprised it works at all!
__________________
2012 328i Sportline - Black Sapphire Metallic - 8AT Sport

I pronounce it "Beemer" and turn my fog lights on even when it's not foggy.
diesel86 is offline   United_States
0
Reply With Quote
      04-03-2013, 02:22 PM   #17
AntBabeee
Lieutenant
 
Drives: 2013 BMW 335i
Join Date: Sep 2012
Location: Bay Area, CA

Posts: 570
iTrader: (2)

Garage List
2013 BMW 335i  [0.00]
Quote:
Originally Posted by narlus View Post
somewhat related...does anyone have a problem w/ their iPod freezing up? i have had to do a hard reset at least a dozen times in the ~4 weeks I've had my car...it's getting annoying.

The occurrence is not predictable either. it can happen during song skips, searches, or even during playback. all of a sudden, the music stops and the iPod option on the screen is grayed out as unavailable. the iPod screen itself will say 'OK to disconnect'

is this an iPod issue, a BMW connectivity issue, or both? for the record, i am in a 2013 335xi and am using the latest generation iPod 160GB model (almost filled).


as a side note, i do like seeing album art (virtually all my mp3s are tagged correctly, with album art) but the screen resolution is rather dodgy...why couldn't have BMW spec'd a slightly nicer screen so the image isn't pixelated?
Could be a classic... i use an ipod touch. my ipod classic use to freeze all the time in my old car too. you can hear the harddrive clicking.

Quote:
Originally Posted by chriskd View Post
Others have complained about ipod classics freezing up. Might be related to them using traditional platter hard drives (http://www.f30post.com/forums/showthread.php?t=817605). Try one of the ipods that use flash memory instead - I use an ipod touch and it never freezes.

As for screen resolution for album art, again my ipod touch was a better choice due to its screen resolution. The album art from my ipod classic was pretty crappy (http://www.f30post.com/forums/showthread.php?t=816572)
+1

Quote:
Originally Posted by Rajput View Post
I have the base system and am using a 160gb 7th gen ipod classic.

I don't get any kind of album art.

I have smart playlists set up in iTunes, e.g. play all songs where the playcount is <10 (and therefore if >10 remove from playlist). This way I get to listen to all of my music over time, and not just my favourites.

If I start off with a song in a playlist on my ipod, and then connect it to the usb/ipod interface, the screen displays only the name of the current playing song. It's not possible to see what's coming up next, but, the title is always correct for whatever is playing.

If on the other hand I choose a playlist via iDrive i.e. after the ipod has been connected, then I can see the name of the "current" playing song, as well as what's coming up next. Effectively iDrive has read the contents of the playlist, so if you have say 100 songs in the playlist, it will display all 100 songs as potential plays. HOWEVER, as the ipod plays songs it effectively updates the smart playlist i.e. if I start out with 100 songs and play 3 of them, then there are only 97 songs remaining to play. Unfortunately, iDrive can't handle this as it thinks there are still 100 songs in the playlist, when in reality there are now only 97. iDrive doesn't update exactly at the end of a song, to say the song has finished, and this time lag is an issue, because by now a new song could have started playing. Hence it ends up displaying the wrong song title.

It's the fact that iDrive reads playlist contents in advance which is the problem.

I haven't tried playing a "static" playlist, to see if the same problem arises, or a smart playlist where none of the songs are removed from the list e.g. all songs by the same artist". Will have to try it out later to see if the song info updates properly or not. I can't remember if the playing via USB has the same problem, as playlist contents don't change - unlike with the latest ipod. I'm also going to disable the smart playlist update feature when I next update my ipod and see if i get the wrong song info if i select a playlist via iDrive.
I understand what your saying and all but i dont use any smart playlist. and it still stuck on previous song title. tends to happen more when i change songs from the HUDs or on the ipod itself.
__________________
F30 BMW 335i M-Sport: Estoril Blue II, 19" Rims, Sports Auto, Premium, Technology, Harmon Kardon, Heated Front Seats, Driver Assistance...
AntBabeee is offline   United_States
0
Reply With Quote
      04-03-2013, 03:22 PM   #18
narlus
Private
 
Drives: 2013 335xi
Join Date: Apr 2013
Location: United States

Posts: 80
iTrader: (0)

Quote:
Originally Posted by ghettodefendant View Post
I'm pretty sure the iPod classic album art is stored in a lower resolution then that of an iPhone or touch. That would be why it's pixelated.
i am not sure that's true...i manually added the artwork myself, not via iTunes...most of the images are at least 600px in dimension.

maybe i'll try my iPad to see how that looks.


and yeah, it's an iPod classic...there's no way they will come out w/ a HDD-based iPod that has 160GB capacity.
narlus is offline  
0
Reply With Quote
      04-03-2013, 03:53 PM   #19
Rajput
New Member
 
Drives: BMW F30 320d 2012
Join Date: Dec 2012
Location: SW, UK

Posts: 19
iTrader: (0)

UPDATE:

I've tested my smart playlist vs. static (i.e. non live updating) and I can report that it now always seems to show the correct name.

In iTunes I left my smart list 'live update' ticked, synched the ipod, then removed the 'live update' tick in the smart list, and re-synched the ipod, so that it thinks that smart updating is not required. This has solved the wrong name for the song playing problem. I can now scroll up and down and it plays the correct song by title when I select the same playlist via iDrive. I can select different songs either via iDrive on the screen, or the scroll wheel on the steering wheel, both 'upwards' and 'downwards', and it plays the correct song as shown by title, which until today I've never managed to get it to do correctly. The song title changes to the new title after about 3 seconds after the new song starts, when going from one song finishing to the new one starting.

With regard to ipod freezing. My ipod was doing the same, even though it was barely a month old, a couple/few times in the car, but usually after i removed it from the car and when I connected it to my pc to do an iTunes sync. I would end up doing a hard reset. The local Apple store suggested I take it in to be looked at, but before I did this, I let iTunes do an ipod software update (currently I am on 2.0.4) and iTunes v11.0.2.26 and this sorted the problem.

At the moment then, by turning off the live update option, as of today, it seems to be working in the way i'd like it to.

I suggest you do a factory reset on the ipod and then let iTunes update the ipod software if required. I'm sure I did this at least once if not more, just after I first got my ipod about 4 months ago. I haven't had any problems since doing the software update.

Try the links in the following post:

https://discussions.apple.com/thread...art=0&tstart=0

Last edited by Rajput; 04-03-2013 at 04:11 PM.
Rajput is offline   United Kingdom
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:41 PM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST