F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Cosmetic and Lighting Modifications (exterior & interior) > F30 LED turnsignals installed
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      03-14-2015, 01:20 AM   #243
Steve33
Captain
Steve33's Avatar
No_Country
23
Rep
800
Posts

Drives: 2013 335i
Join Date: Apr 2013
Location: SoCal

iTrader: (0)

Try and push in and then turn (like a safety lid on a medicine bottle). DO NOT TOUCH THE BULBS DIRECTLY
__________________
Appreciate 0
      07-01-2015, 11:57 PM   #244
gpjustinn
Private First Class
gpjustinn's Avatar
United_States
17
Rep
106
Posts

Drives: 2014 BMW 320i - Alpine White
Join Date: May 2015
Location: Corpus Christi, TX

iTrader: (0)

Just received my 50W amber cree LED's from Horizon (UK vendor) today. Took a little bit for them to arrive and a bit more expensive than some of the other options I'm seeing on the threads, but definitely worth the wait and money. They're much brighter than the incandescent bulbs, and the instant ON/OFF function of the bulbs is a huge improvement. They look great! I'll definitely be ordering some red ones for the rear turn signals, and then maybe for the brake lights and reverse lights later on.

Install was actually easier than I had expected, just popped off the little cut-out in front of the wheels and had direct access to the indicator bulbs. Unfortunately, I didn't realize this until I had already removed some screws on the driver side and tried to peel back the fender lining to get to the indicators. After knowing that, the passenger side literally took like 30 seconds to switch out!
__________________
2014 BMW 320i Alpine White
Appreciate 0
      07-15-2015, 08:44 PM   #245
ronjon400
Dutchman
ronjon400's Avatar
United_States
4
Rep
17
Posts

Drives: 2014 328i M-Sport
Join Date: Jun 2015
Location: Daytona Beach

iTrader: (0)

Here are my led turn signals. Search out motoring max on eBay. $50-60 a pair. I went with amber front and rear. No problems at all.


__________________
2014 328i M-Sport (stock for now)
2004 325ic
2010 128i M-Sport
Twitter: @ronjon400
Appreciate 0
      07-15-2015, 09:16 PM   #246
M47
Private
United_States
9
Rep
89
Posts

Drives: F30 328 XI
Join Date: Jan 2015
Location: Northwest

iTrader: (0)

Quote:
Originally Posted by ronjon400 View Post
Here are my led turn signals. Search out motoring max on eBay. $50-60 a pair. I went with amber front and rear. No problems at all.


No need of coding? How about some flickering during start-up and every few minutes?
Appreciate 0
      07-16-2015, 09:47 AM   #247
thatf30guy
New Member
thatf30guy's Avatar
United_States
1
Rep
12
Posts

Drives: 328i Sport Li
Join Date: Jun 2015
Location: North Carolina

iTrader: (0)

Garage List
Quote:
Originally Posted by M47 View Post
No need of coding? How about some flickering during start-up and every few minutes?
You will definitely need to perform coding even on CANBUS error-free bulbs. The reason for this, as is probably explained on numerous other LED bulbs replacement threads, is because LEDs draw far less current and power than normal incandescents. On the normal bulbs, the car sends a little pulse of current during start-up and every few minutes when driving, to check that the bulb is still working. This doesn't cause the incandescent to light up because it needs more current than what the car's pulse is giving it; however with LEDs, it causes them to flicker rapidly whenever the pulse is sent and that needs to be coded out.

Using E-Sys, the codes that need to be changed for the front two turn signals in are:
(For left bulb)
FEM_BODY 3061 FRA_V_L_KALTUEBERWACHUNG aktiv --> nicht_aktiv
FEM_BODY 3061 FRA_V_L_WARMUEBERWACHUNG aktiv --> nicht_aktiv
FEM_BODY 3061 FRA_V_L_IS_LED nicht_aktiv --> aktiv
(For right bulb)
FEM_BODY 3061 FRA_V_R_KALTUEBERWACHUNG aktiv --> nicht_aktiv
FEM_BODY 3061 FRA_V_R_WARMUEBERWACHUNG aktiv --> nicht_aktiv
FEM_BODY 3061 FRA_V_R_IS_LED nicht_aktiv --> aktiv
Appreciate 1
      07-16-2015, 11:15 AM   #248
ronjon400
Dutchman
ronjon400's Avatar
United_States
4
Rep
17
Posts

Drives: 2014 328i M-Sport
Join Date: Jun 2015
Location: Daytona Beach

iTrader: (0)

Quote:
Originally Posted by M47
Quote:
Originally Posted by ronjon400 View Post
Here are my led turn signals. Search out motoring max on eBay. $50-60 a pair. I went with amber front and rear. No problems at all.


No need of coding? How about some flickering during start-up and every few minutes?
Just installed em. That's it. Nothing seems to be going wrong.
__________________
2014 328i M-Sport (stock for now)
2004 325ic
2010 128i M-Sport
Twitter: @ronjon400
Appreciate 0
      07-16-2015, 12:01 PM   #249
gpjustinn
Private First Class
gpjustinn's Avatar
United_States
17
Rep
106
Posts

Drives: 2014 BMW 320i - Alpine White
Join Date: May 2015
Location: Corpus Christi, TX

iTrader: (0)

Quote:
Originally Posted by thatf30guy View Post
You will definitely need to perform coding even on CANBUS error-free bulbs. The reason for this, as is probably explained on numerous other LED bulbs replacement threads, is because LEDs draw far less current and power than normal incandescents. On the normal bulbs, the car sends a little pulse of current during start-up and every few minutes when driving, to check that the bulb is still working. This doesn't cause the incandescent to light up because it needs more current than what the car's pulse is giving it; however with LEDs, it causes them to flicker rapidly whenever the pulse is sent and that needs to be coded out.

Using E-Sys, the codes that need to be changed for the front two turn signals in are:
(For left bulb)
FEM_BODY 3061 FRA_V_L_KALTUEBERWACHUNG aktiv --> nicht_aktiv
FEM_BODY 3061 FRA_V_L_WARMUEBERWACHUNG aktiv --> nicht_aktiv
FEM_BODY 3061 FRA_V_L_IS_LED nicht_aktiv --> aktiv
(For right bulb)
FEM_BODY 3061 FRA_V_R_KALTUEBERWACHUNG aktiv --> nicht_aktiv
FEM_BODY 3061 FRA_V_R_WARMUEBERWACHUNG aktiv --> nicht_aktiv
FEM_BODY 3061 FRA_V_R_IS_LED nicht_aktiv --> aktiv

Perfect write-up!
__________________
2014 BMW 320i Alpine White
Appreciate 0
      07-16-2015, 12:06 PM   #250
thatf30guy
New Member
thatf30guy's Avatar
United_States
1
Rep
12
Posts

Drives: 328i Sport Li
Join Date: Jun 2015
Location: North Carolina

iTrader: (0)

Garage List
Quote:
Originally Posted by ronjon400 View Post
Just installed em. That's it. Nothing seems to be going wrong.
Are you sure there is no flickering even on starting the engine? I would recommend double checking and at the very least, coding in that the turn signal bulbs are LEDs so the ECU will still tell you if there is a bulb malfunction.

Also, I forgot to add the coding for the rear bulbs which are almost identical to the fronts; only difference is that the ECU is REM instead of FEM. Everything is the same except the beginning phrase which is FRA_H_L instead of FRA_V_L
Appreciate 0
      07-16-2015, 04:29 PM   #251
ronjon400
Dutchman
ronjon400's Avatar
United_States
4
Rep
17
Posts

Drives: 2014 328i M-Sport
Join Date: Jun 2015
Location: Daytona Beach

iTrader: (0)

Quote:
Originally Posted by thatf30guy
Quote:
Originally Posted by ronjon400 View Post
Just installed em. That's it. Nothing seems to be going wrong.
Are you sure there is no flickering even on starting the engine? I would recommend double checking and at the very least, coding in that the turn signal bulbs are LEDs so the ECU will still tell you if there is a bulb malfunction.

Also, I forgot to add the coding for the rear bulbs which are almost identical to the fronts; only difference is that the ECU is REM instead of FEM. Everything is the same except the beginning phrase which is FRA_H_L instead of FRA_V_L
Ok if there is a flicker, then what do I need to do as far as coding? Who does it? Can I do it? I'm pretty computer savvy.
__________________
2014 328i M-Sport (stock for now)
2004 325ic
2010 128i M-Sport
Twitter: @ronjon400
Appreciate 0
      07-16-2015, 04:59 PM   #252
RarScaryFrosty
Private First Class
United_States
10
Rep
137
Posts

Drives: 2013 328i xDrive
Join Date: Oct 2014
Location: Toledo, Ohio

iTrader: (0)

Quote:
Originally Posted by ronjon400 View Post
Ok if there is a flicker, then what do I need to do as far as coding? Who does it? Can I do it? I'm pretty computer savvy.
There most likely is flickering and you're just not noticing it yet. The easiest solution would be to find a local member in your area and to pay them to do it. I don't have a laptop, but the cost of that, plus an enet cable, sourcing a token for esys, etc is just too much for me. I'd rather pay someone with experience to do it for me.
Appreciate 0
      07-16-2015, 06:28 PM   #253
ronjon400
Dutchman
ronjon400's Avatar
United_States
4
Rep
17
Posts

Drives: 2014 328i M-Sport
Join Date: Jun 2015
Location: Daytona Beach

iTrader: (0)

Ok thank you for your help
__________________
2014 328i M-Sport (stock for now)
2004 325ic
2010 128i M-Sport
Twitter: @ronjon400
Appreciate 0
      07-16-2015, 07:17 PM   #254
thatf30guy
New Member
thatf30guy's Avatar
United_States
1
Rep
12
Posts

Drives: 328i Sport Li
Join Date: Jun 2015
Location: North Carolina

iTrader: (0)

Garage List
Quote:
Originally Posted by ronjon400 View Post
Ok if there is a flicker, then what do I need to do as far as coding? Who does it? Can I do it? I'm pretty computer savvy.
You can PM shawnsheridan, he's the one who hooked me up with the coding software. Or you can just browse around on the Coding and DIY section of the forum for other sources. As for the ENET cable, you can either make one or buy one off Amazon for around $40. All of the installation instructions and steps for activating E-Sys as well as connecting to your car are well explained in the included documentation. After that, all you need to do is apply the changes I mentioned above and you should be good to go
Appreciate 0
      07-17-2015, 05:49 AM   #255
ronjon400
Dutchman
ronjon400's Avatar
United_States
4
Rep
17
Posts

Drives: 2014 328i M-Sport
Join Date: Jun 2015
Location: Daytona Beach

iTrader: (0)

Thanks man. Teach a man to fish.
__________________
2014 328i M-Sport (stock for now)
2004 325ic
2010 128i M-Sport
Twitter: @ronjon400
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:32 PM.




f30post
f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST