F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > N55 Turbo Engine / Drivetrain / Exhaust Modifications > Turner Motosports TPM-N55, experience and Drivetrain Malfunction code
European Auto Source
Post Reply
 
Thread Tools Search this Thread
      09-12-2016, 07:42 PM   #1
blueloon
Registered
0
Rep
1
Posts

Drives: 2013 335i Sedan
Join Date: Jun 2016
Location: Carlsbad, CA

iTrader: (0)

Turner Motosports TPM-N55, experience and Drivetrain Malfunction code

I have had my 2013 335i for about 3 months now. I chose this over an Audi S4 because of the turbo vs. supercharger, and the ability to tune it. Not to mention about $5-10K less coin.

It's nicely equipped (Sport Line, Technology, Premium, M-Sport exhaust) and off of a lease.

I installed the Turner Motosports TPM-N55 module and have some things to share, mostly to see if anyone has had similar experience, or any advice.

From day 1, I would throw the occasional "Drivetrain Malfunction" code. This would happen only under serious foot-to-the-floor load, like when winding up on the on-ramp or getting out of silly situations in a real hurry. No loss of power, no limp home mode, just the code. Stopping the engine and restarting always cleared the code, as if nothing had happened. Talking to Chris at Turner, I was asked to check the connectors (all good), plug in the valet connector and drive it for a bit. Try as I might, and I really gave a it good go, the code never reappeared with the module out of the loop. So - it's the module. It's off to TM for repair or replacement. Anyone else see this?

Also - I haven't really noticed more than a slight bump in performance, and even that may be me convincing myself that the module is adding something. The on-board sport display isn't much help, since I'm guessing it's getting data from the module. When I get it back I'll give a good workout to see and post a follow-up
Appreciate 0
      09-12-2016, 07:53 PM   #2
mbanks21
Colonel
604
Rep
2,308
Posts

Drives: 2015 335i MSport
Join Date: Aug 2013
Location: St. Pete Florida

iTrader: (8)

I don't know of anyone else that has this unit. Most people have JB4
__________________
2015 335i Msport/6 JB4/EWG/E30/VRSF DP/ER CP/ Res Delete/ Injen Intake/Verde Axis 19x8.5/9.5 245/35/275/30 Conti Extreme CS/ H&R Sport / Motorsport Lug Conversion
Appreciate 0
      09-13-2016, 12:11 PM   #3
mike@x-ph.com
BimmerPost Supporting Vendor
mike@x-ph.com's Avatar
United_States
7455
Rep
90,326
Posts


Drives: 2007 e92 335i / 2013 F30 328
Join Date: Sep 2013
Location: Las Vegas

iTrader: (16)

Sorry to hear that OP, hopefully they will take care of it quickly
Appreciate 0
      02-01-2017, 11:21 PM   #4
BMW DIY Guy
Captain
435
Rep
806
Posts

Drives: 2014 435i
Join Date: Jan 2017
Location: Maple Valley WA

iTrader: (0)

Quote:
Originally Posted by blueloon View Post
I have had my 2013 335i for about 3 months now. I chose this over an Audi S4 because of the turbo vs. supercharger, and the ability to tune it. Not to mention about $5-10K less coin.

It's nicely equipped (Sport Line, Technology, Premium, M-Sport exhaust) and off of a lease.

I installed the Turner Motosports TPM-N55 module and have some things to share, mostly to see if anyone has had similar experience, or any advice.

From day 1, I would throw the occasional "Drivetrain Malfunction" code. This would happen only under serious foot-to-the-floor load, like when winding up on the on-ramp or getting out of silly situations in a real hurry. No loss of power, no limp home mode, just the code. Stopping the engine and restarting always cleared the code, as if nothing had happened. Talking to Chris at Turner, I was asked to check the connectors (all good), plug in the valet connector and drive it for a bit. Try as I might, and I really gave a it good go, the code never reappeared with the module out of the loop. So - it's the module. It's off to TM for repair or replacement. Anyone else see this?

Also - I haven't really noticed more than a slight bump in performance, and even that may be me convincing myself that the module is adding something. The on-board sport display isn't much help, since I'm guessing it's getting data from the module. When I get it back I'll give a good workout to see and post a follow-up
Any update on this? I JUST picked up my 14 435i today, and have been browsing possible options, and queued in immediately on 70hp gain from turner?!?!
Appreciate 0
Post Reply

Bookmarks

Tags
335i, drivetrain malfucntion, tpm-n55

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:10 PM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST