F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Mechanical Maintenance and TSBs: Break-in / Oil & Fluids / Servicing / TSBs and Service Bulletin > P0597 fault code repair
Vorsteiner
Post Reply
 
Thread Tools Search this Thread
      12-20-2017, 11:49 PM   #1
switchman
Private
United_States
19
Rep
87
Posts

Drives: '15 X5 '14 328i '06 X5 '03 530
Join Date: May 2014
Location: Chesapeake VA

iTrader: (0)

P0597 fault code repair

Hi guys !

My 2014 328i with less than 30,000 miles now have thermostat issue as found with with code P0597.

I'm looking for some help/guidance if anyone has done this work.
Appreciate any info. Thank you.
Appreciate 0
      12-22-2017, 10:57 AM   #2
switchman
Private
United_States
19
Rep
87
Posts

Drives: '15 X5 '14 328i '06 X5 '03 530
Join Date: May 2014
Location: Chesapeake VA

iTrader: (0)

So no one has done this thermostat replacement themselves ?
My warranty expired 10 days ago so I'm going to work on this myself, maybe someone have the procedure from Bentley.
Realoem and the N20 technical drawings shows confusing location of the thermostat, so maybe the Bentley repair manual could show exact location.

Thanks in advance for any help.
Appreciate 0
      12-22-2017, 03:38 PM   #3
Sanelko
Private First Class
Sanelko's Avatar
28
Rep
130
Posts

Drives: 2012 Jet Black 328i
Join Date: Jan 2016
Location: Seattle

iTrader: (0)

There's an extended warranty on the thermostat on the N20
Appreciate 0
      12-22-2017, 10:02 PM   #4
switchman
Private
United_States
19
Rep
87
Posts

Drives: '15 X5 '14 328i '06 X5 '03 530
Join Date: May 2014
Location: Chesapeake VA

iTrader: (0)

Quote:
Originally Posted by Sanelko View Post
There's an extended warranty on the thermostat on the N20
I didn't know that, I'm going to check with my SA.
Thank you.
Appreciate 0
      01-13-2018, 11:27 PM   #5
switchman
Private
United_States
19
Rep
87
Posts

Drives: '15 X5 '14 328i '06 X5 '03 530
Join Date: May 2014
Location: Chesapeake VA

iTrader: (0)

Thermostat has been replaced by dealer and covered by extended warranty but now the temp gauge slowly goes back down to below quarter mark on gauge even after warming up to normal (about 200 degrees). This happens when stopping and idling for about 1minute.
Has anyone noticed their temp gauge acting this way after thermostat replacement ? I don't remember the temp gauge fluctuating after getting engine warmed up normal temperature.
Appreciate 0
      01-14-2018, 09:27 AM   #6
enjoythemusic
Lieutenant
enjoythemusic's Avatar
245
Rep
595
Posts

Drives: 2014 BMW 435i Dinan Stage 4
Join Date: Feb 2017
Location: Florida

iTrader: (0)

Weird, sounds like a defective/stuck thermostat. Rare, yet can happen with new parts.

BTW, the N20 2013 X1 had that problem early in 2017, was fixed under warranty.
__________________
Enjoy the Drive,

Steven

2014 435i M-Opt, M LSD, Dinan CAI/IC/BTurbo/Stage 4, ER TIC/CP, GFB DV+ & Mich PS4S.
Appreciate 0
      05-21-2018, 05:01 PM   #7
Euro-bmw
Registered
0
Rep
3
Posts

Drives: All black
Join Date: May 2018
Location: 613-

iTrader: (0)

I have a P0597 I have. 13 328xi 74km on it have a engine light showing thermostat is open do I need to change only the thermostat or the thermostat and the water pump my car isn't over heating take a lil longer to warm up but it's gets to its normal please help
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:57 AM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST