F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics > Iphone6s library issue snap in
Post Reply
 
Thread Tools Search this Thread
      03-14-2018, 08:14 AM   #1
Madnyah
New Member
Madnyah's Avatar
Switzerland
0
Rep
5
Posts

Drives: 340Xdrive F30 2016
Join Date: Mar 2018
Location: Switzerland

iTrader: (0)

Iphone6s library issue snap in

Hello guys,

It's randomly cut the songs at 6-7sec from the begining since and I change the songs since the last update from Apple, when I play music from my library on my iphone 6s with the snap in.

I've give my car to BMW & they couldn't figure out what's wrong with it... They said it may be my phone. But I haven't this issue when I play music with youtube....

& the worst is that the last update from BMW Switzerland, I have no more the pop & bang. & They have to call the HQ to confirme that point, do you have the same in other contries ??

Thanks in advance
Appreciate 0
      03-15-2018, 06:20 AM   #2
Madnyah
New Member
Madnyah's Avatar
Switzerland
0
Rep
5
Posts

Drives: 340Xdrive F30 2016
Join Date: Mar 2018
Location: Switzerland

iTrader: (0)

Up guys, & sorry for my english. It's quite rusty
Appreciate 0
      03-15-2018, 10:16 AM   #3
vooonoo
\_(ツ)_/
vooonoo's Avatar
206
Rep
451
Posts

Drives: f30 328
Join Date: Nov 2017
Location: nj

iTrader: (0)

I didn't know people actually used the snap in connector
Appreciate 0
      03-15-2018, 11:41 AM   #4
ooshnoo
Lieutenant
ooshnoo's Avatar
United_States
157
Rep
429
Posts

Drives: 2014 428i
Join Date: Mar 2017
Location: Buford, GA

iTrader: (0)

Garage List
2014 GMC Acadia  [0.00]
2014 BMW 428i  [5.00]
Don't use the snap-in adapter. Just connect via USB cable.
__________________

___________________
2014 F32 428i 8AT M-Sport
Appreciate 0
      03-17-2018, 04:53 PM   #5
AdeyD
Registered
0
Rep
4
Posts

Drives: F31
Join Date: Mar 2018
Location: Surrey

iTrader: (0)

I've been having problems since I upgraded my iPhone 7 to iOS 11 last autumn.

I always connect via USB, but regardless of whether I'm streaming Apple Music or playing music stored locally on iPhone most of the time the song stops between the 7-14 second mark.

I've not been able to find a solution anywhere online and I feel it's a iOS issue rather than a BMW issue.
Appreciate 0
      03-17-2018, 06:36 PM   #6
ooshnoo
Lieutenant
ooshnoo's Avatar
United_States
157
Rep
429
Posts

Drives: 2014 428i
Join Date: Mar 2017
Location: Buford, GA

iTrader: (0)

Garage List
2014 GMC Acadia  [0.00]
2014 BMW 428i  [5.00]
Quote:
Originally Posted by AdeyD View Post
I feel it's a iOS issue rather than a BMW issue.
What troubleshooting have you done?
__________________

___________________
2014 F32 428i 8AT M-Sport
Appreciate 0
      03-17-2018, 08:45 PM   #7
AdeyD
Registered
0
Rep
4
Posts

Drives: F31
Join Date: Mar 2018
Location: Surrey

iTrader: (0)

Quote:
Originally Posted by ooshnoo View Post
What troubleshooting have you done?
Different USB cable.

Tried another two Different iPhones, one 7 one 6S, both with new and old cable.
Unfortunately I don't have any devices on iOS 10 to make a comparison.

Cleared down bluetooth pairings and re-paired.

Software on car up to date.

Turned off Apple Music streaming to force phone to use music downloaded on phone - problem still occurs.

Allow streaming - problem occurs. I live 100m from a mast, coverage is not an issue. I can get over 50Mb/s download and 20 Mb/s upload on a speed test sat in the car on my drive.

The single change I remember was updating the iPhone to iOS11, I'd only ever had songs stop when I streamed and had no mobile coverage on previous iOS versions.
Appreciate 0
      03-17-2018, 08:48 PM   #8
ooshnoo
Lieutenant
ooshnoo's Avatar
United_States
157
Rep
429
Posts

Drives: 2014 428i
Join Date: Mar 2017
Location: Buford, GA

iTrader: (0)

Garage List
2014 GMC Acadia  [0.00]
2014 BMW 428i  [5.00]
Reformat phone and setup as a new device...not from backup. Re-pair the phone to the car and try again.
__________________

___________________
2014 F32 428i 8AT M-Sport
Appreciate 0
      03-19-2018, 02:51 AM   #9
Madnyah
New Member
Madnyah's Avatar
Switzerland
0
Rep
5
Posts

Drives: 340Xdrive F30 2016
Join Date: Mar 2018
Location: Switzerland

iTrader: (0)

Thanks guys for your feedbacks.

I've also re-paired & erase all my song and uploead again, same things (I've the last version of IOS).. Randomly cut the song.. & If I look at my Iphone it's in pause mode.

I've been to Geneva car show last thursday & I've been explain the problem to a manager from BMW.
Now I'm waiting for his call..
Appreciate 0
      03-19-2018, 05:47 AM   #10
AdeyD
Registered
0
Rep
4
Posts

Drives: F31
Join Date: Mar 2018
Location: Surrey

iTrader: (0)

Quote:
Originally Posted by ooshnoo View Post
Reformat phone and setup as a new device...not from backup. Re-pair the phone to the car and try again.
I won't try that just yet, but I did run some interesting tests this morning.

Put the iPhone into Airplane mode and searched for some tracks I hadn't played in a while that also weren't currently downloaded to the iPhone. The iPhone managed to play them, not all, but quite a few.

The weird thing is that if you unplug the iPhone and play those songs from the phone itself the phone tells you it doesn't have an internet connection and can't stream. Plug it back into the car and you can play them. Some the tracks hadn't been downloaded onto the phone for at least 6 months and the phone has gone through various iOS updates since but the car can still find them. Bizarre.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:44 PM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST