F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > F30 DIYs and Coding Discussions > Upgrading from HU_ENTRY no BT to HU_ENTRY with BT+USB
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      09-22-2014, 12:24 PM   #1
garathf30
Registered
1
Rep
4
Posts

Drives: 2013 F30
Join Date: Sep 2014
Location: Singapore

iTrader: (0)

Post Upgrading from HU_ENTRY no BT to HU_ENTRY with BT+USB

Situation:

The F30 which I bought brand new did not come with either USB or Bluetooth. It was apparently manufactured with a L7 ENTRY unit (which maps to HU_ENTRY in coding terminology) with no bluetooth of USB capability.

Target:

To install Bluetooth telephone operation and USB audio

Chosen Pathway:

To Install a donor L7_ENTRY with USB and bluetooth telephone capability and do the VO coding (6NH) to enable the functionality.

Assumptions:
  • L7_Entry physical unit maps to HU_ENTRY ECU in coding environment
  • It would be possible to add a donor Head unit, VO code the car and get Bluetooth +USB to work with no FSC codes
  • Using F20 as the E-SYS target for my F30

Tools:
  • E-SYS - 3.25.3
  • PSdZ Version 4.9.0. - 20131128-1331 (as reported by Help-> About Esys)
  • Psdzdata - v51.3
  • Home made ENET Cable with
  • Donor L7_ENTRY with Bluetooth + USB

Thanks to:

Shawnsheridan and everyone else's effort who have brought these methods available to us.


Conclusion : (I have brought it to the front to assist people who might not be interested in the detail below.

It appears the HU_ENTRY needs a FSC code to enable USB and Bluetooth. AppID 129(0x81) - USB music, AppID 130(0x82) - Bluetooth handfree.

Thus if the HU_ENTRY unit (L7_entry) is coming from a donor car, it would not work in the target car without the above codes. I have no idea how one would obtain these codes.




TARGET (my) Vehicle Order before any modification:
169,205,216,240,249,258,2FH,423,428,497,4CG,507,52 0,548,699,825,850,853,861,880,8KK,8S3,8TM,8TN,925, 9AA
(note: I cannot see a Head unit entry in this VO, but this is how it was originally)



Journey:


Introducing the new unit
The donor L7_ENTRY was first introduced by plugging in the following in this order, 2 x diversity Antennas, Rosenberger APIX connector, Quadlock connector. At this point no coding had taken place.
The unit booted up and showed additional menus for Telephone, Contacts and BMW services (or such) which I did not previously have in my head unit.

When I navigated in to the Bluetooth section I could see the Donor units existing bluetooth pairings. At this point, pleasantly surprised that I didn’t need any coding, I proceeded to discover and add my phone in to the Head unit through the normal process. It synced contacts, call logs to the vehicle. At this point I tried to make a call through iDrive, and it worked (i.e. I could hear the dialled party).


Losing Bluetooth
As I continued to play with the system I noticed that data profile (next to the icon representing Hands Free Profile) was inactive. The tweaker in me immediately proceeded to enable it. After which, I went in to the BMW Services (or similarly named) main menu (between contacts and vehicle information options if memory serves) to see these services in action. Within this menu it had an option to update the service (or similar idea). It was promptly clicked, in return a screen indicating that I was trying to connect popped up. And was stuck at trying to connect. Though the iDrive system was fully responsive.

Trying to go back in to the bluetooth menu showed a spinning circle and nothing else. <image attached>. After this point the bluetooth menu showing the devices connected or disconnected has not appeared, though every other aspect of the iDrive system is operational.

Searching using my phone or laptop does not find the previously operational bluetooth client either.



VO coding
At this point I assumed that the ECUs have synced and finally noticed that this L7_ENTRY was not part of the original VO, thus shutting off some of its capability brought in from the donor vehicle.
E-sys was promptly fired up. Then noticed that CAFD was not showing in the HU_ENTRY ECU.

Initializing connection between CAR <-> E-sys
  • Select the correct TargetSelector,F020 -> Select “Connection via VIN" -> “Connect” -> OK.
  • Select "Expert Mode“ -> Click "Coding" -> In Vehicle Order Box, click "Read" button. -> Save

Used the following method to insert CAFD.

Quote:
Connect => Read FA (VO) => Activate FA (VO) => Read SVT (VCM) => Left-Click on HU_ENTRY => Click on "Detect CAF for SWE" => Select the CAFD from latest I-Level displayed => Select OK => Right-Click on HU_ENTRY (the ECU itself not the underlying CAFD) => Select CODE.
The following process was followed to VO code.

Quote:
• In Vehicle Order click Edit this will load FA-editor
• Expand the FAList folder system on left until SALAPA-Element is visible.
• Click on SALAPA-Element to select it.
• Added 6NH to this list -> Save Changes Icon at the upper right corner of the lower window
• Right-click on FA and select Calculate FP -> After FP is calculated, WITHOUT ERROR, saved the new FA.
• Select “Expert Mode” -> “VCM” -> Load saved FA file -> Calculate FP again
• “VCM Master” tab -> “Write FA FP” button -> New FA was written.
• Verified by re reading the VO after exiting E-sys
• Then read VCM and activate FA
• at the top of SVT i right-clicked the VIN and select Code, hopefully VO Coding the entire car (all ECU's).
Still, Trying to go back in to the bluetooth menu showed a spinning circle and nothing else. <see image above>.



VIN mismatch

In Comfort mode -> FSC Status I noticed that the VIN programmed in HU_ENTRY was still the DONOR vehicles VIN.

Code:
--> Read the state from "2" ECU(s) <--

EPS[DiagAddress=48(0x30)]
WBA3D32040F*TARGET*
RootCertStatus not available
SigSCertStatus not available
SWSigStatus accepted
SWTApplications
----------
AppID 131(0x83)
UpgradeIndex 1(0x01)
SWTType SWTclassic light
FSCStatus accepted
FSCCertStatus not available

HU_ENTRY[DiagAddress=99(0x63)]
WBA3E12060F*DONOR*
RootCertStatus accepted
SigSCertStatus accepted
SWSigStatus accepted
SWTApplications
----------
AppID 129(0x81)
UpgradeIndex 1(0x01)
SWTType SWTclassic full
FSCStatus rejected
FSCCertStatus accepted
----------
AppID 130(0x82)
UpgradeIndex 1(0x01)
SWTType SWTclassic full
FSCStatus rejected
FSCCertStatus accepted
----------
AppID 143(0x8F)
UpgradeIndex 1(0x01)
SWTType SWTclassic full
FSCStatus not available
FSCCertStatus accepted
----------
AppID 144(0x90)
UpgradeIndex 1(0x01)
SWTType SWTclassic full
FSCStatus not available
FSCCertStatus accepted
----------
AppID 111(0x6F)
UpgradeIndex 1(0x01)
SWTType SWTclassic full
FSCStatus not available
FSCCertStatus accepted
----------
AppID 27(0x1B)
UpgradeIndex 1(0x01)
SWTType SWTclassic full
FSCStatus not available
FSCCertStatus accepted

The next step was to see if changing the VIN to my TARGET VIN would solve the problem. I used the following process to Flash the firmware of the HU_ENTRY and thus changing the VIN.



Firmware Flashing Process.

Quote:
Go to Comfort Mode => TAL-Calculating
- Read and Save FA
- Activate FA
- Read and Save SVT Actual (SVT_ist)
- Create an SVT Target (SVT_soll)
• Under KIS/SVT Target Calculation Strategy, select Complete Flash
• Select I-Step (shipm.) to your original I-Level as read and shown in VCM I-Step (Shipment)
For the above I used the I-level Data I did the following
VCM Module => VCM Master Tab => click Read under I-Steps
• Select I-Step (target.) to the latest I-Level
• Do a KIS/SVT Target Calculation and Save as SVT_soll
- Do a TAL Calculation and Save (SVT_tal)

Go to Expert Mode => TAL-Processing
- Load TAL
- Load SVT Target (SVT_soll)
- Load or Read FA
- On the TAL, all ECU's identified as a Target for flashing are listed, but select the checkbox only for the desired ECU (HU_ENTRY).
- Make checkboxes at blFlash, swDeploy, cdDeploy, ibaDeploy
- Press Check software availability
- Press Start
The iDrive screen showed the L7_ENTRY going in to bootloader mode.

following the completion I got the following LOG for the flashing process

Code:
TAL execution started.
	ExecutionID=2014/09/21-14:32:27.553
	TAL-Execution finished with status: "Finished". [C207]
	TAL execution finished. Duration: "27min 34s". [C206]
	MSM update: Read current SVT. [C194]
	MSM update started. [C215]
	MSM update finished with error. [C217]
	Error in MSM Update:
	[] - [Exception - MSM - 10] Errors: TSL distribution failed due to an error: FsCSM with diagnostic address 0x63 reports error: error code: 'ERC_MSM_NO_RESPONSE_FROM_CSM', specific error code: 'empty' (F30 key exchange); FsCSM with diagnostic address 0x63 reports error: unknown error (F40 fingerprint exchange)
	Error during MSM update. [C214]
	Errors: TSL distribution failed due to an error: FsCSM with diagnostic address 0x63 reports error: error code: 'ERC_MSM_NO_RESPONSE_FROM_CSM', specific error code: 'empty' (F30 key exchange); FsCSM with diagnostic address 0x63 reports error: unknown error (F40 fingerprint exchange) [1352]
	VCM Update: Write FA to VCM. [C188]
	VCM Update: Write FP to VCM. [C190]
	VCM Update: Write integration levels to VCM. [C186]
	VCM Update: Read current SVT. [C191]
	VCM Update: Check current SVT with TAL. [C192]
	VCM Update: Write target SVT. [C193]
	VCM Update: Write FA to backup. [C189]
	VCM Update: Write integration levels to backup. [C187]
	VCM Update: finished. [C195]
Note: error code: 'ERC_MSM_NO_RESPONSE_FROM_CSM', specific error code: 'empty' (F30 key exchange); FsCSM with diagnostic address 0x63 reports error: unknown error (F40 fingerprint exchange) [1352]


After Flashing the following FSC status was shown. Note that the VIN of the HU_ENTRY ECU was showing the VIN of the TARGET (my) vehicle.

Code:
--> Read the state from "2" ECU(s) <--

EPS[DiagAddress=48(0x30)]
WBA3D32040F*TARGET*
RootCertStatus not available
SigSCertStatus not available
SWSigStatus accepted
SWTApplications
----------
AppID 131(0x83)
UpgradeIndex 1(0x01)
SWTType SWTclassic light
FSCStatus accepted
FSCCertStatus not available

HU_ENTRY[DiagAddress=99(0x63)]
WBA3D32040F*TARGET*
RootCertStatus accepted
SigSCertStatus accepted
SWSigStatus accepted
SWTApplications
----------
AppID 129(0x81)
UpgradeIndex 1(0x01)
SWTType SWTclassic full
FSCStatus rejected
FSCCertStatus accepted
----------
AppID 130(0x82)
UpgradeIndex 1(0x01)
SWTType SWTclassic full
FSCStatus rejected
FSCCertStatus accepted
----------
AppID 143(0x8F)
UpgradeIndex 1(0x01)
SWTType SWTclassic full
FSCStatus not available
FSCCertStatus accepted
----------
AppID 144(0x90)
UpgradeIndex 1(0x01)
SWTType SWTclassic full
FSCStatus not available
FSCCertStatus accepted
----------
AppID 111(0x6F)
UpgradeIndex 1(0x01)
SWTType SWTclassic full
FSCStatus not available
FSCCertStatus accepted
----------
AppID 27(0x1B)
UpgradeIndex 1(0x01)
SWTType SWTclassic full
FSCStatus not available
FSCCertStatus accepted

Then I proceeded to VO code the car following the above outlined process.
Still, Trying to go back in to the bluetooth menu showed a spinning circle and nothing else. <see image above>.


Analysis:

It appears that AppID 129 and 130 are rejecting the FSC codes now due to the change in the VIN. I am assuming that this could be a reason for Bluetooth not working, if it is considered an APP in the system.
(I found someone else eluding to this as well link, link

" AppID 129(0x81) should be USB music, and AppID 130(0x82) should be Bluetooth handfree. "

AppID 129(0x81)
UpgradeIndex 1(0x01)
SWTType SWTclassic full
FSCStatus rejected
FSCCertStatus accepted
----------
AppID 130(0x82)
UpgradeIndex 1(0x01)
SWTType SWTclassic full
FSCStatus rejected
FSCCertStatus accepted



FDL Coding

At this point I tried to go disable anything pertaining to Connected Drive, BMW Live or similar. Coded the updated FDL.

Still, Trying to go back in to the bluetooth menu showed a spinning circle and nothing else. <see image above>.


So Guys at the end of this I am out of explanations or ideas. I wouldn’t have bothered anyone normally, especially guys like shawn who seems to be quite busy with requests by the looks of it. But I am all out, looking for inspiration.





Thanks,
Attached Images
 
Appreciate 1
      09-22-2014, 08:23 PM   #2
shawnsheridan
Lieutenant General
shawnsheridan's Avatar
United_States
973
Rep
10,828
Posts

Drives: 2011 535i M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
All your assumptions are correct. Your dilemma is that the only way you can use the donor FSC Codes is to keep the Head Unit VIN as the donor VIN as if your change it to match the car VIN the FSC Codes will be rejected. The problem with this is that since the Head Unit and car have different VIN's, Activation will still fail.

This is why all Head Unit Retrofits have either OEM FSC Codes ordered form BMW AG matching the car's VIN or they use Donor FSC Codes / VIN and a CAN Filter / Activation Module to fool the car into thinking the Head Unit VIN matches the car's VIN.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Appreciate 0
      09-22-2014, 09:02 PM   #3
garathf30
Registered
1
Rep
4
Posts

Drives: 2013 F30
Join Date: Sep 2014
Location: Singapore

iTrader: (0)

Thanks. this was a fear.
is it possible to get FSC codes issued for my VIN at this point. ? a search on the forum shows a mention of Chang for such things. would I be able to get his or any other contacts email?

interestingly the code generators used for maps seem to be having a private key, even though the output code size is smaller for iDrive entry.
Appreciate 0
      09-23-2014, 12:06 PM   #4
garathf30
Registered
1
Rep
4
Posts

Drives: 2013 F30
Join Date: Sep 2014
Location: Singapore

iTrader: (0)

anyone?
Appreciate 0
      09-23-2014, 11:01 PM   #5
shawnsheridan
Lieutenant General
shawnsheridan's Avatar
United_States
973
Rep
10,828
Posts

Drives: 2011 535i M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
All FSC Codes with the exception of Map FSC Codes must be issued by BMW AG, and signed with their Private Encryption Key. Any seller, be it Chang or Dealer must order them form BMW, so you might as well start with your dealer, and see if they can order them.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Appreciate 0
      09-24-2014, 09:43 AM   #6
Aritaurus
Major
Aritaurus's Avatar
Canada
77
Rep
1,268
Posts

Drives: 2016 328i xDrive M Sport
Join Date: Apr 2010
Location: Toronto

iTrader: (0)

Garage List
This is new to me. It's actually possible to have an F30 with no 6NH????
Appreciate 0
      09-26-2014, 10:56 PM   #7
garathf30
Registered
1
Rep
4
Posts

Drives: 2013 F30
Join Date: Sep 2014
Location: Singapore

iTrader: (0)

Yes. its not usual however. apparently it was a mistake on the part of BMW, according to some posts ive seen on the matter.
Appreciate 0
      06-06-2016, 04:12 AM   #8
ilotas
New Member
0
Rep
5
Posts

Drives: 320d GT
Join Date: Jan 2016
Location: Greece

iTrader: (0)

Hi! I also own a F34_03/2013 with HU_ENTRY without BT+USB only AUX

Is it possible to use an emulator (Maybe the same one that is used for NBT units) to retrofit an HU_ENTRY with BT? will it work?

Same as garathf30 i only have code 698 (Area-Code 2 for DVD Regional) and 6WA (Extended Instrument Cluster). No Head Unit entries. If things work with an emulator which VO Codes do i have to insert for HU_ENTRY with BT+USB?

And a last one. Can i retrofit an NBT Unit?

Sorry for my English!

Thank You!

Last edited by ilotas; 06-06-2016 at 12:26 PM.
Appreciate 0
      06-07-2016, 04:32 PM   #9
ilotas
New Member
0
Rep
5
Posts

Drives: 320d GT
Join Date: Jan 2016
Location: Greece

iTrader: (0)

Exclamation

Any ??
Appreciate 0
      06-11-2016, 01:46 AM   #10
ilotas
New Member
0
Rep
5
Posts

Drives: 320d GT
Join Date: Jan 2016
Location: Greece

iTrader: (0)

Bump
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:34 AM.




f30post
f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST