F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > F30 DIYs and Coding Discussions > Check Engine Light after Coding
Extreme Power House
Post Reply
 
Thread Tools Search this Thread
      06-06-2013, 06:12 PM   #1
radiosmithy
New Member
0
Rep
17
Posts

 
Drives: 328i 2013
Join Date: May 2013
Location: Los Angeles

iTrader: (0)

Check Engine Light after Coding

Just successfully coded a lot of items from the F30 cheat sheet, but now my car is showing the Check Engine light. Has anyone experienced this before?

I checked iDrive and it says that everything is okay, but the light still remains. I coded the following:
  • Seatbelt Reminder Sound
    Legal Dislaimer
    Digital Speed in Cluster
    Sport+
    Sport Display / BHP/KW
    Indicator Amount
    ASS Last setting
    Fogs @ Welcome
    Sideview Mirror close/Open
    Orange Sidemarker Off
Appreciate 0
      06-06-2013, 06:46 PM   #2
radiosmithy
New Member
0
Rep
17
Posts

 
Drives: 328i 2013
Join Date: May 2013
Location: Los Angeles

iTrader: (0)

Just did some digging, and I found a method from ShawnSheridan to read/erase the CEL.

Assuming the fault condition no longer exists, to clear the fault code.

1) Launch C:\EDIABAS\Bin\TOOL32.EXE
2) Hit F3
3) Load C:\EDIABAS\Ecu\F01.PRG
4) In the "Select Job: F01" window, select FS_LOESCHEN_FUNKTIONAL
5) Hit F5
6) "Results" window should show "JOB_STATUS = OKAY"

Hopefully, Problem Solved.
Note: fs_lesen_funktional only read fault codes, FS_LOESCHEN_FUNKTIONAL will delete it.

I assume I should read the fault code first to see what it could be? And since CEL only pertains to emissions, I might take out the Sport+ mode and see if it goes away on its own in a couple days. In the meantime, any thoughts?
Appreciate 0
      06-06-2013, 09:28 PM   #3
shawnsheridan
Brigadier General
shawnsheridan's Avatar
United_States
89
Rep
4,898
Posts

 
Drives: 2011 535i M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by radiosmithy View Post
Just did some digging, and I found a method from ShawnSheridan to read/erase the CEL.

Assuming the fault condition no longer exists, to clear the fault code.

1) Launch C:\EDIABAS\Bin\TOOL32.EXE
2) Hit F3
3) Load C:\EDIABAS\Ecu\F01.PRG
4) In the "Select Job: F01" window, select FS_LOESCHEN_FUNKTIONAL
5) Hit F5
6) "Results" window should show "JOB_STATUS = OKAY"

Hopefully, Problem Solved.
Note: fs_lesen_funktional only read fault codes, FS_LOESCHEN_FUNKTIONAL will delete it.

I assume I should read the fault code first to see what it could be? And since CEL only pertains to emissions, I might take out the Sport+ mode and see if it goes away on its own in a couple days. In the meantime, any thoughts?
I wouldn't waste my time reading them. They are cryptic and wont mean anything to you. Just clear them and be done with it.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Appreciate 0
      06-06-2013, 11:58 PM   #4
radiosmithy
New Member
0
Rep
17
Posts

 
Drives: 328i 2013
Join Date: May 2013
Location: Los Angeles

iTrader: (0)

I disabled the Sport + and the CEL disappeared At the next startup.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:39 AM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST