F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics > OEM Y-cable does not work on my F30
RW Carbon
Post Reply
 
Thread Tools Search this Thread
      07-28-2012, 12:53 AM   #1
Aritaurus
Captain
 
Aritaurus's Avatar
 
Drives: 2012 328i Luxury Line
Join Date: Apr 2010
Location: Toronto

Posts: 886
iTrader: (0)

Garage List
OEM Y-cable does not work on my F30

I've tried just about everything I could to get my iPhone 4 to sync on my F30. I've read several posts on this forum and found out that if you don't have certain packages on your car, you will need the Y-cable.

I got an OEM BMW Y-cable off ebay and it is still not work. Does anyone have any idea why?

I have a Canadian 2012 328i with the premium package and nothing else.

The USB port will work fine if I insert a USB key but not with any an iPhone or iPod. I've already tried my iPhone 4 and my brother's iPhone 4S.

Should I just bring the car back to the dealer and see if there's a problem with the USB interface?
Aritaurus is offline   Canada
0
Reply With Quote
      07-28-2012, 08:23 AM   #2
PrazVT
Second Lieutenant
 
PrazVT's Avatar
 
Drives: '12 F30 Sport 6MT, 6/12 ED
Join Date: Apr 2012
Location: San Ramon, CA

Posts: 210
iTrader: (0)

Yeah - have them try one of their cables. It'll either be the cable or the port - hopefully it's just the cable!
__________________
On Order:
2015 228i M Sport + Track Handling Package
BSM / Coral Red / Aluminum Hex
6MT
Tech / Premium / Lighting / Heated Seats / HK / Enhanced USB+BT
PrazVT is online now   United_States
0
Reply With Quote
      07-28-2012, 02:22 PM   #3
vincethebmwguy
Registered
 
Drives: BMW 335i M Sport Sedan
Join Date: Jul 2012
Location: Middleburgh Hts Ohio

Posts: 1
iTrader: (0)

The new 2012 3 series does not require the "Y" cable. Just use a iPod cable!
vincethebmwguy is offline  
0
Reply With Quote
      07-28-2012, 11:07 PM   #4
rmnoonan
Private First Class
 
Drives: F30 328I (July '12 ED)
Join Date: Apr 2012
Location: Chicagoland

Posts: 142
iTrader: (0)

Not true. If you have BMW assist, you don't need y cable, otherwise you need it.
rmnoonan is offline  
0
Reply With Quote
      07-29-2012, 01:47 AM   #5
Number
 
Number's Avatar
 
Drives: ✚
Join Date: Feb 2012
Location: ✚ ✚

Posts: 1,201
iTrader: (1)

Quote:
Originally Posted by vincethebmwguy View Post
The new 2012 3 series does not require the "Y" cable. Just use a iPod cable!
Congrats on the 1st post but you're wrong. Like rmnoonan said... if you don't have BMW Assist, you need the y-cable.

OP- I suspect ebay as a source of bunk cables. Your dealer should have provided you with a y-cable. Have you checked you car manual? Mine was in there.
Number is offline  
0
Reply With Quote
      08-01-2012, 02:00 AM   #6
sigfe
New Member
 
Drives: F30
Join Date: Mar 2012
Location: Vietnam

Posts: 20
iTrader: (0)

I bought this one:

http://www.amazon.com/neXplug-Adapte.../dp/B004E5J61G

It works fine for me till now
sigfe is offline  
0
Reply With Quote
      08-10-2012, 09:59 AM   #7
CESIUM
Private
 
Drives: 2013 X3 35i Msport
Join Date: May 2012
Location: Ontario

Posts: 88
iTrader: (0)

Ya I have that same one sigfe, I got it off ebay for $13. Works fine
CESIUM is offline  
0
Reply With Quote
      08-15-2012, 10:49 AM   #8
BRN55
Private First Class
 
Drives: 2013 335i M Sport
Join Date: Jul 2012
Location: BR

Posts: 143
iTrader: (0)

Quote:
Originally Posted by rmnoonan View Post
Not true. If you have BMW assist, you don't need y cable, otherwise you need it.
Do you guys have the 8" screen/radio with extenced blueetooth *audio streaming*

I plug my iPad (newest) and it recognizes the iPad fine. I installed the BMW connected app, but doesn't connect trough the iPad even with WiFi to it. Well I wouldn't like to run my Galaxy S3 via bluetooth and the iPad trough USB, but I'll have to try and see if it works.

I though well maybe it's the iPad, so I tried it with my brother's iPhone 4s and doesn't even recognizes the phone. Same with my sister's iPhone 4s. We don't have BMW assist in Brazil.

Why would there be a need for this cable? I am a bit confused. What I am trying to do is get BMW Apps to work trough the iPhone on my 6.5" Professional radio/screen. My Galaxy S3 works, connects to BMW live and everything, activates the bluetooth tethering automatically when needed, but Android doesn't have the BMW Connected (which gives all Apps) etc ... frustrating as the S3 has great integration with this system already.
BRN55 is offline   Brazil
0
Reply With Quote
      08-15-2012, 09:22 PM   #9
tmehanna
New Member
 
Drives: 528i f10
Join Date: Aug 2012
Location: Egypt

Posts: 24
iTrader: (0)

Quote:
Originally Posted by TJF30 View Post
Do you guys have the 8" screen/radio with extenced blueetooth *audio streaming*

I plug my iPad (newest) and it recognizes the iPad fine. I installed the BMW connected app, but doesn't connect trough the iPad even with WiFi to it. Well I wouldn't like to run my Galaxy S3 via bluetooth and the iPad trough USB, but I'll have to try and see if it works.

I though well maybe it's the iPad, so I tried it with my brother's iPhone 4s and doesn't even recognizes the phone. Same with my sister's iPhone 4s. We don't have BMW assist in Brazil.

Why would there be a need for this cable? I am a bit confused. What I am trying to do is get BMW Apps to work trough the iPhone on my 6.5" Professional radio/screen. My Galaxy S3 works, connects to BMW live and everything, activates the bluetooth tethering automatically when needed, but Android doesn't have the BMW Connected (which gives all Apps) etc ... frustrating as the S3 has great integration with this system already.
I will assume you ordered BMW apps with your car. Try the white iPod / iPhone cable. Start BMW connected while pad/phone is connected to car and BMW apps running. There is also a diagnostic mode in BMW connected with simple instructions. Should that not work, you need the iPhone snap in adaptor with BMW app support. Note they have 2 versions of the snap In adaptor, one with and one without BMW apps support
tmehanna is offline  
0
Reply With Quote
      08-16-2012, 06:39 AM   #10
BRN55
Private First Class
 
Drives: 2013 335i M Sport
Join Date: Jul 2012
Location: BR

Posts: 143
iTrader: (0)

Can't order it here. They send whatever they order. I tried the white cable and nothing. Diagnostic also doesn't connect. I suspect my 6NH hands-free facility with usb interface will never allow me to have any BMW apps? I didn't know about the two versions for the snap in adaptor, but I'm talking about the Y cable ...

Last edited by BRN55; 08-16-2012 at 06:45 AM.
BRN55 is offline   Brazil
0
Reply With Quote
      08-16-2012, 05:37 PM   #11
rmnoonan
Private First Class
 
Drives: F30 328I (July '12 ED)
Join Date: Apr 2012
Location: Chicagoland

Posts: 142
iTrader: (0)

Quote:
Originally Posted by TJF30
Quote:
Originally Posted by rmnoonan View Post
Not true. If you have BMW assist, you don't need y cable, otherwise you need it.
Do you guys have the 8" screen/radio with extenced blueetooth *audio streaming*

I plug my iPad (newest) and it recognizes the iPad fine. I installed the BMW connected app, but doesn't connect trough the iPad even with WiFi to it. Well I wouldn't like to run my Galaxy S3 via bluetooth and the iPad trough USB, but I'll have to try and see if it works.

I though well maybe it's the iPad, so I tried it with my brother's iPhone 4s and doesn't even recognizes the phone. Same with my sister's iPhone 4s. We don't have BMW assist in Brazil.

Why would there be a need for this cable? I am a bit confused. What I am trying to do is get BMW Apps to work trough the iPhone on my 6.5" Professional radio/screen. My Galaxy S3 works, connects to BMW live and everything, activates the bluetooth tethering automatically when needed, but Android doesn't have the BMW Connected (which gives all Apps) etc ... frustrating as the S3 has great integration with this system already.
I do not. I have basic idrive and no advanced Bluetooth.
rmnoonan is offline  
0
Reply With Quote
      08-16-2012, 09:26 PM   #12
tmehanna
New Member
 
Drives: 528i f10
Join Date: Aug 2012
Location: Egypt

Posts: 24
iTrader: (0)

Quote:
Originally Posted by TJF30 View Post
Can't order it here. They send whatever they order. I tried the white cable and nothing. Diagnostic also doesn't connect. I suspect my 6NH hands-free facility with usb interface will never allow me to have any BMW apps? I didn't know about the two versions for the snap in adaptor, but I'm talking about the Y cable ...
Let me get this straight: does your idrive have connected drive and BMW apps or not? You cannot use BMW connected if your idrive does not have BMW apps. Not with a cable and not with a snap in adaptor.
tmehanna is offline  
0
Reply With Quote
      08-18-2012, 10:13 AM   #13
toph
Enlisted Member
 
toph's Avatar
 
Drives: 2012 F30 328i Sport 6MT
Join Date: May 2012
Location: Tampa

Posts: 30
iTrader: (0)

My F30 does not have BMW assist and I did have problems with the Y cable. Eventually, I rebooted the iPod and everything started to work. Before that, the USB selection said the iPod was an unsupported device.
__________________
2012 F30 328i Sport Line 6MT. Timeline
toph is offline   United_States
0
Reply With Quote
      08-19-2012, 03:56 PM   #14
TLennox
Enlisted Member
 
Drives: 335i
Join Date: Jun 2012
Location: Delaware

Posts: 45
iTrader: (0)

I have just picked up my 335 & everything is fantastic except can't get my iPhone 4 to play music through the USB. I have non Nav and no assist. It list my songs but no sound? Bad y cable or do I need to set something right? Works with the aux jack just no sound with USB?
TLennox is offline  
0
Reply With Quote
      08-19-2012, 04:47 PM   #15
tmehanna
New Member
 
Drives: 528i f10
Join Date: Aug 2012
Location: Egypt

Posts: 24
iTrader: (0)

Quote:
Originally Posted by TLennox View Post
I have just picked up my 335 & everything is fantastic except can't get my iPhone 4 to play music through the USB. I have non Nav and no assist. It list my songs but no sound? Bad y cable or do I need to set something right? Works with the aux jack just no sound with USB?
Did you try cranking up the volume?

Try rebooting your iPhone and if that doesn't work try the white iPhone cable
tmehanna is offline  
0
Reply With Quote
      08-19-2012, 05:31 PM   #16
rt10415
Private
 
rt10415's Avatar
 
Drives: F30 320d sport auto 18"
Join Date: Jun 2012
Location: Glasgow

Posts: 55
iTrader: (0)

Quote:
Originally Posted by TLennox View Post
I have just picked up my 335 & everything is fantastic except can't get my iPhone 4 to play music through the USB. I have non Nav and no assist. It list my songs but no sound? Bad y cable or do I need to set something right? Works with the aux jack just no sound with USB?
you need the y cable (splits in 2, one aux jack/one usb lead from ipod connector) not usb or aux jack on their own. The aux jack part provides the sound/usb connector provides idrive function.
__________________
F30 320d sport auto 18" alpine white
rt10415 is offline   United Kingdom
0
Reply With Quote
      08-19-2012, 05:44 PM   #17
tmehanna
New Member
 
Drives: 528i f10
Join Date: Aug 2012
Location: Egypt

Posts: 24
iTrader: (0)

Quote:
Originally Posted by rt10415 View Post
you need the y cable (splits in 2, one aux jack/one usb lead from ipod connector) not usb or aux jack on their own. The aux jack part provides the sound/usb connector provides idrive function.
Not true. Mine works just fine with the standard white iphone/ipod/ipad cable.
tmehanna is offline  
0
Reply With Quote
      08-19-2012, 05:55 PM   #18
rt10415
Private
 
rt10415's Avatar
 
Drives: F30 320d sport auto 18"
Join Date: Jun 2012
Location: Glasgow

Posts: 55
iTrader: (0)

Quote:
Originally Posted by tmehanna View Post
Not true. Mine works just fine with the standard white iphone/ipod/ipad cable.
you must have either nav or enhanced audio/usb option, this allows it to work with just the normal ipod cable.
__________________
F30 320d sport auto 18" alpine white
rt10415 is offline   United Kingdom
0
Reply With Quote
      08-19-2012, 06:35 PM   #19
TLennox
Enlisted Member
 
Drives: 335i
Join Date: Jun 2012
Location: Delaware

Posts: 45
iTrader: (0)

Quote:
Originally Posted by rt10415 View Post
you need the y cable (splits in 2, one aux jack/one usb lead from ipod connector) not usb or aux jack on their own. The aux jack part provides the sound/usb connector provides idrive function.
So you plug in both the USB & the aux jack at the same time to hear and control the play list on the idrive if you have non Nav/no assist?
TLennox is offline  
0
Reply With Quote
      08-19-2012, 06:48 PM   #20
tmehanna
New Member
 
Drives: 528i f10
Join Date: Aug 2012
Location: Egypt

Posts: 24
iTrader: (0)

Quote:
Originally Posted by rt10415 View Post
you must have either nav or enhanced audio/usb option, this allows it to work with just the normal ipod cable.
Have both
tmehanna is offline  
0
Reply With Quote
      08-19-2012, 08:25 PM   #21
toph
Enlisted Member
 
toph's Avatar
 
Drives: 2012 F30 328i Sport 6MT
Join Date: May 2012
Location: Tampa

Posts: 30
iTrader: (0)

Quote:
Originally Posted by TLennox View Post
So you plug in both the USB & the aux jack at the same time to hear and control the play list on the idrive if you have non Nav/no assist?
I have non Nav/no assist and have to plug in both to hear music and control my iPod.
__________________
2012 F30 328i Sport Line 6MT. Timeline
toph is offline   United_States
0
Reply With Quote
      08-19-2012, 08:39 PM   #22
TLennox
Enlisted Member
 
Drives: 335i
Join Date: Jun 2012
Location: Delaware

Posts: 45
iTrader: (0)

Quote:
Originally Posted by toph View Post
I have non Nav/no assist and have to plug in both to hear music and control my iPod.
Thanks!
TLennox is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:52 PM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST