F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > 2012-2019 BMW 3 and 4-Series Forums > General F30 Sedan / F32 Coupe / F36 Gran Coupe Forum > Heater failure/not working
Steve Thomas BMW
Post Reply
 
Thread Tools Search this Thread
      09-08-2012, 11:37 PM   #1
RPM90
Major General
105
Rep
6,095
Posts

 
Drives: 335i Msport w/sport AT
Join Date: Mar 2006
Location: Chicago

iTrader: (1)

Heater failure/not working

Only under 500 miles and looks like I'll be heading in for service.

Went for a drive tonight to check out some different settings with driver mode and adaptive suspension. It's in the upper 50's out here.
Set the HVAC temp to 73F, fan about half way. Cool air blowing.
Car was cold, so I kept driving.
A bit later as oil temp is between cold and normal, still no warm air.
Set the temp to 77F. Blowing cold air.
Set to full 84F. Cold air.
I even turned 'auto' mode on, no good.

While driving around with no heat, and testing out driver modes, the sport mode config would grey out the options, and I couldn't make changes.
I switched back to comfort then back to sport, the options were again available. A minute later they would grey out again.
Strange.
I'm sure this is one of those one-off failures, but just curious, anyone else try their heater in their newly delivered 3 series?

So now I've got no heat, sport config acting stupid, added to my steering/steering wheel not locking when I shut the car off.

Gotta get to the dealer.
While there I want them to fix my exhaust tips too.
When I went to pick up my 335i I noticed the tips weren't even, one of them sticks out about 1" farther than the other, and they aren't level. No biggie it's just cosmetic. I figured they could look at it if/when something big comes up. And now it has.
Oh well. It happens. I still love my 335i Msport.
Appreciate 0
      09-09-2012, 01:20 AM   #2
live4wknds
Private First Class
1
Rep
151
Posts

 
Drives: 2012 328i
Join Date: Apr 2012
Location: So Cal

iTrader: (0)

The steering wheel is supposed to lock? I don't believe mine locks when car is off.
Appreciate 0
      09-09-2012, 01:58 AM   #3
RDowson
Private
1
Rep
53
Posts

 
Drives: F30 320d M Sport
Join Date: Aug 2012
Location: Scotland

iTrader: (0)

Quote:
Originally Posted by live4wknds View Post
The steering wheel is supposed to lock? I don't believe mine locks when car is off.
The manual transmission version does. Apparently.
Appreciate 0
      09-09-2012, 02:12 AM   #4
ChiefBroady
Private
0
Rep
78
Posts

 
Drives: 2013 328i M sport
Join Date: Aug 2012
Location: Germany

iTrader: (0)

Quote:
Originally Posted by RDowson View Post
The manual transmission version does. Apparently.
Yes ist does. Mine locks itself quite audible when I climb out of the seat.
__________________
2013 328i M-Sport, EB2, DHP, Adaptive Xenon, CA and some other stuff.
Appreciate 0
      09-13-2012, 04:55 PM   #5
john08135i
Major
john08135i's Avatar
United_States
19
Rep
1,023
Posts

 
Drives: 2013 M Sport, 2010 bmw S1000RR
Join Date: Oct 2008
Location: Orlando

iTrader: (0)

Send a message via Yahoo to john08135i
My heater does not seem to work either.
__________________
M Sport Line Estoril Blue
Appreciate 0
      09-13-2012, 06:02 PM   #6
jpoet
Private First Class
United_States
5
Rep
133
Posts

 
Drives: 2013 335i M Sport
Join Date: Apr 2012
Location: New Mexico

iTrader: (0)

Quote:
Originally Posted by RPM90 View Post
Went for a drive tonight to check out some different settings with driver mode and adaptive suspension. It's in the upper 50's out here.
Set the HVAC temp to 73F, fan about half way. Cool air blowing.
Car was cold, so I kept driving.
A bit later as oil temp is between cold and normal, still no warm air.
Set the temp to 77F. Blowing cold air.
Set to full 84F. Cold air.
I even turned 'auto' mode on, no good.
You are a previous BMW owner, right? So you know that you also need to rotate the dial under the "central locking" button, from blue to red?

I only ask, because you didn't mention that step in your list.
__________________
2013 335i ///M Sport, Estoril Blue II, Dynamic Handling, Sport 8AT
Appreciate 0
      09-13-2012, 07:31 PM   #7
fotios335i
Major General
fotios335i's Avatar
United_States
121
Rep
6,769
Posts

 
Drives: 12 BSM F30 sport/msport 335i
Join Date: Jan 2007
Location: cape cod MA

iTrader: (61)

I dont want to offend but I think the temperaturre dial might be your issue. I atleast hope Im right. It makes a huge difference.
__________________

2012 335i sport to full Msport, M adaptive and vss, sport 8 AT, fully loaded, Black saphire, black dakota leather, mperformance carbon interior with shifter, M performance grills, rear spoiler, front splitter, side sill extensions, MPPK, MPE exhaust, morr alloys vs8.2's with michelin pss, p3 gauge, msport wheel, etc, etc
Appreciate 0
      09-13-2012, 10:17 PM   #8
dbpe
Private
United_States
1
Rep
61
Posts

 
Drives: 2013 335xi M Sport
Join Date: Jun 2012
Location: PA

iTrader: (0)

Same happened with mine, and it was intermittent - they diagnosed it and will replace the sticky water valve on Monday. No biggie - I'll just turn on the seats and steering wheel till then!
__________________
2013 335xi MSport Alpine White/Coral Red, ZMM/337/Walnut, ZPP, 2PE, ZDH, 2TB, ZTP, ZDA, ZDB, ZCW, HK, Shades
2013 X3 35i MSport Black Saphire Metallic/Chestnut, black grill, everything but lane departure, BMW trailer hitch
Appreciate 0
      10-30-2012, 07:52 AM   #9
john08135i
Major
john08135i's Avatar
United_States
19
Rep
1,023
Posts

 
Drives: 2013 M Sport, 2010 bmw S1000RR
Join Date: Oct 2008
Location: Orlando

iTrader: (0)

Send a message via Yahoo to john08135i
Mine works sometimes, but not most of the time when needed.

I set temp to 84+ and the dash dial to red..turn on fan cold air ..try different modes and cold air blows lower also.. tried automatic and see the AC light on all cold still..

sometimes after i power car off and back on it will run hot for a few min then back to cold...i love my car but having to go to the dealer all the time.
__________________
M Sport Line Estoril Blue
Appreciate 0
      10-30-2012, 08:43 AM   #10
Jamesons Viggen
Brigadier General
United_States
50
Rep
3,573
Posts

 
Drives: '98 M Roadster stg 2+ S/C
Join Date: Jul 2012
Location: Rochester Hills MI

iTrader: (3)

Mine did the same. They replaced the whole panel/unit.
__________________
'98 M Roadster S/C @11-16ps
'06 Saab 9-5 wagon 5mt Aero+ Tuned
Appreciate 0
      11-18-2012, 02:54 AM   #11
shutterlife
Private
2
Rep
83
Posts

 
Drives: F30 M Sport AW
Join Date: Aug 2012
Location: Orange County CA

iTrader: (0)

I'm having trouble as well. Set to auto, ac set to 84, center dial to red. Still cold. Dont really want to take it in, but anyone have an fixes yet?
Appreciate 0
      11-18-2012, 09:50 AM   #12
Jamesons Viggen
Brigadier General
United_States
50
Rep
3,573
Posts

 
Drives: '98 M Roadster stg 2+ S/C
Join Date: Jul 2012
Location: Rochester Hills MI

iTrader: (3)

Quote:
Originally Posted by shutterlife View Post
I'm having trouble as well. Set to auto, ac set to 84, center dial to red. Still cold. Dont really want to take it in, but anyone have an fixes yet?
You're going to have to take it in.

It took replaced the whole control unit to fix mine.
__________________
'98 M Roadster S/C @11-16ps
'06 Saab 9-5 wagon 5mt Aero+ Tuned
Appreciate 0
      11-18-2012, 11:45 AM   #13
shivaswrath
Brigadier General
shivaswrath's Avatar
United_States
43
Rep
3,144
Posts

 
Drives: 2012 335i
Join Date: Apr 2008
Location: Lost in NJ

iTrader: (3)

jesus HVAC issues on M Sports?
I'm a standard line, no issues yet in the Cold Northeast, 3000 miles. Makes me wonder WHAT they changed from lines to get this to be an issue...
__________________
2012 335i Mineral Gray
M Performance Whore: PPK|Exhaust|Brakes|Performance Suspension Struts & Springs|LSD|Black Kidney Grilles|CF Spoiler and Mirror Caps|Bav Stage 1|400Ms|BMWF30.com
Appreciate 0
      11-18-2012, 01:25 PM   #14
Jamesons Viggen
Brigadier General
United_States
50
Rep
3,573
Posts

 
Drives: '98 M Roadster stg 2+ S/C
Join Date: Jul 2012
Location: Rochester Hills MI

iTrader: (3)

Quote:
Originally Posted by shivaswrath View Post
jesus HVAC issues on M Sports?
I'm a standard line, no issues yet in the Cold Northeast, 3000 miles. Makes me wonder WHAT they changed from lines to get this to be an issue...
It has nothing to do with M-Sports, the HVAC is the same part number for all '13 lines.
__________________
'98 M Roadster S/C @11-16ps
'06 Saab 9-5 wagon 5mt Aero+ Tuned
Appreciate 0
      11-18-2012, 07:33 PM   #15
john08135i
Major
john08135i's Avatar
United_States
19
Rep
1,023
Posts

 
Drives: 2013 M Sport, 2010 bmw S1000RR
Join Date: Oct 2008
Location: Orlando

iTrader: (0)

Send a message via Yahoo to john08135i
I finally took mine in. The heat when the car was first started cold but if you turned it off for a bit and turned heat back n it did nit work at all just AC.
they recoded mine car and it works perfectly now..
__________________
M Sport Line Estoril Blue
Appreciate 0
      01-23-2013, 07:06 PM   #16
Cadi335i
Enlisted Member
United_States
1
Rep
46
Posts

 
Drives: 2013 BMW 335i M Sport
Join Date: Jul 2012
Location: Rhode Island

iTrader: (0)

For those of you who have heater issues, did you notice your engine running cold as well? I'm currently having the heater issue and the dealer has my car...
Appreciate 0
      01-24-2013, 10:54 PM   #17
Cadi335i
Enlisted Member
United_States
1
Rep
46
Posts

 
Drives: 2013 BMW 335i M Sport
Join Date: Jul 2012
Location: Rhode Island

iTrader: (0)

Any thoughts?
Appreciate 0
      01-24-2013, 11:26 PM   #18
Jamesons Viggen
Brigadier General
United_States
50
Rep
3,573
Posts

 
Drives: '98 M Roadster stg 2+ S/C
Join Date: Jul 2012
Location: Rochester Hills MI

iTrader: (3)

Quote:
Originally Posted by Cadi335i View Post
For those of you who have heater issues, did you notice your engine running cold as well? I'm currently having the heater issue and the dealer has my car...
My issue was independent of engine temp.
__________________
'98 M Roadster S/C @11-16ps
'06 Saab 9-5 wagon 5mt Aero+ Tuned
Appreciate 0
      02-15-2013, 02:58 AM   #19
SergioK
Second Lieutenant
2
Rep
209
Posts

 
Drives: F30 328i
Join Date: Oct 2012
Location: L.A.

iTrader: (0)

For those that had cold air blowing, was it cold as in ambient (exterior) air or was it as though the A/C compressor just kicked in?

It's been pretty mild here lately so in the morning I'll just run the hvac without the A/C compressor and temps set to about 72, center temp dial leaning towards red. Every once in a while I'd get a blast of very cold air, as if the A/C compressor started running even though the A/C button is not illuminated.
Appreciate 0
      02-15-2013, 11:35 AM   #20
BimmerBrova
New Member
BimmerBrova's Avatar
United_States
0
Rep
6
Posts

 
Drives: F30 335i M Sport
Join Date: Jan 2013
Location: PHX

iTrader: (0)

Quote:
Originally Posted by Cadi335i View Post
For those of you who have heater issues, did you notice your engine running cold as well? I'm currently having the heater issue and the dealer has my car...
I have had both happening at the same time also. At this point engine temp is just always pegged to cold no matter what. They have replaced several parts to no avail....
Appreciate 0
      02-24-2013, 10:24 AM   #21
Cadi335i
Enlisted Member
United_States
1
Rep
46
Posts

 
Drives: 2013 BMW 335i M Sport
Join Date: Jul 2012
Location: Rhode Island

iTrader: (0)

Quote:
Originally Posted by BimmerBrova View Post
I have had both happening at the same time also. At this point engine temp is just always pegged to cold no matter what. They have replaced several parts to no avail....
Are you still having the issue?
Appreciate 0
      03-01-2013, 05:29 PM   #22
BimmerBrova
New Member
BimmerBrova's Avatar
United_States
0
Rep
6
Posts

 
Drives: F30 335i M Sport
Join Date: Jan 2013
Location: PHX

iTrader: (0)

Quote:
Originally Posted by Cadi335i View Post
Are you still having the issue?
I was, but they might have found this particular issue. Its crazy. Will post when I know for sure!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:01 AM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST