F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > N20 and N26 Turbo Engine / Drivetrain / Exhaust Modifications > Turbo Lag w/ N26?
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      11-11-2012, 05:01 AM   #1
Adceleratus
Private First Class
Adceleratus's Avatar
United_States
3
Rep
104
Posts

 
Drives: 328i M Sport Estoril Blue II
Join Date: Oct 2012
Location: CA

iTrader: (1)

Turbo Lag w/ N26?

Hello,

Is a decent amount of turbo lag for the N20/N26 normal? It's hard for me to tell how substantial it is as I have never owned a turbo engine before. The only reason I am concerned is because I have read a bunch of articles that say there's no turbo lag with these engines. All of this assuming, of course that what I am experiencing is turbo lag. It feels like it takes a little less than a half a second to get going.
Appreciate 0
      11-11-2012, 08:55 AM   #2
Jbrock22
Second Lieutenant
Jbrock22's Avatar
4
Rep
205
Posts

 
Drives: 2012 328I Sport
Join Date: Feb 2007
Location: Eastern PA

iTrader: (0)

I have the N20 and no lag. Get your car checked out.
Appreciate 0
      11-11-2012, 04:10 PM   #3
Adceleratus
Private First Class
Adceleratus's Avatar
United_States
3
Rep
104
Posts

 
Drives: 328i M Sport Estoril Blue II
Join Date: Oct 2012
Location: CA

iTrader: (1)

Quote:
Originally Posted by Jbrock22 View Post
I have the N20 and no lag. Get your car checked out.
Do you drive a manual transmission? It just feels slow up to about 2000 rpm.
Appreciate 0
      11-11-2012, 04:28 PM   #4
Adceleratus
Private First Class
Adceleratus's Avatar
United_States
3
Rep
104
Posts

 
Drives: 328i M Sport Estoril Blue II
Join Date: Oct 2012
Location: CA

iTrader: (1)

Perhaps what I am experiencing isn't actually turbo lag?
Appreciate 0
      11-11-2012, 04:42 PM   #5
Jbrock22
Second Lieutenant
Jbrock22's Avatar
4
Rep
205
Posts

 
Drives: 2012 328I Sport
Join Date: Feb 2007
Location: Eastern PA

iTrader: (0)

Sport auto
Appreciate 0
      11-14-2012, 08:54 PM   #6
RPM90
Major General
105
Rep
6,095
Posts

 
Drives: 335i Msport w/sport AT
Join Date: Mar 2006
Location: Chicago

iTrader: (1)

Quote:
Originally Posted by Completenewb View Post
Hello,

Is a decent amount of turbo lag for the N20/N26 normal? It's hard for me to tell how substantial it is as I have never owned a turbo engine before. The only reason I am concerned is because I have read a bunch of articles that say there's no turbo lag with these engines. All of this assuming, of course that what I am experiencing is turbo lag. It feels like it takes a little less than a half a second to get going.
Does it feel the same in all driver modes ie: comfort, eco, sport?

The modes also control throttle response.
Comfort is ok, sport is very responsive and very nice.
Eco is awful. You give it throttle but it accelerates slowly as it's designed to help you save fuel. I HATE eco mode it zaps all feeling of driving a "sport" sedan.

Try sport mode and see how it feels.
Barring that being the issue, if you have a loose connection in the intake plumbing it will feel like lag as you're loosing boost.
These engines have very very little turbo lag, you shouldn't feel any lag really.
Again, if you're in eco mode acceleration will suck big time, and you'll be pushing the throttle deeper than you think you should just to get something close to "acceleration". I don't use eco at all.
Appreciate 0
      11-15-2012, 01:33 PM   #7
zeezz
Second Lieutenant
3
Rep
223
Posts

 
Drives: F30 328i Sport Line
Join Date: Jul 2011
Location: Bay Area, CA

iTrader: (0)

If you told me this car were a 6 cylinder with no turbos, I probably would not be able to tell you differently from behind the wheel.
Appreciate 0
      11-15-2012, 03:58 PM   #8
Adceleratus
Private First Class
Adceleratus's Avatar
United_States
3
Rep
104
Posts

 
Drives: 328i M Sport Estoril Blue II
Join Date: Oct 2012
Location: CA

iTrader: (1)

Yeah, I have been driving it in sport mode the whole time, and eco is indeed quite irritating. Throttle response seems alright, the car just feels noticeably slow up to about 1800 - 2000 rpm at which I feel a significant boost. I assume I should have my car checked out?

thanks for the responses guys!

Edit: Just wanted to add that it is only really noticeable when I push the throttle to a certain extent. Mostly when I floor it. In everyday driving I don't notice it that much but when I drive aggressively the problem very pronounced

Last edited by Adceleratus; 11-15-2012 at 04:47 PM.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:56 PM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST