F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Cosmetic and Lighting Modifications (exterior & interior) > Help - LED Bulbs Flicker and Present Error When Xenons Are On
European Auto Source
Post Reply
 
Thread Tools Search this Thread
      01-31-2015, 11:10 AM   #1
Timbits93
Second Lieutenant
Canada
7
Rep
233
Posts

Drives: 2013 BMW 328i xDrive Sportline
Join Date: Sep 2013
Location: Vancouver, BC

iTrader: (0)

Help - LED Bulbs Flicker and Present Error When Xenons Are On

Hi Guys,

I have this strange issue going on. Bought some bulbs from Horizon LEDs and replaced my turn signals front and back. I coded out the Cold and Warm checks as well as setting those bulbs to LED type. However for some strange reason when the Xenons are on (Auto or ON position), it gives my a Lighting Malfunction error as well as flickering/resetting lighting level of my Xenons and Turn Signal bulbs.

Refitted my original PY21W bulbs and no error or flickering of my Xenons. That narrows down that my FEM module isn't fried. But at least now I can drive safely when its dark... Rear signals are fine though (P21W)

So what gives? I've sent an email to the vendor to see if the bulbs are defective and for a new set. However I find it strange that they work just fine unless they are used as Parking Lights essentially and paired with the Xenons being on...

Thanks!
__________________
Present: 2013 BMW 328i xDrive Sport Line in Havanna Metallic/Black Dakota w/ Fineline Anthracite - Premium/Executive/BMW Apps/BMW Assist with Ext BT - Mods - CA Mirrors/Cornering Lights/Sport Config/2TB SAT + LC /RTTI RDS-TMC/Spoiler/F32 HVAC/SS Pedals

Past: 2007 Infiniti G35S in Black Obsidian - 105,250km
Appreciate 0
      01-31-2015, 11:20 AM   #2
tboooe
Major
tboooe's Avatar
69
Rep
1,179
Posts

Drives: 428i Gran Coupe
Join Date: Dec 2014
Location: The OC!

iTrader: (0)

Good to know. I just purchased a set of LEDs from Horizon as well but have not received them. Are you working with Zain? What part number did you purchase? 50w? I have my car coded such that my front turn signals are only on when I use the blinkers. Are you having the same issue with the rear turn signals?
Appreciate 0
      01-31-2015, 11:33 AM   #3
Timbits93
Second Lieutenant
Canada
7
Rep
233
Posts

Drives: 2013 BMW 328i xDrive Sportline
Join Date: Sep 2013
Location: Vancouver, BC

iTrader: (0)

I just received them last night and and sent a mail to Zain this morning. It looks as though I may have to open up an RMA though but I'm just asking him to see what the issue may be (if the bulb is at fault).

I purchased the 30W ones, and do not have issues with the rear turn signals. Rear ones work flawlessly. So not too sure whats wrong with the front when its all coded out unless these bulbs throw errors if they are constantly on rather than just blinking.

The real question is if anyone with any other LEDs installed with the front signals and still have them as parking lights cause a whole front lighting malfunction error and flicker. Because they work as turn signals just fine without error.

Perhaps I just need to code out the parking lights for the front corners but it still serves a good FYI if anyone wants to maintain those parking lights/side markers.
__________________
Present: 2013 BMW 328i xDrive Sport Line in Havanna Metallic/Black Dakota w/ Fineline Anthracite - Premium/Executive/BMW Apps/BMW Assist with Ext BT - Mods - CA Mirrors/Cornering Lights/Sport Config/2TB SAT + LC /RTTI RDS-TMC/Spoiler/F32 HVAC/SS Pedals

Past: 2007 Infiniti G35S in Black Obsidian - 105,250km
Appreciate 0
      01-31-2015, 11:45 AM   #4
tboooe
Major
tboooe's Avatar
69
Rep
1,179
Posts

Drives: 428i Gran Coupe
Join Date: Dec 2014
Location: The OC!

iTrader: (0)

Others have purchased LEDs from Weisslicht and do not seem to have the same problems you described.

It would be interesting to code out the turn signals from being on all the time and see if the issue you are having continues when you turn on the LEDs as just turn signals?
Appreciate 0
      01-31-2015, 12:44 PM   #5
Timbits93
Second Lieutenant
Canada
7
Rep
233
Posts

Drives: 2013 BMW 328i xDrive Sportline
Join Date: Sep 2013
Location: Vancouver, BC

iTrader: (0)

While it would be interesting, it should still function with the entire vehicle system when used as the side marker (dimmed on). It's strange since when used as Welcome Lights, they don't flicker but it only happens when the car is on...

I'll swap it and try it anyways since well its daytime anyways and have the garage to test them in. Will report back in a little.
__________________
Present: 2013 BMW 328i xDrive Sport Line in Havanna Metallic/Black Dakota w/ Fineline Anthracite - Premium/Executive/BMW Apps/BMW Assist with Ext BT - Mods - CA Mirrors/Cornering Lights/Sport Config/2TB SAT + LC /RTTI RDS-TMC/Spoiler/F32 HVAC/SS Pedals

Past: 2007 Infiniti G35S in Black Obsidian - 105,250km
Appreciate 0
      01-31-2015, 01:06 PM   #6
tboooe
Major
tboooe's Avatar
69
Rep
1,179
Posts

Drives: 428i Gran Coupe
Join Date: Dec 2014
Location: The OC!

iTrader: (0)

Quote:
Originally Posted by Timbits93 View Post
While it would be interesting, it should still function with the entire vehicle system when used as the side marker (dimmed on).
Agreed 100%. Hopefully Zain has some feedback.

Looking forward to what you find out when you code out the turn signals being on all the time.

BTW, I asked Zain if I should get the 30 or 50w. He recommended the 50w as he said they more closely resembled the OEM LEDs. I am worried that I am going to blind people now when I turn or switch lanes!
Appreciate 0
      01-31-2015, 01:15 PM   #7
Timbits93
Second Lieutenant
Canada
7
Rep
233
Posts

Drives: 2013 BMW 328i xDrive Sportline
Join Date: Sep 2013
Location: Vancouver, BC

iTrader: (0)

Quote:
Originally Posted by tboooe View Post
Agreed 100%. Hopefully Zain has some feedback.

Looking forward to what you find out when you code out the turn signals being on all the time.
Well installed them back in, first without turning the side markers off (made a video to show whats happening) and then with. No miracle happened without turning them off, still throws error and flickering my Xenons... Turning them off though, so far no issues with it. Signals work as intended too. Heck when it was giving me errors with the side markers, the front signals wouldn't light up when you put the signal on... So least if I want to not bother with returns and stuff, the LEDs work without the side marker function.

It's still a pain though since while there's nothing wrong with having the side markers off, it's just not working with them dimmed. It could perhaps be some more coding that many haven't looked into such as the voltage it's set at, since people with the F32 LED fog lights had to change the voltage from 13.4V to 100% as they experienced flickering when left constantly on - so far my F32 LED fogs are fine and didn't experience flicker and had coded the voltage at a later time.

EDIT: Here's the video I've taken - bare with me, it's still processing.



Quote:
Originally Posted by tboooe View Post
BTW, I asked Zain if I should get the 30 or 50w. He recommended the 50w as he said they more closely resembled the OEM LEDs. I am worried that I am going to blind people now when I turn or switch lanes!
I think the 30W seems sufficient enough. As long as they are the same or brighter than the OEM bulbs (they are), it's all good!
__________________
Present: 2013 BMW 328i xDrive Sport Line in Havanna Metallic/Black Dakota w/ Fineline Anthracite - Premium/Executive/BMW Apps/BMW Assist with Ext BT - Mods - CA Mirrors/Cornering Lights/Sport Config/2TB SAT + LC /RTTI RDS-TMC/Spoiler/F32 HVAC/SS Pedals

Past: 2007 Infiniti G35S in Black Obsidian - 105,250km

Last edited by Timbits93; 01-31-2015 at 01:51 PM. Reason: Video of Malfunction
Appreciate 0
      01-31-2015, 03:04 PM   #8
tboooe
Major
tboooe's Avatar
69
Rep
1,179
Posts

Drives: 428i Gran Coupe
Join Date: Dec 2014
Location: The OC!

iTrader: (0)

Thank you for testing. So no issues using the LEDs just as turn signals/blinkers with the Xeonon lights on?
Appreciate 0
      01-31-2015, 03:11 PM   #9
Timbits93
Second Lieutenant
Canada
7
Rep
233
Posts

Drives: 2013 BMW 328i xDrive Sportline
Join Date: Sep 2013
Location: Vancouver, BC

iTrader: (0)

Yep, no issues whatsoever. Drove for a good hour today with xenons on and side markers off. Turn signals activate as is and nice and amber (its more orange compared to the OEM bulbs.)

I did a little digging, I think the flickering is more to do with the voltage it's getting when dimmed. Probably not meeting the built in resistor's voltage requirements when dimmed. As I said, will look into it as it does it with just one bulb in it too (tried several scenerios) when dimmed/used as side markers.

So either I can be the guinea pig and find the value that correlates to the dimmed voltage or just have it off until someone else figures out which one to change!
__________________
Present: 2013 BMW 328i xDrive Sport Line in Havanna Metallic/Black Dakota w/ Fineline Anthracite - Premium/Executive/BMW Apps/BMW Assist with Ext BT - Mods - CA Mirrors/Cornering Lights/Sport Config/2TB SAT + LC /RTTI RDS-TMC/Spoiler/F32 HVAC/SS Pedals

Past: 2007 Infiniti G35S in Black Obsidian - 105,250km
Appreciate 0
      02-02-2015, 12:27 PM   #10
tboooe
Major
tboooe's Avatar
69
Rep
1,179
Posts

Drives: 428i Gran Coupe
Join Date: Dec 2014
Location: The OC!

iTrader: (0)

Any update from Zain?
Appreciate 0
      02-03-2015, 10:09 AM   #11
Timbits93
Second Lieutenant
Canada
7
Rep
233
Posts

Drives: 2013 BMW 328i xDrive Sportline
Join Date: Sep 2013
Location: Vancouver, BC

iTrader: (0)

Still waiting on a response after he acknowledged my email in regards to the issues with the bulbs. Perhaps should just open an RMA but I wanted to wait and hear back before I do that.

Also I found it strange that while doing more testing, one bulb shows the error almost instantly along with the flickering of the lights, however the other will still show an error but about 1-2 minutes after being on. It is NOT the case once either light is on the passenger side. However it shouldn't be a FEM Body issue given that the OEM bulbs don't pull an error. Though it's strange the error shows up when only in the driver's side but with those discrepancies with either being instant or 1-2 minutes depending on the bulb installed.
__________________
Present: 2013 BMW 328i xDrive Sport Line in Havanna Metallic/Black Dakota w/ Fineline Anthracite - Premium/Executive/BMW Apps/BMW Assist with Ext BT - Mods - CA Mirrors/Cornering Lights/Sport Config/2TB SAT + LC /RTTI RDS-TMC/Spoiler/F32 HVAC/SS Pedals

Past: 2007 Infiniti G35S in Black Obsidian - 105,250km
Appreciate 0
      02-03-2015, 10:14 AM   #12
tboooe
Major
tboooe's Avatar
69
Rep
1,179
Posts

Drives: 428i Gran Coupe
Join Date: Dec 2014
Location: The OC!

iTrader: (0)

Thank you for the update. Maybe the strange behavior you noticed shows that perhaps its a faulty bulb versus the bulbs not working at all for our cars? Maybe I am being too optimistic. I hope Zain has something positive to say. My bulbs from Horizon should be arriving tomorrow. I will code back on my turn signal lights to see if I have the error like you.
Appreciate 0
      02-04-2015, 09:55 AM   #13
Timbits93
Second Lieutenant
Canada
7
Rep
233
Posts

Drives: 2013 BMW 328i xDrive Sportline
Join Date: Sep 2013
Location: Vancouver, BC

iTrader: (0)

Quote:
Originally Posted by tboooe View Post
Thank you for the update. Maybe the strange behavior you noticed shows that perhaps its a faulty bulb versus the bulbs not working at all for our cars? Maybe I am being too optimistic. I hope Zain has something positive to say. My bulbs from Horizon should be arriving tomorrow. I will code back on my turn signal lights to see if I have the error like you.
Given that they've posted multiple F30s with those LEDs, it's probably faulty bulbs. Zain is going to replace both bulbs for me so hopefully those new ones won't give me the same problems!

Looking forward to your update with your 50W bulbs.
__________________
Present: 2013 BMW 328i xDrive Sport Line in Havanna Metallic/Black Dakota w/ Fineline Anthracite - Premium/Executive/BMW Apps/BMW Assist with Ext BT - Mods - CA Mirrors/Cornering Lights/Sport Config/2TB SAT + LC /RTTI RDS-TMC/Spoiler/F32 HVAC/SS Pedals

Past: 2007 Infiniti G35S in Black Obsidian - 105,250km
Appreciate 0
      02-04-2015, 10:09 AM   #14
tboooe
Major
tboooe's Avatar
69
Rep
1,179
Posts

Drives: 428i Gran Coupe
Join Date: Dec 2014
Location: The OC!

iTrader: (0)

Quote:
Originally Posted by Timbits93 View Post
Given that they've posted multiple F30s with those LEDs, it's probably faulty bulbs. Zain is going to replace both bulbs for me so hopefully those new ones won't give me the same problems!

Looking forward to your update with your 50W bulbs.
AWESOME. Glad to know Zain took care of you!

I am nervous about my 50W bulbs blinding everyone!!!!!
Appreciate 0
      02-12-2015, 04:54 PM   #15
Timbits93
Second Lieutenant
Canada
7
Rep
233
Posts

Drives: 2013 BMW 328i xDrive Sportline
Join Date: Sep 2013
Location: Vancouver, BC

iTrader: (0)

Did you bulbs finally arrive?

My replacements did, they sent me 50Ws this time though, see how much brighter they are... and hopefully they don't flicker
__________________
Present: 2013 BMW 328i xDrive Sport Line in Havanna Metallic/Black Dakota w/ Fineline Anthracite - Premium/Executive/BMW Apps/BMW Assist with Ext BT - Mods - CA Mirrors/Cornering Lights/Sport Config/2TB SAT + LC /RTTI RDS-TMC/Spoiler/F32 HVAC/SS Pedals

Past: 2007 Infiniti G35S in Black Obsidian - 105,250km
Appreciate 0
      02-12-2015, 05:24 PM   #16
tboooe
Major
tboooe's Avatar
69
Rep
1,179
Posts

Drives: 428i Gran Coupe
Join Date: Dec 2014
Location: The OC!

iTrader: (0)

Quote:
Originally Posted by Timbits93 View Post
Did you bulbs finally arrive?

My replacements did, they sent me 50Ws this time though, see how much brighter they are... and hopefully they don't flicker
Glad they arrived! I am planning on installing my set this weekend. Let me know if they work for you.
__________________
My build thread

2015 428i GC - Alpine White - M Sport
Appreciate 0
      02-12-2015, 06:50 PM   #17
Timbits93
Second Lieutenant
Canada
7
Rep
233
Posts

Drives: 2013 BMW 328i xDrive Sportline
Join Date: Sep 2013
Location: Vancouver, BC

iTrader: (0)

Installed the 50W bulbs. Work just fine, no flicker. Guess the 30W ones were defective. Pretty bright btw.
__________________
Present: 2013 BMW 328i xDrive Sport Line in Havanna Metallic/Black Dakota w/ Fineline Anthracite - Premium/Executive/BMW Apps/BMW Assist with Ext BT - Mods - CA Mirrors/Cornering Lights/Sport Config/2TB SAT + LC /RTTI RDS-TMC/Spoiler/F32 HVAC/SS Pedals

Past: 2007 Infiniti G35S in Black Obsidian - 105,250km
Appreciate 0
      02-12-2015, 07:10 PM   #18
tboooe
Major
tboooe's Avatar
69
Rep
1,179
Posts

Drives: 428i Gran Coupe
Join Date: Dec 2014
Location: The OC!

iTrader: (0)

Quote:
Originally Posted by Timbits93 View Post
Installed the 50W bulbs. Work just fine, no flicker. Guess the 30W ones were defective. Pretty bright btw.
Great to hear! I installed the brake and rear turn signal bulbs from Horizon last week. They work great. The rear turn signal is 50w as well and as you mentioned they are bright! The brake light is a little less bright than the stock bulb so I will be replacing that with the 50w version. I'm also getting the reverse lights too.
__________________
My build thread

2015 428i GC - Alpine White - M Sport
Appreciate 0
      02-12-2015, 11:41 PM   #19
Timbits93
Second Lieutenant
Canada
7
Rep
233
Posts

Drives: 2013 BMW 328i xDrive Sportline
Join Date: Sep 2013
Location: Vancouver, BC

iTrader: (0)

I'm still thinking if I should replace the brake and reverse bulbs. Only thing with the brakes is that can't replace the inner dynamic ones given the "unique" bulb type - which btw I programmed for flashing when hard/emergency braking rather than just light on.

Actually I have 30W rear turn signals, sometimes wishing I got the 50W instead. But at night, it still lights up signs 1.5 blocks away!
__________________
Present: 2013 BMW 328i xDrive Sport Line in Havanna Metallic/Black Dakota w/ Fineline Anthracite - Premium/Executive/BMW Apps/BMW Assist with Ext BT - Mods - CA Mirrors/Cornering Lights/Sport Config/2TB SAT + LC /RTTI RDS-TMC/Spoiler/F32 HVAC/SS Pedals

Past: 2007 Infiniti G35S in Black Obsidian - 105,250km
Appreciate 0
      02-13-2015, 09:41 AM   #20
tboooe
Major
tboooe's Avatar
69
Rep
1,179
Posts

Drives: 428i Gran Coupe
Join Date: Dec 2014
Location: The OC!

iTrader: (0)

Quote:
Originally Posted by Timbits93 View Post
I'm still thinking if I should replace the brake and reverse bulbs. Only thing with the brakes is that can't replace the inner dynamic ones given the "unique" bulb type - which btw I programmed for flashing when hard/emergency braking rather than just light on.

Actually I have 30W rear turn signals, sometimes wishing I got the 50W instead. But at night, it still lights up signs 1.5 blocks away!
Yeah I am not going to replace the inner ones since I rarely have a hard braking issue. Also, I think Zain said he had LEDs for the inner brakes too?
__________________
My build thread

2015 428i GC - Alpine White - M Sport
Appreciate 0
      02-13-2015, 03:27 PM   #21
tboooe
Major
tboooe's Avatar
69
Rep
1,179
Posts

Drives: 428i Gran Coupe
Join Date: Dec 2014
Location: The OC!

iTrader: (0)

Timbits93 can you please let me know the part # you got from Horizon for the front turn signals? I got the BAU15S-50W. I just tried to install mine and my LED bulb is way to big to fit in the bulb base.

EDIT: looks like Zain forgot to send me the black plastic base that the new LED bulb needs to fit in. I assume you got the bases?

EDIT #2: it seems the bulb for F30 3 series can be removed from the base. The entire assembly with the base has to be replaced for the 4 series. Not sure why Zain didnt know this.
__________________
My build thread

2015 428i GC - Alpine White - M Sport

Last edited by tboooe; 02-13-2015 at 07:26 PM.
Appreciate 0
      02-13-2015, 08:16 PM   #22
Timbits93
Second Lieutenant
Canada
7
Rep
233
Posts

Drives: 2013 BMW 328i xDrive Sportline
Join Date: Sep 2013
Location: Vancouver, BC

iTrader: (0)

I was going to respond earlier but I was at work. But yeah that pretty much sums it up. Base on the F30 can be removed.

EDIT: Did a little research, the F32 uses PY24W for the front turn signals. Horizon stocks them - http://www.horizonleds.co.uk/cree-le...-led-50w-amber
__________________
Present: 2013 BMW 328i xDrive Sport Line in Havanna Metallic/Black Dakota w/ Fineline Anthracite - Premium/Executive/BMW Apps/BMW Assist with Ext BT - Mods - CA Mirrors/Cornering Lights/Sport Config/2TB SAT + LC /RTTI RDS-TMC/Spoiler/F32 HVAC/SS Pedals

Past: 2007 Infiniti G35S in Black Obsidian - 105,250km
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:09 AM.




f30post
f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST