F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > 2012-2019 BMW 3 and 4-Series Forums > General F30 Sedan / F32 Coupe / F36 Gran Coupe Forum > Emission warning light
Post Reply
 
Thread Tools Search this Thread
      01-06-2013, 05:15 PM   #1
howiegu
Member
 
howiegu's Avatar
 
Drives: 13' 335xi Msport
Join Date: Oct 2012
Location: New England

Posts: 126
iTrader: (0)

Emission warning light

The yellow emission light stays on today. System check all green in iDrive and OK.

Before going to the dealer, anyone had same issue? If so, what's the remedy to fix it?

BTW, 13' 335xi, Msport, Sept. 21st production.

Thanks
howiegu is offline   United_States
0
Reply With Quote
      01-06-2013, 06:15 PM   #2
raceing86
Private First Class
 
raceing86's Avatar
 
Drives: '13 335i Sport Melb. Red
Join Date: Apr 2009
Location: Savannah, GA

Posts: 158
iTrader: (0)

Garage List
2013 BMW 335i  [5.00]
Haven't had this issue, but advance auto will scan your car for free and tell you what code it's throwing.
__________________
2013 335i F30 Melb Red Dakota Black/Red highlight
Sport Line, Driver Assistance, Driver Assistance Plus, Dynamic Handling, Premium Pkg, Tech Pkg, Sport Auto Trans, Active Cruise Control, Heated Front Seats, Auto High Beams, Parking Assistant, Harmon Kardon
raceing86 is offline   United_States
0
Reply With Quote
      01-26-2013, 03:15 PM   #3
The Economist
Private
 
Drives: 2013 335i "M-Sport" MPPK MPE
Join Date: May 2012
Location: Toronto

Posts: 72
iTrader: (0)

If you don't mind me asking, what was the issue? (Mine just popped up randomly today; no issues in iDrive)
The Economist is offline  
0
Reply With Quote
      01-26-2013, 03:45 PM   #4
Teemo Panda
*Bimmerpost Plasti Dip Guru*
 
Teemo Panda's Avatar
 
Drives: E53, E46-M3, E70, F25-X3
Join Date: Jun 2011
Location: New Jersey (NJ)

Posts: 1,178
iTrader: (0)

Garage List
2013 BMW X3  [2.83]
I had my F25 serviced 4x in 2months because the Engine light keeps comming up.

So BMWNA agreed to replace the car for a new car, equal to the value when I purchased the car.

Hopefully you would have a new set of wheels soon :P
__________________
Teemo Panda is offline   United_States
0
Reply With Quote
      02-18-2013, 10:05 AM   #5
SamS
Brigadier General
 
SamS's Avatar
 
Drives: 2013 ActiveHybrid 3
Join Date: Jul 2010
Location: Dallas, TX

Posts: 4,527
iTrader: (0)

Got this light today, also nothing showing in iDrive. 1700 miles on the clock. Still drives OK, and I'm trying to get a service appointment scheduled.

What was the resolution?
__________________
SamS is offline  
0
Reply With Quote
      02-23-2013, 03:01 PM   #6
The Economist
Private
 
Drives: 2013 335i "M-Sport" MPPK MPE
Join Date: May 2012
Location: Toronto

Posts: 72
iTrader: (0)

I dropped off my car two days ago and received it today. The issue with the emissions / engine warning light was some "corrosion" with the "wires around the gas tank". Didn't probe further than that as I was running late, but it is what it is... so, if your light comes on, definitely get it checked out sooner than later.

Also, when I dropped the car off they notified me that there was an M Performance exhaust in stock; as such, I had it installed. Sounds nice.
The Economist is offline  
0
Reply With Quote
      03-30-2013, 10:58 AM   #7
elistan
First Lieutenant
 
Drives: F30 328i, AP1 S2000
Join Date: Sep 2012
Location: Longmont, CO

Posts: 317
iTrader: (0)

Any further experiences with this incident? My CEL turned on last night. Car drove fine, no messages in iDrive.
elistan is offline   United_States
0
Reply With Quote
      04-05-2013, 10:50 AM   #8
elistan
First Lieutenant
 
Drives: F30 328i, AP1 S2000
Join Date: Sep 2012
Location: Longmont, CO

Posts: 317
iTrader: (0)

Fixed it (so far) myself very easily. I undid and reseated the gas cap. No more light the next time I fired up the engine. If the light stays off, something must have gone wrong last time I filled up with fuel. If it comes back, there must be a little vapor leak somewhere in the fuel system.
elistan is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:50 PM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST