F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics > Center Console USB Issue
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      03-28-2016, 11:12 AM   #1
tjyates08
New Member
United_States
1
Rep
11
Posts

Drives: 2015 335i M Sport w/ MPPK
Join Date: May 2014
Location: Houston, TX

iTrader: (0)

Center Console USB Issue

Sorry if this has come up before, I have searched and searched and not found a thread associated with the issue I'm having.

I have a 2015 335i M Sport I recently purchased new as a left over 2015 Inventory.

The issue I'm having is my USB port in my center console acts as if it has a short in it.... my phone will connect and disconnect.... sometimes it won't do it... other times it's non stop. I thought maybe it was my cable... but I recently had a loaner and the cable I have worked flawlessly.

I decided to plug in my old ipod Nano... it does the same thing.

The most annoying part of it all is that when it does drop connectivity, it even makes my bluetooth lose connectivity for audio... it will say that my phone is connected, both the phone and music logo are lit up in the bluetooth menu... phone says it's connected... but in the media menu under the bluetooth option it says no device connected... It's like it freezes the entire idrive temporarily.


Anybody else experienced similar behavior out their USB connectivity?
Appreciate 0
      03-28-2016, 01:02 PM   #2
MickAv8r
Lieutenant
MickAv8r's Avatar
United_States
57
Rep
541
Posts

Drives: 2014 EBII 328ix
Join Date: Mar 2014
Location: New Hampster

iTrader: (0)

What phone and os?
__________________
Well weathered leather, hot metal and oil, the scented country air.
Sunlight on chrome, the blur of the landscape, every nerve aware!


2014 328ix EBII - Sport AT, Lighting Pkg, Black Dakota, Moonroof, Navigation, Heated Seats, HK Audio, Driver Assistance, Sport Pedals, Dinan Springs
Appreciate 0
      03-28-2016, 01:02 PM   #3
tjyates08
New Member
United_States
1
Rep
11
Posts

Drives: 2015 335i M Sport w/ MPPK
Join Date: May 2014
Location: Houston, TX

iTrader: (0)

iPhone 6s ios8
Appreciate 0
      03-28-2016, 01:03 PM   #4
tjyates08
New Member
United_States
1
Rep
11
Posts

Drives: 2015 335i M Sport w/ MPPK
Join Date: May 2014
Location: Houston, TX

iTrader: (0)

Does it with my 10 year old iPod as well
Appreciate 0
      03-28-2016, 02:47 PM   #5
Fronzdan
Major
107
Rep
1,476
Posts

Drives: 335i xDrive MSport 6MT
Join Date: Mar 2014
Location: MA

iTrader: (0)

It does this occasionally for me too. Something about the USB gets hosed and I've had to reset iDrive and devices. Device connects/disconnects/connects over and over. Be sure you are using a genuine apple cable too. I've seen non-oem cables behave funny. And yes, it seems when one device got whacky every device connection loses its mind too.
Appreciate 0
      03-28-2016, 03:28 PM   #6
tjyates08
New Member
United_States
1
Rep
11
Posts

Drives: 2015 335i M Sport w/ MPPK
Join Date: May 2014
Location: Houston, TX

iTrader: (0)

Quote:
Originally Posted by Fronzdan View Post
It does this occasionally for me too. Something about the USB gets hosed and I've had to reset iDrive and devices. Device connects/disconnects/connects over and over. Be sure you are using a genuine apple cable too. I've seen non-oem cables behave funny. And yes, it seems when one device got whacky every device connection loses its mind too.
Thanks! now I don't feel like i'm losing my mind... even the other day while on a call through bluetooth, it dropped the call an on idrive said "call ending" and then the call was still going on my phone... changed phone source away from BMW ##### to iphone and was talking and then 10 seconds later bluetooth picked back up again and my call was coming through car.... so annoying.

I will try the hard reset and I also found there is an update for my car that I will try to do via USB flash drive.
Appreciate 0
      03-29-2016, 09:42 PM   #7
tjyates08
New Member
United_States
1
Rep
11
Posts

Drives: 2015 335i M Sport w/ MPPK
Join Date: May 2014
Location: Houston, TX

iTrader: (0)

Okay... I've tried everything I can find on how to reset my idrive.... nothing seems to do anything. Also, the bmw.com/update site says that I am eligible for update UPD05073. I have a new flash drive in FAT32 format... I download the folder to my USB flash drive. When I follow the instructions to install it in my car, the idrive says software update found on USB... or something to that effect.... soooooo frustrating.
Appreciate 0
      03-30-2016, 09:01 AM   #8
dwalls90
Major
United_States
63
Rep
1,454
Posts

Drives: F30 M Sport
Join Date: May 2013
Location: Washington, DC

iTrader: (0)

I would take it to the dealer to have them first update the software if you're unable to do so on your own. Then if the issue persists, bring it up with the dealer.
Appreciate 0
      03-30-2016, 11:10 AM   #9
Fronzdan
Major
107
Rep
1,476
Posts

Drives: 335i xDrive MSport 6MT
Join Date: Mar 2014
Location: MA

iTrader: (0)

Wouldn't you know it...the day I posted my response above, I get in my car and my damn iPod (which I leave connected in the armrest) loses connection and I have to fight with it a bit.

To restart iDrive push and hold the power button until the screen goes blank and it resets. It takes several seconds.
Appreciate 0
      03-30-2016, 11:25 AM   #10
tjyates08
New Member
United_States
1
Rep
11
Posts

Drives: 2015 335i M Sport w/ MPPK
Join Date: May 2014
Location: Houston, TX

iTrader: (0)

I tried that, sat there for nearly a minute with it pushed... Only thing that happened was my audio muted lol
Appreciate 0
      03-30-2016, 04:08 PM   #11
Peter-K
Private
5
Rep
51
Posts

Drives: 220d M Sport
Join Date: Aug 2014
Location: North Yorkshire (UK)

iTrader: (0)

Somewhere I've seen a post about dust/fluff/hair in the USB socket causing intermittent connection issues.
Appreciate 0
      03-30-2016, 09:57 PM   #12
Fronzdan
Major
107
Rep
1,476
Posts

Drives: 335i xDrive MSport 6MT
Join Date: Mar 2014
Location: MA

iTrader: (0)

Yeah it could be longer than a minute, now that you mention it. It seems like forever. Keep it pressed, it'll reset.
Appreciate 1
      04-25-2016, 08:50 PM   #13
Senator
Burgh Bimmer
United_States
2
Rep
15
Posts

Drives: 2014 F30 335i
Join Date: Apr 2014
Location: PA

iTrader: (0)

I posted a similar thread in this forum. Link here: http://f30.bimmerpost.com/forums/sho....php?t=1163296

I did a couple things last year.

Install the software update from the BMW website that owners have access to.
Had BMW dealer install their whole car program update (I forget the proper name).
Bought a brand new cable that was certified Made for iPhone (MFi).

I hear that the issue is related to the center console not allowing the power draw that the iphone wants. This will be particularly noticeable when the battery is low because the iphone wants to draw more power than the center console was initially spec'd to do.
Appreciate 0
      04-26-2016, 06:22 AM   #14
Dyl
Enlisted Member
1
Rep
30
Posts

Drives: 420i GC
Join Date: Jan 2016
Location: Greater Manchester, UK

iTrader: (0)

Quote:
Originally Posted by Senator View Post

I hear that the issue is related to the center console not allowing the power draw that the iphone wants. This will be particularly noticeable when the battery is low because the iphone wants to draw more power than the center console was initially spec'd to do.
I took this video of me using my old iPod touch just last night to post on here to find out if this happened with anyone else...



Seems a low battery may be the cause and it is drawing too much current to charge. You'd think BMW would spec it to charge these types of devices though.

It occasionally does it with my iPhone 6 too.
__________________
Appreciate 0
      04-26-2016, 09:30 AM   #15
Senator
Burgh Bimmer
United_States
2
Rep
15
Posts

Drives: 2014 F30 335i
Join Date: Apr 2014
Location: PA

iTrader: (0)

Quote:
Originally Posted by Dyl View Post
I took this video of me using my old iPod touch just last night to post on here to find out if this happened with anyone else...



Seems a low battery may be the cause and it is drawing too much current to charge. You'd think BMW would spec it to charge these types of devices though.

It occasionally does it with my iPhone 6 too.
That's exactly what was happening with my iphone. For your ipod touch i recommend these, which I bought. http://www.amazon.com/MFI-Certified-...r_1_10&sr=8-10.

I've also read good things about these: http://www.amazon.com/iPhone-Chargin...=sr_1_1&sr=8-1

BMW's solution on this is pretty poor. We pretty much have to stream via Bluetooth and use the BMW adapter which restricts the current to what the console can handle or use use a cigarette lighter power plug.
Appreciate 1
      04-26-2016, 05:50 PM   #16
Fronzdan
Major
107
Rep
1,476
Posts

Drives: 335i xDrive MSport 6MT
Join Date: Mar 2014
Location: MA

iTrader: (0)

Quote:
Originally Posted by Senator View Post
I posted a similar thread in this forum. Link here: http://f30.bimmerpost.com/forums/sho....php?t=1163296

I did a couple things last year.

Install the software update from the BMW website that owners have access to.
Had BMW dealer install their whole car program update (I forget the proper name).
Bought a brand new cable that was certified Made for iPhone (MFi).

I hear that the issue is related to the center console not allowing the power draw that the iphone wants. This will be particularly noticeable when the battery is low because the iphone wants to draw more power than the center console was initially spec'd to do.
I think you mean an I-step flash for the second one.....and did that help? Mine does this randomly and sort of infrequently, but it's still annoying. It may be that iOS devices have some mode where they just try to draw more current. That combined with limited ports in the car and it happens...but it's hard to MAKE it happen i.e. when at the dealer.
Appreciate 0
      04-26-2016, 08:15 PM   #17
Arthurrs
New Member
1
Rep
16
Posts

Drives: 2014 328i xdrive
Join Date: Jan 2016
Location: Canada

iTrader: (0)

Quote:
Originally Posted by Dyl View Post
Seems a low battery may be the cause and it is drawing too much current to charge. You'd think BMW would spec it to charge these types of devices though.

It occasionally does it with my iPhone 6 too.
Actually the USB port in the BMW delivers a full 500 mA as per standard USB 2.0 spec. Unfortunately with increasing battery capacities in newer smartphones, higher charging currents are required to charge those phones, and each manufacturer has their own unique chargers and ways to signal the charger to deliver the higher current required to charge the phones, because USB standards have not kept up, even USB 3.0! It's different from manufacturer to manufacturer. I bet when BMW designed this USB interface for the 3 series, no one was even anticipating the need for higher current charging capabilities, so you really can't blame them for not supporting it, even with current model cars. So for now either keep your phone with a healthy charge, or using a high current cigarette lighter charging adapter and output audio via 3.5 mm jack or bluetooth audio.
__________________
2014 328i xdrive Luxury Line
Appreciate 0
      04-27-2016, 12:32 AM   #18
mbfanos
Private First Class
9
Rep
102
Posts

Drives: 328i
Join Date: May 2014
Location: California

iTrader: (0)

The thing I hate the most about this issue is that it makes the iDrive "shut down" bluetooth and backup camera in addition to USB music
Appreciate 0
      04-27-2016, 02:55 AM   #19
Ella Aram
Registered
Ella Aram's Avatar
United_States
0
Rep
1
Posts

Drives: BMW M6
Join Date: Apr 2016
Location: Los Angeles, CA

iTrader: (0)

I had the same problem, so I even called the BMW concierge and they told me "it the phone". They have a list of phones that are "problematic" but it did my iPhone and Galaxy.
Take it to the dealership - have them look at it.
Appreciate 0
      04-27-2016, 06:04 AM   #20
Dyl
Enlisted Member
1
Rep
30
Posts

Drives: 420i GC
Join Date: Jan 2016
Location: Greater Manchester, UK

iTrader: (0)

Quote:
Originally Posted by Arthurrs View Post
Actually the USB port in the BMW delivers a full 500 mA as per standard USB 2.0 spec. Unfortunately with increasing battery capacities in newer smartphones, higher charging currents are required to charge those phones, and each manufacturer has their own unique chargers and ways to signal the charger to deliver the higher current required to charge the phones, because USB standards have not kept up, even USB 3.0! It's different from manufacturer to manufacturer. I bet when BMW designed this USB interface for the 3 series, no one was even anticipating the need for higher current charging capabilities, so you really can't blame them for not supporting it, even with current model cars. So for now either keep your phone with a healthy charge, or using a high current cigarette lighter charging adapter and output audio via 3.5 mm jack or bluetooth audio.
I totally get what you are saying but that is a 2007 iPod touch, the same year the iPhone was launched. The car is a late 2014. You would think they would have it sorted by now.

It's still doing it now, fully charged the a genuine iPod lead. Next plan, try a software update (Then dealer!).
__________________
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:46 AM.




f30post
f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST