F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > N20, N26, B46, B48 Turbo Engine / Drivetrain / Exhaust Modifications > BMS Stage 1 smoothness
Post Reply
 
Thread Tools Search this Thread
      01-10-2015, 08:59 PM   #1
TBolts10
Second Lieutenant
27
Rep
247
Posts

Drives: '13 F30
Join Date: Aug 2011
Location: Tampa

iTrader: (1)

BMS Stage 1 smoothness

BIMMERPOST
     Featured on BIMMERPOST.com
I have the BMS stage 1 tune on my 320i and i have noticed that for some reason it seems to be jerky under full throttle. Its not massively pronounced but its definitely present. For example, if I floor it from a dead stop it will accelerate hard but at about 4500 rpm it feels like almost hitting a dead zone. It feels like it momentarily cuts power but then immediately continues after, almost like a surging effect. Anyone else experience this? It doesn't really bother me too much I'm just trying to make sure there is nothing wrong with my car. Car also has an injen intake. Any input would be greatly appreciated!
Appreciate 1
      01-10-2015, 11:50 PM   #2
Seraphblade@sg
Private First Class
26
Rep
188
Posts

Drives: F30 328i
Join Date: Jun 2013
Location: Singapore

iTrader: (0)

Quote:
Originally Posted by tyler20c View Post
I have the BMS stage 1 tune on my 320i and i have noticed that for some reason it seems to be jerky under full throttle. Its not massively pronounced but its definitely present. For example, if I floor it from a dead stop it will accelerate hard but at about 4500 rpm it feels like almost hitting a dead zone. It feels like it momentarily cuts power but then immediately continues after, almost like a surging effect. Anyone else experience this? It doesn't really bother me too much I'm just trying to make sure there is nothing wrong with my car. Car also has an injen intake. Any input would be greatly appreciated!
Did u try ur car before that? I have such an issue too, but it wasn't attributed to the BMS piggyback. It was because the car had a failed pressure converter from day 1.
Appreciate 0
      01-11-2015, 12:09 AM   #3
TBolts10
Second Lieutenant
27
Rep
247
Posts

Drives: '13 F30
Join Date: Aug 2011
Location: Tampa

iTrader: (1)

Quote:
Originally Posted by Seraphblade@sg View Post
Did u try ur car before that? I have such an issue too, but it wasn't attributed to the BMS piggyback. It was because the car had a failed pressure converter from day 1.
I didn't notice it before but the car had so little power before I'm not sure I would have noticed it.
Appreciate 0
      01-11-2015, 12:24 AM   #4
TBolts10
Second Lieutenant
27
Rep
247
Posts

Drives: '13 F30
Join Date: Aug 2011
Location: Tampa

iTrader: (1)

Quote:
Originally Posted by Seraphblade@sg View Post
Did u try ur car before that? I have such an issue too, but it wasn't attributed to the BMS piggyback. It was because the car had a failed pressure converter from day 1.
By the way what is a pressure converter? Lol
Appreciate 0
      01-11-2015, 10:00 PM   #5
CntryClub007
First Lieutenant
74
Rep
368
Posts

Drives: 2015 320i | 2013 X5-35i
Join Date: Jul 2014
Location: United States

iTrader: (0)

I have BMS Stage 1 4PSI & Injen, no issues here. Car only has 600 miles on it though, 500 with the mods. 320i. I haven't gotten on the car incredibly hard though due to cold temps outside and break-in timing / mileage.
Appreciate 0
      01-11-2015, 10:05 PM   #6
TBolts10
Second Lieutenant
27
Rep
247
Posts

Drives: '13 F30
Join Date: Aug 2011
Location: Tampa

iTrader: (1)

Quote:
Originally Posted by CntryClub007 View Post
I have BMS Stage 1 4PSI & Injen, no issues here. Car only has 600 miles on it though, 500 with the mods. 320i. I haven't gotten on the car incredibly hard though due to cold temps outside and break-in timing / mileage.
Thanks for the reply. I guess I will try removing the mods and trying them alone and seeing if one of them is causing it or if its something else. Gonna be a pain the ass!
Appreciate 0
      01-12-2015, 12:11 AM   #7
CntryClub007
First Lieutenant
74
Rep
368
Posts

Drives: 2015 320i | 2013 X5-35i
Join Date: Jul 2014
Location: United States

iTrader: (0)

I re-read your first post, with you talking about a dead zone, don't forget the car has ~220HP with that tune/intake combo. You are going to feel the cars power come off right about 4K RPM.

I tell everyone, 2-4K is a blast, but anything past 4500-5K in this car is a joke, it has zero pulling power. As I drive around mainly 2-4500K, not a big problem for me, but the car isn't going to be giving a "continuous pull" like you will feel in a 328 or 335i.
Appreciate 1
      01-12-2015, 10:25 AM   #8
TBolts10
Second Lieutenant
27
Rep
247
Posts

Drives: '13 F30
Join Date: Aug 2011
Location: Tampa

iTrader: (1)

Quote:
Originally Posted by CntryClub007 View Post
I re-read your first post, with you talking about a dead zone, don't forget the car has ~220HP with that tune/intake combo. You are going to feel the cars power come off right about 4K RPM.

I tell everyone, 2-4K is a blast, but anything past 4500-5K in this car is a joke, it has zero pulling power. As I drive around mainly 2-4500K, not a big problem for me, but the car isn't going to be giving a "continuous pull" like you will feel in a 328 or 335i.
The problem is it's more of a hiccup than a dead zone. It's hard to describe but the power will come back on after it hesitates. I guess a hesitation is more like it?
Appreciate 0
      01-12-2015, 11:37 AM   #9
CntryClub007
First Lieutenant
74
Rep
368
Posts

Drives: 2015 320i | 2013 X5-35i
Join Date: Jul 2014
Location: United States

iTrader: (0)

Ah - OK - I tried it this morning after my car warmed up, def no dead zone or hiccup in any of the three modes. I've had the same mods on both 2015 320i's with build dates from AUG 2014 & Nov 2014. No issue on either.

Let us know what you report back with - I guess the tune is the easiest to remove, eh?
Appreciate 0
      01-12-2015, 12:12 PM   #10
TBolts10
Second Lieutenant
27
Rep
247
Posts

Drives: '13 F30
Join Date: Aug 2011
Location: Tampa

iTrader: (1)

Thanks for the help. Ya tune will be easiest so i'll probably go ahead and remove it today. Ill try to post a video too. Not sure if it will show up much in it though.
Appreciate 0
      01-12-2015, 12:42 PM   #11
TBolts10
Second Lieutenant
27
Rep
247
Posts

Drives: '13 F30
Join Date: Aug 2011
Location: Tampa

iTrader: (1)

Heres a video. It did it slightly towards the top of 1st gear but not as bad as it can be. It doesn't seem to be down on power, I clocked 0-60 in about 6.5 which i think with a soft launch like that is about where it should be.

Appreciate 0
      01-12-2015, 12:43 PM   #12
Mike@N54Tuning.com
BimmerPost Supporting Vendor
Canada
1929
Rep
35,534
Posts


Drives: 2007 335i, 2015 M3
Join Date: Dec 2008
Location: N54tuning.com

iTrader: (89)

Intakes for the n20 add no power and can cause tuning issues as the vehicle is maf based. I'd remove that first.

Mike
Appreciate 1
      01-12-2015, 12:44 PM   #13
TBolts10
Second Lieutenant
27
Rep
247
Posts

Drives: '13 F30
Join Date: Aug 2011
Location: Tampa

iTrader: (1)

Quote:
Originally Posted by Mike@N54Tuning.com View Post
Intakes for the n20 add no power and can cause tuning issues as the vehicle is maf based. I'd remove that first.

Mike
Hm okay I'll try that too! thanks for the reply.
Appreciate 0
      01-12-2015, 02:41 PM   #14
CntryClub007
First Lieutenant
74
Rep
368
Posts

Drives: 2015 320i | 2013 X5-35i
Join Date: Jul 2014
Location: United States

iTrader: (0)

Quote:
Originally Posted by tyler20c
Heres a video. It did it slightly towards the top of 1st gear but not as bad as it can be. It doesn't seem to be down on power, I clocked 0-60 in about 6.5 which i think with a soft launch like that is about where it should be.

To me - it seems like there is nothing wrong with the video. I know you mentioned the problem isn't really clear from the video, but the car isn't a huge power machine either, so your power will tend to dip off...
Appreciate 0
      01-12-2015, 08:07 PM   #15
TBolts10
Second Lieutenant
27
Rep
247
Posts

Drives: '13 F30
Join Date: Aug 2011
Location: Tampa

iTrader: (1)

Quote:
Originally Posted by CntryClub007 View Post
To me - it seems like there is nothing wrong with the video. I know you mentioned the problem isn't really clear from the video, but the car isn't a huge power machine either, so your power will tend to dip off...
Im probably just over reacting then... lol. I appreciate the help man!
Appreciate 0
      01-20-2015, 11:52 PM   #16
FSociety
@Frikiton on Instagram
FSociety's Avatar
Dominican Republic
973
Rep
4,018
Posts

Drives: 2016 X4 M40i LBB
Join Date: Apr 2012
Location: NYC(past), NJ(now), South(eventually)

iTrader: (3)

Garage List
16' BMW X4 M40i  [0.00]
14' X3 M-Sport 28ix  [5.00]
11 Benz C300  [0.00]
06 Cadillac STS  [0.00]
07 BMW 328 XI  [0.00]
Send a message via AIM to FSociety
Quote:
Originally Posted by Mike@N54Tuning.com View Post
Intakes for the n20 add no power and can cause tuning issues as the vehicle is maf based. I'd remove that first.

Mike
Is this why BMS has a CAI for N55 but not N20 ?
Even though aFe makes a CAI for N20 is it more marketing gimmick than real world performance or is it only for sound ? Because it does sound way better!
__________________
F26 LBB X4 M40i | Custom @AIMPerformanceNJ Downpipe | @EnzoRacing PTF/BootMod3

FS: MPSS 245/40/20 275/35/20
Check out my YouTube Channel
IG:@Frikiton
Appreciate 0
      01-25-2015, 01:39 PM   #17
CntryClub007
First Lieutenant
74
Rep
368
Posts

Drives: 2015 320i | 2013 X5-35i
Join Date: Jul 2014
Location: United States

iTrader: (0)

Quote:
Originally Posted by ROBNYC View Post
Is this why BMS has a CAI for N55 but not N20 ?
Even though aFe makes a CAI for N20 is it more marketing gimmick than real world performance or is it only for sound ? Because it does sound way better!
N20 is totally a sound thing, which I thoroughly enjoy when bumping up to sport mode.
Appreciate 1
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:01 AM.




f30post
f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST