F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > N55 Turbo Engine / Drivetrain / Exhaust Modifications > Engine Light came on and decided to stay
Extreme Power House
Post Reply
 
Thread Tools Search this Thread
      03-06-2013, 11:09 PM   #1
rallybull
Captain
rallybull's Avatar
United_States
18
Rep
818
Posts

 
Drives: F30 335i w/PPK
Join Date: Jul 2012
Location: USA

iTrader: (0)

Engine Light came on and decided to stay

The orange engine light (the owners manuals calls it the emission light) is staying on.

What could be the reason? Is there something I can do to figure out (other than taking it to the dealer)?
Appreciate 0
      03-06-2013, 11:22 PM   #2
David328M-Sport
Brigadier General
Australia
45
Rep
3,464
Posts

 
Drives: F30 M-Sport 328i Estoril Blue
Join Date: Jun 2005
Location: Melbourne Australia

iTrader: (0)

Could be one of many. many issues. Any other info come up? Could be a faulty sensor. A few people have reported faulty sensors causing issues. Best have your dealer check it out ASAP. No use speculating. Cheers.
__________________
328i M-Sport, Estoril Blue, Carbon XP 35 Tint, front heated seats, black Dakota, Sports Suspension, Anthracite Headliner, HUD, Pro Nav, Sunroof, hk 600w, Bi-Xenon, 19" 403M wheels, Reversing Camera, DAB+, Xenon, BT Ext Connect.
Appreciate 0
      03-07-2013, 03:38 PM   #3
rallybull
Captain
rallybull's Avatar
United_States
18
Rep
818
Posts

 
Drives: F30 335i w/PPK
Join Date: Jul 2012
Location: USA

iTrader: (0)

I took it to the dealer. Initial reports state it was caused by the water pump. They checked the water pump and it appeared to work fine. They have raised a question to the main BMW tech support on how to proceed with this issue and are awaiting an answer.

Appreciate 0
      03-07-2013, 08:04 PM   #4
David328M-Sport
Brigadier General
Australia
45
Rep
3,464
Posts

 
Drives: F30 M-Sport 328i Estoril Blue
Join Date: Jun 2005
Location: Melbourne Australia

iTrader: (0)

Many people's posts here have stated that one warning or another has come to their attention once, never to surface again. Hopefully that is the same in your case.

I remember soon after I took delivery of my E90 325i in 2005, the CEL came on one evening. Turned the car off, waited a few mins, turned it on and off I went, like it never happened. CEL never came on again after that.

Best thing was you taking it to the dealer for a check. Now they have it on record.
__________________
328i M-Sport, Estoril Blue, Carbon XP 35 Tint, front heated seats, black Dakota, Sports Suspension, Anthracite Headliner, HUD, Pro Nav, Sunroof, hk 600w, Bi-Xenon, 19" 403M wheels, Reversing Camera, DAB+, Xenon, BT Ext Connect.
Appreciate 0
      03-07-2013, 09:10 PM   #5
rallybull
Captain
rallybull's Avatar
United_States
18
Rep
818
Posts

 
Drives: F30 335i w/PPK
Join Date: Jul 2012
Location: USA

iTrader: (0)

Congratulations on you 3000th post!!
Appreciate 0
      03-08-2013, 12:18 PM   #6
DarkTrigger
Professional
DarkTrigger's Avatar
United_States
13
Rep
973
Posts

 
Drives: 335i MPPK
Join Date: Oct 2012
Location: LB, SoCal

iTrader: (0)

Bmw's are notorious for faulty O2 sensors.
Appreciate 0
      03-08-2013, 12:40 PM   #7
The Economist
Private
3
Rep
72
Posts

 
Drives: 2013 335i "M-Sport" MPPK MPE
Join Date: May 2012
Location: Toronto

iTrader: (0)

I recently had this issue; many of the same hypotheses were floated as you see in this thread. However, it turned out to be corrosion around the gas tank wiring... just took that at face value and moved on. In either case, whatever it turns out to be, it's a pain in the ass and the light annyoed the holy hell out of me; happy to have it resolved.
Appreciate 0
      03-08-2013, 04:41 PM   #8
David328M-Sport
Brigadier General
Australia
45
Rep
3,464
Posts

 
Drives: F30 M-Sport 328i Estoril Blue
Join Date: Jun 2005
Location: Melbourne Australia

iTrader: (0)

Quote:
Originally Posted by tojo_m View Post
Congratulations on you 3000th post!!
Thank you. Never noticed. Wow!!! Best forum on the planet.
__________________
328i M-Sport, Estoril Blue, Carbon XP 35 Tint, front heated seats, black Dakota, Sports Suspension, Anthracite Headliner, HUD, Pro Nav, Sunroof, hk 600w, Bi-Xenon, 19" 403M wheels, Reversing Camera, DAB+, Xenon, BT Ext Connect.
Appreciate 0
      03-09-2013, 12:36 AM   #9
rallybull
Captain
rallybull's Avatar
United_States
18
Rep
818
Posts

 
Drives: F30 335i w/PPK
Join Date: Jul 2012
Location: USA

iTrader: (0)

The service dept got a response from BMW tech and have been asked to replace the water pump. So my car is still with them over this weekend. Hopefully, I'll get it back this Monday.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:20 PM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST