F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics > Andream MMI Box - Wireless CarPlay & Android Auto
ARMA SPEED
Post Reply
 
Thread Tools Search this Thread
      08-03-2020, 04:49 AM   #3873
FransL
Enlisted Member
Netherlands
3
Rep
32
Posts

Drives: bmw
Join Date: Jan 2020
Location: Home

iTrader: (0)

Quote:
Originally Posted by f304dr View Post
Can someone double check the link to see my idrive menu if I have NBT? Was told i have cic high and to get the NBT unit because i have a 2013 328i but the seller thinks i need cic? Not sure which anymore.
NBT with some audio issues and work arounds. See this thread for HIGH-CIC
Appreciate 0
      08-03-2020, 06:15 AM   #3874
Chase123
New Member
0
Rep
8
Posts

Drives: BMW 328i F30
Join Date: Jul 2020
Location: Germany

iTrader: (0)

Quote:
Originally Posted by HeatGun View Post
Quote:
Originally Posted by Chase123 View Post
Hello together,

I also have the black screen problem with my andream nbt unit. I got the cic-high system in my f30 from 2012, so I bought the nbt version that fits with the cables and the screen. I built everything up and tried to boot but when I long press the menu button to start CarPlay there is "click" noise and a black screen 😢 when I press again, the normal bmw system runs again. Does anybody have the same issues? Do I have to press the small white switches on the box to solve the problem or is it anything else?

Thank you advance guys!
The switches in the back gotta be in 1,2,3 on, rest off
Thank you, it worked! 🙏
Appreciate 0
      08-03-2020, 07:14 AM   #3875
f304dr
New Member
2
Rep
18
Posts

Drives: 328xi
Join Date: Jul 2020
Location: Canada

iTrader: (0)

Quote:
Originally Posted by Fishie View Post
You have the same car as me, you need the NBT MMI because you have CIC-high. You also might run into some audio or microphone issues.
Kk thanks so much again, I ordered the NBT based of you saying that before and mentioned cic high is the reason for getting nbt but had the seller and even bimmertech saying I need cic when their own website even says I actually need NBT due to the pin out of the screen right?

Last edited by f304dr; 08-03-2020 at 07:50 AM..
Appreciate 0
      08-03-2020, 08:24 AM   #3876
f304dr
New Member
2
Rep
18
Posts

Drives: 328xi
Join Date: Jul 2020
Location: Canada

iTrader: (0)

Quote:
Originally Posted by FransL View Post
NBT with some audio issues and work arounds. See this thread for HIGH-CIC
Thanks for the link, im aware of the issues and knew about the road top mic tap but could never find the store on AliExpress. Guessing this is the preferred version for our model year.
Appreciate 0
      08-03-2020, 08:44 AM   #3877
muniz_ri
Captain
United_States
168
Rep
607
Posts

Drives: BMA 320I
Join Date: Mar 2019
Location: Irvine, CA

iTrader: (1)

Quote:
Originally Posted by cerij101 View Post
Quote:
Originally Posted by muniz_ri View Post
The mcu is the "bridge" between the cars inputs, e.g. headlights, idrive controller, and the mmi system sw. It translates those inputs into commands usable by the system sw.
Thanks. I wonder, if it's possible to develop customised firmware, is it possible to customise the MCU as well? For example, to make the phone button work in Android Auto
I believe that there are people on here working on a solution that will make the Android Auto experience much better including routing calls via the oem bluetooth connection which will enable the phone button on the steering wheel and allow you to hear incoming phone calls even when using the iDrive for FM radio for example, auto-launch so that AA automatically starts up when you unlock your car like it does for CarPlay, automatic night mode switching fix, widescreen support including dpi fix, and some aesthetic customizations. Pretty much making the experience the way it should be.

Last edited by muniz_ri; 08-03-2020 at 10:33 AM..
Appreciate 0
      08-03-2020, 11:30 AM   #3878
Chase123
New Member
0
Rep
8
Posts

Drives: BMW 328i F30
Join Date: Jul 2020
Location: Germany

iTrader: (0)

I currently use the andream box with wired CarPlay. Everything works fine, but I'm thinking of putting in the antenna to have the option for wireless CarPlay. (Unfortunately I didn't build it in, when I got the box, so I have to remove everything again and put it back in). Are there any disadvantages of using wireless CarPlay? Do you guys have any problems in comparison to wired CarPlay?
Appreciate 0
      08-03-2020, 11:59 AM   #3879
xDHC
Second Lieutenant
Netherlands
91
Rep
289
Posts

Drives: F20 116i
Join Date: Mar 2019
Location: Europe

iTrader: (0)

Quote:
Originally Posted by Chase123 View Post
I currently use the andream box with wired CarPlay. Everything works fine, but I'm thinking of putting in the antenna to have the option for wireless CarPlay. (Unfortunately I didn't build it in, when I got the box, so I have to remove everything again and put it back in).
Initially i broke my antenna but you can still get signal without it, its going to be 1-2 stripes only so massive lags and delays.

Quote:
Originally Posted by Chase123 View Post
Are there any disadvantages of using wireless CarPlay? Do you guys have any problems in comparison to wired CarPlay?
Apart from your phone not charging, no.
Appreciate 0
      08-03-2020, 12:02 PM   #3880
SDriver18i
Private
SDriver18i's Avatar
No_Country
48
Rep
82
Posts

Drives: BMW X1 s18i 2019
Join Date: May 2019
Location: *

iTrader: (0)

Hey guys, I'm from the F48 forums and just bought an MMI from x5m254 for the F48 but I keep getting this clicking noise and "No Signal" message when I switch to the MMi.

I've looked around and found nothing. x5m254 helped me try a few things but to no avail. Swapped cables in probably every different manner available. Nothing. Anyone seen this and can diagnose this?

The unit connects and it works perfectly as I could screenshot the Carplay screen from my iPhone. idrive, audio, camera and all controls work perfectly fine. It just doesn't display the MMi. Weird.

Appreciate 0
      08-03-2020, 01:58 PM   #3881
Firefly1337
Second Lieutenant
Firefly1337's Avatar
Germany
487
Rep
237
Posts

Drives: F20 M135i LCI
Join Date: Aug 2019
Location: Germany

iTrader: (0)

New update

New version B_V1.0.2 for Andream NBT available on the 1st page.

This is for the latest unit with the new UI. Please only flash it e.g. if you are coming from version B-V1.0.0. It's not compatible with the 'older' units (currently there are no benefits anyway).
Changelog is, as always, unknown.

We will post an update for the custom mod as well later today (if everything checks out).
Appreciate 0
      08-03-2020, 02:11 PM   #3882
yulian
New Member
Ukraine
3
Rep
15
Posts

Drives: BMW X5 F15 2014
Join Date: Jun 2020
Location: Ukraine, Kyiv

iTrader: (0)

Hi everyone,

On my Carlinkit I just tried custom v1.0.C0.mod FW from cossie1 and Firefly1337, everything works well except selector cursor in Android Auto is totally gone. So I can't use any functions because I don't see what I select ))

Ok, no worries I thought - just install v9.2.7.t.yl.b and cursor will be back, but NO CURSOR... Ok, lets switch MCU's - tried MCU 20.06.02, MCU 20.1.4, MCU 19.12.12 - NO CURSOR. Ok, maybe old MCU 19.12.12 + v9.1.9.yl.b firmware - NO CURSOR.

So right now I can't bring back selection cursor to my Android Auto interface at any Firmware and MCU version.

Any thoughts maybe?

Is there firmware restore option to clean unit? I think some old config files from v1.0.C0.mod stuck in the system even after FW update/reinstall.

Last edited by yulian; 08-03-2020 at 02:25 PM..
Appreciate 0
      08-03-2020, 02:43 PM   #3883
CARR601
Enlisted Member
9
Rep
43
Posts

Drives: BMW 320d F30
Join Date: Jul 2018
Location: UK

iTrader: (0)

Quote:
Originally Posted by yulian View Post
Hi everyone,

On my Carlinkit I just tried custom v1.0.C0.mod FW from cossie1 and Firefly1337, everything works well except selector cursor in Android Auto is totally gone. So I can't use any functions because I don't see what I select ))

Ok, no worries I thought - just install v9.2.7.t.yl.b and cursor will be back, but NO CURSOR... Ok, lets switch MCU's - tried MCU 20.06.02, MCU 20.1.4, MCU 19.12.12 - NO CURSOR. Ok, maybe old MCU 19.12.12 + v9.1.9.yl.b firmware - NO CURSOR.

So right now I can't bring back selection cursor to my Android Auto interface at any Firmware and MCU version.

Any thoughts maybe?

Is there firmware restore option to clean unit? I think some old config files from v1.0.C0.mod stuck in the system even after FW update/reinstall.
I believe it's an issue with AA in general not just the MMI. There's a few posts on Reddit with the same issue. It's came and went multiple times in the last 10 months I've had AA. Very annoying.
Appreciate 0
      08-03-2020, 02:50 PM   #3884
muniz_ri
Captain
United_States
168
Rep
607
Posts

Drives: BMA 320I
Join Date: Mar 2019
Location: Irvine, CA

iTrader: (1)

Quote:
Originally Posted by CARR601 View Post
Quote:
Originally Posted by yulian View Post
Hi everyone,

On my Carlinkit I just tried custom v1.0.C0.mod FW from cossie1 and Firefly1337, everything works well except selector cursor in Android Auto is totally gone. So I can't use any functions because I don't see what I select ))

Ok, no worries I thought - just install v9.2.7.t.yl.b and cursor will be back, but NO CURSOR... Ok, lets switch MCU's - tried MCU 20.06.02, MCU 20.1.4, MCU 19.12.12 - NO CURSOR. Ok, maybe old MCU 19.12.12 + v9.1.9.yl.b firmware - NO CURSOR.

So right now I can't bring back selection cursor to my Android Auto interface at any Firmware and MCU version.

Any thoughts maybe?

Is there firmware restore option to clean unit? I think some old config files from v1.0.C0.mod stuck in the system even after FW update/reinstall.
I believe it's an issue with AA in general not just the MMI. There's a few posts on Reddit with the same issue. It's came and went multiple times in the last 10 months I've had AA. Very annoying.
Yep, it's an AA thing not caused by the mmi or sw. Try clearing cache and data from the AA, Google, and Google Play Services apps.
Appreciate 0
      08-03-2020, 02:58 PM   #3885
yulian
New Member
Ukraine
3
Rep
15
Posts

Drives: BMW X5 F15 2014
Join Date: Jun 2020
Location: Ukraine, Kyiv

iTrader: (0)

Quote:
Originally Posted by CARR601 View Post
I believe it's an issue with AA in general not just the MMI. There's a few posts on Reddit with the same issue. It's came and went multiple times in the last 10 months I've had AA. Very annoying.
Quote:
Originally Posted by muniz_ri View Post
Yep, it's an AA thing not caused by the mmi or sw. Try clearing cache and data from the AA, Google, and Google Play Services apps.
Will do, thank you - but issue happened exactly after MOD installation and I cleaned AA cache every time, but not G Services.
Appreciate 0
      08-03-2020, 03:12 PM   #3886
muniz_ri
Captain
United_States
168
Rep
607
Posts

Drives: BMA 320I
Join Date: Mar 2019
Location: Irvine, CA

iTrader: (1)

Quote:
Originally Posted by yulian View Post
Quote:
Originally Posted by CARR601 View Post
I believe it's an issue with AA in general not just the MMI. There's a few posts on Reddit with the same issue. It's came and went multiple times in the last 10 months I've had AA. Very annoying.
Quote:
Originally Posted by muniz_ri View Post
Yep, it's an AA thing not caused by the mmi or sw. Try clearing cache and data from the AA, Google, and Google Play Services apps.
Will do, thank you - but issue happened exactly after MOD installation and I cleaned AA cache every time, but not G Services.
Here's a whole string about that issue:
https://support.google.com/androidau...msgid=12809223
Appreciate 0
      08-03-2020, 03:47 PM   #3887
Firefly1337
Second Lieutenant
Firefly1337's Avatar
Germany
487
Rep
237
Posts

Drives: F20 M135i LCI
Join Date: Aug 2019
Location: Germany

iTrader: (0)

New custom version v2.0

Hey,

here's the newest update for our custom version: v2.0.B0.mod for BMW NBT and v2.0.M0.mod for MINI NBT. They are available on the 1st page.
The biggest change is that this version will run on any device. It does not matter if you have an Andream, Carlinkit, RoadTop or Bimmertech device.
It is based on the latest Bimmertech update featuring their UI (see below).

//Edit: Since it's based on the Bimmertech update, calls on AA should be fixed as well.
//Edit2: A word regarding MCU updates: With this update you can only flash the MCU updates by Bimmertech. Flashing the default MCU from Andream/Carlinkit etc is only possible on their firmware. Currently there is no need to do anything (no new features etc), so you can leave everything as is. Also note that Bimmertech transforms the first digits of the MCU version from '20' to '10'.

I'd like to take the opportunity and thank cossie1 for the update, he really did most of the changes and created many new icons and images.
Also thanks to dkeruza and Feisar328i for their continuous support and muniz_ri and xDHC for test flashing the update

Changelog/Contents:
  • Android Auto Widescreen Fix
  • Android Auto DPI Fix
  • Autolink Mirroring Screen Size Fix
  • Renamed MMI to BMW-MMI/MINI-MMI for Carplay and AA
  • Replaced MMI icon with BMW/MINI icon
  • Replaced car image on integrated PDC/camera screen
  • Changed icons to Blue when highlighted
  • Removed update / key checks
  • BMW/MINI Boot Logo
  • Custom Flash/update screen

Name:  v2.0-UI.jpeg
Views: 1253
Size:  79.9 KB

Last edited by Firefly1337; 08-04-2020 at 02:34 AM..
      08-03-2020, 04:03 PM   #3888
muniz_ri
Captain
United_States
168
Rep
607
Posts

Drives: BMA 320I
Join Date: Mar 2019
Location: Irvine, CA

iTrader: (1)

Quote:
Originally Posted by Firefly1337 View Post
I'd like to take the opportunity and thank cossie1 for the update, he really did most of the changes and created many new icons and images.
Also thanks to dkeruza and Feisar328i for their continuous support and muniz_ri and xDHC for test flashing the update
Attachment 2380355
You guys are incredible. I am finally satisfied with my mmi unit!
Appreciate 1
      08-03-2020, 04:38 PM   #3889
eduwinner
Enlisted Member
2
Rep
31
Posts

Drives: BMW 320d F30 M
Join Date: Oct 2017
Location: Spain

iTrader: (0)

Quote:
Originally Posted by Firefly1337 View Post
Hey,

here's the newest update for our custom version: v2.0.B0.mod for BMW NBT and v2.0.M0.mod for MINI NBT. They are available on the 1st page.
The biggest change is that this version will run on any device. It does not matter if you have an Andream, Carlinkit, RoadTop or Bimmertech device.
It is based on the latest Bimmertech update featuring their UI (see below).

//Edit: Since it's based on the Bimmertech update, calls on AA should be fixed as well.

I'd like to take the opportunity and thank cossie1 for the update, he really did most of the changes and created many new icons and images.
Also thanks to dkeruza and Feisar328i for their continuous support and muniz_ri and xDHC for test flashing the update

Changelog/Contents:
  • Android Auto Widescreen Fix
  • Android Auto DPI Fix
  • Autolink Mirroring Screen Size Fix
  • Renamed MMI to BMW-MMI/MINI-MMI for Carplay and AA
  • Replaced MMI icon with BMW/MINI icon
  • Replaced car image on integrated PDC/camera screen
  • Changed icons to Blue when highlighted
  • Removed update / key checks
  • BMW/MINI Boot Logo
  • Custom Flash/update screen

Attachment 2380355
Thank you so much for your effort and your work. I will install the MMI this week and will test your new custom firmware.
Appreciate 0
      08-03-2020, 04:43 PM   #3890
muniz_ri
Captain
United_States
168
Rep
607
Posts

Drives: BMA 320I
Join Date: Mar 2019
Location: Irvine, CA

iTrader: (1)

Quote:
Originally Posted by SDriver18i View Post
Hey guys, I'm from the F48 forums and just bought an MMI from x5m254 for the F48 but I keep getting this clicking noise and "No Signal" message when I switch to the MMi.

I've looked around and found nothing. x5m254 helped me try a few things but to no avail. Swapped cables in probably every different manner available. Nothing. Anyone seen this and can diagnose this?

The unit connects and it works perfectly as I could screenshot the Carplay screen from my iPhone. idrive, audio, camera and all controls work perfectly fine. It just doesn't display the MMi. Weird.

Are the first two dip switches set to On and rest to Off for your 6.5" screen?
Appreciate 0
      08-03-2020, 05:01 PM   #3891
Unspec
Captain
Unspec's Avatar
United_States
330
Rep
965
Posts

Drives: 2015 BMW 535xi
Join Date: Apr 2019
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by Firefly1337 View Post
Hey,

here's the newest update for our custom version: v2.0.B0.mod for BMW NBT and v2.0.M0.mod for MINI NBT. They are available on the 1st page.
The biggest change is that this version will run on any device. It does not matter if you have an Andream, Carlinkit, RoadTop or Bimmertech device.
It is based on the latest Bimmertech update featuring their UI (see below).

//Edit: Since it's based on the Bimmertech update, calls on AA should be fixed as well.

I'd like to take the opportunity and thank cossie1 for the update, he really did most of the changes and created many new icons and images.
Also thanks to dkeruza and Feisar328i for their continuous support and muniz_ri and xDHC for test flashing the update

Changelog/Contents:
  • Android Auto Widescreen Fix
  • Android Auto DPI Fix
  • Autolink Mirroring Screen Size Fix
  • Renamed MMI to BMW-MMI/MINI-MMI for Carplay and AA
  • Replaced MMI icon with BMW/MINI icon
  • Replaced car image on integrated PDC/camera screen
  • Changed icons to Blue when highlighted
  • Removed update / key checks
  • BMW/MINI Boot Logo
  • Custom Flash/update screen

Attachment 2380355
Awesome work! I still kinda wish the icons in the home screen were sharper. The rounded out look for the icons, for me, makes it look cheap and something out of a mid-2000 UI design. Something like Material Design from Google would be nice
__________________
2015 BMW 535xi

Bootmod3 Stage 2 | ER Catted DP | Remus Exhaust | Gplus FMIC
Appreciate 0
      08-03-2020, 05:35 PM   #3892
cossie1
Captain
United Kingdom
449
Rep
825
Posts

Drives: 2015 F82 M4
Join Date: Nov 2018
Location: UK

iTrader: (0)

Quote:
Originally Posted by Firefly1337 View Post
Hey,

here's the newest update for our custom version: v2.0.B0.mod for BMW NBT and v2.0.M0.mod for MINI NBT. They are available on the 1st page.
The biggest change is that this version will run on any device. It does not matter if you have an Andream, Carlinkit, RoadTop or Bimmertech device.
It is based on the latest Bimmertech update featuring their UI (see below).

//Edit: Since it's based on the Bimmertech update, calls on AA should be fixed as well.

I'd like to take the opportunity and thank cossie1 for the update, he really did most of the changes and created many new icons and images.
Also thanks to dkeruza and Feisar328i for their continuous support and muniz_ri and xDHC for test flashing the update

Changelog/Contents:
  • Android Auto Widescreen Fix
  • Android Auto DPI Fix
  • Autolink Mirroring Screen Size Fix
  • Renamed MMI to BMW-MMI/MINI-MMI for Carplay and AA
  • Replaced MMI icon with BMW/MINI icon
  • Replaced car image on integrated PDC/camera screen
  • Changed icons to Blue when highlighted
  • Removed update / key checks
  • BMW/MINI Boot Logo
  • Custom Flash/update screen

Attachment 2380355
Just a point to note.

You can update the MCU to the Bimmertech MCU (also on the 1st page) once this update is installed.

But if you want to flash back to the Andream / Carlinkit / Roadtop MCU you will have to reflash your mmi with the correct software for your unit first then update the MCU.
Appreciate 0
      08-03-2020, 05:38 PM   #3893
chambo622
Private First Class
United_States
11
Rep
129
Posts

Drives: F31 LCI 328i M Sport EBII
Join Date: May 2020
Location: Orange County, CA

iTrader: (0)

Quote:
Originally Posted by cossie1 View Post
You can update the MCU to the Bimmertech MCU (also on the 1st page) once this update is installed.
Is there a benefit to doing that?
Appreciate 0
      08-03-2020, 05:41 PM   #3894
cossie1
Captain
United Kingdom
449
Rep
825
Posts

Drives: 2015 F82 M4
Join Date: Nov 2018
Location: UK

iTrader: (0)

Quote:
Originally Posted by chambo622 View Post
Is there a benefit to doing that?
Nope, the scroll wheel works backwards (up for next and down for back, which is the opposite of how it works in the i-drive) other than that I didn't notice any difference, but I am sure some will want to try it for themselves.
Appreciate 0
Post Reply

Bookmarks

Tags
andream, android, android auto, apple, carplay, mmi, retrofit

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:04 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST