F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > F30 DIYs and Coding Discussions > Engine oil measurement stopping at 15-17%
Post Reply
 
Thread Tools Search this Thread
      05-04-2017, 09:11 PM   #1
harkes
Lieutenant Colonel
harkes's Avatar
China
705
Rep
1,638
Posts

Drives: M135i, NSX and AE86
Join Date: Apr 2014
Location: Xiamen, China

iTrader: (0)

Engine oil measurement stopping at 15-17%

Hi

UPDATE: It's not because of the below valve, but because the oil does not have the right temperature that the measurement stops at 15-17%. Oil temp must be between ~65 and 100C and as operating temp is 110-115C the level must be measured during warm up (pretty stupid and even more so that no information is provided in iDrive)...

IF the measurement still does not work, the next step would be to check the below valve for functionality.

*************

I have been having this issue for a while but finally decided to do something about it.
A bit of research revealed that the problem most likely is this valve (which I can now confirm): Hydraulic valve 11417622768

1: Disconnect battery
2: Remove undertray
3: Remove 3pc screws for waterpump
4: Disconnect waterpump and valve
5: Remove 1pc screw for valve
6: Turn valve 90 CCW (then you can get a finger behind it) and remove
7: Exercise valve/check function with 12v
8: Reinstall and see if it now works
Attached Images
      
__________________
M135i PWG, MHD, Pure Stage2, Torqbyte CM5-LT, xHP
(A Dane in China)

Last edited by harkes; 01-09-2018 at 08:52 AM..
Appreciate 3
      05-04-2017, 09:41 PM   #2
harkes
Lieutenant Colonel
harkes's Avatar
China
705
Rep
1,638
Posts

Drives: M135i, NSX and AE86
Join Date: Apr 2014
Location: Xiamen, China

iTrader: (0)

Jason Move to Maintenance section perhaps?
__________________
M135i PWG, MHD, Pure Stage2, Torqbyte CM5-LT, xHP
(A Dane in China)
Appreciate 0
      05-06-2017, 01:01 AM   #3
harkes
Lieutenant Colonel
harkes's Avatar
China
705
Rep
1,638
Posts

Drives: M135i, NSX and AE86
Join Date: Apr 2014
Location: Xiamen, China

iTrader: (0)

Update
I found that the oil has to be between 65 and 100 degreeC for my car to measure it. Below the measurement will not start and above it stops at 15-17%. Nothing wrong with the mechanics probably.
__________________
M135i PWG, MHD, Pure Stage2, Torqbyte CM5-LT, xHP
(A Dane in China)
Appreciate 0
      06-28-2017, 12:44 PM   #4
heartwork
New Member
Romania
0
Rep
5
Posts

Drives: 2013 BMW F30 335ix
Join Date: Feb 2017
Location: Bucharest

iTrader: (0)

Quote:
Originally Posted by harkes View Post
Update
I found that the oil has to be between 65 and 100 degreeC for my car to measure it. Below the measurement will not start and above it stops at 15-17%.
Where did you find that oil measurement above 100 degrees C will stop at 15%-17% ?!?
Where did you find this information? From a BMW dealer or service or there is some documentation that you found ?
Thanks
Appreciate 0
      09-07-2017, 03:26 PM   #5
F30RiK
First Lieutenant
81
Rep
375
Posts

Drives: 13' 335 xdrive M-sport 6 Speed
Join Date: Aug 2014
Location: QC, LAval

iTrader: (1)

maybe if everybody can try that, mesure oil level at 120 degrees C , my car does the same thing, it will stop between 15-17% above 100 degrees C.
Appreciate 0
      09-07-2017, 08:48 PM   #6
harkes
Lieutenant Colonel
harkes's Avatar
China
705
Rep
1,638
Posts

Drives: M135i, NSX and AE86
Join Date: Apr 2014
Location: Xiamen, China

iTrader: (0)

Quote:
Originally Posted by heartwork View Post
Where did you find that oil measurement above 100 degrees C will stop at 15%-17% ?!?
Where did you find this information? From a BMW dealer or service or there is some documentation that you found ?
Thanks
Tested it myself. Would be cool if you tested it too! 100C = 212F.
__________________
M135i PWG, MHD, Pure Stage2, Torqbyte CM5-LT, xHP
(A Dane in China)
Appreciate 0
      01-08-2018, 09:27 PM   #7
TheBreeze
Lieutenant
United_States
136
Rep
404
Posts

Drives: '08 e92 M3 (Silverstone II)
Join Date: Aug 2012
Location: Cary, NC

iTrader: (6)

Interesting. I was having the same problem, measuring would stop at 15%. I let the car cool a bit, oil gauge at 160, and it worked perfectly. Very odd indeed.
Appreciate 0
      04-19-2018, 04:29 AM   #8
heartwork
New Member
Romania
0
Rep
5
Posts

Drives: 2013 BMW F30 335ix
Join Date: Feb 2017
Location: Bucharest

iTrader: (0)

Update:

They replace both hydraulic valve 11417622768 and the oil sensor.
When I start the car and keep it idle until 'Start Measurement' become available - it measure for the first time. (it took at least 5-7 minutes and when it was cold even more than 12 minutes)
I checked the temperatures : where like 89 for water and 78-79 Celsius for the oil.
If I try a second measurement in a minute or up to 80 Celsius degrees oil temperature - it always quits at 15%.
I think that it is 15% or 17% depending on software version
Fortunately that is working at least once - but this is odd not to work even above 80 Celsius degrees...
For example on a 2012 F30 328i is working just fine at 115 Celsius degrees...
Appreciate 0
      02-09-2019, 02:37 AM   #9
harkes
Lieutenant Colonel
harkes's Avatar
China
705
Rep
1,638
Posts

Drives: M135i, NSX and AE86
Join Date: Apr 2014
Location: Xiamen, China

iTrader: (0)

Added info:
Using ISTA to trouble shoot the oil level measurement it automatically set the revs at 2000rpm until the oil has reached 90C.
Attached Images
 
__________________
M135i PWG, MHD, Pure Stage2, Torqbyte CM5-LT, xHP
(A Dane in China)
Appreciate 0
      10-19-2019, 01:54 PM   #10
BoriMkanoW35i
Registered
United_States
0
Rep
2
Posts

Drives: BMW 335GT
Join Date: Oct 2019
Location: Winter Park, Florida

iTrader: (0)

Anyone figured out the problem yet? Out of nowhere my GR started to do the same thing with measuring the oil. It stops at 15-20% when measuring, my trunk wont lock and I get a weird sound from possibly the frame when I have 1 or 2 passengers and take a turn. It sounds like theres too much weight on a metal or cracking your knuckles...
Appreciate 0
      10-20-2019, 10:56 AM   #11
bryanbrian
New Member
6
Rep
6
Posts

Drives: 2012 328i
Join Date: Apr 2018
Location: Toronto

iTrader: (0)

Mine would stop at 17%. Started right after an oil change. When the garage threw out the oil filter, they also threw out that little thingy inside the oil filter. Bought a new thingy and it's now fixed.
Appreciate 0
      10-20-2019, 08:46 PM   #12
harkes
Lieutenant Colonel
harkes's Avatar
China
705
Rep
1,638
Posts

Drives: M135i, NSX and AE86
Join Date: Apr 2014
Location: Xiamen, China

iTrader: (0)

Quote:
Originally Posted by BoriMkanoW35i View Post
Anyone figured out the problem yet? Out of nowhere my GR started to do the same thing with measuring the oil. It stops at 15-20% when measuring, my trunk wont lock and I get a weird sound from possibly the frame when I have 1 or 2 passengers and take a turn. It sounds like theres too much weight on a metal or cracking your knuckles...
Quote:
Originally Posted by bryanbrian View Post
Mine would stop at 17%. Started right after an oil change. When the garage threw out the oil filter, they also threw out that little thingy inside the oil filter. Bought a new thingy and it's now fixed.
Read the first post: UPDATE
__________________
M135i PWG, MHD, Pure Stage2, Torqbyte CM5-LT, xHP
(A Dane in China)
Appreciate 0
      10-20-2019, 09:29 PM   #13
Billfitz
Major General
Billfitz's Avatar
United_States
3259
Rep
7,824
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

Quote:
Originally Posted by harkes View Post

UPDATE: It's.. because the oil does not have the right temperature that the measurement stops at 15-17%. Oil temp must be between ~65 and 100C and as operating temp is 110-115C the level must be measured during warm up (pretty stupid and even more so that no information is provided in iDrive)...
It may not be shown in iDrive, but it is in the manual, where it says:
Requirements (for detailed oil measurement)
▷ Vehicle is on level road.
▷ Steptronic transmission: selector lever in
selector lever position N or P and accelerator
pedal not depressed.
▷ Engine is running and is at operating temperature.
Appreciate 0
      10-20-2019, 11:25 PM   #14
harkes
Lieutenant Colonel
harkes's Avatar
China
705
Rep
1,638
Posts

Drives: M135i, NSX and AE86
Join Date: Apr 2014
Location: Xiamen, China

iTrader: (0)

Quote:
Originally Posted by Billfitz View Post
It may not be shown in iDrive, but it is in the manual, where it says:
Requirements (for detailed oil measurement)
▷ Vehicle is on level road.
▷ Steptronic transmission: selector lever in
selector lever position N or P and accelerator
pedal not depressed.
▷ Engine is running and is at operating temperature.
Operating temp is ~112C at which I cannot measure the oil so my manual is wrong. Higher than 100C I cannot measure it on my F20 N55 - the N20 might be different.
__________________
M135i PWG, MHD, Pure Stage2, Torqbyte CM5-LT, xHP
(A Dane in China)
Appreciate 0
      10-21-2019, 12:38 AM   #15
bimmer456
Major General
1779
Rep
5,046
Posts

Drives: 340i
Join Date: Nov 2016
Location: Pasadena, CA

iTrader: (0)

The car measures the oil level or oil pressure throughout the driving cycle and will let you know if you need more oil, so no need to measure it manually.
Appreciate 0
      10-21-2019, 07:34 AM   #16
harkes
Lieutenant Colonel
harkes's Avatar
China
705
Rep
1,638
Posts

Drives: M135i, NSX and AE86
Join Date: Apr 2014
Location: Xiamen, China

iTrader: (0)

Quote:
Originally Posted by bimmer456 View Post
The car measures the oil level or oil pressure throughout the driving cycle and will let you know if you need more oil, so no need to measure it manually.
Because we care for our cars and just out of interest for the oil consumption
__________________
M135i PWG, MHD, Pure Stage2, Torqbyte CM5-LT, xHP
(A Dane in China)
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:51 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST