F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Cosmetic and Lighting Modifications (exterior & interior) > Depo LCI Tail Lights
Post Reply
 
Thread Tools Search this Thread
      11-12-2018, 01:12 PM   #67
vooonoo
\_(ツ)_/
vooonoo's Avatar
514
Rep
965
Posts

Drives: f30 328
Join Date: Nov 2017
Location: nj

iTrader: (0)

Garage List
2014 f30 328i  [0.00]
Quote:
Originally Posted by MONSTAR View Post
Quote:
Originally Posted by bkkeys View Post
I've had mine for maybe 9 months or so, without issues. My set was a development set, so I had an issue with the inner light coming a little loose, but the ones on my car were hand made and were just a prototype. Nothing a little 3m tape couldn't fix, but you shouldn't need it on the production lights.

Bryan
Mine have been on for a little over a week and I am actually having problems with the left inner light piece coming loose. I had to pull the carpet and basically do a re-install of that part this weekend. I tried "locking" it in both ways......hooking in the curved piece and pressing in and to right to get the nub in; and placing the nub in first and pushing/pulling out and to the left to get the hooked part in. Both ways, there is a substantial "snap" sound that makes it seem like it is in there good. But if you tighten the nut all the way, it just pops right out. I have the nut tightened to about 90% right now and it seems ok.....hopefully. I may have to try some double sided tape like you mentioned
Let me know what happens bc I think I was having trouble with this too. Until I pushed on the inner most part of the light until I heard a pop. After that I could tighten the nut and it wouldn't pop out.
Appreciate 0
      11-12-2018, 11:29 PM   #68
Mega8489
Private First Class
57
Rep
159
Posts

Drives: 335xdrive m sport Mppk+Mpe
Join Date: Aug 2015
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by bkkeys View Post
Looks awesome!!!
Thanks Bryan always a pleasure deal with you!
Appreciate 0
      11-14-2018, 11:43 PM   #69
Bryan_KiesMotorsports
310
Rep
449
Posts

Drives: 2013 BMW 335i xdrive
Join Date: Dec 2015
Location: US of A

iTrader: (0)

Quote:
Originally Posted by Mega8489 View Post
Quote:
Originally Posted by bkkeys View Post
Looks awesome!!!
Thanks Bryan always a pleasure deal with you!
Thanks!
Appreciate 0
      11-17-2018, 03:57 PM   #70
rcaso26
Second Lieutenant
rcaso26's Avatar
129
Rep
255
Posts

Drives: 2015 328i xdrive
Join Date: Oct 2017
Location: Long Island, NY

iTrader: (0)

Hey has anyone had any issues with the reverse lights not working on the Depo LCI tail lights? I've had these installed for a week and just realized that my reverse lights don't turn on when in reverse! I contacted USR, but I'm hoping someone had a quick fix for this. Maybe switching the wiring harnesses?
Appreciate 0
      11-18-2018, 03:06 AM   #71
MONSTAR
#gotboost
MONSTAR's Avatar
United_States
238
Rep
684
Posts

Drives: 2013 F30 328i
Join Date: Sep 2016
Location: Irvine, California

iTrader: (0)

Quote:
Originally Posted by rcaso26 View Post
Hey has anyone had any issues with the reverse lights not working on the Depo LCI tail lights? I've had these installed for a week and just realized that my reverse lights don't turn on when in reverse! I contacted USR, but I'm hoping someone had a quick fix for this. Maybe switching the wiring harnesses?
Are you positive that you put the right harness on the right side and left harness on the left side? That is the symptom of reversed wiring harnesses
Appreciate 1
rcaso26129.00

      11-18-2018, 10:05 AM   #72
rcaso26
Second Lieutenant
rcaso26's Avatar
129
Rep
255
Posts

Drives: 2015 328i xdrive
Join Date: Oct 2017
Location: Long Island, NY

iTrader: (0)

I am not sure! I'll switch today. Thanks.
Appreciate 0
      11-18-2018, 02:51 PM   #73
rcaso26
Second Lieutenant
rcaso26's Avatar
129
Rep
255
Posts

Drives: 2015 328i xdrive
Join Date: Oct 2017
Location: Long Island, NY

iTrader: (0)

MONSTAR - I switched the harnesses and everything works! Thanks for the help. This is why this forum is amazing.
Appreciate 1
MONSTAR237.50

      11-19-2018, 12:25 PM   #74
MONSTAR
#gotboost
MONSTAR's Avatar
United_States
238
Rep
684
Posts

Drives: 2013 F30 328i
Join Date: Sep 2016
Location: Irvine, California

iTrader: (0)

Quote:
Originally Posted by rcaso26 View Post
MONSTAR - I switched the harnesses and everything works! Thanks for the help. This is why this forum is amazing.
NP buddy. I did the same thing when I had the IKON blacklines (their harnesses weren't labeled L or R)
__________________
Schwartz II | M3 Front Bumper | M Sport Rear and Sideskirts | JB4 - Map 1 | ER Catless Downpipe | Injen Intake | 437m | H&R Sport Springs | Hankook Ventus V12 Evo2 | Carbon Fiber Interior | Carbon Fiber Diffuser | Muffler Delete | Carbon Fiber High Kick Spoiler
Appreciate 0
      11-27-2018, 12:57 PM   #75
dashBMW
Enlisted Member
United_States
2
Rep
31
Posts

Drives: BMW F30
Join Date: Oct 2018
Location: Boston

iTrader: (0)

Wire Tap

Instead of tapping the OEM plug cables, I tapped the green white wire going in the headlight assembly after the bricks . the tap wire was also green white and it worked
Appreciate 0
      01-16-2019, 10:55 PM   #76
yoon_209
Masterchief
yoon_209's Avatar
United_States
241
Rep
777
Posts

Drives: 13' BMW 335i
Join Date: Aug 2016
Location: Irvine, CA

iTrader: (0)

Quote:
Originally Posted by DrewF View Post
Had these installed for less than 24 hours.... they already have condensation on the inside.
Any update on condensation for your depo taillights?
__________________
BMS Intake | ER CP | VRSF FMIC & DP | MPE | JB4 | APEX ARC-8 | H&R Sport | CF Everythang
Appreciate 0
      01-16-2019, 11:10 PM   #77
DrewF
New Member
United_States
9
Rep
29
Posts

Drives: 2013 F30 328i
Join Date: Oct 2018
Location: Charlotte, NC

iTrader: (0)

Quote:
Originally Posted by yoon_209 View Post
Quote:
Originally Posted by DrewF View Post
Had these installed for less than 24 hours.... they already have condensation on the inside.
Any update on condensation for your depo taillights?
Yes, small update.

So the condensation went away. BUT WAIT. The condensation does come back every time there is a drastic temperature change. For example if it's 20 degrees in the morning and 60 degrees in the afternoon, there will be a large amount of condensation on the inside. But thankfully it does go away after a day or two.

It's also possible that I'm the only one with this issue. But I would say that if you live in an area with a steady daily temperature you should have absolutely no problem. And even if you don't, the condensation goes away naturally, it just takes a day or two and it's no big deal at all. So far.

Other than that I love the tail lights and couldn't be more pleased.
__________________
2013 F30 328i N20 | Alpine White | OEM 437M | BCRacing Coilovers | Muffler Delete | DEPO Headlights | Blackline Tail Lights | Debadged | F80 Style CF Mirrors | M-Sport Front |
Appreciate 0
      01-16-2019, 11:33 PM   #78
yoon_209
Masterchief
yoon_209's Avatar
United_States
241
Rep
777
Posts

Drives: 13' BMW 335i
Join Date: Aug 2016
Location: Irvine, CA

iTrader: (0)

Quote:
Originally Posted by DrewF View Post
Quote:
Originally Posted by yoon_209 View Post
Quote:
Originally Posted by DrewF View Post
Had these installed for less than 24 hours.... they already have condensation on the inside.
Any update on condensation for your depo taillights?
Yes, small update.

So the condensation went away. BUT WAIT. The condensation does come back every time there is a drastic temperature change. For example if it's 20 degrees in the morning and 60 degrees in the afternoon, there will be a large amount of condensation on the inside. But thankfully it does go away after a day or two.

It's also possible that I'm the only one with this issue. But I would say that if you live in an area with a steady daily temperature you should have absolutely no problem. And even if you don't, the condensation goes away naturally, it just takes a day or two and it's no big deal at all. So far.

Other than that I love the tail lights and couldn't be more pleased.
I'm in Cali so the temp is usually consistent.

Do you think it's due to poor quality and seals that hold the tail light together that causes it?
__________________
BMS Intake | ER CP | VRSF FMIC & DP | MPE | JB4 | APEX ARC-8 | H&R Sport | CF Everythang
Appreciate 0
      01-17-2019, 11:54 AM   #79
yoon_209
Masterchief
yoon_209's Avatar
United_States
241
Rep
777
Posts

Drives: 13' BMW 335i
Join Date: Aug 2016
Location: Irvine, CA

iTrader: (0)

Quote:
Originally Posted by MONSTAR View Post
Are you positive that you put the right harness on the right side and left harness on the left side? That is the symptom of reversed wiring harnesses
Quote:
Originally Posted by rcaso26 View Post
I am not sure! I'll switch today. Thanks.
have you guys had any issues with condensation so far?
__________________
BMS Intake | ER CP | VRSF FMIC & DP | MPE | JB4 | APEX ARC-8 | H&R Sport | CF Everythang
Appreciate 0
      01-17-2019, 01:27 PM   #80
rcaso26
Second Lieutenant
rcaso26's Avatar
129
Rep
255
Posts

Drives: 2015 328i xdrive
Join Date: Oct 2017
Location: Long Island, NY

iTrader: (0)

Quote:
Originally Posted by yoon_209 View Post
Quote:
Originally Posted by MONSTAR View Post
Are you positive that you put the right harness on the right side and left harness on the left side? That is the symptom of reversed wiring harnesses
Quote:
Originally Posted by rcaso26 View Post
I am not sure! I'll switch today. Thanks.
have you guys had any issues with condensation so far?
Nope not yet!
Appreciate 1
yoon_209241.00

      01-17-2019, 02:07 PM   #81
MONSTAR
#gotboost
MONSTAR's Avatar
United_States
238
Rep
684
Posts

Drives: 2013 F30 328i
Join Date: Sep 2016
Location: Irvine, California

iTrader: (0)

Quote:
Originally Posted by yoon_209 View Post
have you guys had any issues with condensation so far?
Lots of rain this week....no condensation!

Also using pre-LCI drip trays....no issues
__________________
Schwartz II | M3 Front Bumper | M Sport Rear and Sideskirts | JB4 - Map 1 | ER Catless Downpipe | Injen Intake | 437m | H&R Sport Springs | Hankook Ventus V12 Evo2 | Carbon Fiber Interior | Carbon Fiber Diffuser | Muffler Delete | Carbon Fiber High Kick Spoiler
Appreciate 1
yoon_209241.00

      01-17-2019, 02:18 PM   #82
DrewF
New Member
United_States
9
Rep
29
Posts

Drives: 2013 F30 328i
Join Date: Oct 2018
Location: Charlotte, NC

iTrader: (0)

Quote:
Originally Posted by yoon_209 View Post
Quote:
Originally Posted by DrewF View Post
Quote:
Originally Posted by yoon_209 View Post
Quote:
Originally Posted by DrewF View Post
Had these installed for less than 24 hours.... they already have condensation on the inside.
Any update on condensation for your depo taillights?
Yes, small update.

So the condensation went away. BUT WAIT. The condensation does come back every time there is a drastic temperature change. For example if it's 20 degrees in the morning and 60 degrees in the afternoon, there will be a large amount of condensation on the inside. But thankfully it does go away after a day or two.

It's also possible that I'm the only one with this issue. But I would say that if you live in an area with a steady daily temperature you should have absolutely no problem. And even if you don't, the condensation goes away naturally, it just takes a day or two and it's no big deal at all. So far.

Other than that I love the tail lights and couldn't be more pleased.
I'm in Cali so the temp is usually consistent.

Do you think it's due to poor quality and seals that hold the tail light together that causes it?
I think it's just because of the weather. It's fine when it rains. Just temperature.:.
__________________
2013 F30 328i N20 | Alpine White | OEM 437M | BCRacing Coilovers | Muffler Delete | DEPO Headlights | Blackline Tail Lights | Debadged | F80 Style CF Mirrors | M-Sport Front |
Appreciate 0
      01-22-2019, 06:49 AM   #83
rayjuan
Registered
0
Rep
3
Posts

Drives: f30 316i
Join Date: Jan 2019
Location: singapore

iTrader: (0)

hi guys, i just spent the last 4 hours figuring out why both my turn signals and reverse lights are showing red instead of amber for signals and white for reverse. every other thing worked fine.

just got my depos from ebay. followed the step by step installation guide and still clueless on rectifying this. does anyone here have the wiring diagram of sorts?

i connected the black and white wire from my car to the depos as instructed but signals and reverse lights still showing red

can someone please help!!!

thank u
Appreciate 0
      01-22-2019, 01:24 PM   #84
XxThe_RemedyXx
Lieutenant Colonel
Greece
582
Rep
1,735
Posts

Drives: 2014 335i XDrive
Join Date: Aug 2009
Location: Westchester, NY

iTrader: (0)

Installed these a few weeks ago and they've been pretty solid. No issues so far. I've been using the Pre-LCI drip trays as well. Using the posi-taps makes wiring super simple.

I also installed the LED reverse lights which make a tremendous difference.
Attached Images
  
__________________
'14 335 xDrive EWG FBO - VRSF Chargepipe - VRSF Catless Downpipe - AA Intercooler - MPE - BM3 Custom Tune by Cary Jordan - R1 Concepts Front/Rear Geomet Cross Drilled and Slotted Rotors
Appreciate 1
rcaso26129.00

      01-22-2019, 01:30 PM   #85
XxThe_RemedyXx
Lieutenant Colonel
Greece
582
Rep
1,735
Posts

Drives: 2014 335i XDrive
Join Date: Aug 2009
Location: Westchester, NY

iTrader: (0)

Quote:
Originally Posted by rayjuan View Post
hi guys, i just spent the last 4 hours figuring out why both my turn signals and reverse lights are showing red instead of amber for signals and white for reverse. every other thing worked fine.

just got my depos from ebay. followed the step by step installation guide and still clueless on rectifying this. does anyone here have the wiring diagram of sorts?

i connected the black and white wire from my car to the depos as instructed but signals and reverse lights still showing red

can someone please help!!!

thank u
There are two wires you have to tap into, one GRAY/BLACK and one WHITE/BLACK. Did you wire both to one of them?
__________________
'14 335 xDrive EWG FBO - VRSF Chargepipe - VRSF Catless Downpipe - AA Intercooler - MPE - BM3 Custom Tune by Cary Jordan - R1 Concepts Front/Rear Geomet Cross Drilled and Slotted Rotors
Appreciate 0
      01-22-2019, 02:25 PM   #86
rcaso26
Second Lieutenant
rcaso26's Avatar
129
Rep
255
Posts

Drives: 2015 328i xdrive
Join Date: Oct 2017
Location: Long Island, NY

iTrader: (0)

Quote:
Originally Posted by rayjuan View Post
hi guys, i just spent the last 4 hours figuring out why both my turn signals and reverse lights are showing red instead of amber for signals and white for reverse. every other thing worked fine.

just got my depos from ebay. followed the step by step installation guide and still clueless on rectifying this. does anyone here have the wiring diagram of sorts?

i connected the black and white wire from my car to the depos as instructed but signals and reverse lights still showing red

can someone please help!!!

thank u
I had this issue. Switch the harnesses from left to right and that should fix the problem.
Appreciate 0
      01-22-2019, 06:43 PM   #87
rayjuan
Registered
0
Rep
3
Posts

Drives: f30 316i
Join Date: Jan 2019
Location: singapore

iTrader: (0)

Quote:
Originally Posted by XxThe_RemedyXx View Post
There are two wires you have to tap into, one GRAY/BLACK and one WHITE/BLACK. Did you wire both to one of them?
i think i might have missed out the gray one! so its gray/black on the left and white/black for the right?
Appreciate 0
      01-22-2019, 07:04 PM   #88
rayjuan
Registered
0
Rep
3
Posts

Drives: f30 316i
Join Date: Jan 2019
Location: singapore

iTrader: (0)

update:

i just emailed fishcake on his depos and realized the ones i bought only came with the red led turn signals! now ill have to change them bulbs

does anyone know what led bulbs are for the depos turn signals? i figured that the reverse bulb is H21W.

is it safe to open up the depos for bulb changes???
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:29 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST