F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics > iDrive contacts go missing after iOS 13 update
European Auto Source (EAS)
Post Reply
 
Thread Tools Search this Thread
      09-22-2019, 07:39 AM   #1
jyc093
Private
16
Rep
81
Posts

Drives: 2016 430i
Join Date: Sep 2017
Location: Australia

iTrader: (0)

iDrive contacts go missing after iOS 13 update

Hi all, recently after updating to iOS 13, part of my contact list (synced via Bluetooth) goes missing when I go through the page on iDrive. So now when I get calls or receive messages it only displays the number instead of contact name. Is this a known bug with iOS 13?
Appreciate 0
      09-24-2019, 04:33 PM   #2
jamiem1987
Private First Class
United Kingdom
25
Rep
188
Posts

Drives: BMW 335D LCI
Join Date: Aug 2014
Location: United Kingdom

iTrader: (0)

My contacts only half sync with ios13. Anyone know a solution?
Appreciate 0
      09-25-2019, 03:00 AM   #3
Bolten88
Registered
0
Rep
4
Posts

Drives: BMW 118i M Sport
Join Date: Aug 2019
Location: Netherlands

iTrader: (0)

I have the same issue that contacts only sync half. I thought it had something to do with contacts that have an picture. But it turns out that, that is not true. When i disconnect and connect the phone multiple times i manage to get the contacts sync once. But when you disconnect and connect again the contacts are gone again.
Appreciate 0
      09-25-2019, 03:25 AM   #4
Bolten88
Registered
0
Rep
4
Posts

Drives: BMW 118i M Sport
Join Date: Aug 2019
Location: Netherlands

iTrader: (0)

I found this youtube video about the same issue:
Appreciate 0
      09-25-2019, 03:31 AM   #5
jamiem1987
Private First Class
United Kingdom
25
Rep
188
Posts

Drives: BMW 335D LCI
Join Date: Aug 2014
Location: United Kingdom

iTrader: (0)

Quote:
Originally Posted by Bolten88 View Post
I found this youtube video about the same issue:
interesting as repairing doesnt work for me.

I have filed a bug report with apple.
Appreciate 0
      09-25-2019, 03:59 AM   #6
Bolten88
Registered
0
Rep
4
Posts

Drives: BMW 118i M Sport
Join Date: Aug 2019
Location: Netherlands

iTrader: (0)

I've contacted Apple support and they told that it is a known issue and they are investigating it.
Appreciate 0
      09-25-2019, 05:37 AM   #7
jamiem1987
Private First Class
United Kingdom
25
Rep
188
Posts

Drives: BMW 335D LCI
Join Date: Aug 2014
Location: United Kingdom

iTrader: (0)

Quote:
Originally Posted by Bolten88 View Post
I've contacted Apple support and they told that it is a known issue and they are investigating it.
Did you speak to them on the phone and they had no idea about it, and said it's probably the car that doesn't support ios13?!
Appreciate 0
      09-26-2019, 12:29 AM   #8
therealm3
Major
67
Rep
1,198
Posts

Drives: F30 340 MSport
Join Date: Aug 2006
Location: CA, USA

iTrader: (6)

With every major Apple release there is always something that doesn't work right with my car. They blame bmw, bmw blames Apple and then "magically" all functionality returns with a subsequent iOS release. We'll just have to be patient. Dark mode was worth it. 😀
Appreciate 1
      09-26-2019, 03:56 AM   #9
Bolten88
Registered
0
Rep
4
Posts

Drives: BMW 118i M Sport
Join Date: Aug 2019
Location: Netherlands

iTrader: (0)

Quote:
Originally Posted by jamiem1987 View Post
Did you speak to them on the phone and they had no idea about it, and said it's probably the car that doesn't support ios13?!
Yes, i spoke to them and they only told me that the issue is being investigated. They did not say anything about unsupported iOS versions. I have a friend with an peugeot facing similar issues.
Appreciate 0
      09-26-2019, 10:30 AM   #10
FIREXTREMESLAYER
Registered
FIREXTREMESLAYER's Avatar
United_States
0
Rep
4
Posts

Drives: 15 BMW 328i
Join Date: Sep 2019
Location: Florida

iTrader: (0)

I had this issue when iOS 12 came out that magically resolved itself after a while so I guess this won't be any different lol
Appreciate 0
      09-30-2019, 07:36 PM   #11
therealm3
Major
67
Rep
1,198
Posts

Drives: F30 340 MSport
Join Date: Aug 2006
Location: CA, USA

iTrader: (6)

13.1.2 update hit my phone today. Release notes say something about Bluetooth connectivity fix but nothing specific to the contact issue. Updating now and will try in a few hours.
Appreciate 0
      10-02-2019, 11:43 PM   #12
jyc093
Private
16
Rep
81
Posts

Drives: 2016 430i
Join Date: Sep 2017
Location: Australia

iTrader: (0)

Quote:
Originally Posted by therealm3 View Post
13.1.2 update hit my phone today. Release notes say something about Bluetooth connectivity fix but nothing specific to the contact issue. Updating now and will try in a few hours.
Ive just tried the new update, just like with 13.1.1 all contacts synced for the first time, then they go missing the next. This is quite frustrating
Appreciate 0
      10-03-2019, 12:30 AM   #13
therealm3
Major
67
Rep
1,198
Posts

Drives: F30 340 MSport
Join Date: Aug 2006
Location: CA, USA

iTrader: (6)

Quote:
Originally Posted by jyc093 View Post
Quote:
Originally Posted by therealm3 View Post
13.1.2 update hit my phone today. Release notes say something about Bluetooth connectivity fix but nothing specific to the contact issue. Updating now and will try in a few hours.
Ive just tried the new update, just like with 13.1.1 all contacts synced for the first time, then they go missing the next. This is quite frustrating
So, my contacts are all there and it works fine for phone calls, just not text messages. Which honestly isn't the end of the world for me , but annoying none the less. Hopefully by 13.2 they will have figured it out.
Appreciate 0
      10-08-2019, 12:41 PM   #14
JuiceDude
Enlisted Member
0
Rep
39
Posts

Drives: Car
Join Date: Jul 2012
Location: London

iTrader: (0)

I had the same issue, I deleted the Bluetooth connection from iDrive and my iPhone and repaired. All the contacts came back.
Appreciate 0
      10-11-2019, 07:35 PM   #15
och
Lieutenant
och's Avatar
108
Rep
432
Posts

Drives: .
Join Date: Jan 2010
Location: Brooklyn, NY

iTrader: (0)

Garage List
2012 X5 xDrive50i  [0.00]
2018 BMW M2  [0.00]
2017 X6M  [0.00]
2013 Suzuki Bouleva ...  [0.00]
Same here, some of the contacts go missing after ios 13, both in my m2 and x6m
Appreciate 0
      10-15-2019, 03:44 PM   #16
jamiem1987
Private First Class
United Kingdom
25
Rep
188
Posts

Drives: BMW 335D LCI
Join Date: Aug 2014
Location: United Kingdom

iTrader: (0)

still not fixed on the newly released today ios
13.1.3, amazed bmw or apple are not sorting this given how well documented it is on twitter / forums
Appreciate 0
      10-15-2019, 03:45 PM   #17
jamiem1987
Private First Class
United Kingdom
25
Rep
188
Posts

Drives: BMW 335D LCI
Join Date: Aug 2014
Location: United Kingdom

iTrader: (0)

Quote:
Originally Posted by JuiceDude View Post
I had the same issue, I deleted the Bluetooth connection from iDrive and my iPhone and repaired. All the contacts came back.
not fixed for me, they sync for a couple of times after repairing but they drop off after that and only sync around half of the contacts
Appreciate 0
      10-18-2019, 06:52 AM   #18
JuiceDude
Enlisted Member
0
Rep
39
Posts

Drives: Car
Join Date: Jul 2012
Location: London

iTrader: (0)

Quote:
Originally Posted by jamiem1987 View Post
not fixed for me, they sync for a couple of times after repairing but they drop off after that and only sync around half of the contacts
I am also facing this issue spoke with BMW who advised me to send an email to bmwconnecteddrive@bmwfin.com.

Also, any Siri commands activated from the steering wheel button is failing for me. Currently on iOS 13.1.3.
Appreciate 0
      10-25-2019, 01:40 PM   #19
amancuso
Major
amancuso's Avatar
269
Rep
1,132
Posts

Drives: Z3, X5 4.8is,M5, M2
Join Date: Oct 2008
Location: Burlington, New Jersey

iTrader: (1)

Garage List
2004 X5 4.8iS  [0.00]
2000 Z3  [0.00]
2003 M5  [0.00]
I noticed this for the first time today on my M2. So far no issues in the 428
__________________
2016 428xi, 2000 Z3 2.3, 2003 M5, 2004 X5 4.8iS, 2018 M2 Visit the Northeast M2/ 2 series owners group on Facebook https://www.facebook.com/groups/1832292440408437/
Appreciate 0
      10-29-2019, 09:19 AM   #20
JuiceDude
Enlisted Member
0
Rep
39
Posts

Drives: Car
Join Date: Jul 2012
Location: London

iTrader: (0)

Hi,

iOS 13.2 is out and it has fixed the contact issue for me
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:54 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST