F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics > ios 13.1 issue when selecting songs
European Auto Source (EAS)
Post Reply
 
Thread Tools Search this Thread
      10-19-2019, 01:32 AM   #23
about94ninjas
Enlisted Member
about94ninjas's Avatar
United_States
35
Rep
35
Posts

Drives: 18 340i
Join Date: Oct 2018
Location: Fresno, CA

iTrader: (0)

Quote:
Originally Posted by damack View Post
Quote:
Originally Posted by about94ninjas View Post
I just updated to 13.1.3 last night, and the issue seems to have been fixed for me. Try deleting the phone from idrive, and then reset network setting on your phone.
Weird, I'm on 13.1.3 and have the issue.

Odd that the issue is present while playing music through usb too, although I don't really know how the interface works.
I take back what I said, it stopped working again lmao. It's been on and off for me. I'll try USB tomorrow and see if I have the same issue.
Appreciate 1
Blubaron791059.50

      10-21-2019, 01:15 PM   #24
DonOnCapeCod
Registered
5
Rep
1
Posts

Drives: 2014 428i Xdrive
Join Date: Apr 2017
Location: Cape Cod, MA

iTrader: (0)

I updated to the BETA 13.2 and the PLAYLIST issue is fixed.
But, I still have the issue whereas only the CELL NUMBER appears verses the Contact Name when receiving TEXT MESSAGES.
Appreciate 3
      10-21-2019, 08:41 PM   #25
wilbur_the_goose
Major
228
Rep
1,085
Posts

Drives: 2014 F30 Sport Line Sedan
Join Date: Apr 2010
Location: Metro Philly

iTrader: (0)

13.1.3 messed up my stuff again. 13.1.2 worked perfectly at 10am Saturday. 13.1.3 failed at 4pm Saturday.

"My Stuff" = Playing Tidal from my iPhone 8 via USB. It didn't even see my phone as connected via USB - it was playing Bluetooth. I have an iPhone adapter -plugged in the phone, and it worked, but I lost album art.

Friggin Apple
Appreciate 0
      10-22-2019, 03:46 PM   #26
rjd598
Major General
rjd598's Avatar
United_States
1215
Rep
6,418
Posts

Drives: F30 340i
Join Date: Jan 2009
Location: San Diego,CA

iTrader: (2)

Garage List
2016 BMW 340i  [0.00]
does anyone have spotify issues? the native app on the car won't connect at all anymore which is insanely stupid. do we basically just have to wait for ios updates?
Appreciate 0
      10-23-2019, 05:13 PM   #27
kmershly
Registered
0
Rep
4
Posts

Drives: BMW, Lexus, Nissan and a GMC
Join Date: Mar 2019
Location: Central Florida

iTrader: (0)

Quote:
Originally Posted by rjd598 View Post
does anyone have spotify issues? the native app on the car won't connect at all anymore which is insanely stupid. do we basically just have to wait for ios updates?
I have been having issues with Spotify for over a year now, in fact I reached out to both Spotify and BMW about it and I was basically told to just deal with it.

Some speculation that there was a change either in the BMW app and or the Spotify app changed something which requires a change in the BMW in-car software.

I should note that I am on Android and ID6.
Appreciate 0
      10-24-2019, 08:52 AM   #28
justsuvi
Private
justsuvi's Avatar
5
Rep
71
Posts

Drives: 2017 330ix
Join Date: Mar 2019
Location: Italy

iTrader: (0)

know issue we have the same problem some even dont see their contacts.
asked the local dealr they say it's apple problem
Appreciate 0
      10-25-2019, 03:20 PM   #29
damack
Registered
damack's Avatar
Canada
2
Rep
2
Posts

Drives: 2017 F31 330i M-Performance
Join Date: May 2019
Location: Canada

iTrader: (0)

Playing around with it for a bit, I found something interesting. The song selection issue is only present when I'm in a playlist. If I'm in category songs, artists, albums etc, I can select songs like I used to.

I'm still baffled why this issue happens using the usb plug though. If we think it's a bluetooth problem, shouldn't it work properly when using it via usb?
Appreciate 1
Blubaron791059.50

      10-28-2019, 03:11 PM   #30
Cpatel
Private First Class
18
Rep
119
Posts

Drives: N26 328i
Join Date: Oct 2018
Location: USA

iTrader: (0)

Quote:
Originally Posted by damack View Post
Playing around with it for a bit, I found something interesting. The song selection issue is only present when I'm in a playlist. If I'm in category songs, artists, albums etc, I can select songs like I used to.

I'm still baffled why this issue happens using the usb plug though. If we think it's a bluetooth problem, shouldn't it work properly when using it via usb?
Yup. I don't use playlists at all anymore. I go to all songs, hit shuffle, and then select from the steering wheel no problem.
The stupid thing about apple music is that you can have a song downloaded in a playlist but it won't appear in 'all music' unless you explicitly add it to all music.
99% sure I'm moving to android for my next phone. Apple is trash.
Appreciate 0
      10-28-2019, 05:02 PM   #31
Blubaron79
Brigadier General
Blubaron79's Avatar
United_States
1060
Rep
4,301
Posts

Drives: '18 340 XDrive
Join Date: May 2009
Location: PA

iTrader: (0)

Quote:
Originally Posted by Cpatel View Post
Quote:
Originally Posted by damack View Post
Playing around with it for a bit, I found something interesting. The song selection issue is only present when I'm in a playlist. If I'm in category songs, artists, albums etc, I can select songs like I used to.

I'm still baffled why this issue happens using the usb plug though. If we think it's a bluetooth problem, shouldn't it work properly when using it via usb?
Yup. I don't use playlists at all anymore. I go to all songs, hit shuffle, and then select from the steering wheel no problem.
The stupid thing about apple music is that you can have a song downloaded in a playlist but it won't appear in 'all music' unless you explicitly add it to all music.
99% sure I'm moving to android for my next phone. Apple is trash.
Just updated to 13.2. Will let everyone know if that works
__________________
'18 340 xDrive: Glacier Silver, MSport, 19's, every option (except ACC and DAP), MPPSK, black grille, splitter, side sills, CF Spoiler, clear bra.
Previous: '15 335 F30 xDrive; '14 435 F32 xDrive; '09 335 E92 xDrive
Appreciate 0
      10-28-2019, 05:16 PM   #32
Blubaron79
Brigadier General
Blubaron79's Avatar
United_States
1060
Rep
4,301
Posts

Drives: '18 340 XDrive
Join Date: May 2009
Location: PA

iTrader: (0)

Holy shit.. 13.2 fixed the issue!!!! Woo!
__________________
'18 340 xDrive: Glacier Silver, MSport, 19's, every option (except ACC and DAP), MPPSK, black grille, splitter, side sills, CF Spoiler, clear bra.
Previous: '15 335 F30 xDrive; '14 435 F32 xDrive; '09 335 E92 xDrive
Appreciate 0
      10-28-2019, 09:15 PM   #33
about94ninjas
Enlisted Member
about94ninjas's Avatar
United_States
35
Rep
35
Posts

Drives: 18 340i
Join Date: Oct 2018
Location: Fresno, CA

iTrader: (0)

13.2 fixed the issue for me as well
Appreciate 2
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:14 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST