F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > N20, N26, B46, B48 Turbo Engine / Drivetrain / Exhaust Modifications > BMW Shops in the Hudson Valley NY?
Extreme Powerhouse
Post Reply
 
Thread Tools Search this Thread
      01-21-2019, 12:50 PM   #1
Drlu23
Private
Drlu23's Avatar
9
Rep
87
Posts

Drives: X1 Xdrive 28i, 328 I Xdrive
Join Date: Jun 2013
Location: Hyde Park NY

iTrader: (0)

BMW Shops in the Hudson Valley NY?

Does anyone know of reputable BMW shops in the Hudson Valley NY area (Poughkeepsie, Fishkill, Kingston).

Thanks,

Lu
Appreciate 0
      01-21-2019, 04:42 PM   #2
smallba
Private First Class
smallba's Avatar
United_States
59
Rep
147
Posts

Drives: 2013 328i xDrive
Join Date: May 2016
Location: Orange County, NY

iTrader: (0)

Garage List
What are you looking to be done?
Appreciate 0
      01-21-2019, 07:21 PM   #3
Drlu23
Private
Drlu23's Avatar
9
Rep
87
Posts

Drives: X1 Xdrive 28i, 328 I Xdrive
Join Date: Jun 2013
Location: Hyde Park NY

iTrader: (0)

Quote:
Originally Posted by smallba View Post
What are you looking to be done?
The car is skipping a lot under medium and hard acceleration and I believe it has to do with fuel delivery. I changed spark plugs and gapped them correctly, changed intercooler and piping is tight. I need to clean the MAF as a third option but so far no ECL lights are on. I checked bimmer code and saw the MAF sensor notification on there. I just want a second opinion if I am still having an issue after I clean the MAF.
Appreciate 0
      02-09-2019, 06:51 AM   #4
Drlu23
Private
Drlu23's Avatar
9
Rep
87
Posts

Drives: X1 Xdrive 28i, 328 I Xdrive
Join Date: Jun 2013
Location: Hyde Park NY

iTrader: (0)

Bump
Appreciate 0
      02-12-2019, 06:37 PM   #5
sq86
Captain
sq86's Avatar
United_States
134
Rep
616
Posts

Drives: 2013 328i E92 LMB
Join Date: Apr 2007
Location: Brooklyn

iTrader: (0)

Garage List
Bavarian Rocket Science is supposed to be good but they're further north in Albany.

Based on your description it could be coils or maybe carbon buildup too, depending on your mileage. I hope it works out!
__________________

BMW CCA Member, Click to Join!
Current: 2013 E92 328i, 2005 Ford Focus
Sold: 2011 1M, 2008 E90 328xi, 2001 E46 330xi
Appreciate 0
      02-19-2019, 07:08 AM   #6
smallba
Private First Class
smallba's Avatar
United_States
59
Rep
147
Posts

Drives: 2013 328i xDrive
Join Date: May 2016
Location: Orange County, NY

iTrader: (0)

Garage List
Sorry Didn't get back to you, you could reach out to Lomotion in poughkeepsie, JJ has alot of experience with European cars, any thing else with be Jersey (AUTOcouture Motoring)
Appreciate 0
      02-20-2019, 08:00 AM   #7
Drlu23
Private
Drlu23's Avatar
9
Rep
87
Posts

Drives: X1 Xdrive 28i, 328 I Xdrive
Join Date: Jun 2013
Location: Hyde Park NY

iTrader: (0)

Thanks. I'll reach out to Lomotion.
Appreciate 0
      02-20-2019, 08:05 AM   #8
pjkbrit
Second Lieutenant
pjkbrit's Avatar
93
Rep
216
Posts

Drives: 2018 340i 6MT ZHP
Join Date: Feb 2016
Location: New York

iTrader: (0)

How many miles? The coils die after so many heat cycles.
Appreciate 0
      02-20-2019, 08:09 AM   #9
Drlu23
Private
Drlu23's Avatar
9
Rep
87
Posts

Drives: X1 Xdrive 28i, 328 I Xdrive
Join Date: Jun 2013
Location: Hyde Park NY

iTrader: (0)

Quote:
Originally Posted by pjkbrit View Post
How many miles? The coils die after so many heat cycles.
75K. I've gone through the coils and overall the system is working well. I took off the tune and have noticed no hesitations now during full throttle acceleration. I do believe either I have a fuel issue or boost leak, or maybe something with the tune (Jb Stage 1)
Appreciate 0
      02-20-2019, 08:33 AM   #10
Drlu23
Private
Drlu23's Avatar
9
Rep
87
Posts

Drives: X1 Xdrive 28i, 328 I Xdrive
Join Date: Jun 2013
Location: Hyde Park NY

iTrader: (0)

I'm also looking to clean out the intake valves; possible carbon buildup causing the hesitations. If this doesn't work, at least I'll have cleaner intake valves!
Appreciate 0
      02-21-2019, 04:12 PM   #11
pjkbrit
Second Lieutenant
pjkbrit's Avatar
93
Rep
216
Posts

Drives: 2018 340i 6MT ZHP
Join Date: Feb 2016
Location: New York

iTrader: (0)

Ah.... could be the JB tune then
Appreciate 0
      02-21-2019, 08:39 PM   #12
Drlu23
Private
Drlu23's Avatar
9
Rep
87
Posts

Drives: X1 Xdrive 28i, 328 I Xdrive
Join Date: Jun 2013
Location: Hyde Park NY

iTrader: (0)

Quote:
Originally Posted by pjkbrit View Post
Ah.... could be the JB tune then
Have you guys heard of the tune acting this way? I would have thought the tune would only apply a single code set to the parameters of the car.... wasn't sure if you guys are aware of a tune not functioning as it should later during it's life. Any feedback would be great on this topic.
Appreciate 0
      02-23-2019, 07:38 PM   #13
smallba
Private First Class
smallba's Avatar
United_States
59
Rep
147
Posts

Drives: 2013 328i xDrive
Join Date: May 2016
Location: Orange County, NY

iTrader: (0)

Garage List
Sounds like your issues are pointing towards JB stage 1 (I'm assuming) or is it a JB4
Appreciate 0
      02-24-2019, 11:33 AM   #14
rjdnyy224
Colonel
rjdnyy224's Avatar
United_States
1181
Rep
2,746
Posts

Drives: 2013 328i xDrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by Drlu23 View Post
Have you guys heard of the tune acting this way? I would have thought the tune would only apply a single code set to the parameters of the car.... wasn't sure if you guys are aware of a tune not functioning as it should later during it's life. Any feedback would be great on this topic.
Absolutely, it's likely that it is the tune if the issue stops when the tune is removed. If it never did this before however, even with the tune, then that points to a mechanical problem, it's either not getting spark or fuel and that's being exacerbated with the tune. The tune the will degrade over time though, if that's what you're asking.
__________________
2013 328i xDrive N20 8AT | Bootmod3 Stage 2 OTS 93oct AGG | VRSF Street 5" HD Front-Mount Intercooler | VRSF Catless Downpipe | M Performance Exhaust | NGK L/I Spark Plugs | K&N Drop-in | Dinan 20" Wheels Wearing Michelin PS4S's | Dinan Springs and Bumpstops | F80 Style Decklid Spoiler | Debadged | F80 Style Grille | Various Interior Bits |
Appreciate 0
      02-24-2019, 12:06 PM   #15
Drlu23
Private
Drlu23's Avatar
9
Rep
87
Posts

Drives: X1 Xdrive 28i, 328 I Xdrive
Join Date: Jun 2013
Location: Hyde Park NY

iTrader: (0)

Quote:
Originally Posted by rjdnyy224 View Post
Quote:
Originally Posted by Drlu23 View Post
Have you guys heard of the tune acting this way? I would have thought the tune would only apply a single code set to the parameters of the car.... wasn't sure if you guys are aware of a tune not functioning as it should later during it's life. Any feedback would be great on this topic.
Absolutely, it's likely that it is the tune if the issue stops when the tune is removed. If it never did this before however, even with the tune, then that points to a mechanical problem, it's either not getting spark or fuel and that's being exacerbated with the tune. The tune the will degrade over time though, if that's what you're asking.
Quote:
Originally Posted by rjdnyy224 View Post
Quote:
Originally Posted by Drlu23 View Post
Have you guys heard of the tune acting this way? I would have thought the tune would only apply a single code set to the parameters of the car.... wasn't sure if you guys are aware of a tune not functioning as it should later during it's life. Any feedback would be great on this topic.
Absolutely, it's likely that it is the tune if the issue stops when the tune is removed. If it never did this before however, even with the tune, then that points to a mechanical problem, it's either not getting spark or fuel and that's being exacerbated with the tune. The tune the will degrade over time though, if that's what you're asking.

I am going to clean out the intake runners to see if there is extensive carbon build up. Again, I am at 75K so why not anyway. But I am thinking it is a fuel issue, I just don't want to do the fuel injectors; 1 haven't done that before and 2 I can do it but it's time and also a lot of things to do too like also changing the seals on the filter which makes this job not so much fun to do right now I'm the winter.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:22 PM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST