F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > F30 DIYs and Coding Discussions > How to keep using expired E-Sys Launcher Premium by reverting system date (hack)
European Auto Source (EAS)
Post Reply
 
Thread Tools Search this Thread
      01-17-2018, 11:26 AM   #23
Tony Twoclicks
Second Lieutenant
99
Rep
257
Posts

Drives: 2012 F30 320i
Join Date: Jan 2018
Location: Europe

iTrader: (0)

What OS did you use? And did the script run OK (no errors)? Did you run it elevated? Have you tried the latest version? Are there multiple user accounts on your system?
Appreciate 0
      01-17-2018, 11:36 AM   #24
BimmerSI
Enlisted Member
18
Rep
48
Posts

Drives: F31 320d, F10 520d
Join Date: Jun 2017
Location: Slovenia

iTrader: (0)

I am using windows 10 x64. This is what I get when i run script:



I run it as administrator. I have downloaded your latest verison. Only one user in OS.
Appreciate 0
      01-17-2018, 11:40 AM   #25
BimmerSI
Enlisted Member
18
Rep
48
Posts

Drives: F31 320d, F10 520d
Join Date: Jun 2017
Location: Slovenia

iTrader: (0)

I got it working! It looks like problem was finding the right path to the folder due to virtual windows.

Then I copied rearm folder to "Program Files(x86)\TokenMaster\E-Sys Launcher Premium" and it is working now.


OK, so I am playing with it now and for me it seems to be working only when I enter date: 01.04.2017. If I put like 17.01.2017 it says date manipulation.

On other thing: Manual entered date automaticaly changes to real date after 2 minutes in winodws 10?!?

Last edited by BimmerSI; 01-17-2018 at 11:50 AM.. Reason: Added date findings.
Appreciate 0
      01-17-2018, 12:17 PM   #26
BimmerSI
Enlisted Member
18
Rep
48
Posts

Drives: F31 320d, F10 520d
Join Date: Jun 2017
Location: Slovenia

iTrader: (0)

Time reset was performed due to Parallels Desktop setting where Sync Date with Mac was checked.
Appreciate 0
      01-17-2018, 12:32 PM   #27
Maxwell4321
New Member
3
Rep
6
Posts

Drives: BMW F13 M6
Join Date: Jul 2014
Location: UK

iTrader: (0)

Works perfectly Win 10 x64 and 3.27, well done and thanks
Appreciate 0
      01-17-2018, 02:36 PM   #28
maciek49912
Registered
No_Country
0
Rep
3
Posts

Drives: F30 2.0d 184hp
Join Date: Oct 2017
Location: Europe

iTrader: (0)

I can't do nothing :/

Program is still showing "date manipulated"...

What can I do with that ?

Maybe my version is not ok - I have 2.7.1.135 instaled.
Esys version - 3.28.1
Windows 10 Pro x64

Last edited by maciek49912; 01-17-2018 at 03:40 PM..
Appreciate 0
      01-17-2018, 04:01 PM   #29
Tony Twoclicks
Second Lieutenant
99
Rep
257
Posts

Drives: 2012 F30 320i
Join Date: Jan 2018
Location: Europe

iTrader: (0)

Quote:
Originally Posted by BimmerSI View Post
I got it working! It looks like problem was finding the right path to the folder due to virtual windows.

Then I copied rearm folder to "Program Files(x86)\TokenMaster\E-Sys Launcher Premium" and it is working now.


OK, so I am playing with it now and for me it seems to be working only when I enter date: 01.04.2017. If I put like 17.01.2017 it says date manipulation.

On other thing: Manual entered date automaticaly changes to real date after 2 minutes in winodws 10?!?

Looks like you didn't read the Readme.txt in the package very well....
It is stated that the package should be installed on your desktop or local system. Hence the UNC path error in your screenshot.

About predating to 17.01.2017, please reread note #2 in your screenshot...

Good that it's working now for you.
Appreciate 1
      01-17-2018, 04:09 PM   #30
Tony Twoclicks
Second Lieutenant
99
Rep
257
Posts

Drives: 2012 F30 320i
Join Date: Jan 2018
Location: Europe

iTrader: (0)

Updated version

Version 1.3 is out! I needed to update the script again to fix a bug in 32/64-bit support. Compatibility with Launcher 2.7.1, Windows 10 and 32/64-bit should have improved. Please download again to avoid future issues.

Also, as I have no 32-bit OS to test in, I have no way to be sure whether the script works the same. Would be nice to get some feedback on that.

Cheers, Tony

-----------
Tony Twoclicks

Last edited by Tony Twoclicks; 01-17-2018 at 04:09 PM.. Reason: typo
Appreciate 0
      01-17-2018, 04:11 PM   #31
Tony Twoclicks
Second Lieutenant
99
Rep
257
Posts

Drives: 2012 F30 320i
Join Date: Jan 2018
Location: Europe

iTrader: (0)

Quote:
Originally Posted by maciek49912 View Post
I can't do nothing :/

Program is still showing "date manipulated"...

What can I do with that ?

Maybe my version is not ok - I have 2.7.1.135 instaled.
Esys version - 3.28.1
Windows 10 Pro x64

There was a bug in the last version. Please retry with the latest version 1.3
Appreciate 0
      01-17-2018, 04:14 PM   #32
a803sgo
Captain
164
Rep
616
Posts

Drives: BMW 320D M-SPORT (F30)
Join Date: Apr 2015
Location: Kent, UK

iTrader: (0)

Launcher 2.6.2 and esys 3.24.3, script (1.2) runs fine but still get date manipulated warning, esys worked fine beforehand, well before the time bomb anyway, any ideas?

Uninstalled esys and launcher with the date set back and with the proper date but it made no difference.
Appreciate 0
      01-17-2018, 04:26 PM   #33
a803sgo
Captain
164
Rep
616
Posts

Drives: BMW 320D M-SPORT (F30)
Join Date: Apr 2015
Location: Kent, UK

iTrader: (0)

1.3 doesn't work either, script runs fine but end up getting this...



Pic off Google, mine doesn't have anything filled in, with 1.2 I was just getting the date manipulation warning and nothing else.
Appreciate 0
      01-17-2018, 04:27 PM   #34
maciek49912
Registered
No_Country
0
Rep
3
Posts

Drives: F30 2.0d 184hp
Join Date: Oct 2017
Location: Europe

iTrader: (0)

Quote:
Originally Posted by Tony Twoclicks View Post
There was a bug in the last version. Please retry with the latest version 1.3
Look at this




I don't know where is problem (still)

I have esys in this direction C:\EC-APPS\ESG\E-Sys
Esys launcher premium in this direction C:\Program Files (x86)\TokenMaster\E-Sys Launcher Premium\

Maybe this is the problem ?

Last edited by maciek49912; 01-17-2018 at 04:37 PM..
Appreciate 0
      01-17-2018, 04:42 PM   #35
Tony Twoclicks
Second Lieutenant
99
Rep
257
Posts

Drives: 2012 F30 320i
Join Date: Jan 2018
Location: Europe

iTrader: (0)

Quote:
Originally Posted by a803sgo View Post
1.3 doesn't work either, script runs fine but end up getting this...

Pic off Google, mine doesn't have anything filled in, with 1.2 I was just getting the date manipulation warning and nothing else.

What happens when you fill in the form? Do you get the car model selection screen, or just the same form again (but then empty)?

Once you've created a token, open Explorer and go to the folder you selected in the 'Path' field of the form. There should be a file "freetoken.est". Open this in Notepad. What start- and end-dates are mentioned there in the header? Does your adjusted system clock fit in between these dates?
Appreciate 0
      01-17-2018, 04:59 PM   #36
Tony Twoclicks
Second Lieutenant
99
Rep
257
Posts

Drives: 2012 F30 320i
Join Date: Jan 2018
Location: Europe

iTrader: (0)

Quote:
Originally Posted by maciek49912 View Post
I don't know where is problem (still)

I have esys in this direction C:\EC-APPS\ESG\E-Sys
Esys launcher premium in this direction C:\Program Files (x86)\TokenMaster\E-Sys Launcher Premium\

Maybe this is the problem ?

Looking good to me...
It could be there is another check that I haven't found yet. Also, as a general thought, revert the system clock BEFORE you run the script. When you do it after, it might negate the actions of my script by changing system folders back to the wrong date(s).

For Launcher version 2.7.1 you could also try to set the date a bit higher (towards 2018) to see if that makes a difference.
Appreciate 0
      01-17-2018, 05:06 PM   #37
maciek49912
Registered
No_Country
0
Rep
3
Posts

Drives: F30 2.0d 184hp
Join Date: Oct 2017
Location: Europe

iTrader: (0)

Quote:
Originally Posted by Tony Twoclicks View Post
Looking good to me...
It could be there is another check that I haven't found yet. Also, as a general thought, revert the system clock BEFORE you run the script. When you do it after, it might negate the actions of my script by changing system folders back to the wrong date(s).

For Launcher version 2.7.1 you could also try to set the date a bit higher (towards 2018) to see if that makes a difference.
Unfortunately, problem is still existing.

I don't know where is problem all files and time are good :/
Appreciate 0
      01-17-2018, 05:15 PM   #38
a803sgo
Captain
164
Rep
616
Posts

Drives: BMW 320D M-SPORT (F30)
Join Date: Apr 2015
Location: Kent, UK

iTrader: (0)

Quote:
Originally Posted by Tony Twoclicks View Post
What happens when you fill in the form? Do you get the car model selection screen, or just the same form again (but then empty)?

Once you've created a token, open Explorer and go to the folder you selected in the 'Path' field of the form. There should be a file "freetoken.est". Open this in Notepad. What start- and end-dates are mentioned there in the header? Does your adjusted system clock fit in between these dates?
No car selection screen, just this screen initially, filling in the form creates the token and takes me to the car selection screen.

The headers shows a NotValidBefore date of 2016-11-30 and a NotValidAfter date of 2017-12-31, I've set the system date to 01/12/2016.

After selecting a model, launches esys and looks to be working but not tried it with FDL coding, finger corssed it looks to be working.

Appreciate 0
      01-17-2018, 05:26 PM   #39
Tony Twoclicks
Second Lieutenant
99
Rep
257
Posts

Drives: 2012 F30 320i
Join Date: Jan 2018
Location: Europe

iTrader: (0)

Quote:
Originally Posted by a803sgo View Post
No car selection screen, just this screen initially, filling in the form creates the token and takes me to the car selection screen.

The headers shows a NotValidBefore date of 2016-11-30 and a NotValidAfter date of 2017-12-31, I've set the system date to 01/12/2016.

After selecting a model, launches esys and looks to be working but not tried it with FDL coding, finger corssed it looks to be working.

You're OK.
That initial screen that you get is for token generation. This is normal.
Everytime you run my script you'll see this screen again because it resets the Launcher. Normally, it would show up only once upon first use.

Cheers, Tony
Appreciate 0
      01-17-2018, 05:39 PM   #40
a803sgo
Captain
164
Rep
616
Posts

Drives: BMW 320D M-SPORT (F30)
Join Date: Apr 2015
Location: Kent, UK

iTrader: (0)

Nice one, thanks.
Appreciate 0
      01-18-2018, 06:36 AM   #41
marcospoffo
Private
marcospoffo's Avatar
Brazil
10
Rep
82
Posts

Drives: 320 F30 - 2013
Join Date: Mar 2015
Location: Brazil - SC

iTrader: (0)

Thank you very much. It worked perfect here.

I made my donation to get the Master token on January 4th. I already emailed him the same day.

I already sent 3x email and until today 14 days later I had no response.

So your solution is very welcome.
__________________
320 F30 2013.
Appreciate 0
      01-18-2018, 07:26 AM   #42
shawnsheridan
General
shawnsheridan's Avatar
United_States
3554
Rep
19,249
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by marcospoffo View Post
Thank you very much. It worked perfect here.

I made my donation to get the Master token on January 4th. I already emailed him the same day.

I already sent 3x email and until today 14 days later I had no response.

So your solution is very welcome.
PM me your email address that you send TM email from.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Appreciate 0
      01-18-2018, 07:44 AM   #43
spudvti
Enlisted Member
Ukraine
2
Rep
34
Posts

Drives: f30 USDM
Join Date: Oct 2017
Location: UA-DP

iTrader: (0)

hi there
I've tried 2.5.3 launcher with your script on date november, 15 2017. No good - just looping launcher at token generating moment.
then, I've deleted old FreeToken.est - same - no good

where should i go? what's wrong? hmmm

Last edited by spudvti; 01-18-2018 at 09:34 AM..
Appreciate 0
      01-18-2018, 08:28 AM   #44
thedredd
New Member
9
Rep
17
Posts

Drives: BMW F30 320D LCI Sport
Join Date: Oct 2017
Location: ITALY

iTrader: (0)

Quote:
Originally Posted by maciek49912 View Post
Look at this




I don't know where is problem (still)

I have esys in this direction C:\EC-APPS\ESG\E-Sys
Esys launcher premium in this direction C:\Program Files (x86)\TokenMaster\E-Sys Launcher Premium\

Maybe this is the problem ?

I have the same problem
Appreciate 0
Post Reply

Bookmarks

Tags
clock, date, esys, launcher, premium

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:36 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST