F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > F30 DIYs and Coding Discussions > Coding cable and ESYS, psdzdata
Post Reply
 
Thread Tools Search this Thread
      12-07-2019, 08:11 PM   #3037
shawnsheridan
General
shawnsheridan's Avatar
United_States
3907
Rep
21,039
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by paimon.soror View Post
new laptop, so if you get a free moment, mind sending me a fresh link to esys/psdzdata

tia
PM sent.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Appreciate 0
      12-07-2019, 09:09 PM   #3038
paimon.soror
Captain
paimon.soror's Avatar
United_States
364
Rep
683
Posts

Drives: 2016 F36 435x MSport
Join Date: Oct 2017
Location: Hartford, CT

iTrader: (2)

Garage List
Quote:
Originally Posted by shawnsheridan View Post
PM sent.
__________________
2010 Mazda RX8 - Sold (11/17)
2016 BMW 435xi GC - Current
Appreciate 0
      12-11-2019, 11:34 AM   #3039
roma3
Enlisted Member
United_States
15
Rep
34
Posts

Drives: F30 328i xdrive
Join Date: Jul 2017
Location: Fairfax, VA

iTrader: (0)

Hello, please send a link when you can. thanks in advance
Appreciate 0
      12-11-2019, 11:57 AM   #3040
shawnsheridan
General
shawnsheridan's Avatar
United_States
3907
Rep
21,039
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by roma3 View Post
Hello, please send a link when you can. thanks in advance
PM sent.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Appreciate 0
      12-12-2019, 10:35 AM   #3041
Fast400
Captain
Fast400's Avatar
United_States
208
Rep
661
Posts

Drives: X4 M40i G02
Join Date: May 2014
Location: Arizona

iTrader: (0)

Garage List
2014 BMW  [0.00]
Has anyone else had issues with Launcher 3? I haven't accessed in a several months, now when I try to log in with my google authenticator pin I get "verification failed".
I only code occasionally, and it's getting frustrating using Esys, as I've paid some folks $$$ to get 'updated' versions in the past....don't use for a few months, and boom, doesn't work anymore.
I'm not surprised most people are using Bimmercode, which is what I've been using too. Just figured I do some in-depth stuff with Esys….nope, not today.
Does anyone have a solution, or experience the same issue?
Appreciate 0
      12-14-2019, 05:46 AM   #3042
Boisee
Enlisted Member
Scotland
13
Rep
39
Posts

Drives: 2015 F31 330D
Join Date: Feb 2017
Location: North East Scotland

iTrader: (0)

Garage List
Hi,
Would appreciate a link when you get a moment Shawn.

Thanks in advance.
Appreciate 0
      12-17-2019, 04:56 PM   #3043
lukas85
New Member
0
Rep
22
Posts

Drives: BMW F30
Join Date: Dec 2019
Location: Poland

iTrader: (0)

Hi
Can I use E-Sys 3.30.0 and psdzdata v63.3 to flash ECU of BMW F30 2018 ?

If not which version should I use ?

Thanks for help.
Appreciate 0
      12-17-2019, 05:08 PM   #3044
shawnsheridan
General
shawnsheridan's Avatar
United_States
3907
Rep
21,039
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by lukas85 View Post
Hi
Can I use E-Sys 3.30.0 and psdzdata v63.3 to flash ECU of BMW F30 2018 ?

If not which version should I use ?

Thanks for help.
You can flash with E-Sys 3.3x, and you can use any PSdZData Full version you choose to use.
Appreciate 0
      12-17-2019, 05:14 PM   #3045
lukas85
New Member
0
Rep
22
Posts

Drives: BMW F30
Join Date: Dec 2019
Location: Poland

iTrader: (0)

I'm asking because while programming with ISTA+ 4.18 the car turned off itself. Communication was lost and now almost nothing works. I need to reprogram ECU and I don't know if E-Sys can handle in such situation.
Appreciate 0
      12-17-2019, 05:28 PM   #3046
shawnsheridan
General
shawnsheridan's Avatar
United_States
3907
Rep
21,039
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by lukas85 View Post
I'm asking because while programming with ISTA+ 4.18 the car turned off itself. Communication was lost and now almost nothing works. I need to reprogram ECU and I don't know if E-Sys can handle in such situation.
Of course car shut itself off. E-Sys would do the same. Programming puts car in Transport Mode. This is why car should be on a Commercial Grade, 50+ Amp Charger during Programming.

You need to make sure car is not stuck in Transport Mode now.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Appreciate 0
      12-17-2019, 06:52 PM   #3047
lukas85
New Member
0
Rep
22
Posts

Drives: BMW F30
Join Date: Dec 2019
Location: Poland

iTrader: (0)

Sorry my english is not my native language. What do you mean by "commercial grade". It means that a car has some sort of "sensor" detecting it is on commercial grade therefore it will not turn off ?
Appreciate 0
      12-17-2019, 06:56 PM   #3048
shawnsheridan
General
shawnsheridan's Avatar
United_States
3907
Rep
21,039
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by lukas85 View Post
Sorry my english is not my native language. What do you mean by "commercial grade". It means that a car has some sort of "sensor" detecting it is on commercial grade therefore it will not turn off ?
No. A High-Current Charger given it high-cost is designed for commercial applications. You can jump car to another car with its motor running if you have no charger.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Appreciate 0
      12-17-2019, 07:16 PM   #3049
lukas85
New Member
0
Rep
22
Posts

Drives: BMW F30
Join Date: Dec 2019
Location: Poland

iTrader: (0)

Ok, I will try to disable transport mode. Thanks for help.
Appreciate 0
      12-18-2019, 08:18 AM   #3050
lukas85
New Member
0
Rep
22
Posts

Drives: BMW F30
Join Date: Dec 2019
Location: Poland

iTrader: (0)

Nope, no success. I connected ICOM, established connection with E-sys but nothing works.


Then I tried again with Ista+, I tried to diable Transport mode, but it didn't help. The ignition of the car can't be turned on/off. The dashboard turns on when I connect the car battery.








When I click "calculate measures plan", program just hangs, nothing works, I even left it for 20 minutes andnothing happened.


Any clues, maybye I'm doing something wrong or I really bricked ECU.
Appreciate 0
      12-18-2019, 08:48 AM   #3051
atzebmw
Major
Germany
276
Rep
1,271
Posts

Drives: BMW 335XD F30 LCI
Join Date: May 2016
Location: Germany

iTrader: (0)

Quote:
Originally Posted by lukas85 View Post
Nope, no success. I connected ICOM, established connection with E-sys but nothing works.

Did you ever work with E-Sys?
Do you get a connection to the car with E-Sys?
Appreciate 0
      12-18-2019, 08:55 AM   #3052
lukas85
New Member
0
Rep
22
Posts

Drives: BMW F30
Join Date: Dec 2019
Location: Poland

iTrader: (0)

Nope, I never worked with E-sys I selected connection to ICOM IP Address and I'm trying to read antyhing from the car to make sure it is working before programming. It is e-sys 3.30 with launcher pro 2.8.2 by tokenmaster.
Appreciate 0
      12-18-2019, 09:09 AM   #3053
atzebmw
Major
Germany
276
Rep
1,271
Posts

Drives: BMW 335XD F30 LCI
Join Date: May 2016
Location: Germany

iTrader: (0)

Quote:
Originally Posted by lukas85 View Post
Nope, I never worked with E-sys I selected connection to ICOM IP Address and I'm trying to read antyhing from the car to make sure it is working before programming. It is e-sys 3.30 with launcher pro 2.8.2 by tokenmaster.
Then try to connect by VIN.
Do you see the VIN of your car at the connection window?
Attached Images
 
Appreciate 0
      12-18-2019, 09:15 AM   #3054
lukas85
New Member
0
Rep
22
Posts

Drives: BMW F30
Join Date: Dec 2019
Location: Poland

iTrader: (0)

I have ENET cable but It somehow doesn't work. ICOM works ok on ISTA+, so I decided to connect to my car through tcp://169.254.92.38:50160 because that IP address is my ICOM device. ENET cable doesn't show under "ZGW" it is greyed out.


I believe that ICOM works with ista+ because ZGW module in my car was corrupted during flashing procedure. That's why ENET will not work.

If anyone is interested with helping me to programm DME or whatever is the problem I am willing to pay by paypal. We can use teamviewer for this purpose. Just contact me on pm.

Last edited by lukas85; 12-18-2019 at 11:40 AM..
Appreciate 0
      12-18-2019, 01:18 PM   #3055
shawnsheridan
General
shawnsheridan's Avatar
United_States
3907
Rep
21,039
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by lukas85 View Post
Nope, no success. I connected ICOM, established connection with E-sys but nothing works.


Then I tried again with Ista+, I tried to diable Transport mode, but it didn't help. The ignition of the car can't be turned on/off. The dashboard turns on when I connect the car battery.

...
When I click "calculate measures plan", program just hangs, nothing works, I even left it for 20 minutes andnothing happened.

Any clues, maybye I'm doing something wrong or I really bricked ECU.
Quote:
Originally Posted by lukas85 View Post
I have ENET cable but It somehow doesn't work. ICOM works ok on ISTA+, so I decided to connect to my car through tcp://169.254.92.38:50160 because that IP address is my ICOM device. ENET cable doesn't show under "ZGW" it is greyed out.

I believe that ICOM works with ista+ because ZGW module in my car was corrupted during flashing procedure. That's why ENET will not work.

If anyone is interested with helping me to programm DME or whatever is the problem I am willing to pay by paypal. We can use teamviewer for this purpose. Just contact me on pm.
If ICOM is working, Connect with ICOM and E-Sys, and use Read (ECU), not Read (SVT). If that works, look under DDE or DME Module, and see if CAFD is corrupted (cafd_ffffffff-255_255_255) or CAFD is missing.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Appreciate 0
      12-18-2019, 01:23 PM   #3056
lukas85
New Member
0
Rep
22
Posts

Drives: BMW F30
Join Date: Dec 2019
Location: Poland

iTrader: (0)

I'm not right know ath the car. I'll be there tomorrow. What I remember that when I clicked READ ECU the FA poped out but it was 0 (nothing in it).

I think I know wy e-sys is not properly communicationg with icom. I think I need to use "easy conneect utility" to change the bus of ICOM.

Last edited by lukas85; 12-18-2019 at 01:38 PM..
Appreciate 0
      12-18-2019, 01:42 PM   #3057
shawnsheridan
General
shawnsheridan's Avatar
United_States
3907
Rep
21,039
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by lukas85 View Post
I'm not right know ath the car. I'll be there tomorrow. What I remember that when I clicked READ ECU the FA poped out but it was 0 (nothing in it).

I think I know wy e-sys is not properly communicationg with icom. I think I need to use "easy conneect utility" to change the bus of ICOM.
If ECU List is "0", your Conneciton is not correct.

Connection via ENET is a lot easier and simpler. You say it is not working because ZGW failed flash, but when you connected with ENET 1) Did you bypass E-Sys launcher and use E-Sys Direct? 2) Was MOTOR Running? 3) Did you disable All Windows Defender / Windows or any 3rd Party Firewall applications?
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Appreciate 0
      12-18-2019, 01:44 PM   #3058
lukas85
New Member
0
Rep
22
Posts

Drives: BMW F30
Join Date: Dec 2019
Location: Poland

iTrader: (0)

1. No. I always run E-Sys with Launcher pro
2. No, I can't turn on the motor (start/stop doesn't work)
3. Yes windows defender and Firewall disabled, no third party apps.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:06 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST