F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > N55 Turbo Engine / Drivetrain / Exhaust Modifications > O2 issue that won't go away.
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      10-26-2019, 02:24 AM   #1
controllerplus
Private First Class
7
Rep
101
Posts

Drives: e46 m3
Join Date: May 2016
Location: St. Louis

iTrader: (0)

Long story. O2 'went bad' but it really was the ground wire. We replaced the o2 in lambda bank 1 and redid the pin wire.

All codes went away and car ran flawlessly. Now after driving it I'm getting an o2 heater malfunction fault code. I cant log any AFRs or STFT which is very important since I'm running a PS2 & Port injection.

What else can I do? Dealer even looked at it and have no idea.
Appreciate 1
      10-26-2019, 10:17 AM   #2
harkes
Lieutenant Colonel
harkes's Avatar
China
707
Rep
1,653
Posts

Drives: M135i, NSX and AE86
Join Date: Apr 2014
Location: Xiamen, China

iTrader: (0)

Quote:
Originally Posted by controllerplus View Post
Long story. O2 'went bad' but it really was the ground wire. We replaced the o2 in lambda bank 1 and redid the pin wire.

All codes went away and car ran flawlessly. Now after driving it I'm getting an o2 heater malfunction fault code. I cant log any AFRs or STFT which is very important since I'm running a PS2 & Port injection.

What else can I do? Dealer even looked at it and have no idea.
What happens running stock map?
__________________
M135i PWG, MHD, Pure Stage2, Torqbyte CM5-LT, xHP
(A Dane in China)
Appreciate 0
      10-26-2019, 11:09 AM   #3
Tchao
Boost Addict
Tchao's Avatar
United_States
268
Rep
347
Posts

Drives: E30, E82, F30
Join Date: Feb 2015
Location: Charleston

iTrader: (0)

Did you mix up your pre and post cat O2 sensor wires?
__________________
N55 PWG | Three Pedal Club | E30TU
Appreciate 0
      10-26-2019, 05:40 PM   #4
controllerplus
Private First Class
7
Rep
101
Posts

Drives: e46 m3
Join Date: May 2016
Location: St. Louis

iTrader: (0)

Quote:
Originally Posted by Tchao View Post
Did you mix up your pre and post cat O2 sensor wires?
No. that's literally impossible to do. the connections are different.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:14 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST