F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics > Andream MMI Box - Wireless CarPlay & Android Auto
proTUNING Freaks
Post Reply
 
Thread Tools Search this Thread
      07-28-2021, 01:32 PM   #8405
FlyingCheese
New Member
Canada
0
Rep
5
Posts

Drives: 2017 F30 320i
Join Date: Jun 2021
Location: Canada

iTrader: (0)

Quote:
Originally Posted by S133py View Post
My cables also went to the side(for both the F20 and F30 units), didn't really have any issues, the cables were more than long enough to reach and be routed properly/neatly.

Is the cable catching somewhere?
Yeah, the cable was on the way of the back guides of the screen, so I could not get it to sit correctly on the dash.
I ended up having to use the straight end for the screen, with the angled end connected to the MMI box. For it to fit the little space it had, I had to strip out the strain relief on the connector and really bend the cable. It works for now, but I don't think it'll last too long, the bend is pretty ugly.

Mine came with version E_V.1.5.6, but i think i saw a 1.5.7 floating in this thread.

On another note, is it not possible at all to get the audio over native bluetooth?
Appreciate 0
      07-28-2021, 01:46 PM   #8406
Unspec
Lieutenant Colonel
Unspec's Avatar
United_States
677
Rep
1,878
Posts

Drives: 2015 BMW 535xi
Join Date: Apr 2019
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by RAAF12 View Post
Quickcharge version 5 in 2020 is common there's a listing see
https://en.wikipedia.org/wiki/Quick_Charge Note d
It's much safer to have a fully charged battery in case of an accident and one have to contact emergency folks.
QC 5.0 is absolutely uncommon. As per Qualcomm, literally 2 devices support it as of May 2021: the RedMagic 6 and 6Pro

Source: https://www.qualcomm.com/media/docum...evice-list.pdf

Beyond that, trying to get QC5.0 in a car is just unnecessary. It's far more effective to keep a battery bank on hand.
__________________
2015 BMW 535xi
Bootmod3 Stage 2 | ER charge pipe | ER Catted DP | Remus Exhaust | Gplus FMIC | KW V3 | Turner Monoball thrust arm bushings | Wallet regrets
ISTA VM Setup/Tutorial
Appreciate 0
      07-28-2021, 05:07 PM   #8407
RAAF12
Second Lieutenant
Netherlands
40
Rep
282
Posts

Drives: 2016 F20 120i
Join Date: Nov 2020
Location: North

iTrader: (0)

Quote:
Originally Posted by Unspec View Post
QC 5.0 is absolutely uncommon. As per Qualcomm, literally 2 devices support it as of May 2021: the RedMagic 6 and 6Pro

Source: https://www.qualcomm.com/media/docum...evice-list.pdf

Beyond that, trying to get QC5.0 in a car is just unnecessary. It's far more effective to keep a battery bank on hand.
You are missing the point. Slow charging means the phone is running out of juice on long trips. Worse case. Always use a quickcharger. Just my two cents!

Last edited by RAAF12; 07-28-2021 at 05:43 PM..
Appreciate 0
      07-28-2021, 05:45 PM   #8408
donkim
New Member
3
Rep
21
Posts

Drives: Porsche 944
Join Date: Jan 2021
Location: Cleveland

iTrader: (0)

Quote:
Originally Posted by S133py View Post
My cables also went to the side(for both the F20 and F30 units), didn't really have any issues, the cables were more than long enough to reach and be routed properly/neatly.

Is the cable catching somewhere?
I have the same issue w/the new Roadtop unit I recently purchased. On my 2 series there isn't any way I can see how the angle connector facing the right vs down would fit. Also, switching the end will not work either, since the angle connector would block the other LVDS connector on the mmi box. I contacted Roadtop after sending pix and they are sending a new cable. BTW, I purchased directly from them and I received the unit from China in 4 days!
Don
Appreciate 0
      07-28-2021, 06:37 PM   #8409
Unspec
Lieutenant Colonel
Unspec's Avatar
United_States
677
Rep
1,878
Posts

Drives: 2015 BMW 535xi
Join Date: Apr 2019
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by RAAF12 View Post
You are missing the point. Slow charging means the phone is running out of juice on long trips. Worse case. Always use a quickcharger. Just my two cents!
Even when I'm going ham, such as driving the android auto with my phone and running waze/bm3 live data monitoring via splitscreen on the phone, I lose maybe 1% over an hour. If I'm low at my destination, I just plug into my battery bank while I'm out and about. I get your point, but you're blowing it way out of proportion.
__________________
2015 BMW 535xi
Bootmod3 Stage 2 | ER charge pipe | ER Catted DP | Remus Exhaust | Gplus FMIC | KW V3 | Turner Monoball thrust arm bushings | Wallet regrets
ISTA VM Setup/Tutorial
Appreciate 0
      07-29-2021, 01:35 AM   #8410
S133py
New Member
South Africa
12
Rep
17
Posts

Drives: BMW F20 135i
Join Date: Jul 2021
Location: South Africa

iTrader: (0)

Quote:
Originally Posted by FlyingCheese View Post
Yeah, the cable was on the way of the back guides of the screen, so I could not get it to sit correctly on the dash.
I ended up having to use the straight end for the screen, with the angled end connected to the MMI box. For it to fit the little space it had, I had to strip out the strain relief on the connector and really bend the cable. It works for now, but I don't think it'll last too long, the bend is pretty ugly.

Mine came with version E_V.1.5.6, but i think i saw a 1.5.7 floating in this thread.

On another note, is it not possible at all to get the audio over native bluetooth?
Interesting, all I did was to wiggle the cable from below as I lowered in the screen. The cable should be fine though, as long as its not rubbing against anything, and you don't drive on gravel roads regularly.

As for the all audio over native Bluetooth... Solid maybe... I have an idea of how to do it, will try it on my unit, and if I get it to work, I will post what I did to get it to work. Will need to change how I connect though, I use the USB cable for wired AA, and the native Bluetooth for calls only.
Appreciate 0
      07-29-2021, 02:22 AM   #8411
f32bimmer
Registered
United_States
0
Rep
4
Posts

Drives: BMW F32
Join Date: Jul 2021
Location: San Jose, CA

iTrader: (0)

My module conflict with bimmercode. I have to uninstall entire thing to load my car into bimmercode. Sometimes unplug CAN harness from module, bimmercode can load, but headunits disappear.
Does anyone has similar situation?
Appreciate 0
      07-29-2021, 02:27 AM   #8412
toddel68
New Member
9
Rep
22
Posts

Drives: Mercedes AMG GT S
Join Date: Apr 2021
Location: Frankfurt

iTrader: (0)

Quote:
Originally Posted by RAAF12 View Post
Audio mixer settings. But it depends on the car-audiosystem.
To be honest, I'm confused. Yesterday I tried to adjust the too low audio for NAV directions vs music from my radio app and it seems that "alert" controls NAV announcements while "speech" is music volume which totally makes no sense.
Appreciate 0
      07-29-2021, 07:38 AM   #8413
ce23
New Member
Germany
0
Rep
22
Posts

Drives: 2014 F20 118i
Join Date: Aug 2019
Location: Germany

iTrader: (0)

Hi all,

one quick question related to the updates. My Andream Box is currently running on v2.1.0.6.gpe.b, I wanted to update to the most recent version v2.2.0.5.gpe.b. Can I update straight from my current version or do I have to do all updates one by one?

These version would be the ones in between:
v2.1.0.7.gpe.b
v2.1.0.8.multiusb.gpe.b
v2.1.0.9.gpe.b
v2.1.1.2.gpe.b
v2.1.1.5.gpe.b
Appreciate 0
      07-29-2021, 08:00 AM   #8414
mjb77
Registered
0
Rep
1
Posts

Drives: BMW X5
Join Date: Jul 2021
Location: Northamptonshire

iTrader: (0)

Waiting for GPS?

Hi All, I'm really hoping someone can help here. I have the Andream MMI installed and it's been working great for a while with my Samsung S10, recently though I upgraded to an S20 and since then when using Google Maps I keep getting "Waiting for GPS" pop up, obviously the map doesn't update during this time, then a couple of minutes later it'll update briefly to the current location then stop again, anyone else seen this kind of behaviour? I've updated the FW to B_V1.2.5 but this hasn't made any difference...a bit stumped now!

Would appreciate any thoughts!
Appreciate 0
      07-29-2021, 08:24 AM   #8415
muniz_ri
Major
United_States
357
Rep
1,105
Posts

Drives: BMW 320I
Join Date: Mar 2019
Location: Irvine, CA

iTrader: (1)

Quote:
Originally Posted by f32bimmer View Post
My module conflict with bimmercode. I have to uninstall entire thing to load my car into bimmercode. Sometimes unplug CAN harness from module, bimmercode can load, but headunits disappear.
Does anyone has similar situation?
Try a different mcu for your unit.
Appreciate 0
      07-29-2021, 09:17 AM   #8416
sas46
New Member
sas46's Avatar
Italy
2
Rep
13
Posts

Drives: BMW 116d @140hp
Join Date: May 2019
Location: Italy

iTrader: (0)

Is there a way to get this theme instead of the orange one on an Andream B-Version [NBT EVO ID5/ID6] ?
Attached Images
 
Appreciate 0
      07-29-2021, 11:37 AM   #8417
Rajconp
New Member
Austria
2
Rep
12
Posts

Drives: F11
Join Date: May 2021
Location: Austria/Vienna

iTrader: (0)

Hello guys, is there an update for my version now?
Attached Images
 
Appreciate 0
      07-29-2021, 02:54 PM   #8418
ibi100
New Member
0
Rep
24
Posts

Drives: BMW
Join Date: Apr 2021
Location: France

iTrader: (0)

Quote:
Originally Posted by Rajconp View Post
Hello guys, is there an update for my version now?
hi I'm in the same situation as you ...
Appreciate 0
      07-29-2021, 04:21 PM   #8419
emulajavi
Second Lieutenant
emulajavi's Avatar
Spain
284
Rep
280
Posts

Drives: MINI JCW F56
Join Date: Jun 2009
Location: Spain

iTrader: (0)

Hi

About this option: Using Car BT Phone On/Off

What is it exactly supposed to do?

When in ON…
1.- CarPlay won’t be used for incoming/outgoing calls and no matter if you are on the CarPlay or the iDrive interface, the iDrive UI for calls and the CarBT will be used and sound will be heared no matter if you have AUX set as audio source or not?
2.- Or it means, that if you are on the CarPlay UI, calls will go through CarPlay and you need to be in AUX to be able to hear something; and if you are on iDrive UI, calls will go though the Car’s BT and will be heard no matter what your selected audio source is?

When in OFF…
3.- Does it mean that CarPlay will ‘grab’ all calls ho matter if you are on iDrive UI or CarPlay UI and you need to always have the audio source set as AUX to be able to hear anything?


Thanks.


Appreciate 0
      07-30-2021, 12:44 AM   #8420
S133py
New Member
South Africa
12
Rep
17
Posts

Drives: BMW F20 135i
Join Date: Jul 2021
Location: South Africa

iTrader: (0)

Quote:
Originally Posted by emulajavi View Post
Hi

About this option: Using Car BT Phone On/Off

What is it exactly supposed to do?

When in ON…
1.- CarPlay won’t be used for incoming/outgoing calls and no matter if you are on the CarPlay or the iDrive interface, the iDrive UI for calls and the CarBT will be used and sound will be heared no matter if you have AUX set as audio source or not?
2.- Or it means, that if you are on the CarPlay UI, calls will go through CarPlay and you need to be in AUX to be able to hear something; and if you are on iDrive UI, calls will go though the Car’s BT and will be heard no matter what your selected audio source is?

When in OFF…
3.- Does it mean that CarPlay will ‘grab’ all calls ho matter if you are on iDrive UI or CarPlay UI and you need to always have the audio source set as AUX to be able to hear anything?


Thanks.



That setting determines if the calls goes through the OEM BT or the MMI.

On - the OEM BT grabs the audio attention, and handles the call, then reverts back once done(personally this is what I use, as the cars built in calling is much better overall than the MMI).
Off - the call is handled solely by the MMI, so if your audio is not set to Aux, you will not hear anything on the call(this option makes more sense if your car doesn't have BT Calling, rare but cases exist).
Appreciate 2
sas461.50
valex0.00
      07-30-2021, 09:22 AM   #8421
emulajavi
Second Lieutenant
emulajavi's Avatar
Spain
284
Rep
280
Posts

Drives: MINI JCW F56
Join Date: Jun 2009
Location: Spain

iTrader: (0)

Thanks!

I have version B2_1.5.0 and seems that something is broken with this setting on this version, because despite have ‘Using Car BT Phone’ set to ON, the OEM BT doesn’t grab anything and still the CarPlay UI is shown and I don’t hear anything if audio is not set to Aux

If I remember correctly, on versions B2_1.1.2 and B2_1.1.5 OEM BT UI (iDrive UI) was shown and it worked correctly.
Appreciate 0
      07-30-2021, 02:10 PM   #8422
ZGadson
New Member
5
Rep
27
Posts

Drives: 2016 BMW 228i
Join Date: May 2019
Location: Atlanta, GA

iTrader: (0)

Could not be more satisfied with how easy and cheap it was to add CarPlay to my 228i. But that was over a year ago and I just stumbled across this amazing thread when researching how to update the software - for which I'm now super excited to play with.

BUT, I do have a question that I've searched for and haven't seemed to find an answer. Simply put: VOLUME DISPLAY. You don't realize the necessity of a volume indicator until it's gone (or in this case, stupidly inconvenient to navigate to). So has anyone figured this out? Is it even possible? Or does it already exist in a later software release and I just don't realize it yet because I've never updated my system?
Appreciate 0
      07-30-2021, 09:28 PM   #8423
Homersbud
Private First Class
United_States
38
Rep
177
Posts

Drives: BMW X1
Join Date: Mar 2020
Location: Chicago

iTrader: (0)

Quote:
Originally Posted by ZGadson View Post
Could not be more satisfied with how easy and cheap it was to add CarPlay to my 228i. But that was over a year ago and I just stumbled across this amazing thread when researching how to update the software - for which I'm now super excited to play with.

BUT, I do have a question that I've searched for and haven't seemed to find an answer. Simply put: VOLUME DISPLAY. You don't realize the necessity of a volume indicator until it's gone (or in this case, stupidly inconvenient to navigate to). So has anyone figured this out? Is it even possible? Or does it already exist in a later software release and I just don't realize it yet because I've never updated my system?
join club - been waiting for this option as well but still not available in any of the latest firmware.

I still switch to idrive to set vol level & switch back to carplay. I really hope one day this will be included in an update
Appreciate 0
      07-31-2021, 05:06 AM   #8424
Tony_B
Newbie
Tony_B's Avatar
United Kingdom
3
Rep
52
Posts

Drives: BWM 435d Xdrive
Join Date: Jul 2021
Location: South West

iTrader: (0)

Quote:
Originally Posted by serial_driver View Post
Hi guys,

I just received my Andream MMI device and it's now mounted in my BMW 2016 F11 with NBT.

Mounting is OK but I experience a lot of troubles in terms of stability (audio loss/stop, device crash, etc.) and lost the Carplay wireless pairing with my iPhone 7.

I had a look on the first page with the list of possible software updates, but can't figure out which one is relevant for my device.

Any kind of advice would be highly appreciated.

Thanks !
I'm exactly the same. I bought what I thought was the latest box from the official Aliexpress store (AIOCOAI Official Store ) and looks like a v1 with custom software? Seller ignoring me for latest firmware details. Date on box is Aug 2020 and firware detail attached.

Really looking for options on upgrading to the latest firmware - if it gives me better audio options. Any help would be very much appreciated.
Attached Images
 

Last edited by Tony_B; 08-01-2021 at 09:30 AM..
Appreciate 0
      07-31-2021, 06:33 AM   #8425
valex
New Member
Bulgaria
0
Rep
12
Posts

Drives: BMW F31 330 xdrive
Join Date: Jun 2017
Location: Sofia, Bulgaria

iTrader: (0)

Hello guys

I have a problem connecting the iphone 12 pro to Andream B2 NBT box.
Does not want to connect wired and wireless.
Has anyone had the same problem
Appreciate 0
      07-31-2021, 08:15 AM   #8426
tiago_c
Registered
2
Rep
4
Posts

Drives: BMW i3
Join Date: Mar 2021
Location: London

iTrader: (0)

RoadTop B BR157 update

I just received a an update for RoadTop B-Versions, for anyone interested. It comes with the new youtube feature, seen on other models.

Version: BR157

https://we.tl/t-jA8cbmwE8R
Appreciate 1
Post Reply

Bookmarks

Tags
andream, android, android auto, apple, carplay, mmi, retrofit

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:09 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST