F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > 2012-2019 BMW 3 and 4-Series Forums > General F30 Sedan / F32 Coupe / F36 Gran Coupe Forum > Had Aquapel applied wipers chattering now
Extreme Power House
Post Reply
 
Thread Tools Search this Thread
      07-06-2018, 06:07 PM   #1
mattryan
Lieutenant
mattryan's Avatar
Canada
47
Rep
588
Posts

Drives: 2018 440i xDrive Coupé
Join Date: Dec 2010
Location: Toronto, ON

iTrader: (0)

Took my car into a local Speedy Glass to have a stone chip fixed and was talked into having Aquapel applied on my 440 however now my wipers chatter when going downwards at the last few inches. I've tried cleaning the wiper blades and NIL. I haven't tried replacing them yet as the car is only 3 months old. The weird thing is though if I spray the windshield with enough washer fluid they don't. Does anyone have any recommendations on how to fix this issue or know how to remove it?
__________________
Current: 2018 440i xDrive Coupé | Mineral Grey | Coral Red | M Performance | Premium Enhanced | Adaptive LED | Smartphone Connectivity
Previous: 2012 135i
Appreciate 0
      07-06-2018, 07:07 PM   #2
Mbbrewer
Captain
Mbbrewer's Avatar
124
Rep
649
Posts

Drives: 550i
Join Date: Apr 2012
Location: Houston

iTrader: (1)

Quote:
Originally Posted by mattryan View Post
Took my car into a local Speedy Glass to have a stone chip fixed and was talked into having Aquapel applied on my 440 however now my wipers chatter like crazy especially when going downwards at the last few inches. I've tried cleaning the wiper blades and NIL. I haven't tried replacing them yet as the car is only 3 months old. The weird thing is though if I spray the windshield with enough washer fluid they don't. Does anyone have any recommendations on how to fix this issue or know how to remove it?
Shouldn't need wipers with aquapel. Are
You sure they didn't do a bait and switch and use rain X or some crappy immitation?
Appreciate 0
      07-06-2018, 07:08 PM   #3
mattryan
Lieutenant
mattryan's Avatar
Canada
47
Rep
588
Posts

Drives: 2018 440i xDrive Coupé
Join Date: Dec 2010
Location: Toronto, ON

iTrader: (0)

Quote:
Originally Posted by Mbbrewer View Post
Quote:
Originally Posted by mattryan View Post
Took my car into a local Speedy Glass to have a stone chip fixed and was talked into having Aquapel applied on my 440 however now my wipers chatter like crazy especially when going downwards at the last few inches. I've tried cleaning the wiper blades and NIL. I haven't tried replacing them yet as the car is only 3 months old. The weird thing is though if I spray the windshield with enough washer fluid they don't. Does anyone have any recommendations on how to fix this issue or know how to remove it?
Shouldn't need wipers with aquapel. Are
You sure they didn't do a bait and switch and use rain X or some crappy immitation?
Nope I watched them do it and they don't sell Rain-X
__________________
Current: 2018 440i xDrive Coupé | Mineral Grey | Coral Red | M Performance | Premium Enhanced | Adaptive LED | Smartphone Connectivity
Previous: 2012 135i
Appreciate 0
      07-06-2018, 08:47 PM   #4
Busa1
Lieutenant
Busa1's Avatar
United_States
145
Rep
595
Posts

Drives: 2014 435i xDrive M-Sport
Join Date: Feb 2011
Location: Long Island, NY

iTrader: (4)

Quote:
Originally Posted by mattryan View Post
Quote:
Originally Posted by Mbbrewer View Post
Quote:
Originally Posted by mattryan View Post
Took my car into a local Speedy Glass to have a stone chip fixed and was talked into having Aquapel applied on my 440 however now my wipers chatter like crazy especially when going downwards at the last few inches. I've tried cleaning the wiper blades and NIL. I haven't tried replacing them yet as the car is only 3 months old. The weird thing is though if I spray the windshield with enough washer fluid they don't. Does anyone have any recommendations on how to fix this issue or know how to remove it?
Shouldn't need wipers with aquapel. Are
You sure they didn't do a bait and switch and use rain X or some crappy immitation?
Nope I watched them do it and they don't sell Rain-X
Try this, it's worked for me before


__________________
Appreciate 0
      07-06-2018, 08:51 PM   #5
mattryan
Lieutenant
mattryan's Avatar
Canada
47
Rep
588
Posts

Drives: 2018 440i xDrive Coupé
Join Date: Dec 2010
Location: Toronto, ON

iTrader: (0)

Quote:
Originally Posted by Busa1 View Post
Quote:
Originally Posted by mattryan View Post
Quote:
Originally Posted by Mbbrewer View Post
Quote:
Originally Posted by mattryan View Post
Took my car into a local Speedy Glass to have a stone chip fixed and was talked into having Aquapel applied on my 440 however now my wipers chatter like crazy especially when going downwards at the last few inches. I've tried cleaning the wiper blades and NIL. I haven't tried replacing them yet as the car is only 3 months old. The weird thing is though if I spray the windshield with enough washer fluid they don't. Does anyone have any recommendations on how to fix this issue or know how to remove it?
Shouldn't need wipers with aquapel. Are
You sure they didn't do a bait and switch and use rain X or some crappy immitation?
Nope I watched them do it and they don't sell Rain-X
Try this, it's worked for me before


The cars only 3 months old I don't think the arm would be bent...
__________________
Current: 2018 440i xDrive Coupé | Mineral Grey | Coral Red | M Performance | Premium Enhanced | Adaptive LED | Smartphone Connectivity
Previous: 2012 135i
Appreciate 0
      07-07-2018, 11:37 AM   #6
Orion4
Captain
United_States
190
Rep
973
Posts

Drives: 2013 335i Sport Line Sedan
Join Date: Aug 2009
Location: Melbourne, FL

iTrader: (0)

Been using Aquapel for years without that issue unless blades were worn or if there was a build up on the blade edges. I usually clean the edges with a cloth and rubbing alcohol once a month. Seems to work for me
Appreciate 0
      07-07-2018, 12:27 PM   #7
Billfitz
Brigadier General
United_States
1993
Rep
4,992
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

Quote:
Originally Posted by Orion4 View Post
Been using Aquapel for years without that issue unless blades were worn or if there was a build up on the blade edges.
Same here.
Appreciate 0
      07-17-2018, 09:40 PM   #8
mattryan
Lieutenant
mattryan's Avatar
Canada
47
Rep
588
Posts

Drives: 2018 440i xDrive Coupé
Join Date: Dec 2010
Location: Toronto, ON

iTrader: (0)

Quote:
Originally Posted by Orion4 View Post
Been using Aquapel for years without that issue unless blades were worn or if there was a build up on the blade edges. I usually clean the edges with a cloth and rubbing alcohol once a month. Seems to work for me
I've cleaned the wiper blades and it's still chatter horribly! I've Googled and Googled and Googled and no one seems to know how to get this stuff off! Here's a vid of how bad it is I'm thinking my only solution is to replace the windshield at this point...



vimeo.com/280463306
__________________
Current: 2018 440i xDrive Coupé | Mineral Grey | Coral Red | M Performance | Premium Enhanced | Adaptive LED | Smartphone Connectivity
Previous: 2012 135i
Appreciate 0
      07-17-2018, 09:47 PM   #9
Orion4
Captain
United_States
190
Rep
973
Posts

Drives: 2013 335i Sport Line Sedan
Join Date: Aug 2009
Location: Melbourne, FL

iTrader: (0)

Quote:
Originally Posted by mattryan View Post
I've cleaned the wiper blades and it's still chatter horribly! I've Googled and Googled and Googled and no one seems to know how to get this stuff off! Here's a vid of how bad it is I'm thinking my only solution is to replace the windshield at this point...



vimeo.com/280463306

That is a bit drastic! Try new blades first. If still chattering, you can remove the Aquapel with Bon Ami cleansing powder, water and good sponge. Will take some elbow grease, but it will come off,.
Appreciate 0
      07-17-2018, 09:48 PM   #10
Orion4
Captain
United_States
190
Rep
973
Posts

Drives: 2013 335i Sport Line Sedan
Join Date: Aug 2009
Location: Melbourne, FL

iTrader: (0)

[quote=mattryan;23469653]I've cleaned the wiper blades and it's still chatter horribly! I've Googled and Googled and Googled and no one seems to know how to get this stuff off! Here's a vid of how bad it is I'm thinking my only solution is to replace the windshield at this point...


That is a bit drastic! Try new blades first. If still chattering, you can remove the Aquapel with Bon Ami cleansing powder, water and good sponge. Will take some elbow grease, but it will come off,.
Appreciate 0
      07-17-2018, 10:12 PM   #11
montr
Lieutenant
United_States
90
Rep
565
Posts

Drives: 2010 335d, 2018 430i G-Coupe
Join Date: Sep 2009
Location: Atlanta, GA

iTrader: (0)

+1 for Bon Ami. Test it on a corner of the windshield. It should not scratch the windshield
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:23 PM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST