F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > 2012-2019 BMW 3 and 4-Series Forums > General F30 Sedan / F32 Coupe / F36 Gran Coupe Forum > acceleration hiccups
Extreme Power House
Post Reply
 
Thread Tools Search this Thread
      07-18-2018, 04:11 PM   #1
cesarortiz23
Captain
cesarortiz23's Avatar
United_States
89
Rep
705
Posts

Drives: f30 335i / e82 135i
Join Date: Feb 2014
Location: pasadena

iTrader: (0)

acceleration hiccups

hey you guys so I have been having this problem for some time now but have been ignoring it

I got some other stuff fixed on the car now I want to get this taken car if


So on sport mode I notice that when I do a slightly hard acceleration or hard acceleration I get like misfires it hiccups like even a burble at mid Rpm even tho I'm pressing the gas pedal and some times a big cloud of black smoke



The car is stock only thing is muffler delete and bms intake


you think is a ignition problem
Maybe new coils packs

Sparks was replaced at 55k

Car has 68k now


or is it carbon build up

Maybe I need a walnut shell blasting or ?????


Anyone have any suggestions or opinions


By the way I do not get a check engine light or nothing
__________________
2012 f30 335i lowered on h&r super sport springs on stance sc-6 wheels
e82 135i dct build in progress
Appreciate 0
      07-19-2018, 08:07 AM   #2
roundel335
Major General
roundel335's Avatar
United_States
951
Rep
5,881
Posts

Drives: 15 M3 Sedan, 16 228i Cabrio
Join Date: Apr 2010
Location: Leland, NC

iTrader: (2)

Garage List
2015 BMW M3  [0.00]
2016 BMW 228i  [3.00]
First thing you want to do is check for any problem codes with an OBD-II code reader - they don't always produce a check-engine light. Could be a bad coil pack or injector issues - I'd have those checked. Carbon buildup would likely not produce the misfire or black smoke you mentioned.
__________________

2015 F80 M3 Sedan 7DCT Tanzanite, 2016 228i M-Sport Cabrio 8AT Melbourne
Appreciate 0
      07-19-2018, 10:37 AM   #3
Mouse
Second Lieutenant
62
Rep
218
Posts

Drives: 2013F30 335i
Join Date: Aug 2016
Location: Cypress, TX

iTrader: (0)

Quote:
Originally Posted by roundel335 View Post
First thing you want to do is check for any problem codes with an OBD-II code reader - they don't always produce a check-engine light. Could be a bad coil pack or injector issues - I'd have those checked. Carbon buildup would likely not produce the misfire or black smoke you mentioned.
^Good advice. I would recommend the same.
__________________
13' F30 335i - BMS Intake -- VRSF DP -- VRSF CP -- VRSF 5" Stepped Intercooler -- Corsa Touring Catback -- JB4 -- H&R Springs -- Miro Flow Formed F25's
Appreciate 0
      07-19-2018, 12:09 PM   #4
Sea-Tac
Major
Sea-Tac's Avatar
United_States
829
Rep
1,109
Posts

Drives: 2108 X3 xDrive30i
Join Date: Apr 2018
Location: Bellevue, Wa

iTrader: (0)

Garage List
Quote:
Originally Posted by roundel335 View Post
First thing you want to do is check for any problem codes with an OBD-II code reader - they don't always produce a check-engine light. Could be a bad coil pack or injector issues - I'd have those checked. Carbon buildup would likely not produce the misfire or black smoke you mentioned.
Good comments. Good direction to go.
Appreciate 0
      07-19-2018, 12:11 PM   #5
cesarortiz23
Captain
cesarortiz23's Avatar
United_States
89
Rep
705
Posts

Drives: f30 335i / e82 135i
Join Date: Feb 2014
Location: pasadena

iTrader: (0)

Quote:
Originally Posted by roundel335 View Post
First thing you want to do is check for any problem codes with an OBD-II code reader - they don't always produce a check-engine light. Could be a bad coil pack or injector issues - I'd have those checked. Carbon buildup would likely not produce the misfire or black smoke you mentioned.
Ok thanks for the advise

Ima look in to that today
__________________
2012 f30 335i lowered on h&r super sport springs on stance sc-6 wheels
e82 135i dct build in progress
Appreciate 0
      07-19-2018, 02:26 PM   #6
cesarortiz23
Captain
cesarortiz23's Avatar
United_States
89
Rep
705
Posts

Drives: f30 335i / e82 135i
Join Date: Feb 2014
Location: pasadena

iTrader: (0)

Quote:
Originally Posted by roundel335 View Post
First thing you want to do is check for any problem codes with an OBD-II code reader - they don't always produce a check-engine light. Could be a bad coil pack or injector issues - I'd have those checked. Carbon buildup would likely not produce the misfire or black smoke you mentioned.
One thing I forgot t mention is when I do WOT


the car runs great

I only feel this when I have the pedal like 50 to 85%

Once I hit the button on the bottom of the pedal

The car pulls smooth no problem no hiccups

So idk if that helps a bit
__________________
2012 f30 335i lowered on h&r super sport springs on stance sc-6 wheels
e82 135i dct build in progress
Appreciate 0
      07-19-2018, 02:29 PM   #7
cesarortiz23
Captain
cesarortiz23's Avatar
United_States
89
Rep
705
Posts

Drives: f30 335i / e82 135i
Join Date: Feb 2014
Location: pasadena

iTrader: (0)

Quote:
Originally Posted by Mouse View Post
Quote:
Originally Posted by roundel335 View Post
First thing you want to do is check for any problem codes with an OBD-II code reader - they don't always produce a check-engine light. Could be a bad coil pack or injector issues - I'd have those checked. Carbon buildup would likely not produce the misfire or black smoke you mentioned.
^Good advice. I would recommend the same.
No codes popped up

I just got that checked at a local shop

No codes pop up never has


I been having this issue for quite a while

Even when I had jb4

At first I thought it was jb4 so I removed it

Now I'm stock and I still have the same issue


But never saw a check engine light or a code for this

So what you guys think

Maybe carbon build up ?
__________________
2012 f30 335i lowered on h&r super sport springs on stance sc-6 wheels
e82 135i dct build in progress
Appreciate 0
      07-19-2018, 02:35 PM   #8
cesarortiz23
Captain
cesarortiz23's Avatar
United_States
89
Rep
705
Posts

Drives: f30 335i / e82 135i
Join Date: Feb 2014
Location: pasadena

iTrader: (0)

Quote:
Originally Posted by roundel335 View Post
First thing you want to do is check for any problem codes with an OBD-II code reader - they don't always produce a check-engine light. Could be a bad coil pack or injector issues - I'd have those checked. Carbon buildup would likely not produce the misfire or black smoke you mentioned.
No codes popped up by the way :
__________________
2012 f30 335i lowered on h&r super sport springs on stance sc-6 wheels
e82 135i dct build in progress
Appreciate 0
      07-19-2018, 03:14 PM   #9
cesarortiz23
Captain
cesarortiz23's Avatar
United_States
89
Rep
705
Posts

Drives: f30 335i / e82 135i
Join Date: Feb 2014
Location: pasadena

iTrader: (0)

https://www.fcpeuro.com/products/bmw...-12131712219x6






can anybody confirm that these would be the correct ignition coil pack aro buy for my car ?


Or is there another brand that's recommended



I'm thinking of starting off with coil packs and see if that helps my problem
__________________
2012 f30 335i lowered on h&r super sport springs on stance sc-6 wheels
e82 135i dct build in progress
Appreciate 0
      07-19-2018, 05:17 PM   #10
SteelBlue46
New Member
United_States
3
Rep
9
Posts

Drives: Alpine White '13 335i XDrive
Join Date: Apr 2018
Location: Pennsylvania

iTrader: (0)

Quote:
Originally Posted by cesarortiz23 View Post
https://www.fcpeuro.com/products/bmw...-12131712219x6






can anybody confirm that these would be the correct ignition coil pack aro buy for my car ?


Or is there another brand that's recommended



I'm thinking of starting off with coil packs and see if that helps my problem
those coils should work. They look exactly like mine and FCPeuro shows compatible with 335i from 2007-2015
Appreciate 0
      07-19-2018, 05:18 PM   #11
cesarortiz23
Captain
cesarortiz23's Avatar
United_States
89
Rep
705
Posts

Drives: f30 335i / e82 135i
Join Date: Feb 2014
Location: pasadena

iTrader: (0)

Quote:
Originally Posted by SteelBlue46 View Post
Quote:
Originally Posted by cesarortiz23 View Post
https://www.fcpeuro.com/products/bmw...-12131712219x6






can anybody confirm that these would be the correct ignition coil pack aro buy for my car ?


Or is there another brand that's recommended



I'm thinking of starting off with coil packs and see if that helps my problem
those coils should work. They look exactly like mine and FCPeuro shows compatible with 335i from 2007-2015
I think Ima start off by buying the coil packs and see if that helps
__________________
2012 f30 335i lowered on h&r super sport springs on stance sc-6 wheels
e82 135i dct build in progress
Appreciate 0
      07-19-2018, 10:12 PM   #12
XutvJet
Lieutenant Colonel
1094
Rep
1,767
Posts

Drives: 2016 M235 6MT
Join Date: Mar 2016
Location: Kansas City

iTrader: (-1)

Put the stock intake back on and see how it drives. I'd do that before throwing new parts at it in hopes of fixing the issue.
Appreciate 1
Wires251.00

      07-20-2018, 12:42 AM   #13
cesarortiz23
Captain
cesarortiz23's Avatar
United_States
89
Rep
705
Posts

Drives: f30 335i / e82 135i
Join Date: Feb 2014
Location: pasadena

iTrader: (0)

Quote:
Originally Posted by XutvJet View Post
Put the stock intake back on and see how it drives. I'd do that before throwing new parts at it in hopes of fixing the issue.
It did it before the bms intake aswell


The bms intake I just installed maybe about a week ago

I have been having this issue way before the intake
__________________
2012 f30 335i lowered on h&r super sport springs on stance sc-6 wheels
e82 135i dct build in progress
Appreciate 0
      07-20-2018, 06:22 AM   #14
BashShah
Lieutenant Colonel
Canada
129
Rep
1,699
Posts

Drives: 2012 335i Sedan
Join Date: Oct 2012
Location: Vancouver, Canada

iTrader: (0)

If you do get a walnut blast done. can you please post picture of what your intakes looked like before the blasting?

I just want to see how much build up there was.

Also you did everything for your problem except Walnut blast, so try it.
or at least have them inspected.
Appreciate 0
      07-20-2018, 08:51 PM   #15
cesarortiz23
Captain
cesarortiz23's Avatar
United_States
89
Rep
705
Posts

Drives: f30 335i / e82 135i
Join Date: Feb 2014
Location: pasadena

iTrader: (0)

Quote:
Originally Posted by BashShah View Post
If you do get a walnut blast done. can you please post picture of what your intakes looked like before the blasting?

I just want to see how much build up there was.

Also you did everything for your problem except Walnut blast, so try it.
or at least have them inspected.
first Ima do do the plugs since is cheap and easy for me to do my self

Then

Next will be walnut shell blast
__________________
2012 f30 335i lowered on h&r super sport springs on stance sc-6 wheels
e82 135i dct build in progress
Appreciate 0
      07-20-2018, 09:24 PM   #16
rjdnyy224
Major
rjdnyy224's Avatar
United_States
347
Rep
1,148
Posts

Drives: 2013 328i xDrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

Sounds kinda like LSPI (low-speed pre-ignition). I only say that because of the black smoke, otherwise I wouldn't have thought of it. This happens in low rpm, but high load conditions, like 50% throttle at 2500-3000 rpms. I'd read about LSPI a bit and see if that sounds like the issue you're having.
__________________
2013 328i xDrive N20 | Bootmod3 Stage 2 OTS 93oct | VRSF Street 5" HD Front-Mount Intercooler | VRSF Catless Downpipe | NGK L/I Spark Plugs | M Performance Exhaust | K&N Drop-in | Dinan 20" Wheels Wearing Michelin PSS | F80 Style Decklid Spoiler | Debadged | F80 Style Grille |
Appreciate 0
      07-20-2018, 09:56 PM   #17
cesarortiz23
Captain
cesarortiz23's Avatar
United_States
89
Rep
705
Posts

Drives: f30 335i / e82 135i
Join Date: Feb 2014
Location: pasadena

iTrader: (0)

Quote:
Originally Posted by rjdnyy224 View Post
Sounds kinda like LSPI (low-speed pre-ignition). I only say that because of the black smoke, otherwise I wouldn't have thought of it. This happens in low rpm, but high load conditions, like 50% throttle at 2500-3000 rpms. I'd read about LSPI a bit and see if that sounds like the issue you're having.
Hey thanks on that input Ima check that out for sure
__________________
2012 f30 335i lowered on h&r super sport springs on stance sc-6 wheels
e82 135i dct build in progress
Appreciate 0
      07-21-2018, 01:48 AM   #18
cesarortiz23
Captain
cesarortiz23's Avatar
United_States
89
Rep
705
Posts

Drives: f30 335i / e82 135i
Join Date: Feb 2014
Location: pasadena

iTrader: (0)

Quote:
Originally Posted by rjdnyy224 View Post
Sounds kinda like LSPI (low-speed pre-ignition). I only say that because of the black smoke, otherwise I wouldn't have thought of it. This happens in low rpm, but high load conditions, like 50% throttle at 2500-3000 rpms. I'd read about LSPI a bit and see if that sounds like the issue you're having.
So I looked in to it there isn't really much about this happening to bmws :


I did read and saw some videos and they said something about high gear and building up boost on a high gear and having Miss fires


But my car is doing it on 1st 2nd 3rd lol

Is like a constant hiccups all through gears from 1-8
__________________
2012 f30 335i lowered on h&r super sport springs on stance sc-6 wheels
e82 135i dct build in progress
Appreciate 0
      07-21-2018, 08:31 AM   #19
rjdnyy224
Major
rjdnyy224's Avatar
United_States
347
Rep
1,148
Posts

Drives: 2013 328i xDrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by cesarortiz23 View Post
So I looked in to it there isn't really much about this happening to bmws :


I did read and saw some videos and they said something about high gear and building up boost on a high gear and having Miss fires


But my car is doing it on 1st 2nd 3rd lol

Is like a constant hiccups all through gears from 1-8
Ah gotcha, probably not your culprit then. I haven't heard of it happening to BMWs either but figured it was worth mentioning. Hate to say I don't know what else to suggest, as anything else I'd recommend has already been said. Is your car tuned by the way? If so it could definitely be a tuning issue. I had a sorta similar problem and it was an issue with the tune and was very easy to work out.
__________________
2013 328i xDrive N20 | Bootmod3 Stage 2 OTS 93oct | VRSF Street 5" HD Front-Mount Intercooler | VRSF Catless Downpipe | NGK L/I Spark Plugs | M Performance Exhaust | K&N Drop-in | Dinan 20" Wheels Wearing Michelin PSS | F80 Style Decklid Spoiler | Debadged | F80 Style Grille |
Appreciate 0
      07-22-2018, 11:05 PM   #20
cesarortiz23
Captain
cesarortiz23's Avatar
United_States
89
Rep
705
Posts

Drives: f30 335i / e82 135i
Join Date: Feb 2014
Location: pasadena

iTrader: (0)

Quote:
Originally Posted by rjdnyy224 View Post
Quote:
Originally Posted by cesarortiz23 View Post
So I looked in to it there isn't really much about this happening to bmws :


I did read and saw some videos and they said something about high gear and building up boost on a high gear and having Miss fires


But my car is doing it on 1st 2nd 3rd lol

Is like a constant hiccups all through gears from 1-8
Ah gotcha, probably not your culprit then. I haven't heard of it happening to BMWs either but figured it was worth mentioning. Hate to say I don't know what else to suggest, as anything else I'd recommend has already been said. Is your car tuned by the way? If so it could definitely be a tuning issue. I had a sorta similar problem and it was an issue with the tune and was very easy to work out.
No is not tuned at the moment


When I had jb4

Had the same exact problem

I think is the coil packs
__________________
2012 f30 335i lowered on h&r super sport springs on stance sc-6 wheels
e82 135i dct build in progress
Appreciate 0
      07-23-2018, 06:22 PM   #21
SoDiezl350
Private First Class
59
Rep
153
Posts

Drives: F30 328i M-Sport EBII
Join Date: Oct 2015
Location: Los Angeles

iTrader: (2)

I had a similar problem. Was worse with the piggyback but present even without. Car was otherwise stock. Dealer replaced coils and plugs @ 55k and it went away. 12k miles later and it's back....
Appreciate 0
      07-23-2018, 07:08 PM   #22
Mission3
New Member
United_States
2
Rep
7
Posts

Drives: 335i M Sport
Join Date: Jun 2018
Location: Los Angeles

iTrader: (0)

This happened to me at WOT throttle only. It didn't always throw a code. It would throw a code maybe after 3-4 back-to-back WOT runs. Cylinder 6 misfire. Only happened on my BM3 tune though. I ended up replacing the coil packs and everything is fine now.
__________________
2015 335i ///M-Sport 8AT | M Performance Exhaust/Brakes/Suspension | BM3 | VRSF FMIC | AR Design DP | AFE Filter | RES Delete |
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:37 PM.




f30post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST