F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics > Andream MMI Box - Wireless CarPlay & Android Auto
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      Yesterday, 06:53 AM   #6183
Len_Beach
Major
146
Rep
1,186
Posts

Drives: E92 M3
Join Date: Jun 2011
Location: UK

iTrader: (0)

Quote:
Originally Posted by Firefly1337 View Post
New update v2.1.0.0.mmi.b for Bimmertech NBT can be found on the 1st page.

They call it the December update but it's from early November:
Code:
created: 2020-11-06 02:21:32
They only have a single entry in their changelog. They added a couple of new internal config options that seem to improve the Android Auto resolution.
Also some other internal changes that also appeared in previous RoadTop and Andream updates.



Quote:
Originally Posted by fdaw750 View Post
Still working with the RoadTop support team who keep sending me one version after another without success.
Let us know if they send you a new update that's not yet available on the 1st page
Thanks for sharing. Is there any advantage to running this on my Andream running custom firmware and MCU?

I use CarPlay so wouldn't see the advantage from the Android updates.
Appreciate 0
      Yesterday, 08:09 AM   #6184
Evgenyproject
Registered
0
Rep
3
Posts

Drives: F30 330
Join Date: Nov 2020
Location: Germany

iTrader: (0)

Hi guys, which update can I use for this device from the first page ?! It was bought on Amazon. Manufacturer / supplier (NRpfell) Thank you
Attached Images
 
Appreciate 0
      Yesterday, 10:54 AM   #6185
Firefly1337
Second Lieutenant
Firefly1337's Avatar
Germany
599
Rep
259
Posts

Drives: F20 M135i LCI
Join Date: Aug 2019
Location: Germany

iTrader: (0)

Quote:
Originally Posted by Len_Beach View Post
Thanks for sharing. Is there any advantage to running this on my Andream running custom firmware and MCU?

I use CarPlay so wouldn't see the advantage from the Android updates.
I can't say for sure since I don't use Carplay. But the update wouldn't work anyway as it's for Bimmertech devices only (it will produce the 'Invalid update' screen).

Quote:
Originally Posted by Evgenyproject View Post
Hi guys, which update can I use for this device from the first page ?! It was bought on Amazon. Manufacturer / supplier (NRpfell) Thank you
Do you happen to have an update file on hand for your version? Then I can take a look which version it really is.

Judging from the version number I would've said a newer version for Andream CIC A-Version. But I saw someone else with that version number before and they said it was asking for a GEMINI_PACK.BIN which would indicate a B-Version. So far I haven't seen an update for your type of device.

-----------------

Also here's a sneak peek of what we are currently working on:
Attached Images
 

Last edited by Firefly1337; Yesterday at 11:00 AM..
Appreciate 12
muniz_ri227.00
eexxcc9.00
Len_Beach146.00
x-m4n137.50
rcaso26205.00
Fishie7.50
liam7718.00
Frrr3.00
knipz4.50
ckarv10.50

      Yesterday, 11:01 AM   #6186
Fishie
Private
8
Rep
74
Posts

Drives: 2013 BMW 32ix
Join Date: Jul 2020
Location: Canada

iTrader: (0)

Quote:
Originally Posted by Firefly1337 View Post
I can't say for sure since I don't use Carplay. But the update wouldn't work anyway as it's for Bimmertech devices only (it will produce the 'Invalid update' screen).



Do you happen to have an update file on hand for your version? Then I can take a look which version it really is.

Judging from the version number I would've said a newer version for Andream CIC A-Version. But I saw someone else with that version number before and they said it was asking for a GEMINI_PACK.BIN which would indicate a B-Version. So far I haven't seen an update for your type of device.

-----------------

Also here's a sneek peak of what we are currently working on:
Woah, love the update with your current progress! Iím sure weíre all excited for you to release it, and now we want it even more! The Home Screen looks awesome, great work.

Appreciate everything you do for this community.

Last edited by Fishie; Yesterday at 11:48 AM..
Appreciate 0
      Yesterday, 12:30 PM   #6187
rimsilva
Enlisted Member
Portugal
4
Rep
43
Posts

Drives: i3 60Ah BEV
Join Date: Jan 2017
Location: Portugal

iTrader: (0)

Quote:
Originally Posted by Primax View Post
It works fine with original MEDIA from the car, after entering Android Auto music still plays, but if i do something regarding with music (spotify), musics just stops. Haven't tried any diferent app, but no sound at all.

Tried with BT's car, and with Andream BT's, same issue. Seller says i need to use AUX Cable to have sound, but having more cables inside is pointeless for me...

Wich version is mine? A or B?
View post on imgur.com
You have a B version.

Interesting, seems that you have a different firmware version "B2_V1.1.2" than the ones that we have here.

to have audio with your box you don't need to use a AUX cable, what you need to do is to activate in idrive multimedia menu the AUX connection.
Appreciate 0
      Yesterday, 01:06 PM   #6188
Primax
New Member
Portugal
2
Rep
13
Posts

Drives: BMW 420D F36 2015
Join Date: Jan 2021
Location: Lisbon

iTrader: (0)

Quote:
Originally Posted by rimsilva View Post
You have a B version.

Interesting, seems that you have a different firmware version "B2_V1.1.2" than the ones that we have here.

to have audio with your box you don't need to use a AUX cable, what you need to do is to activate in idrive multimedia menu the AUX connection.
What i read from FAQ that Andream Sent, that setting is for Carplay (Iphone), is that the same for Android Auto? even though there is nothing pluged in to Aux?

Or is it refered carplay the device itself? as i see the log in imagem says carplay with a blue car.
Appreciate 0
      Yesterday, 04:20 PM   #6189
muniz_ri
Captain
United_States
227
Rep
756
Posts

Drives: BMW 320I
Join Date: Mar 2019
Location: Irvine, CA

iTrader: (1)

Quote:
Originally Posted by Bigjule1111 View Post
Any new updates for the carlinkit units ?
9.2.9.yl.b is the latest .bin floating around. But they are currently shipping with 9.2.10.yl.b which adds AA widescreen view and auto-start.
Appreciate 1
Frrr3.00

      Yesterday, 06:03 PM   #6190
tekibg
New Member
6
Rep
14
Posts

Drives: BMW E60 LCI
Join Date: Sep 2019
Location: Serbia

iTrader: (0)

Quote:
Originally Posted by tekibg View Post
Hi. I have flashed firmware to Universal version CIC from first page, but Android Auto doesnít work, I canít connect neither wired or wirelessly. CarPlay works nice. My MMI is Andream A CIC. Everything worked fine on original software. Do you have some ideas what is possible problem? Thanks
Finally, I have returned to Andream firmware, and AA is working again. Universal CIC version seems to have some AA issue.
Appreciate 1
      Yesterday, 07:52 PM   #6191
biomed27
First Lieutenant
16
Rep
358
Posts

Drives: f30
Join Date: Dec 2009
Location: usa

iTrader: (1)

Quote:
Originally Posted by sas46 View Post
Hi, I've luckily found this awesome thread!

I own an F20 2017 lci2 with entrynav EVO (no navi) with a retrofittted 8,8"
I didn't purchased any backup camera when ordered the car and after a few years I've decided to buy an MMI with the camera option and also Android Auto.

I bought and Andream one on Aliexpress, the seller says on the post that's an EW-BMCP-NBT01A
I looked at the main thread and it seems that to access the update menu in Andream "A" version I need to use pin 2863 but instead it works only with 5025, so I believe I recieved a B one

Also looking around I didn't see anyone using the EVO version.
My question is, is it possible/safe to update it to v1.0.A0.mod or other versions having an EVO instead of NBT? As I see I run a version that's not out yet

I'm attaching some screens
Same question. Can we use NBT updates on EVO version?
Appreciate 0
      Yesterday, 08:20 PM   #6192
muniz_ri
Captain
United_States
227
Rep
756
Posts

Drives: BMW 320I
Join Date: Mar 2019
Location: Irvine, CA

iTrader: (1)

Quote:
Originally Posted by tekibg View Post
Finally, I have returned to Andream firmware, and AA is working again. Universal CIC version seems to have some AA issue.
The custom sw is based on the Bimmertech sw and requires a slightly different pairing than Andream, RoadTop, etc. sw:

Android Auto wireless pairing:

Enable WiFi on your smartphone. Next go to Bluetooth settings and switch Bluetooth OFF and back ON. On MMI Prime go to Settings-> Wireless Devices-> Wireless CarPlay Pairing and click Start Search. Wait until your phone appears on the list and the search process ends. Click on your phone name and accept all of the pop-ups that will appear on your smartphone screen. Within around a minute your smartphone should connect to Android Auto wirelessly. If after around a minute Android Auto does not connect, go to Settings-> Wireless Devices-> Paired Devices on your MMI Prime, select your phone and click to connect. For Android phones you should also connect your smartphone to the factory BMW Bluetooth system.
Appreciate 1
Frrr3.00

      Yesterday, 10:04 PM   #6193
drlc101
Enlisted Member
United_States
2
Rep
35
Posts

Drives: F10 M5
Join Date: Feb 2018
Location: Central FL

iTrader: (2)

Colors on F10 NBT

Hi,

I installed my unit today on my F10 with NBT (2014 M5). Everything works great but my only complaint is colors do seem a bit washed out. I played around with display settings and got it to improve slightly but it could be better. My unit came with b2_v1.1.2 pre-installed.

Anyone on experiencing this? Curious if a different firmware or display settings can help improve. Thanks!
Appreciate 0
      Yesterday, 10:59 PM   #6194
muniz_ri
Captain
United_States
227
Rep
756
Posts

Drives: BMW 320I
Join Date: Mar 2019
Location: Irvine, CA

iTrader: (1)

Quote:
Originally Posted by drlc101 View Post
Hi,

I installed my unit today on my F10 with NBT (2014 M5). Everything works great but my only complaint is colors do seem a bit washed out. I played around with display settings and got it to improve slightly but it could be better. My unit came with b2_v1.1.2 pre-installed.

Anyone on experiencing this? Curious if a different firmware or display settings can help improve. Thanks!
It's likely the mmi software.

I have noticed variations in the quality of the color and graphics among the various sw versions that I have flashed. You may want to see if the seller has an update.
Appreciate 0
      Today, 02:41 AM   #6195
guafra
Registered
0
Rep
3
Posts

Drives: 118i F20 170hp
Join Date: Sep 2018
Location: ITALIA

iTrader: (0)

Hi everyone
I don't have a wireless AA compatible phone.
I would like to leave a second fixed SIM-free phone in the car connected USB to AA and with the tethering of the first personal phone with SIM provide network to the second phone for multimedia and navigation functions of AA.
Can it work?
Obviously, I will not be able to use telephony with AA, but can I do it with the car's original hands-free Bluetooth system?
Thanks
Appreciate 0
      Today, 04:11 AM   #6196
Evgenyproject
Registered
0
Rep
3
Posts

Drives: F30 330
Join Date: Nov 2020
Location: Germany

iTrader: (0)

Quote:
Originally Posted by Firefly1337 View Post
Quote:
Originally Posted by Len_Beach View Post
Thanks for sharing. Is there any advantage to running this on my Andream running custom firmware and MCU?

I use CarPlay so wouldn't see the advantage from the Android updates.
I can't say for sure since I don't use Carplay. But the update wouldn't work anyway as it's for Bimmertech devices only (it will produce the 'Invalid update' screen).

Quote:
Originally Posted by Evgenyproject View Post
Hi guys, which update can I use for this device from the first page ?! It was bought on Amazon. Manufacturer / supplier (NRpfell) Thank you
Do you happen to have an update file on hand for your version? Then I can take a look which version it really is.

Judging from the version number I would've said a newer version for Andream CIC A-Version. But I saw someone else with that version number before and they said it was asking for a GEMINI_PACK.BIN which would indicate a B-Version. So far I haven't seen an update for your type of device.

-----------------

Also here's a sneak peek of what we are currently working on:
Quote:
Originally Posted by Firefly1337 View Post
Quote:
Originally Posted by Len_Beach View Post
Thanks for sharing. Is there any advantage to running this on my Andream running custom firmware and MCU?

I use CarPlay so wouldn't see the advantage from the Android updates.
I can't say for sure since I don't use Carplay. But the update wouldn't work anyway as it's for Bimmertech devices only (it will produce the 'Invalid update' screen).

Quote:
Originally Posted by Evgenyproject View Post
Hi guys, which update can I use for this device from the first page ?! It was bought on Amazon. Manufacturer / supplier (NRpfell) Thank you
Do you happen to have an update file on hand for your version? Then I can take a look which version it really is.

Judging from the version number I would've said a newer version for Andream CIC A-Version. But I saw someone else with that version number before and they said it was asking for a GEMINI_PACK.BIN which would indicate a B-Version. So far I haven't seen an update for your type of device.

-----------------

Also here's a sneak peek of what we are currently working on:
Hello and thank you for your Answer Firefly1337,

I am also asked for the Gmini file for update. Unfortunately, I don't get an update file for the interface from the seller. So it looks like I can't use modified firmware from the first page ?! Sorry for my bad english. I write in German and then translate into English with Google.
Attached Images
      
Appreciate 0
      Today, 04:50 AM   #6197
alex0607
New Member
8
Rep
20
Posts

Drives: F30 & E60
Join Date: Nov 2020
Location: Asia

iTrader: (0)

Roadtop reverse camera connection cause minor issues

I just installed my rear camera for my F30 to my Roadtop MMI. I know this discussion is for the Andream unit but they are basically the same unit. Below is how I connected the camera.
Name:  Roadtop camera connection.jpg
Views: 40
Size:  276.3 KB
Everything works fine except the reverse light will stay on for a while (although dimmer than usual). But occasionally when I open my trunk even when engine is off, the reverse light where I tapped the 12V from has a dim lit also for a short while. This quite annoying. Secondly when ever I start my car or press the start button to on, the car will register a reverse light failure. But all's well when I start moving reversing or going forward.

I suspect the red wire that comes with the video cable that I connected one end to the Roadtop reverse cam 12V out and the other to the reverse light 12V is causing this issue. I am not sure if this is how I should connect it but by not connecting both ends, the camera will work for a short while and off itself. While connecting just one end to either the 12V reverse light or the Roadtop Reverse cam 12V out will also cause the camera to turn on for a short while before switching off.

No idea what is causing the issue. Will write to Roadtop to seek their advice but was wondering if anyone here came across similar issue and how did you resolve this. Thanks.
Appreciate 0
      Today, 04:58 AM   #6198
alex0607
New Member
8
Rep
20
Posts

Drives: F30 & E60
Join Date: Nov 2020
Location: Asia

iTrader: (0)

Name:  WhatsApp Image 2021-01-24 at 17.56.37.jpeg
Views: 40
Size:  82.3 KB This is my current set version
Appreciate 0
Post Reply

Bookmarks

Tags
andream, android, android auto, apple, carplay, mmi, retrofit

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:29 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST