F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics > Andream MMI Box - Wireless CarPlay & Android Auto
ARMA SPEED
Post Reply
 
Thread Tools Search this Thread
      08-04-2020, 03:22 AM   #3917
cjattard
New Member
3
Rep
18
Posts

Drives: i8
Join Date: Jan 2020
Location: London

iTrader: (0)

That’s phenomenal! So last stupid question (and perhaps one to update on the sticky thread at the top). How do we go about installing the bimmertech MCU on Andream. Is it as simple as
1. Install SW V2.0.B0.mod
2. Install bimmertech MCU with the bimmertech pin on Andream box.

I think i am confusing my self with the “not cross compatable” notes on the first page.

Thanks

Quote:
Originally Posted by xDHC View Post
Right so been running v2.0.B0.mod for a while now and next to what was in the change log i can confirm the following (all tested on Android Auto):

- calls route through the BWM idrive now (when also connected to BWM via bluetooth)
- which also means the echo is gone!
- i can use steering wheel phone button to pickup and hangup calls
- AA auto day/night works based on cars headlights

Have to say i am running SW v2.0.B0.mod and bimmertech MCU 10.6.18.21 on andream.

It also added another issue someone pointed out earlier which was not present in the previous custom version:
- when a call comes in on AA i am unable to move focus via commander knob to the middle screen and tilt to top to set focus on either hangup or pickup call. Workaround is steering wheel button but just wanted to point out the issue is there and is not fixable via clearing AA cache.
Appreciate 0
      08-04-2020, 03:51 AM   #3918
contracts34
Private
contracts34's Avatar
United Kingdom
41
Rep
90
Posts

Drives: BMW 4 Series F33
Join Date: Apr 2019
Location: Lancashire

iTrader: (0)

Quote:
Originally Posted by contracts34 View Post
Thanks again to everyone involved. The work you guys put in to this for the benefit of the rest of us is appreciated beyond words. Most are like me, unable to do such wizardry, I just wish I could somehow help
Just installed and first impression is it's brilliant. Well done guys
Appreciate 1
x-m4n136.50

      08-04-2020, 04:18 AM   #3919
nitsuj17
Second Lieutenant
United_States
55
Rep
256
Posts

Drives: F30 328ix
Join Date: Jan 2020
Location: USA

iTrader: (0)

Great work on the custom firmware Firefly and cossie!

Since I hadn't been paying attention to bt updates relu for awhile, can the the OEM Bluetooth fix be used with car play as well as aa?
Appreciate 0
      08-04-2020, 04:25 AM   #3920
x-m4n
Captain
x-m4n's Avatar
United Kingdom
137
Rep
724
Posts

Drives: Gran Turismo (F34)
Join Date: Mar 2014
Location: London

iTrader: (0)

Quote:
Originally Posted by Firefly1337 View Post
here's the newest update for our custom version: v2.0.B0.mod...

//Edit2: A word regarding MCU updates: With this update you can only flash the MCU updates by Bimmertech.
To skips songs on CarPlay, double tilt the idrive controller right/reft now works!

cossie1 , some feedback here, we discussed the idrive tilt gesture earlier:

= v2.0.2.3t7.mmi.b + MCU 10.1.4.11 has a single tilt to skip songs gesture.
= v2.0.B0.mod + MCU 10.1.4.11 is now has a double tilt to skip songs gesture. (BT mentioned this change on release notes recently)

contracts34 and I think this behaviour is coded somewhere in the firmware (as opposed to the MCU), it would be great if this skip song behavour could be changed back to the original single tilt.

Other than that, I am so grateful, thank you and all so much for the fantastic work, attention to detail and for helping us all out here.

Last edited by x-m4n; 08-04-2020 at 04:39 AM..
Appreciate 0
      08-04-2020, 04:37 AM   #3921
Furbz
New Member
5
Rep
26
Posts

Drives: Possible X5 50i
Join Date: Jul 2020
Location: Gauteng

iTrader: (0)

oh my hat. i just flashed to the latest Custom.
to all those involved thank you!
Appreciate 0
      08-04-2020, 04:44 AM   #3922
wildandbeyond
Registered
0
Rep
2
Posts

Drives: BMW X1 (F48)
Join Date: Aug 2020
Location: London

iTrader: (0)

Quote:
Originally Posted by SDriver18i View Post
Hey guys, I'm from the F48 forums and just bought an MMI from x5m254 for the F48 but I keep getting this clicking noise and "No Signal" message when I switch to the MMi.

I've looked around and found nothing. x5m254 helped me try a few things but to no avail. Swapped cables in probably every different manner available. Nothing. Anyone seen this and can diagnose this?

The unit connects and it works perfectly as I could screenshot the Carplay screen from my iPhone. idrive, audio, camera and all controls work perfectly fine. It just doesn't display the MMi. Weird.


2016 x1 owner here. Unfortunately these boxes only work with NBT 4. If you have a 2019 model you will have NBT evo ID5/6 I believe.

Hope that helps sorry if it’s bad news!
Appreciate 0
      08-04-2020, 05:52 AM   #3923
SDriver18i
Private
SDriver18i's Avatar
No_Country
48
Rep
82
Posts

Drives: BMW X1 s18i 2019
Join Date: May 2019
Location: *

iTrader: (0)

Quote:
Originally Posted by wildandbeyond View Post
2016 x1 owner here. Unfortunately these boxes only work with NBT 4. If you have a 2019 model you will have NBT evo ID5/6 I believe.

Hope that helps sorry if it’s bad news!
Wait, so it won't work, no matter what, on a 2019 model?
Appreciate 0
      08-04-2020, 06:23 AM   #3924
mako2388
New Member
3
Rep
14
Posts

Drives: X3 f25 2016
Join Date: Jul 2020
Location: Ct

iTrader: (0)

Quote:
Originally Posted by mako2388 View Post
Just an update they are sort of giving me the run around. Does anyone else have this issue? Basically I cannot interact with waze at all unless voice command, and often times when I go to the application "launcher" page in AA there is no "cursor/selection box" to pick a different app.
There is an Android Auto update being pushed out. I found this by chance while browsing the web. After the update I haven't had a single issue. Getting the cursor/selection box works flawlessly in all apps now.

https://mobile.softpedia.com/apk/android-auto/5.5.6029/

I tried to get the seller to send me an update anyway but wasn't able to get it. They really don't want to give it out lol
Appreciate 0
      08-04-2020, 07:09 AM   #3925
mako2388
New Member
3
Rep
14
Posts

Drives: X3 f25 2016
Join Date: Jul 2020
Location: Ct

iTrader: (0)

I will probably flash the custom software later today though, as long as 5025 is the PIN I need to proceed. The widescreen AA is sexy
Appreciate 0
      08-04-2020, 07:11 AM   #3926
mako2388
New Member
3
Rep
14
Posts

Drives: X3 f25 2016
Join Date: Jul 2020
Location: Ct

iTrader: (0)

Quote:
Originally Posted by SDriver18i View Post
Hey guys, I'm from the F48 forums and just bought an MMI from x5m254 for the F48 but I keep getting this clicking noise and "No Signal" message when I switch to the MMi.

I've looked around and found nothing. x5m254 helped me try a few things but to no avail. Swapped cables in probably every different manner available. Nothing. Anyone seen this and can diagnose this?

The unit connects and it works perfectly as I could screenshot the Carplay screen from my iPhone. idrive, audio, camera and all controls work perfectly fine. It just doesn't display the MMi. Weird.

I honestly don't know if this applies to you at all, but I got the NO SIGNAL message when I was installing and it turned out I had the video cables plugged in backwards. Switched them and then all was good.
Appreciate 0
      08-04-2020, 07:23 AM   #3927
cossie1
Captain
United Kingdom
449
Rep
825
Posts

Drives: 2015 F82 M4
Join Date: Nov 2018
Location: UK

iTrader: (0)

Quote:
Originally Posted by i3BEV View Post
Can this be safely renamed to GEMINI_PACK.BIN for the newer B units?
NO

If you do that, your unit will no longer accept the newer updates.

Which means if Andream / Carlinkit / Bimmertech / Roadtop etc stop doing updates for the older boxes, your newer unit will also no longer get any updates.
Appreciate 2
x-m4n136.50

      08-04-2020, 07:27 AM   #3928
cossie1
Captain
United Kingdom
449
Rep
825
Posts

Drives: 2015 F82 M4
Join Date: Nov 2018
Location: UK

iTrader: (0)

Quote:
Originally Posted by muniz_ri View Post
cossie...you now need to get yourself a proper phone, i.e Android, to take advantage of all of your work
I'm ok thanks, I enjoy having a phone that works
Appreciate 3
x-m4n136.50
xargs0.00

      08-04-2020, 07:33 AM   #3929
cossie1
Captain
United Kingdom
449
Rep
825
Posts

Drives: 2015 F82 M4
Join Date: Nov 2018
Location: UK

iTrader: (0)

Quote:
Originally Posted by Minims View Post
I have update my Andream NBT to the MINI version.
It's really good but there is just one missing thing.

With Andream version I can adjust screen size.
On MINI, screen is round on left and right and you can't see everything on the screen with default size.
So you need to adjust. I have setting left to 30.
I can't find how to change this in this custom fw.
Is it possible to add this in the config menu ?
Many Thanks.
Ahh yes bimmertech have removed the screen "scrap" options (completely forgot about that when I decided to create the mini version).

Nothing we can do about that sadly, unless bimmertech add those options in a future update.

Quote:
Originally Posted by x-m4n View Post
To skips songs on CarPlay, double tilt the idrive controller right/reft now works!

cossie1 , some feedback here, we discussed the idrive tilt gesture earlier:

= v2.0.2.3t7.mmi.b + MCU 10.1.4.11 has a single tilt to skip songs gesture.
= v2.0.B0.mod + MCU 10.1.4.11 is now has a double tilt to skip songs gesture. (BT mentioned this change on release notes recently)

contracts34 and I think this behaviour is coded somewhere in the firmware (as opposed to the MCU), it would be great if this skip song behavour could be changed back to the original single tilt.

Other than that, I am so grateful, thank you and all so much for the fantastic work, attention to detail and for helping us all out here.
Again we can't change the functions of the unit, we don't have the SDK for the units, therefore we are limited to the way functions are set to work in the update provided by the vendor.
Appreciate 1
x-m4n136.50

      08-04-2020, 07:35 AM   #3930
terrymcg
Private First Class
United Kingdom
29
Rep
142
Posts

Drives: 2015 M4
Join Date: Jun 2012
Location: West Lothian

iTrader: (0)

Quote:
Originally Posted by cossie1 View Post
Quote:
Originally Posted by muniz_ri View Post
cossie...you now need to get yourself a proper phone, i.e Android, to take advantage of all of your work
I'm ok thanks, I enjoy having a phone that works
Cossie, so is it all sorted now? Phone only uses the OEM BT and not the MMI?
Appreciate 0
      08-04-2020, 07:38 AM   #3931
cossie1
Captain
United Kingdom
449
Rep
825
Posts

Drives: 2015 F82 M4
Join Date: Nov 2018
Location: UK

iTrader: (0)

Quote:
Originally Posted by terrymcg View Post
Cossie, so is it all sorted now? Phone only uses the OEM BT and not the MMI?
Sadly not even with the bimmertech / v2.0.B0 update it still uses the MMI for phone calls
Appreciate 0
      08-04-2020, 07:41 AM   #3932
terrymcg
Private First Class
United Kingdom
29
Rep
142
Posts

Drives: 2015 M4
Join Date: Jun 2012
Location: West Lothian

iTrader: (0)

Quote:
Originally Posted by cossie1 View Post
Quote:
Originally Posted by terrymcg View Post
Cossie, so is it all sorted now? Phone only uses the OEM BT and not the MMI?
Sadly not even with the bimmertech / v2.0.B0 update it still uses the MMI for phone calls
Ah sorry I thought with the earlier post someone said using the Bummertech MCU sorted all! What's the chances of ever getting this to work mate?
Appreciate 0
      08-04-2020, 07:47 AM   #3933
dws199
Private
5
Rep
60
Posts

Drives: BMW 520d M Sport 2014
Join Date: Jun 2011
Location: England

iTrader: (0)

Amazing work guys on the new update, thanks so much.

I just had one question which frviana mentioned, I also see some pixelation around words and icons in AA, I saw this in the previous version too. I have the 10.2" screen and wondered if this is due to this firmware not being quite the correct resolution for this screen, could this be why?
Appreciate 0
      08-04-2020, 07:48 AM   #3934
cossie1
Captain
United Kingdom
449
Rep
825
Posts

Drives: 2015 F82 M4
Join Date: Nov 2018
Location: UK

iTrader: (0)

Quote:
Originally Posted by terrymcg View Post
Ah sorry I thought with the earlier post someone said using the Bummertech MCU sorted all! What's the chances of ever getting this to work mate?
With Carplay the bimmertech MCU doesn't seem to do anything except make the scroll wheel work backwards.

As for getting it fixed, if Andream, Carplay, RoadTop or Bimmertech bring out an update that fixes this, then there will be a new custom update soon afterwards

But as above we don't have the SDK for the units (we have tried our best to get this, I have even emailed sunplus directly trying to get it), but none of the vendors are willing to share it and none of them seem interested (or even seem to have any idea of how) to fix it themselves.
Appreciate 0
      08-04-2020, 07:51 AM   #3935
cossie1
Captain
United Kingdom
449
Rep
825
Posts

Drives: 2015 F82 M4
Join Date: Nov 2018
Location: UK

iTrader: (0)

Quote:
Originally Posted by dws199 View Post
Amazing work guys on the new update, thanks so much.

I just had one question which frviana mentioned, I also see some pixelation around words and icons in AA, I saw this in the previous version too. I have the 10.2" screen and wondered if this is due to this firmware not being quite the correct resolution for this screen, could this be why?
Probably due to the dpi being increased in AA to make use of the widescreen (as the default settings when switched to widescreen makes it pretty much impossible to read road names in maps from what I understand).
Appreciate 0
      08-04-2020, 08:02 AM   #3936
Firefly1337
Second Lieutenant
Firefly1337's Avatar
Germany
487
Rep
237
Posts

Drives: F20 M135i LCI
Join Date: Aug 2019
Location: Germany

iTrader: (0)

Quote:
Originally Posted by dws199 View Post
Amazing work guys on the new update, thanks so much.

I just had one question which frviana mentioned, I also see some pixelation around words and icons in AA, I saw this in the previous version too. I have the 10.2" screen and wondered if this is due to this firmware not being quite the correct resolution for this screen, could this be why?
Can you try and take a picture of it?
It looks fine on my 8.8"
Appreciate 0
      08-04-2020, 08:54 AM   #3937
dws199
Private
5
Rep
60
Posts

Drives: BMW 520d M Sport 2014
Join Date: Jun 2011
Location: England

iTrader: (0)

Quote:
Originally Posted by Firefly1337 View Post
Can you try and take a picture of it?
It looks fine on my 8.8"

Sorry not the best picture but hopefully you can see what I mean around the green and orange text and also round the Google Maps image
Attached Images
 
Appreciate 0
      08-04-2020, 09:06 AM   #3938
cerij101
Enlisted Member
United Kingdom
3
Rep
36
Posts

Drives: BMW 520d F11
Join Date: Jun 2008
Location: Wales

iTrader: (0)

Quote:
Originally Posted by xDHC View Post
Right so been running v2.0.B0.mod for a while now and next to what was in the change log i can confirm the following (all tested on Android Auto):

- calls route through the BWM idrive now (when also connected to BWM via bluetooth)
- which also means the echo is gone!
- i can use steering wheel phone button to pickup and hangup calls
- AA auto day/night works based on cars headlights

Have to say i am running SW v2.0.B0.mod and bimmertech MCU 10.6.18.21 on andream.

It also added another issue someone pointed out earlier which was not present in the previous custom version:
- when a call comes in on AA i am unable to move focus via commander knob to the middle screen and tilt to top to set focus on either hangup or pickup call. Workaround is steering wheel button but just wanted to point out the issue is there and is not fixable via clearing AA cache.
- minor issue; in AA when a call comes through or you call someone, it says "no bluetooth connection" but everything works. I believe it says this because theres no bluetooth connection active to the MMI and things are being handled by idrive.
Just to clarify how you have this set up. Do you have the bluetooth connection to the MMI set for 'media audio' only, and the bluetooth connection to the OEM iDrive is 'phone calls' only? Plus contact sharing to both I guess?
Appreciate 0
Post Reply

Bookmarks

Tags
andream, android, android auto, apple, carplay, mmi, retrofit

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:25 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST