F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics > Andream MMI Box - Wireless CarPlay & Android Auto
Extreme Powerhouse
Post Reply
 
Thread Tools Search this Thread
      08-04-2020, 01:35 PM   #3961
xDHC
Second Lieutenant
Netherlands
91
Rep
289
Posts

Drives: F20 116i
Join Date: Mar 2019
Location: Europe

iTrader: (0)

Tested over the course of 1 hour today, 100% calls go over idrive now and not mmi on latest custom firmware on AA. I even see call history in idrive.

Do note, i use latest bimmertech mcu.
Appreciate 0
      08-04-2020, 01:41 PM   #3962
cerij101
Enlisted Member
United Kingdom
3
Rep
36
Posts

Drives: BMW 520d F11
Join Date: Jun 2008
Location: Wales

iTrader: (0)

Quote:
Originally Posted by bowen159 View Post
Hi,

Just wanted to what a great job youíve done!
One thing Iíve noticed today after installing the custom firmware v2 to my Mini, the volume for the navigation is low. When I go to increase it when the Navigation is talking, it increases everything including the radio via the Tunein app. This then makes the radio too loud.

Iíve tried setting the volume to ĎLoudí in Google Maps settings but is doesnít appear to do anything.

Any ideas?
Think I may hold off updating if that's the case
Appreciate 0
      08-04-2020, 01:46 PM   #3963
muniz_ri
Captain
United_States
168
Rep
607
Posts

Drives: BMA 320I
Join Date: Mar 2019
Location: Irvine, CA

iTrader: (1)

Quote:
Originally Posted by xDHC View Post
Tested over the course of 1 hour today, 100% calls go over idrive now and not mmi on latest custom firmware on AA. I even see call history in idrive.

Do note, i use latest bimmertech mcu.
My experience has been the same. Everything works great. I also love being able to use the phone button on the steering wheel and also the auto launch feature and having AA ready to go when I get into my car.
Appreciate 0
      08-04-2020, 01:51 PM   #3964
jjra
Registered
0
Rep
4
Posts

Drives: E90 > F48
Join Date: Aug 2020
Location: Spain

iTrader: (0)

Hi all,

Congratulation to people involved in the development of the new custom V2, wich is a fantastic job. It works fine, and now the auto day/night mode works again in AA, and of course, the new autostart AA feature is great.

Quote:
Originally Posted by mako2388 View Post
Was able to update the to 1.0.2 with a different USB drive and got the MCU updated too. Still don't have the widescreen though
mako2388 , I had issues with the new widescreen layout in a Samsung S8, I can't see it. The solution was the resolution of the phone screen, if it is set to 720 the old widescreen is shown, but if you select 1080 or more, the new widescreen layout appears. Check your phone resolution display if possible and try it.

Last edited by jjra; 08-04-2020 at 01:59 PM..
Appreciate 0
      08-04-2020, 02:08 PM   #3965
mako2388
New Member
3
Rep
14
Posts

Drives: X3 f25 2016
Join Date: Jul 2020
Location: Ct

iTrader: (0)

Quote:
Originally Posted by cossie1 View Post
Sorry my mistake.

It was v2.1.0.8.multiusb.gpe.b that they fixed it in not the B version
Ah OK. I'm sure I'll get it eventually. I'm happy things are working, was having serious issues the first few days it was installed (cursor issues) but everything works now at least!
Appreciate 0
      08-04-2020, 02:17 PM   #3966
mako2388
New Member
3
Rep
14
Posts

Drives: X3 f25 2016
Join Date: Jul 2020
Location: Ct

iTrader: (0)

Quote:
Originally Posted by jjra View Post
Hi all,

Congratulation to people involved in the development of the new custom V2, wich is a fantastic job. It works fine, and now the auto day/night mode works again in AA, and of course, the new autostart AA feature is great.



mako2388 , I had issues with the new widescreen layout in a Samsung S8, I can't see it. The solution was the resolution of the phone screen, if it is set to 720 the old widescreen is shown, but if you select 1080 or more, the new widescreen layout appears. Check your phone resolution display if possible and try it.
Ah I will give that a shot. I have a oneplus 7 pro which has like a "smart" setting where it switches the res by what you are doing. I can set it to high and see if that changes anything. Thanks for the suggestion!
Appreciate 0
      08-04-2020, 03:09 PM   #3967
cerij101
Enlisted Member
United Kingdom
3
Rep
36
Posts

Drives: BMW 520d F11
Join Date: Jun 2008
Location: Wales

iTrader: (0)

Quote:
Originally Posted by mako2388 View Post
Ah I will give that a shot. I have a oneplus 7 pro which has like a "smart" setting where it switches the res by what you are doing. I can set it to high and see if that changes anything. Thanks for the suggestion!
Is the OP7 Pro wired or wireless AA?
Appreciate 0
      08-04-2020, 03:46 PM   #3968
corduroy
Private
United_States
24
Rep
88
Posts

Drives: '16 X5 xDrive40e (F15)
Join Date: Sep 2019
Location: MD

iTrader: (0)

Wow, great work!

I can confirm that my phone calls don't go through the MMI. I'm using the Road Top (early) MMI for NBT with wireless AA. It will show that I'm on a phone call (as pictured) but it's not using bluetooth to control the call. BT doesn't show connected to the MMI.



edit: photos

Last edited by corduroy; 08-04-2020 at 03:51 PM..
Appreciate 1
      08-04-2020, 04:07 PM   #3969
Kyokushin
Private
Kyokushin's Avatar
Poland
8
Rep
71
Posts

Drives: F32 428i, E92 325Xi
Join Date: Feb 2019
Location: Warsaw

iTrader: (0)

Can anyone play with Carplay and BT? Maybe there is also way to configure it with Apple to use BT for calls.
Appreciate 0
      08-04-2020, 04:17 PM   #3970
bowen159
Registered
0
Rep
2
Posts

Drives: Mini
Join Date: Dec 2017
Location: Redditch

iTrader: (0)

Quote:
Originally Posted by cerij101 View Post
Think I may hold off updating if that's the case
Iíve found a work round for this after a couple of hours of messing.

Firstly, when not connected to the mmi, load Google Maps and in Settings, find Navigation settings. In there, set the sound level to loud.

The next thing I did was in the MMI Audio setting, select the EQ. Reduce all the frequencies to around -5. I found that if you do them all equally, it sounds the same but reduces the volume for all sound volume streamed ie Tune in radio, Spotify, BBC Sounds, etc but doesnít reduce the Navigation announcements therefore making the Navigation louder than the radio.

Been out for a drive and itís now the same volume levels I had on the stock navigation announcements with the radio!

One bug Iíve noticed. If you have the volume set to say 50% on the I-drive and you reset the MMI (hold the menu button down), it resets the volume to almost mute in the mmi but itís still 50% through the I-drive. To get round this, you have to set the volume to 0 on the I-drive and then complete a reset in the mmi. This sets both to the same levels.
Appreciate 0
      08-04-2020, 04:25 PM   #3971
Kyokushin
Private
Kyokushin's Avatar
Poland
8
Rep
71
Posts

Drives: F32 428i, E92 325Xi
Join Date: Feb 2019
Location: Warsaw

iTrader: (0)

I am curious the case - what will happen?
1) connect by USB to the OEM port in car. It should then use something called Bluetooth through USB. It is always engaging when i am using spotify by bmw apps (NBT not evo)
By this way i can hear all sounds from the cellphone as navigation on mobile, spotify or just usb music from OEM speakers, and as a 'source' i am picking the 'usb'. I noticed it is engaging only on iPhone.
2) after step 1 (set source as "BT via USB" (dont remember exact name)) connect to the carplay

What i would like to achieve - to transfer all phones audio via OEM USB - after that maybe it will also transfer calls via usb/bt?
Appreciate 0
      08-04-2020, 04:30 PM   #3972
cerij101
Enlisted Member
United Kingdom
3
Rep
36
Posts

Drives: BMW 520d F11
Join Date: Jun 2008
Location: Wales

iTrader: (0)

Quote:
Originally Posted by bowen159 View Post
Iíve found a work round for this after a couple of hours of messing.

Firstly, when not connected to the mmi, load Google Maps and in Settings, find Navigation settings. In there, set the sound level to loud.

The next thing I did was in the MMI Audio setting, select the EQ. Reduce all the frequencies to around -5. I found that if you do them all equally, it sounds the same but reduces the volume for all sound volume streamed ie Tune in radio, Spotify, BBC Sounds, etc but doesnít reduce the Navigation announcements therefore making the Navigation louder than the radio.

Been out for a drive and itís now the same volume levels I had on the stock navigation announcements with the radio!

One bug Iíve noticed. If you have the volume set to say 50% on the I-drive and you reset the MMI (hold the menu button down), it resets the volume to almost mute in the mmi but itís still 50% through the I-drive. To get round this, you have to set the volume to 0 on the I-drive and then complete a reset in the mmi. This sets both to the same levels.
OK, thanks for the heads up.
Appreciate 0
      08-04-2020, 04:36 PM   #3973
frviana
New Member
0
Rep
5
Posts

Drives: F36
Join Date: Jul 2020
Location: Vancouver

iTrader: (0)

Quote:
Originally Posted by Dracon View Post
Anyone have a good suggestion on an alternative vendor than Andream for the hardware?

I bought an Andream unit 6 weeks ago direct from their website store and it's been a bit of a pain in the rear ever since. Their shipping company lost the package in the US (no movement in over 3 weeks) and the guys over at Andream have basically washed their hands of the situation saying there's nothing they can do about it because they can't track the package.

I'd probably caution others from purchasing direct from their web store as well or just use another version.

The whole reason for going with Andream was that it appeared to be better supported especially among a lot of the custom firmware work going on but now it's looking like that's less important now.
I bought Carlinkit from Aliexpress, its their store on Aliexpress. I picked DHL and payed the premium for shipping and it was delivered to my door 4 days after I placed the order (order was placed on Friday and I received it on Monday which was a holiday). I was extremely happy. Installed on the same day and everything worked. It came with a couple plastic tools to remove the dash and a very nice large microfiber cloth too. Very nice touch. They shipped the same day I put the order.
Appreciate 0
      08-04-2020, 05:21 PM   #3974
chabzer
Enlisted Member
5
Rep
43
Posts

Drives: F30 318d
Join Date: Apr 2020
Location: france

iTrader: (0)

Quote:
Originally Posted by cossie1 View Post
With Carplay the bimmertech MCU doesn't seem to do anything except make the scroll wheel work backwards.

As for getting it fixed, if Andream, Carplay, RoadTop or Bimmertech bring out an update that fixes this, then there will be a new custom update soon afterwards

But as above we don't have the SDK for the units (we have tried our best to get this, I have even emailed sunplus directly trying to get it), but none of the vendors are willing to share it and none of them seem interested (or even seem to have any idea of how) to fix it themselves.
The scroll wheel stopped working ?
Appreciate 0
      08-04-2020, 05:22 PM   #3975
muniz_ri
Captain
United_States
168
Rep
607
Posts

Drives: BMA 320I
Join Date: Mar 2019
Location: Irvine, CA

iTrader: (1)

Quote:
Originally Posted by Dracon View Post
Anyone have a good suggestion on an alternative vendor than Andream for the hardware?

I bought an Andream unit 6 weeks ago direct from their website store and it's been a bit of a pain in the rear ever since. Their shipping company lost the package in the US (no movement in over 3 weeks) and the guys over at Andream have basically washed their hands of the situation saying there's nothing they can do about it because they can't track the package.

I'd probably caution others from purchasing direct from their web store as well or just use another version.

The whole reason for going with Andream was that it appeared to be better supported especially among a lot of the custom firmware work going on but now it's looking like that's less important now.
I bought a Carlinkit from this seller: https://www.ebay.com/itm/18438643988...m=184386439888

He is U.S. based so the unit arrived in about 2-3 days.

Andream may now be shipping their new unit exclusively which isn't compatible with the custom firmware.
Appreciate 0
      08-04-2020, 05:49 PM   #3976
xDHC
Second Lieutenant
Netherlands
91
Rep
289
Posts

Drives: F20 116i
Join Date: Mar 2019
Location: Europe

iTrader: (0)

Quote:
Originally Posted by chabzer View Post
The scroll wheel stopped working ?
No its the scroll wheel on the steering wheel that works backwards ONLY in the middle screen of android auto. It works perfectly fine everywhere else (which i noticed) and is a minor problem.
Appreciate 0
      08-04-2020, 05:56 PM   #3977
chabzer
Enlisted Member
5
Rep
43
Posts

Drives: F30 318d
Join Date: Apr 2020
Location: france

iTrader: (0)

Quote:
Originally Posted by xDHC View Post
No its the scroll wheel on the steering wheel that works backwards ONLY in the middle screen of android auto. It works perfectly fine everywhere else (which i noticed) and is a minor problem.
ok thanks for that info
good job for the update !

do you guys know how to fix the issue on Waze , default output always set to Carlpay, can't choose BMW ... tried multiple things nothing worked..

Last edited by chabzer; 08-04-2020 at 06:17 PM..
Appreciate 0
      08-04-2020, 06:29 PM   #3978
cossie1
Captain
United Kingdom
449
Rep
825
Posts

Drives: 2015 F82 M4
Join Date: Nov 2018
Location: UK

iTrader: (0)

Quote:
Originally Posted by xDHC View Post
No its the scroll wheel on the steering wheel that works backwards ONLY in the middle screen of android auto. It works perfectly fine everywhere else (which i noticed) and is a minor problem.
The scroll wheel is backwards for everything in carplay with the bimmertech mcu.

The 20.6.2 mcu from andream / carlinkit works fine and the scroll wheel works the correct way in carplay.
Appreciate 0
      08-04-2020, 06:50 PM   #3979
propernorf
Enlisted Member
propernorf's Avatar
No_Country
9
Rep
39
Posts

Drives: 16' M5 F10
Join Date: Apr 2016
Location: Out

iTrader: (0)

Hello, there guys grat work you doing here. I have a question regarding the customer version. Will it work with The newer andream unites or is it not compatible;e.
Appreciate 0
      08-04-2020, 07:37 PM   #3980
Besty78
Enlisted Member
Besty78's Avatar
6
Rep
30
Posts

Drives: Bmw f30 330d
Join Date: Jul 2020
Location: Uk

iTrader: (0)

Quote:
Originally Posted by Besty78 View Post
Quote:
Originally Posted by cossie1 View Post
Quote:
Originally Posted by Besty78 View Post
absolutely awesome job guys i love it although have a few questions please

what's reverse cam alternative

it doesn't recognise the bimmertec mcu

i need a password to connect to the wifi? can't use autolink

it's not showing any bluetooth connection to the mmi ?
what's reverse cam alternative - no idea (didn't see to change anything when I tried it)

it doesn't recognise the bimmertec mcu - it does, do not rename it, they name it upgrade_mmi.bin for a reason

i need a password to connect to the wifi? can't use autolink - don't need it with carplay but iirc the password for the wifi is 12345678

it's not showing any bluetooth connection to the mmi - no idea don't have an android
thanks for the answers dude

i paired the bluetooth in the end

thanks for the password

i didn't change the filename of the mcu mate
the mcu file lost it's data somehow so i dloaded again and it worked

all problems resolved apart from still not being able to screen mirror with android and autolink

love the fact i can have full screen reverse cam with the pdc sensors graphics overlay

thanks again guys , epic job !
Appreciate 0
      08-04-2020, 09:29 PM   #3981
thestimp
Lieutenant
United_States
142
Rep
561
Posts

Drives: F80 M3 - X3M
Join Date: Jun 2014
Location: Pittsburgh, PA

iTrader: (0)

Flashed 2.0, everythings perfect. The revisions I made for myself seem to work as well. With 2.0 lost the ability to do a custom boot logo via the menu.
__________________
This muthafuka got the RONA!
2016 YMB FBO
Appreciate 0
      08-04-2020, 10:19 PM   #3982
frviana
New Member
0
Rep
5
Posts

Drives: F36
Join Date: Jul 2020
Location: Vancouver

iTrader: (0)

Is there a way to have AA not changing to Night mode when lights turns on? I don't like the dark mode. Running Custom 2 btw.
Appreciate 0
Post Reply

Bookmarks

Tags
andream, android, android auto, apple, carplay, mmi, retrofit

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:26 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST