F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics > Andream MMI Box - Wireless CarPlay & Android Auto
Extreme Powerhouse
Post Reply
 
Thread Tools Search this Thread
      08-05-2020, 10:48 AM   #4005
MrSeabass
New Member
2
Rep
7
Posts

Drives: BMW X3
Join Date: Aug 2020
Location: Georgia

iTrader: (0)

Quote:
Originally Posted by MrSeabass View Post
Hey, I'm close to pulling the trigger on one of these MMI add-ons, and I've read through the thread quite a bit, but I want to make sure I've got all the answers I need before making my decision. Vehicle is a 2013 X3 F25 35i, manufacture date 04/2012 with 103K miles, CIC system 8.8", rear and side mirror cameras. MMI device I plan on ordering is a RoadTop model from Amazon, AA usage only.

1. Will there be any issue with the top/overhead parking view, or the side mirror cameras regardless? All documentation I've seen so far only mention front and rear cameras, but nothing about side mirror cameras.

2. Is the additional(?) USB female cable required for install? Can the USB port inside the center console be used for any and all MMI USB connection/functionality? Likewise, am I going to need to run a 3.5mm cable to the aux port in the center console?

3. Do I need to be concerned about any 'widescreen' issues, based on my 8.8" screen size?

4. Is there any additional storage provided by the MMI unit/impacting the CIC storage space? I am researching swapping out the HDD for a possible SD-to-IDE adapter upgrade or similar in the future.

5. *Purely an opinion*, but is there any incentive to spend the extra money on a complete touchscreen replacement android auto upgrade vs just the MMI addition? Is the software/hardware/support for one type of upgrade more stable than the other?

That's all I can think of for now, thanks!
I take it these have been answered before and I didn't do enough searching...
Appreciate 0
      08-05-2020, 11:04 AM   #4006
evilFive
New Member
12
Rep
14
Posts

Drives: i3
Join Date: Jul 2020
Location: Las Vegas

iTrader: (0)

Man all these widescreen issues, factory phone resets and Developer setting tweaks really makes me appreciate my iPhone 😀.
Appreciate 2
      08-05-2020, 11:17 AM   #4007
evilFive
New Member
12
Rep
14
Posts

Drives: i3
Join Date: Jul 2020
Location: Las Vegas

iTrader: (0)

Quote:
Originally Posted by MrSeabass View Post
I take it these have been answered before and I didn't do enough searching...
You're right , but I'll do my best to answer a few of them though.

Quote:
1. Will there be any issue with the top/overhead parking view, or the side mirror cameras regardless? All documentation I've seen so far only mention front and rear cameras, but nothing about side mirror cameras.
I don't have those options so it's tough to say but if you access those cameras via the PDC you'll be fine. The box will automatically switch to the PDC menu in reverse or if you set your front PDC to enable it as well. From there I would assume you could activate whatever other cameras you have. I can manually push the PDC button and it will switch from CarPlay to PDC and when you press the button to deactivate it goes right back to CarPlay so I think you're good there.

Quote:
2. Is the additional(?) USB female cable required for install? Can the USB port inside the center console be used for any and all MMI USB connection/functionality? Likewise, am I going to need to run a 3.5mm cable to the aux port in the center console?
It is required to use for updating or wired CarPlay. Some have been able to replace the USB in the center console but it will not just work with the existing USB in the center console.

You will not need to run a 3.5mm cable to the Aux port but you will need to set your car to Aux to hear the audio.

Quote:
3. Do I need to be concerned about any 'widescreen' issues, based on my 8.8" screen size?
Are you on Android or iPhone? iPhone, no, Android yesish. Use the custom firmware and you should enjoy the same benefits the Apple people get out of the box .

Quote:
4. Is there any additional storage provided by the MMI unit/impacting the CIC storage space? I am researching swapping out the HDD for a possible SD-to-IDE adapter upgrade or similar in the future.
No. This unit provides for a wireless GUI of your phone instead of the factory infotainment system. You will use apps on your phone or stored music on your phone to play music. So if your phone has 256GB of storage you've now upgraded your car's capacity to 256GB plus all the streaming services.

Quote:
5. *Purely an opinion*, but is there any incentive to spend the extra money on a complete touchscreen replacement android auto upgrade vs just the MMI addition? Is the software/hardware/support for one type of upgrade more stable than the other?
I don't think there is a benefit but everyone has to decide for themselves. I like the almost factory like integration with the iDrive controller.
Appreciate 3
      08-05-2020, 11:25 AM   #4008
muniz_ri
Captain
United_States
168
Rep
607
Posts

Drives: BMA 320I
Join Date: Mar 2019
Location: Irvine, CA

iTrader: (1)

Quote:
Originally Posted by jluzbet View Post
Just got my box and finished the install on a f15, looks like I have the new version just need to uodate tomorrow, I feel it sluggish at times is it like that?
Updating to the latest mcu should resolve that. Also, try wifi channel 149.
Appreciate 0
      08-05-2020, 11:31 AM   #4009
muniz_ri
Captain
United_States
168
Rep
607
Posts

Drives: BMA 320I
Join Date: Mar 2019
Location: Irvine, CA

iTrader: (1)

Quote:
Originally Posted by yulian View Post
Thank you! Cleaning cache, rebooting and disabling day/night switch in AA developer mode helped to get back cursor in AA. Maybe this one should go to FAQ?


And my new question to get perfection)))

Maybe someone have MCU 19.12.12 for Bimmertech firmware? I want to try it with v2.0.0.B0.mod because only this MCU makes button "back" working and bringing me back to NBT menu. Have tried andream MCU's even with renaming to fool bimmertech firmware but it doesn't want to flash.

P.S. Have tried all flashable bimmertech MCU's from first page - no luck. (
Holding down the Menu button for a couple of seconds doesn't take you back to iDrive?

It does for me on my Carlinkit unit using either the latest Carlinkit/Andream mcu or Bimmertech's latest mcu.
Appreciate 0
      08-05-2020, 11:34 AM   #4010
yulian
New Member
Ukraine
3
Rep
15
Posts

Drives: BMW X5 F15 2014
Join Date: Jun 2020
Location: Ukraine, Kyiv

iTrader: (0)

Quote:
Originally Posted by muniz_ri View Post
Holding down the Menu button for a couple of seconds doesn't take you back to iDrive?

It does for me on my Carlinkit unit using either the latest Carlinkit/Andream mcu or Bimmertech's latest mcu.
Sadly but no. Only revert to MCU 19.12.12 with any Carlinkit firmware makes it working via 2 sec hold "back" and "menu". Sadly bimmertech 2.0 custom does not support old MCU's. Maybe it's because I have updated all BMW firmware with local dealer recently and I have newer version somewhere, I don't know...

Last edited by yulian; 08-05-2020 at 11:47 AM..
Appreciate 0
      08-05-2020, 11:49 AM   #4011
thestimp
Lieutenant
United_States
139
Rep
559
Posts

Drives: F80 M3 - X3M
Join Date: Jun 2014
Location: Pittsburgh, PA

iTrader: (0)

Quote:
Originally Posted by frviana View Post
Is there a way to have AA not changing to Night mode when lights turns on? I don't like the dark mode. Running Custom 2 btw.
in AA settings, under dev options you can do it yourself i believe.
__________________
This muthafuka got the RONA!
2016 YMB FBO
Appreciate 0
      08-05-2020, 12:05 PM   #4012
HeatGun
Private
7
Rep
57
Posts

Drives: BMW E93 335i N55
Join Date: Apr 2017
Location: California

iTrader: (0)

I used to be able to answer and end calls by pressing the "phone" button on the steering wheel, I lost that feature with the latest update plus voice command button used to allow me to control Siri. no longer working.
Any idea?
Appreciate 0
      08-05-2020, 12:19 PM   #4013
xDHC
Second Lieutenant
Netherlands
91
Rep
289
Posts

Drives: F20 116i
Join Date: Mar 2019
Location: Europe

iTrader: (0)

Quote:
Originally Posted by HeatGun View Post
I used to be able to answer and end calls by pressing the "phone" button on the steering wheel, I lost that feature with the latest update plus voice command button used to allow me to control Siri. no longer working.
Any idea?
Latest update of what? And which versions? What car?
Appreciate 0
      08-05-2020, 12:22 PM   #4014
HeatGun
Private
7
Rep
57
Posts

Drives: BMW E93 335i N55
Join Date: Apr 2017
Location: California

iTrader: (0)

Quote:
Originally Posted by xDHC View Post
Latest update of what? And which versions? What car?
Sorry for not being clear.
I own 2014 X5.
Previous MCU version which worked fine with buttons was: 20.5.9.10 and now the version I have is 20.6.2 which fixed other various issues with unit except the new issue is the existing buttons.
Appreciate 0
      08-05-2020, 12:24 PM   #4015
ViperBoy2
Enlisted Member
United_States
7
Rep
31
Posts

Drives: 2015 X5M
Join Date: Jan 2014
Location: San Jose, CA

iTrader: (0)

Upgraded to the latest "B" custom firmware from "A" on my Andream and it resolves wired AA auto start and night mode change. However, I have lost wireless AA connectivity even if I connect to wifi using the 12345678 passwd

When I click either the ios or android icons, nothing happens - no warning msg like the USB gives or any hint that it started an app (previously I got a dialog about not being connected). Is there some way to reset all config? Selecting "reset" in the settings menu just reboots - it doesn't reset config

Since wired AA works, I'm using that, though i start the car and then connect the wire. Otherwise I sometimes get reboots or failure to connect
Appreciate 0
      08-05-2020, 12:35 PM   #4016
muniz_ri
Captain
United_States
168
Rep
607
Posts

Drives: BMA 320I
Join Date: Mar 2019
Location: Irvine, CA

iTrader: (1)

Quote:
Originally Posted by ViperBoy2 View Post
Upgraded to the latest "B" custom firmware from "A" on my Andream and it resolves wired AA auto start and night mode change. However, I have lost wireless AA connectivity even if I connect to wifi using the 12345678 passwd

When I click either the ios or android icons, nothing happens - no warning msg like the USB gives or any hint that it started an app (previously I got a dialog about not being connected). Is there some way to reset all config? Selecting "reset" in the settings menu just reboots - it doesn't reset config

Since wired AA works, I'm using that, though i start the car and then connect the wire. Otherwise I sometimes get reboots or failure to connect
Unpair the mmi bluetooth connection from your phone. Then go to Settings - - Wireless Devices -- CarPlay Pairing in the mmi and click Start Search. Wait until your phone appears on the list then click on the phone name to re-pair your phone. AA should then appear.
Appreciate 0
      08-05-2020, 12:47 PM   #4017
Matusov
Matusov
United_States
14
Rep
37
Posts

Drives: F15 X5
Join Date: May 2020
Location: NJ

iTrader: (0)

Quote:
Originally Posted by cossie1 View Post
Just a point to note.

You can update the MCU to the Bimmertech MCU (also on the 1st page) once this update is installed.

But if you want to flash back to the Andream / Carlinkit / Roadtop MCU you will have to reflash your mmi with the correct software for your unit first then update the MCU.
Thanks for all the hard work!

I just flashed the software (not the MCU) on my Carlinkit. I only spent 15-20 min on it and so far I noticed couple of things:

1) It now automatically goes into AA wirelessly after 20 or so seconds
2) As far as "Autolink Mirroring Screen Size Fix" i don't see any changes from previous versions on my X5 F15 NBT 10.25 screen. There are still black bars on both sides. Was hoping it would be full screen...
3) Some odd behavior when trying to go in and out of Mirror Link. If going from AA it did not launch Mirror Link unless I disconnected and reconnected the wire. And the same thing going back to AA from Mirror Link, it would not go back unless I unplugged and plugged the wire back in. Is this normal?
4) The menu button does not exit out of AA or Mirrorlink anymore.
Appreciate 0
      08-05-2020, 12:52 PM   #4018
Unspec
Captain
Unspec's Avatar
United_States
321
Rep
945
Posts

Drives: 2015 BMW 535xi
Join Date: Apr 2019
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by CARR601 View Post
Had frequent disconnections on 6. Changed to 36, been fine ever since.
This is because channel 6 is 2.4ghz WiFi, and 36 is 5ghz. 2.4ghz is hugely congested and is very prone to interference.
__________________
2015 BMW 535xi

Bootmod3 Stage 2 | ER Catted DP | Remus Exhaust | Gplus FMIC
Appreciate 0
      08-05-2020, 02:15 PM   #4019
jluzbet
Enlisted Member
United_States
0
Rep
33
Posts

Drives: F10 535 & F15 X5
Join Date: Aug 2009
Location: Miami

iTrader: (0)

Wondering if you can help with my issues.

1- Reverse Camara does not come in, it did when I tested bedore putting it together, prc makes the sound however.

2- if I select Spotify music wont be heard if I dont choose carplay on the phine, it defaults to Bluetooth of car

3 - Calls, same thing as 2, for me to listen I need to take off car,

Pretty sure I am missing a step along the line.

Thank you in advance
Appreciate 0
      08-05-2020, 06:02 PM   #4020
muniz_ri
Captain
United_States
168
Rep
607
Posts

Drives: BMA 320I
Join Date: Mar 2019
Location: Irvine, CA

iTrader: (1)

Quote:
Originally Posted by jluzbet View Post
Wondering if you can help with my issues.

Thank you in advance
1- Reverse Camara does not come in -- make sure that the camera is set correctly in settings as either original or aftermarket

2- if I select Spotify music wont be heard if I dont choose carplay on the phine, it defaults to Bluetooth of car -- try switching off media audio in idrive bluetooth setting

3 - Calls, same thing as 2, for me to listen I need to take off car, --- not sure on this. I use Android

Last edited by muniz_ri; 08-05-2020 at 06:21 PM..
Appreciate 0
      08-05-2020, 06:05 PM   #4021
muniz_ri
Captain
United_States
168
Rep
607
Posts

Drives: BMA 320I
Join Date: Mar 2019
Location: Irvine, CA

iTrader: (1)

Quote:
Originally Posted by Matusov View Post
Thanks for all the hard work!

I just flashed the software (not the MCU) on my Carlinkit. I only spent 15-20 min on it and so far I noticed couple of things:

4) The menu button does not exit out of AA or Mirrorlink anymore.
Double click the back button to exit AA.
Appreciate 1
Matusov13.50

      08-05-2020, 06:10 PM   #4022
BzsBimmer
Brigadier General
BzsBimmer's Avatar
United_States
1455
Rep
4,980
Posts

Drives: 2015 F80 M3 & 2019 X7
Join Date: Mar 2006
Location: Nor. Cal

iTrader: (26)

Quote:
Originally Posted by jluzbet View Post
Wondering if you can help with my issues.

1- Reverse Camara does not come in, it did when I tested bedore putting it together, prc makes the sound however.
Check to make sure your connection is good. I had same issue and found that my crimp connection wasn’t making full contact.
Appreciate 0
      08-05-2020, 07:14 PM   #4023
phil5556
Private
9
Rep
55
Posts

Drives: 330D Touring E91 2011
Join Date: Apr 2018
Location: Ayrshire

iTrader: (0)

Not totally related to this thread but has anyone else got a new voice in Google maps??

The google maps lady has taken the night off by the sounds of it and been replaced by a guy.
Appreciate 0
      08-05-2020, 07:53 PM   #4024
Matusov
Matusov
United_States
14
Rep
37
Posts

Drives: F15 X5
Join Date: May 2020
Location: NJ

iTrader: (0)

Quote:
Originally Posted by phil5556 View Post
Not totally related to this thread but has anyone else got a new voice in Google maps??

The google maps lady has taken the night off by the sounds of it and been replaced by a guy.

You can change the voice back to English(US) in the Navigation Settings of the maps if you want the lady to tell you where to go.
Appreciate 0
      08-05-2020, 08:37 PM   #4025
TE26M3
Private First Class
TE26M3's Avatar
46
Rep
112
Posts

Drives: 2015 Nardo Grey M5 Competition
Join Date: Jan 2017
Location: Westchester County, NY

iTrader: (0)

Sorry if this was answered, but I have the Andream system and I have a few comments/questions that maybe you guys could help with. I apologize in advance, but I searched the thread and couldnt find exactly what I was looking for.

I have the Andream unit in my F10 M5 and installed it perfectly.
SDK: 25.0.0.5.6.0.0.0
MCU: 20.4.2.14 (downloaded the MCU 20.06.02.zip...need to know how to upload to unit)

I use Apple Carplay as well through my iPhone 10.

1. Wifi shows on my phone as Carplay but says below it No Internet Data Available. PW is 8888888. Anyone have this issue?

2. Phone calls come in on the Carplay, but when I call someone or use my calls through carplay I cant hear anyone but they can hear me. Also, sometimes if I answer through carplay the call immediately drops.

If I use my calls and have it connected through the BMW BT, both work.

3. USB plug doesnt seem to work but all connections are secure

4. How do I upload the latest firmware into the Andream unit? I downloaded MCU 20.06.02

5. Airplay doesnt recognize because the wifi doesnt have internet data

Seeing if anyone could help and MUCH APPRECIATED.
Appreciate 0
      08-05-2020, 11:22 PM   #4026
jacobtc
Private
8
Rep
80
Posts

Drives: BMW F20LCI
Join Date: Jan 2020
Location: Denmark

iTrader: (0)

Just got version 2 installed on my Andream unit, and it seems to work great with auto connect etc. The only problem I have is when I have auto switch AUX on, it seems to switch to it every 1-2 minutes, meaning that if I hear radio, it will switch to AUX by it self.

Does anyone else have this problem as well?
Appreciate 0
Post Reply

Bookmarks

Tags
andream, android, android auto, apple, carplay, mmi, retrofit

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:57 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST