F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > N55 Turbo Engine / Drivetrain / Exhaust Modifications > JB4 issue.
European Auto Source (EAS)
Post Reply
 
Thread Tools Search this Thread
      01-04-2017, 07:31 AM   #1
Trcb777
Captain
Trcb777's Avatar
United_States
291
Rep
885
Posts

Drives: 2013 335i M Sport
Join Date: Jan 2013
Location: Atlanta

iTrader: (1)

JB4 issue.

I'm currently running a ER dp, intake, cp and JB4 on map 5 or 2. My issue is that I'm getting a very long delay before that JB4 "kicks in". If I do a run from a dig, it not until third gear before the boost really comes on and the fuel gage boost high jack shows boost. So basically first and second gear is stock. Zero boost limit set for the gears. If I run from 3rd gear it also take several seconds of "normal or stock boost" until the jb4 kicks in. I'm also having a logging issue and will only get very short logs that don't show enough data. I'm running the latest firmware and I'm pwg 93 octane. Any ideas
Appreciate 0
      01-04-2017, 07:40 AM   #2
mbanks21
Colonel
979
Rep
2,810
Posts

Drives: 2015 335i MSport
Join Date: Aug 2013
Location: St. Pete Florida

iTrader: (8)

You can change the time frame that the log records in the settings. I think the shortest is like 3 seconds, the longest I think is 10.
Appreciate 0
      01-04-2017, 07:52 AM   #3
Chicken_Joe
Lieutenant Colonel
Chicken_Joe's Avatar
United_States
559
Rep
1,760
Posts

Drives: 2013 F30 335i M Sport. EB 6M
Join Date: Dec 2015
Location: Frontenac, Missouri

iTrader: (3)

I had this issue as well. Check the boost by gear settings in the boost menu. Somehow mine got changed and the 1st and 2nd gear boost cap was set and I was getting stock boost in both of those gears
__________________
13' 335i M Sport. EBII/Coral Red 6MT. RPI GT exhaust, Resonator delete, BM3 Stage 2, ER CP, VRSF DP. Dinan Shockware. Varis Japan carbon front lip. Carbon M Performance rear diffuser. M4 trunk lip. Vvroom custom carbon side fins. Firehawk Indy 500 225/40/19 and 255/35/19
Appreciate 0
      01-04-2017, 08:11 AM   #4
Trcb777
Captain
Trcb777's Avatar
United_States
291
Rep
885
Posts

Drives: 2013 335i M Sport
Join Date: Jan 2013
Location: Atlanta

iTrader: (1)

I'll check that out thanks
Appreciate 0
      01-06-2017, 03:22 PM   #5
STR8-6IX
Banned
Canada
469
Rep
2,826
Posts

Drives: RWD 528i N52
Join Date: Nov 2016
Location: Toronto

iTrader: (0)

i hear nothing but problems from the JB4. remove that garbage from your car.
Appreciate 0
      01-06-2017, 03:54 PM   #6
Mike@N54Tuning.com
BimmerPost Supporting Vendor
Canada
3817
Rep
98,495
Posts


Drives: 2007 335i, 2015 M3
Join Date: Dec 2008
Location: N54tuning.com

iTrader: (89)

JB4 includes free pro tuning support so definitely take advantage of it. To do that record a longer log and post it to n54tech's support forum. The JB4 is the best and most flexible tuning system out for the F series but it's only as good as the car its being used on and its settings.

Mike
Appreciate 0
      01-06-2017, 04:39 PM   #7
mike@x-ph.com
BimmerPost Supporting Vendor
mike@x-ph.com's Avatar
United_States
11282
Rep
123,663
Posts


Drives: 2007 e92 335i / 2013 F30 328
Join Date: Sep 2013
Location: Las Vegas

iTrader: (20)

Quote:
Originally Posted by 6IX-F10-N52 View Post
i hear nothing but problems from the JB4. remove that garbage from your car.
You are not serious right? Jb4 outsells all the tunes out there combined, this is why you hear more feedback on it (good and bad) than any other tune.

BTW problems are almost always from user error, either bad install or change in the settings.

We offer a ton of tunes, JB4 by far the most popular with a 14 days money back guarantee. Return rate is less than 1%
Appreciate 1
mbanks21978.50

      01-06-2017, 04:40 PM   #8
STR8-6IX
Banned
Canada
469
Rep
2,826
Posts

Drives: RWD 528i N52
Join Date: Nov 2016
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by mike@x-ph.com View Post
You are not serious right? Jb4 outsells all the tunes out there combined, this is why you hear more feedback on it (good and bad) than any other tune.

BTW problems are almost always from user error, either bad install or change in the settings.

We offer a ton of tunes, JB4 by far the most popular with a 14 days money back guarantee. Return rate is less than 1%
JB4 is the most popular, but i hear lots of issues regarding this tune. like lots. all over this forum.
Appreciate 0
      01-06-2017, 04:42 PM   #9
Paz1
Banned
214
Rep
667
Posts

Drives: 2018 m3
Join Date: Oct 2015
Location: NY

iTrader: (1)

Quote:
Originally Posted by 6IX-F10-N52 View Post
JB4 is the most popular, but i hear lots of issues regarding this tune. like lots. all over this forum.
Agree.
Appreciate 1
J_MENIS96.50

      01-06-2017, 04:43 PM   #10
mike@x-ph.com
BimmerPost Supporting Vendor
mike@x-ph.com's Avatar
United_States
11282
Rep
123,663
Posts


Drives: 2007 e92 335i / 2013 F30 328
Join Date: Sep 2013
Location: Las Vegas

iTrader: (20)

Quote:
Originally Posted by 6IX-F10-N52 View Post
JB4 is the most popular, but i hear lots of issues regarding this tune. like lots. all over this forum.
I already explained to you why you hear more issues than other tunes. You also hear more good reviews that other tunes ... More JB4 sold = more feedback (good or bad)

Follow up the threads with issues and you will realize most of them are user error.

I do think if BMS makes better install guide and include it with the Jb4 when shipped, we would see a lot less negative feedback
Appreciate 0
      01-06-2017, 06:39 PM   #11
Mike@N54Tuning.com
BimmerPost Supporting Vendor
Canada
3817
Rep
98,495
Posts


Drives: 2007 335i, 2015 M3
Join Date: Dec 2008
Location: N54tuning.com

iTrader: (89)

Quote:
Originally Posted by 6IX-F10-N52 View Post
JB4 is the most popular, but i hear lots of issues regarding this tune. like lots. all over this forum.
When you're mixing modifications, different versions of the JB4 hardware and software, cars in various conditions, and customers with various levels of experience making changes, it's easy to run in to a situation where you need professional help resolving some problem you've created. Those who post on BMS' support forum get their problems resolved very quickly.

Mike
Appreciate 0
      01-06-2017, 06:53 PM   #12
Ristau
Private First Class
Ristau's Avatar
United_States
58
Rep
136
Posts

Drives: 2020 M340i XDrive
Join Date: Sep 2016
Location: Ballwin, MO

iTrader: (0)

Quote:
Originally Posted by mike@x-ph.com View Post
I do think if BMS makes better install guide and include it with the Jb4 when shipped, we would see a lot less negative feedback

This x100

I'm sure they could hire some random person on the internet to make it for them for like a few bucks too. Maybe even make a full video step-by-step idiot proof installation guide.
Appreciate 0
      01-07-2017, 10:38 AM   #13
stxf30
First Lieutenant
stxf30's Avatar
United_States
91
Rep
389
Posts

Drives: '13 F30 335i MSport
Join Date: Jan 2012
Location: San Antonio, Texas

iTrader: (0)

Garage List
Quote:
Originally Posted by Trcb777
I'm currently running a ER dp, intake, cp and JB4 on map 5 or 2. My issue is that I'm getting a very long delay before that JB4 "kicks in". If I do a run from a dig, it not until third gear before the boost really comes on and the fuel gage boost high jack shows boost. So basically first and second gear is stock. Zero boost limit set for the gears. If I run from 3rd gear it also take several seconds of "normal or stock boost" until the jb4 kicks in. I'm also having a logging issue and will only get very short logs that don't show enough data. I'm running the latest firmware and I'm pwg 93 octane. Any ideas
I'd check your canbus/ obd2 connections.
__________________
2013 GSM 335i MSport
Appreciate 0
      01-07-2017, 12:23 PM   #14
Minty_
New Member
United_States
10
Rep
29
Posts

Drives: .
Join Date: Mar 2014
Location: .

iTrader: (0)

Quote:
Originally Posted by Ristau View Post
This x100

I'm sure they could hire some random person on the internet to make it for them for like a few bucks too. Maybe even make a full video step-by-step idiot proof installation guide.
Agree 100%. There has been so many iterations of the JB4 versions and the install guide from BMS can be very confusing. A straight-forward video install guide would be very helpful and eliminate many "customer install errors". It's not fair to blame the customer every time there's an issue.
Appreciate 0
      01-07-2017, 12:38 PM   #15
Trcb777
Captain
Trcb777's Avatar
United_States
291
Rep
885
Posts

Drives: 2013 335i M Sport
Join Date: Jan 2013
Location: Atlanta

iTrader: (1)

I've checked everything twice. Obdii dash control work, latest firmware installed, all connections checked. Happens on map 2 or 5. It's just very inconsistent when the jb4 bumps the boost. When it does boost right its pulls great but the inconsistency is driving me crazy.
Appreciate 0
      01-07-2017, 01:04 PM   #16
HotTea69
First Lieutenant
United_States
127
Rep
308
Posts

Drives: 2014 F32 AW M-Sport
Join Date: Jul 2016
Location: Queens, NYC

iTrader: (0)

Quote:
Originally Posted by 6IX-F10-N52 View Post
JB4 is the most popular, but i hear lots of issues regarding this tune. like lots. all over this forum.

It's human nature to complain even at the slightest bit of dissatisfaction but it takes a great deal for someone to leave positive feedback.

I for one am one of those happy customers. I love everything about it and I have no issues. But I didn't exactly post a positive review. If you don't like JB4 that's your opinion. You cannot deny that it is the most popular tune for our car though.
__________________

AWE Cat Back | BBS - LM | CF M Mirror Caps | CF M Trunk Spoiler | CF R-Style Rear Diffuser | ER Charge Pipe | ER Down Pipe | ER Front Mount Intercooler | Enzo Tuned | Injen SR Intake | M Front Grill
Appreciate 0
      01-07-2017, 01:14 PM   #17
jgoens
Major General
jgoens's Avatar
3609
Rep
5,753
Posts

Drives: 2013 335i msport
Join Date: Nov 2014
Location: San Mateo, CA

iTrader: (0)

Quote:
Originally Posted by Trcb777 View Post
I've checked everything twice. Obdii dash control work, latest firmware installed, all connections checked. Happens on map 2 or 5. It's just very inconsistent when the jb4 bumps the boost. When it does boost right its pulls great but the inconsistency is driving me crazy.
Does it happen on Map 1?
__________________
2013 335i Msport Black sapphire/Coral red. MHD. stage 2--e30 VRSF DP, ER CP, Dinan Shockware. VRSF 12mm/15mm spacers. Cobra dashcam. Various codings.
Last car: 2011 335i Msport. JB4. Vrsf CP
Appreciate 0
      01-07-2017, 01:18 PM   #18
jgoens
Major General
jgoens's Avatar
3609
Rep
5,753
Posts

Drives: 2013 335i msport
Join Date: Nov 2014
Location: San Mateo, CA

iTrader: (0)

Quote:
Originally Posted by HotTea69 View Post
It's human nature to complain even at the slightest bit of dissatisfaction but it takes a great deal for someone to leave positive feedback.

I for one am one of those happy customers. I love everything about it and I have no issues. But I didn't exactly post a positive review. If you don't like JB4 that's your opinion. You cannot deny that it is the most popular tune for our car though.
I agree. Think his statement does not have much basis on a statistical level. You can read complaint after complaint on N54 tech and most of the issues get resolved and that being said, the amount of issues is very, very small compared to people running the tune across several platforms. Just like these cars, there are quirks and the OP should try to work with Terry or Jon@BMS to resolve the issue and rule out a defective JB4 which is a remote possibility as well.
__________________
2013 335i Msport Black sapphire/Coral red. MHD. stage 2--e30 VRSF DP, ER CP, Dinan Shockware. VRSF 12mm/15mm spacers. Cobra dashcam. Various codings.
Last car: 2011 335i Msport. JB4. Vrsf CP
Appreciate 0
      01-07-2017, 01:27 PM   #19
Trcb777
Captain
Trcb777's Avatar
United_States
291
Rep
885
Posts

Drives: 2013 335i M Sport
Join Date: Jan 2013
Location: Atlanta

iTrader: (1)

Quote:
Originally Posted by jgoens View Post
Does it happen on Map 1?
I'll have to try. I'm currently out of town
Appreciate 0
      01-07-2017, 01:39 PM   #20
Mike@N54Tuning.com
BimmerPost Supporting Vendor
Canada
3817
Rep
98,495
Posts


Drives: 2007 335i, 2015 M3
Join Date: Dec 2008
Location: N54tuning.com

iTrader: (89)

Quote:
Originally Posted by Trcb777 View Post
I've checked everything twice. Obdii dash control work, latest firmware installed, all connections checked. Happens on map 2 or 5. It's just very inconsistent when the jb4 bumps the boost. When it does boost right its pulls great but the inconsistency is driving me crazy.
Step1: Record JB4 log of specific issue

Step2: Post log on BMS' support forum with a list of mods, fuel, and short description of issue

Step3: BMS will help you resolve the problem

Mike
Appreciate 0
      01-08-2017, 09:17 AM   #21
Trcb777
Captain
Trcb777's Avatar
United_States
291
Rep
885
Posts

Drives: 2013 335i M Sport
Join Date: Jan 2013
Location: Atlanta

iTrader: (1)

Yeah, I've sent logs but I'm also having a logging issue with the blue tooth connect logging short, choppy logs with not enough data.

I'm just looking for trouble shooting ideas or if anyone else had this issue? I've double checked everything and I'm very familiar with the proper JB4 setup. I seeems to be a JB4 software issue? Is there a JB4 system reset I could do?
Appreciate 0
      01-08-2017, 10:11 PM   #22
Mike@N54Tuning.com
BimmerPost Supporting Vendor
Canada
3817
Rep
98,495
Posts


Drives: 2007 335i, 2015 M3
Join Date: Dec 2008
Location: N54tuning.com

iTrader: (89)

Quote:
Originally Posted by Trcb777 View Post
Yeah, I've sent logs but I'm also having a logging issue with the blue tooth connect logging short, choppy logs with not enough data.

I'm just looking for trouble shooting ideas or if anyone else had this issue? I've double checked everything and I'm very familiar with the proper JB4 setup. I seeems to be a JB4 software issue? Is there a JB4 system reset I could do?
No one here is going to know whats going on with your setup. If you are not getting consistent CANbus data then that would casue all sorts of tuning issues. Hopefully you get better feedback in the BMS support forum thread you make with logs and details.

Mike
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:20 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST