F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > N55 Turbo Engine / Drivetrain / Exhaust Modifications > Help check engine light p10f5 and p10e2
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      07-13-2019, 11:44 AM   #1
JDMDC231
Private
2
Rep
51
Posts

Drives: 2006 BMW x5
Join Date: Feb 2013
Location: Minnesota

iTrader: (0)

Help check engine light p10f5 and p10e2

Looking for some help on which direction to go with this or a diagram to tackle it codes are as listed above p10e2 and p10f5. Car seems to have a misfire and looking at a live data seems like cylinder 5 and no injector pulse on that cylinder which I believe the dme is just shutting the cylinder down as a fail safe. Any help would be greatly appreciated!

Attached a copy of a recent log

https://docs.google.com/spreadsheets...it?usp=sharing

Last edited by JDMDC231; 07-20-2019 at 10:30 PM.. Reason: log file added
Appreciate 0
      07-13-2019, 01:08 PM   #2
JoeyMcMahon101
Banned
45
Rep
202
Posts

Drives: 2013 BMW 328i xDrive
Join Date: Nov 2018
Location: Iselin NJ

iTrader: (0)

It has to do regarding your first code, Valvetronic servomotor or sensor. I will look up your second code now.
Appreciate 0
      07-13-2019, 01:14 PM   #3
JoeyMcMahon101
Banned
45
Rep
202
Posts

Drives: 2013 BMW 328i xDrive
Join Date: Nov 2018
Location: Iselin NJ

iTrader: (0)

Other code is in correspondence to Valvetronic sensor.
Appreciate 0
      07-13-2019, 03:39 PM   #4
JDMDC231
Private
2
Rep
51
Posts

Drives: 2006 BMW x5
Join Date: Feb 2013
Location: Minnesota

iTrader: (0)

Is there a way to test the sensor before you deem it bad?
Appreciate 0
      07-14-2019, 09:59 AM   #5
JoeyMcMahon101
Banned
45
Rep
202
Posts

Drives: 2013 BMW 328i xDrive
Join Date: Nov 2018
Location: Iselin NJ

iTrader: (0)

Not that I'm aware of. I would have an Indy check it, report back here and lmk what you find.
Appreciate 0
      07-19-2019, 09:49 PM   #6
JDMDC231
Private
2
Rep
51
Posts

Drives: 2006 BMW x5
Join Date: Feb 2013
Location: Minnesota

iTrader: (0)

Well been messing with it more and found out some issues that took care of most the problems which ended up being a bad Vanos solenoid replaced and car still have a misfire issue with a IAT code checked some values and seemed like I was getting unmetered air so did a smoke test and found a bad intake to turbo plastic one bad/cracked basically fell apart when I went to take it apart ordered new one. Now runs a lot better then it has been running but still getting a miss on idle to 1500 rpm cylinder 5 seems to be the culprit of this problem pulled some codes with BimmerLink FF135B, 081403, 481358, 081405.
Did a full spark plug change gapped and tighten to spec still has miss then swapped coils around with no change. Plug on cylinder 5 is a little wet like itís a leaking injector. Only part now is how do you code in a new injector or check if the values match what is in there?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:33 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST