F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > F30 DIYs and Coding Discussions > F30 2016 LED Headlights retrofit.
Extreme Powerhouse
Post Reply
 
Thread Tools Search this Thread
      10-25-2018, 01:43 AM   #155
Markom051
New Member
0
Rep
7
Posts

Drives: F31
Join Date: Oct 2018
Location: Rijeka, Croatia

iTrader: (0)

Quote:
Originally Posted by atzebmw View Post
Quote:
Originally Posted by Markom051 View Post
Can somebody help me, I have an f31 12/2012, and I am aware about k-Can 2 signal for the led headlights. Where they are connected in the fem on the model before 07/13? As teh models before 07/13 are using the K-Can instead of the K-Can 2. Thanx
https://www.newtis.info/tisv2/a/en/f...74-2v/GS6Y5b7J
Quote:
Originally Posted by atzebmw View Post
Quote:
Originally Posted by Markom051 View Post
Can somebody help me, I have an f31 12/2012, and I am aware about k-Can 2 signal for the led headlights. Where they are connected in the fem on the model before 07/13? As teh models before 07/13 are using the K-Can instead of the K-Can 2. Thanx
https://www.newtis.info/tisv2/a/en/f...74-2v/GS6Y5b7J
Thanx
Appreciate 0
      10-26-2018, 03:13 PM   #156
Furbo80
New Member
0
Rep
7
Posts

Drives: BMW F31 328 Xdrive
Join Date: May 2017
Location: Valencia

iTrader: (0)

guys is there any guide for the coding? I think the wiring is very easy see the attached for some additional detail.
LEFT
Headlight Connector FEM Connector
Pin 1 Pin 48 A173*3B
Pin 2 Ground Z10*1B
Pin 3 Front Fuse Box
Pin 4 Empty Empty
Pin 5 Empty Empty
Pin 6 Empty Empty
Pin 7 Empty Empty
Pin 8 Pin 53 A173*4B
Pin 9 Pin 21 A173*2B
Pin 10 Pin 20 A173*2B
Pin 11 Empty Empty
Pin 12 Empty Empty
Appreciate 0
      10-26-2018, 09:25 PM   #157
Jhnblckwood
Captain
105
Rep
716
Posts

Drives: F30 2014 320i xdrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by Furbo80 View Post
guys is there any guide for the coding? I think the wiring is very easy see the attached for some additional detail.
LEFT
Headlight Connector FEM Connector
Pin 1 Pin 48 A173*3B
Pin 2 Ground Z10*1B
Pin 3 Front Fuse Box
Pin 4 Empty Empty
Pin 5 Empty Empty
Pin 6 Empty Empty
Pin 7 Empty Empty
Pin 8 Pin 53 A173*4B
Pin 9 Pin 21 A173*2B
Pin 10 Pin 20 A173*2B
Pin 11 Empty Empty
Pin 12 Empty Empty
Add 5A2 to ur fa and vo code fem rem and both fleís, change build date to 7/15 if ur car is older. 5A2 is for non adaptive 552 is adaptive.
Appreciate 0
      10-26-2018, 10:05 PM   #158
Jhnblckwood
Captain
105
Rep
716
Posts

Drives: F30 2014 320i xdrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by Furbo80 View Post
guys is there any guide for the coding? I think the wiring is very easy see the attached for some additional detail.
LEFT
Headlight Connector FEM Connector
Pin 1 Pin 48 A173*3B
Pin 2 Ground Z10*1B
Pin 3 Front Fuse Box
Pin 4 Empty Empty
Pin 5 Empty Empty
Pin 6 Empty Empty
Pin 7 Empty Empty
Pin 8 Pin 53 A173*4B
Pin 9 Pin 21 A173*2B
Pin 10 Pin 20 A173*2B
Pin 11 Empty Empty
Pin 12 Empty Empty
https://www.newtis.info/tisv2/a/en/f30-320i-xdrive-lim/1VnYXI4hru

This is what I used, sorry idk what I uploaded last time.
Appreciate 0
      10-26-2018, 11:32 PM   #159
Furbo80
New Member
0
Rep
7
Posts

Drives: BMW F31 328 Xdrive
Join Date: May 2017
Location: Valencia

iTrader: (0)

thanks Man did know was that easy.
Appreciate 0
      10-27-2018, 01:38 AM   #160
Jhnblckwood
Captain
105
Rep
716
Posts

Drives: F30 2014 320i xdrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by Furbo80 View Post
thanks Man did know was that easy.
No problem man Goodluck. Coding isnít that bad as long as u kno what ur doing. U may have to flash ur fleís with esys and psdzdata full but I didnít. Idk if thatís bc mine were used or what but if u canít code them then u prolly have to flash first. Goodluck.

Ps I heard some ppl having to initiate ledís With ista+ if all else fails then try that too. Again I didnít have to but heard of ppl needing too.
Appreciate 0
      10-31-2018, 01:33 AM   #161
JuanF30
New Member
5
Rep
25
Posts

Drives: BMW F30 328i, BMW F15 50i
Join Date: Jun 2017
Location: Panama

iTrader: (0)

Quote:
Originally Posted by Icydubloon View Post
Quote:
Originally Posted by maximed3 View Post
Im looking for someone to code my lights. I did already THE installation but they didnt work. When i start the car the light doesn't work and I have to take out the fuse and put it again and then it's working. THE adaptieve system and THE high Bram assistent didn't work Also. Can someone help me ?
Turn off the engine, get out of the car, and lock the doors. Wait 30 seconds. Then unlock the car. Do the headlights turn on for 1-2 seconds (then go off)? Or do they not come on at all?
Quote:
Originally Posted by Icydubloon View Post
Quote:
Originally Posted by maximed3 View Post
Im looking for someone to code my lights. I did already THE installation but they didnt work. When i start the car the light doesn't work and I have to take out the fuse and put it again and then it's working. THE adaptieve system and THE high Bram assistent didn't work Also. Can someone help me ?
Turn off the engine, get out of the car, and lock the doors. Wait 30 seconds. Then unlock the car. Do the headlights turn on for 1-2 seconds (then go off)? Or do they not come on at all?

I just installed the headlights and its just right how you saying.
I start the car and the headlights turn on, but in 1-2 seconds, it turn off by itself.
What do i need to do?
Appreciate 0
      11-04-2018, 01:08 PM   #162
kubax86
Captain
kubax86's Avatar
Germany
417
Rep
790
Posts

Drives: M4
Join Date: Jul 2017
Location: World

iTrader: (2)

Hello,
Where in front fuse box PIN3 should be plugged in?
I don't have socket Z7*10B in front fuse box, can I connect it to different one?
How you guys did that?

Thanks
Appreciate 0
      11-07-2018, 07:39 AM   #163
kubax86
Captain
kubax86's Avatar
Germany
417
Rep
790
Posts

Drives: M4
Join Date: Jul 2017
Location: World

iTrader: (2)

Did anyone have problem with wdbi_plain error when coding FLEL? Iím coding it with modified FA(zeitkriterium and 552 in Salapa Elements).
e-sys and ista see FLE 43(ecu with fault memory)
Thanks!
Appreciate 0
      11-07-2018, 09:58 PM   #164
Jhnblckwood
Captain
105
Rep
716
Posts

Drives: F30 2014 320i xdrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by kubax86 View Post
Did anyone have problem with wdbi_plain error when coding FLEL? I’m coding it with modified FA(zeitkriterium and 552 in Salapa Elements).
e-sys and ista see FLE 43(ecu with fault memory)
Thanks!
May need to flash it with psdzdata full.
Appreciate 0
      11-08-2018, 10:07 AM   #165
kubax86
Captain
kubax86's Avatar
Germany
417
Rep
790
Posts

Drives: M4
Join Date: Jul 2017
Location: World

iTrader: (2)

Ok figure it out.
They work fine in F82.
Strange, that i also have STMR AND STML in ista shown in red. How to get rid of them in ista tree?
Change FA in VCM?(i didnt do it)
Appreciate 0
      11-08-2018, 12:47 PM   #166
s-type
New Member
0
Rep
6
Posts

Drives: Bmw f20
Join Date: Oct 2017
Location: Croatia

iTrader: (0)

Hi, I made a wiring harness for a 552 adaptive led, all made same as official bmw retrofit.

I have brand new headlights with brand new modules. My car is 11/2011 with regular halogen lights.

I added 552 code to VO, but problem is that FLE modules should come after coding VO but they don't.

Do You know maybe where is problem ? Do I need to update I-step because my vehicle is from 11/2011, do I need somehow to teach-in modules because they are brand new unused ?


Thanks in advance.
Appreciate 0
      11-08-2018, 01:18 PM   #167
kubax86
Captain
kubax86's Avatar
Germany
417
Rep
790
Posts

Drives: M4
Join Date: Jul 2017
Location: World

iTrader: (2)

I think you should try update your FEM_BODY to newer psdzdata, then vo code FLE with modified FA(552 and zeitkriterium).
Appreciate 0
      11-08-2018, 01:27 PM   #168
s-type
New Member
0
Rep
6
Posts

Drives: Bmw f20
Join Date: Oct 2017
Location: Croatia

iTrader: (0)

Quote:
Originally Posted by kubax86 View Post
I think you should try update your FEM_BODY to newer psdzdata, then vo code FLE with modified FA(552 and zeitkriterium).
latest month/year on zeitkriterium which I can set is 11/15, why I can't newer ?
Appreciate 0
      11-09-2018, 04:25 PM   #169
kubax86
Captain
kubax86's Avatar
Germany
417
Rep
790
Posts

Drives: M4
Join Date: Jul 2017
Location: World

iTrader: (2)

Quote:
Originally Posted by s-type View Post
latest month/year on zeitkriterium which I can set is 11/15, why I can't newer ?

Try differnet newer, you have whole lot of options, there are exact zeitkritera that will work.
Actuallt when i retrofitted my f82 lights i didnt have to change zeitkriterium
Appreciate 0
      11-14-2018, 07:08 AM   #170
JuanF30
New Member
5
Rep
25
Posts

Drives: BMW F30 328i, BMW F15 50i
Join Date: Jun 2017
Location: Panama

iTrader: (0)

Quote:
Originally Posted by Icydubloon View Post
Quote:
Originally Posted by maximed3 View Post
Im looking for someone to code my lights. I did already THE installation but they didnt work. When i start the car the light doesn't work and I have to take out the fuse and put it again and then it's working. THE adaptieve system and THE high Bram assistent didn't work Also. Can someone help me ?
Turn off the engine, get out of the car, and lock the doors. Wait 30 seconds. Then unlock the car. Do the headlights turn on for 1-2 seconds (then go off)? Or do they not come on at all?
I just installed the LCI HEADLIGHTS but in my situation is just how you discribed.
I start up the car and both headlights works for 1-2 seconds and then they turn off by itself.
And just remain the passenger side DRL on with the indicator on; and the driver side just the indicator on with the DRL lights off.
Also, both indicators stay on, not blinking and are flicking like there is not enough power.
What do i need to do now?
I havent do the retrofit wiring yet.
Attached Images
 
Appreciate 0
      11-14-2018, 07:58 PM   #171
Jhnblckwood
Captain
105
Rep
716
Posts

Drives: F30 2014 320i xdrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by JuanF30 View Post
Quote:
Originally Posted by Icydubloon View Post
Quote:
Originally Posted by maximed3 View Post
Im looking for someone to code my lights. I did already THE installation but they didnt work. When i start the car the light doesn't work and I have to take out the fuse and put it again and then it's working. THE adaptieve system and THE high Bram assistent didn't work Also. Can someone help me ?
Turn off the engine, get out of the car, and lock the doors. Wait 30 seconds. Then unlock the car. Do the headlights turn on for 1-2 seconds (then go off)? Or do they not come on at all?
I just installed the LCI HEADLIGHTS but in my situation is just how you discribed.
I start up the car and both headlights works for 1-2 seconds and then they turn off by itself.
And just remain the passenger side DRL on with the indicator on; and the driver side just the indicator on with the DRL lights off.
Also, both indicators stay on, not blinking and are flicking like there is not enough power.
What do i need to do now?
I havent do the retrofit wiring yet.
As I already explained to u numerous times thru pm's, how do u expect them to work correctly if u haven't re wired them?????? Again they are not plug n play. Smfh
Appreciate 0
      11-15-2018, 06:56 AM   #172
Littlebear
Major Major
Littlebear's Avatar
United_States
1183
Rep
1,471
Posts

Drives: 2017 330i
Join Date: Oct 2017
Location: Brklyn. Got a problem wit dat?

iTrader: (2)

If anyone has an "F30 LED Headlight Replacement Wiring for Dummies", could you pls share?

TIA! Murf
Appreciate 0
      03-04-2019, 01:15 PM   #173
Brunquaaaa
Private
United_States
3
Rep
76
Posts

Drives: BMW F30 335iPWG, BMW E46 330ci
Join Date: Sep 2018
Location: South Florida

iTrader: (1)

Quote:
Originally Posted by knightsabers View Post
Wiring harness arrived installing tomorrow
Where did you get this retrofit wiring from??? Super interested in buying it
Appreciate 0
      03-14-2019, 08:42 AM   #174
alexmars
New Member
Ukraine
2
Rep
7
Posts

Drives: BMW F30 BMW E87
Join Date: Mar 2019
Location: Ukraine

iTrader: (0)

Hello,
so where did you put new wires for K-CAN2 in FEM???
for left headlight:
Pin 9 from headlight to Pin 21--A173*2B
Pin 10 from headlight to Pin 20--A173*2B

For right headlight:
Pin 9 from headlight to Pin 50--A173*8B
Pin 10 from headlight to Pin 49--A173*8B

When i'm putting these wires,it didn't work,nothing at all.
Even worser,KOMBI,HU-ENTRY are not working.
How do You solved that??
F30 2013/07
Already have newest i-Level, edited zeitkriterium to 07/2015, added 552(adaptive),coded FEM,REM.ESYS not show any FLE's.
ISTA shows just one FLER block...

Thanks.
Appreciate 0
      03-15-2019, 01:25 AM   #175
alexmars
New Member
Ukraine
2
Rep
7
Posts

Drives: BMW F30 BMW E87
Join Date: Mar 2019
Location: Ukraine

iTrader: (0)

Quote:
Originally Posted by alexmars View Post
Hello,
so where did you put new wires for K-CAN2 in FEM???
for left headlight:
Pin 9 from headlight to Pin 21--A173*2B
Pin 10 from headlight to Pin 20--A173*2B

For right headlight:
Pin 9 from headlight to Pin 50--A173*8B
Pin 10 from headlight to Pin 49--A173*8B

When i'm putting these wires,it didn't work,nothing at all.
Even worser,KOMBI,HU-ENTRY are not working.
How do You solved that??
F30 2013/07
Already have newest i-Level, edited zeitkriterium to 07/2015, added 552(adaptive),coded FEM,REM.ESYS not show any FLE's.
ISTA shows just one FLER block...

Thanks.
SOLVED.
Had bad contact on left headlight CAN-Low, everything working fine now,looks amazing)
Thank You
Appreciate 0
      07-23-2019, 01:28 PM   #176
shawnsheridan
General
shawnsheridan's Avatar
United_States
4667
Rep
24,954
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by deneyer View Post
Did an retrofit from adaptive xenon to adaptieve led, all wires are connect as show on newtis.info I updated my fem body, removed 522 and vo coded 552, when i try to vo code fem i cant i get error, and when i want to add cafd to fle43 the are not the same as fle44 an i get an error to when i try to vo code it.

When i try to code fem i get this

Caf's suchen
Tal wird generiert
Abarbeitung wird gestartet

TAL execution started.
VCM Update: VCM-Update is deactivated. VCM will not be updated. [C197]
ExecutionID=2019/07/23-15:59:13.820
[] prepareTALExecution started
[] prepareTALExecution finished
[] prepareVehicleForCoding started
[] prepareVehicleForCoding finished
[FEM_BODY - 40] prepareECUforCoding started
[FEM_BODY - 40] There was an error during TAL execution, please check the log files.
[FEM_BODY - 40] - [Exception - UNKNOWN] Errors during NCD generation for CAF cafd_00000794-018_070_003:
DataGroup ., Function .: More than one condition parameter is active: [., .]
DataGroup ., Function .: More than one condition parameter is active: [., .]
DataGroup ., Function .: More than one condition parameter is active: [., .]
DataGroup ., Function .: More than one condition parameter is active: [., .]
DataGroup ., Function .: More than one condition parameter is active: [., .]
DataGroup ., Function .: More than one condition parameter is active: [., .]
[FEM_BODY - 40] finalizeECUCoding started
[FEM_BODY - 40] finalizeECUCoding finished
[] finalizeVehicleCoding started
[] finalizeVehicleCoding finished
[] finalizeTALExecution started
[] finalizeTALExecution finished
TAL execution finished
TAL-Execution finished with status: "FinishedWithError". [C207]
TAL execution finished. Duration: "17s". [C206]
Abarbeitung beendet


So annyone have an idea on what the problem is and how to fix it? can it be cause my Zeitkriterium=1113 is set on that?
"More than one condition parameter is active" means FA is conflicted.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:27 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST