F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Mechanical Maintenance and TSBs: Break-in / Oil & Fluids / Servicing / TSBs and Service Bulletin > Please help smoke after spark plug change
proTUNING Freaks
Post Reply
 
Thread Tools Search this Thread
      11-15-2019, 02:52 PM   #1
Gertsee
Enlisted Member
Gertsee's Avatar
United_States
20
Rep
46
Posts

Drives: BMW 435i
Join Date: May 2019
Location: New York

iTrader: (0)

Please help smoke after spark plug change

After experiencing a rough idle, engine hesitation and surging, and a CEL Cylinder 1 Misfire I changed all 6 of my spark plugs yesterday. After the change I drove about 2 blocks and noticed white smoke coming from the passenger side of my engine bay and a burning oil smell. I took it to a nearby mechanic who said my Valve Cover Gasket was leaking and he charged me 450$ to fix it overnight. The car is still smoking a little and has a burnt oil smell the mechanic said that is normal and i have to drive it more to burn off the oil that was leaking before but I feel like he didnt fix any problem. Is this smoke and smell normal after a spark plug change?


Here is a picture of my old plugs
[IMG][/IMG]
Attached Images
 
Appreciate 0
      11-15-2019, 04:03 PM   #2
Billfitz
Lieutenant General
Billfitz's Avatar
United_States
4503
Rep
10,178
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

Changing plugs won't create an oil leak. I wouldn't be surprised if the valve cover gasket was bad, it's a common problem past 50k miles, which I assume you are if you needed plugs. It will take some time for the oil that leaked to all burn off.
Appreciate 0
      11-16-2019, 06:40 AM   #3
Gertsee
Enlisted Member
Gertsee's Avatar
United_States
20
Rep
46
Posts

Drives: BMW 435i
Join Date: May 2019
Location: New York

iTrader: (0)

Quote:
Originally Posted by Billfitz View Post
Changing plugs won't create an oil leak. I wouldn't be surprised if the valve cover gasket was bad, it's a common problem past 50k miles, which I assume you are if you needed plugs. It will take some time for the oil that leaked to all burn off.
Thanks! The car is at 63K I still feel a slightly rough idle and the occasional light jerk I might change out the coil packs too but I've been told those usually don't go out this early
Appreciate 0
      11-16-2019, 08:56 AM   #4
Billfitz
Lieutenant General
Billfitz's Avatar
United_States
4503
Rep
10,178
Posts

Drives: '15 328iX GT
Join Date: Jan 2015
Location: New Hampshire

iTrader: (0)

Have you ever cleaned your MAF sensor?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:37 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST