F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > F30 DIYs and Coding Discussions > DIY - F30 OEM Backup / reversing camera retrofit installed!
ARMA SPEED
Post Reply
 
Thread Tools Search this Thread
      09-18-2020, 12:32 PM   #639
jkwhar
Captain
137
Rep
636
Posts

Drives: F30 328i Xdrive | F15 x35i
Join Date: Jun 2016
Location: Central NJ

iTrader: (6)

Quote:
Originally Posted by Suprnowa View Post
I connected and coded as you wrote. I took the power of the camera from the reverse lamp
Unfortunately, the image from the camera is black and white, then some horizontal lines appear and then the image turns off everything is gray.
Previously, the same camera connected to Android worked Ok and the image was in color



Look into something like this...read the description on the listing. It may or may not fix your issue.
https://www.amazon.com/Dasaita-Capac.../dp/B074P35T3M
__________________
Did my post help? Click "Appreciate!"

F30 328i xDrive | Cold Weather | Nav Pro | Tech Pkg | Injen Intake | CW DP | VRSF IC | MR Dual Exhaust | BM3 | BC coilovers & Swift springs | Integral Audio | Retrofit: 522 & 524 EDM | 5AC | 508 | 3AG | 5DL | 6WB | 8TH | FCW/LDW/SLI | Carplay
Appreciate 0
      09-21-2020, 08:30 AM   #640
hugo325
New Member
7
Rep
21
Posts

Drives: 118i (M sport) [F20-2018]
Join Date: Aug 2018
Location: FRANCE

iTrader: (0)

Hi everyone,

I also have the same problem regarding the display of the "TRSVC" module in my SVT.
My FEM module does not have any default wire on the K_CAN 51/52 pins (A173*8B).
Once connected, I checked the voltage levels on the connector of my "TRSVC" module (A167*2B). All is OK

I have 12V on pin 7 (Supply, terminal 15)
1.8V on pin 6 (K-CAN_L)
3.3V on pin 5 (K_CAN_H)
Pin 1 is well connected to the ground plane.

I add "3AG" in my FA code.
Unfortunately I don't have a "TRSVC" module that appears in my SVT ...
I have the fault error :
E59449 No message (status, qualifier rear-view, 0x39B), REM receiver, TRSVC transmitter

My car model is : 118i (F20) LCI (04/2018), I-step 17-11-540.

The reference of my FEM is : 61358707677-01
ZB FEM LEAR V13
HW: D9.0, SW: 16.114.030

It's so strange because when I do a TAL calculating (with my Istep shipment), I get a TRSVC.
So normally my TRSVC module should be recognized ...
Only the hardware version is wrong between the TRSVC display by TAL calculating (HW: 10.003.000) and my TRVSC purchase (HW: 10.002.000).



Does anyone have an explanation to this ?
Appreciate 0
      09-21-2020, 10:52 AM   #641
atzebmw
Lieutenant Colonel
Germany
383
Rep
1,731
Posts

Drives: BMW 335XD F30 LCI
Join Date: May 2016
Location: Germany

iTrader: (0)

Quote:
Originally Posted by hugo325 View Post
Hi everyone,

I also have the same problem regarding the display of the "TRSVC" module in my SVT.
My FEM module does not have any default wire on the K_CAN 51/52 pins (A173*8B).
Once connected, I checked the voltage levels on the connector of my "TRSVC" module (A167*2B). All is OK

I have 12V on pin 7 (Supply, terminal 15)
1.8V on pin 6 (K-CAN_L)
3.3V on pin 5 (K_CAN_H)
Pin 1 is well connected to the ground plane.

I add "3AG" in my FA code.
Unfortunately I don't have a "TRSVC" module that appears in my SVT ...
I have the fault error :
E59449 No message (status, qualifier rear-view, 0x39B), REM receiver, TRSVC transmitter
You can try to connect the 2 K_CAN wires with Pin 33/34 on A173*7B.

https://www.newtis.info/tisv2/a/en/f...-2v/1VnXT4PbeT

If you then have the same problem the TRSVC is defective i think.
Appreciate 0
      09-21-2020, 12:05 PM   #642
hugo325
New Member
7
Rep
21
Posts

Drives: 118i (M sport) [F20-2018]
Join Date: Aug 2018
Location: FRANCE

iTrader: (0)

I just checked, I don't have anything on pin 33/34 (A173*7B).

I try to connect the bus to these 2 pins anyway ?

The exacte wiring schematic is :
https://www.newtis.info/tisv2/a/en/f...-2v/1VnXgq8kBl
Appreciate 0
      09-21-2020, 12:42 PM   #643
atzebmw
Lieutenant Colonel
Germany
383
Rep
1,731
Posts

Drives: BMW 335XD F30 LCI
Join Date: May 2016
Location: Germany

iTrader: (0)

Quote:
Originally Posted by hugo325 View Post
I just checked, I don't have anything on pin 33/34 (A173*7B).

I try to connect the bus to these 2 pins anyway ?

The exacte wiring schematic is :
https://www.newtis.info/tisv2/a/en/f...-2v/1VnXgq8kBl
But on pin 33/34 (A173 * 7B) the control unit for the air conditioning must have be connected. So the K_CAN must definitely be activated there. And that in any case.
You can anyway try connecting the 2 pins there.
Appreciate 0
      09-21-2020, 03:22 PM   #644
hugo325
New Member
7
Rep
21
Posts

Drives: 118i (M sport) [F20-2018]
Join Date: Aug 2018
Location: FRANCE

iTrader: (0)

No sorry on my car 118i, the air conditionning is connecting to K_CAN2 on the connector X20*1B.

I think my TRSVC module is dead, so I will change it in few day...
I hope I am right.
Appreciate 0
      10-08-2020, 01:32 AM   #645
Maxfusion
New Member
0
Rep
9
Posts

Drives: 320I XDrive
Join Date: Mar 2019
Location: Russia

iTrader: (0)

Quote:
Originally Posted by Jaykob View Post
Hi guys!
I'm trying to figure out the best solution for my 6/2016 320d F31 with NBT EVO ID4.
I'm reading that mine doesn't support ICAM, is that correct?
However I've heard that there are special adapters (CAN-filters) that I could use? Like this one: http://carsystems.com.ua/bmw-product...fit-adapter-en

Quality-wise the ICAM should be preferred over the TRSVC solution, right?
I have the same question. 320I 06/2016 with retrofitted NBT Evo Touch ID6.
Can we install ICAM natively without special adapters and without changing FEM to a newer version?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:03 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST