F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics > Andream MMI Box - Wireless CarPlay & Android Auto
ARMA SPEED
Post Reply
 
Thread Tools Search this Thread
      01-24-2022, 03:29 PM   #9681
jamesdwong
Registered
0
Rep
1
Posts

Drives: M235i
Join Date: Jan 2022
Location: Liverpool

iTrader: (0)

I have an Andream A unit and am currently running the custom firmware but wish to upgrade to the latest official Andream firmware. I cannot get the box to recognise any of the update files that I use. I have tried 6 different USB sticks all of different sizes and freshly formatted in Windows. Can anybody help?
Appreciate 0
      01-24-2022, 03:36 PM   #9682
Langzeit
Registered
0
Rep
3
Posts

Drives: BMW F31 (01/2015)
Join Date: Jan 2022
Location: Germany

iTrader: (0)

Quote:
Originally Posted by muniz_ri View Post
Correct, the wifi antenna only affects the range. The mmi will work fine without it.

In regard to audio quality...I would disable loudness then try each of the prest EQ settings as a starting point for fine tuning. I believe that I am currently using the Pop preset.

You may also need to adjust your iDrive tone settings, i.e. bass and treble as they also affect music played through the mmi.
Thanks again! I will try to deactivate loudness tomorrow!
Appreciate 0
      01-24-2022, 04:17 PM   #9683
AbnormallyAspirated
Private
12
Rep
86
Posts

Drives: 2016 M235i 6-Speed Convertible
Join Date: Oct 2021
Location: Rochester, NY

iTrader: (0)

Black screen from cold weather, maybe low battery

Bad day. My MMI box has been working well, but today I moved my car outside, and after a few hours came Out and door wouldn't unlock. Used key and car was dead, and even holding the key on the steering column did nothing. Alarm also went off. I want and got my 2nd key and everything seemed fine, BUT my cars screen is completely dead. Nothing. Holding down menu did nothing. Holding down BACK does nothing. Holding down the BAcK while starting does nothing. My whole audio and idrive system seems dead. Ugh.

Any ideas? Is there a fuse I should check? What is the *full* reboot process?

A couple times lately the car has put up a message saying there is drain whil the car is off, and my joke seems to pair to CarPlay sometimes when I'm not in the car. Lie if I just open the door.

2016 2-series with HU_ENTRYNAV

HELP!
Appreciate 0
      01-25-2022, 02:45 AM   #9684
Lolo_14
New Member
France
3
Rep
15
Posts

Drives: BMW F31
Join Date: Feb 2020
Location: France

iTrader: (0)

Happy owner for a Andream NBT01A with v2.2.0.5.gpe.b / MCU 20.06.02, I wanted to inform that upgrading my Iphone 13 to iOS 15.2.1 solved the "freezes" I had from time to time with Carplay.
Previously I had to double press the BACK button to go back to the MMI menu and restart Carplay interface, all Carplay interface was frozen [Often on Waze] (all keys except double BACK key press were not functioning) even if the music was still continuing to play and reacting to the "<" ">" press.

Else my advice would be to upgrade the MMI MCU and firmware only when known it will solve an issue you have or a new feature you would like to get. There are always risk to brick the device so "upgrading to get the latest release installed" is definitely not a good way.
I have it since end 2019 and this is probably the best buy I could make for my BMW!
If it break I will certain buy immediately a new one (probbaly a NBT02B)

Last edited by Lolo_14; 01-25-2022 at 02:51 AM..
Appreciate 1
fe756539.00
      01-25-2022, 03:05 AM   #9685
fe7565
Second Lieutenant
United_States
39
Rep
226
Posts

Drives: 2012 BMW 328i
Join Date: Nov 2013
Location: United States

iTrader: (0)

Quote:
Originally Posted by AbnormallyAspirated View Post
Bad day. My MMI box has been working well, but today I moved my car outside, and after a few hours came Out and door wouldn't unlock. Used key and car was dead, and even holding the key on the steering column did nothing. Alarm also went off. I want and got my 2nd key and everything seemed fine, BUT my cars screen is completely dead. Nothing. Holding down menu did nothing. Holding down BACK does nothing. Holding down the BAcK while starting does nothing. My whole audio and idrive system seems dead. Ugh.

Any ideas? Is there a fuse I should check? What is the *full* reboot process?

A couple times lately the car has put up a message saying there is drain whil the car is off, and my joke seems to pair to CarPlay sometimes when I'm not in the car. Lie if I just open the door.

2016 2-series with HU_ENTRYNAV

HELP!
Worst case scenario is a short circuit. But you may be onto something with the cold weather. If you can, warm up the car temperature inside and see if the MMI box comes back to life. I had a couple of USB cameras that completely shut down in cold weather and had to hand warm them to start operating again. It's likely these Chinese units don't have quite durable components designed for wide temperature ranges.

If you cannot warm the interior of the car, I would remove the quad lock for the MMI box and reconnect factory harness and the LVDS cable from the monitor to the HU. The BMW OEM components are definitely rated for cold weather. This way you eliminate all but the MMI box. Your factory components should start up without any issue if your battery is charged enough.

Take the MMI box inside, warm to room temperature bring it back, install it and see if everything works again.
Appreciate 0
      01-25-2022, 05:00 AM   #9686
serbandan
Registered
0
Rep
1
Posts

Drives: Bmw 5 series gt
Join Date: Jan 2022
Location: Uk

iTrader: (0)

Quote:
Originally Posted by p_rhodan View Post
I have a big problem after updating from Andream firmware to latest Binmertech firmware. I get only the MMI start logo and after few seconds only the screen ‚INVALID UPDATE‘ ��

I did in the past often switching between the different versions (Andream original, Custom, RoadTop, Binmertech) and had never an issue.

It's an original Andream NBT LC Box in a BMW i3.

I tried the ‚Force update‘ method, also removed/inserted fuse 61 which is for the NBT. Pressed always the Back button on the iDrive controller. Tried it also with any other button on the controller.

MMI reboots, after 2-3 second it access the USB drive (lights flash on it) the MMI still boot about 10 sec and display than the error.

Any ideas how I can force an update? Would it be possible if I connect it directly with PC and any restore app?

Thanks!


Hi. I have e the same problem. Do you find any way to fix that? If yes please let me know how, that gonna be very helpful for me. Thank you!
Appreciate 0
      01-25-2022, 06:06 AM   #9687
Meza
New Member
0
Rep
10
Posts

Drives: BMW m140i
Join Date: Dec 2017
Location: Brum

iTrader: (0)

I'm in the UK and looking to get one of these for my CIC pro headunit
Which, if any, of these would people recommend?


AIOCOAI £189 inc delivery to UK from China
https://www.aliexpress.com/item/4000...yAdapt=glo2fra

EBILAEN £171 inc delivery to UK from China
https://www.aliexpress.com/item/1005...mend-recommend

Navifly £155 inc delivery to UK from China
https://www.aliexpress.com/item/1005...mend-recommend
Attached Images
   
Appreciate 0
      01-25-2022, 06:14 AM   #9688
Meza
New Member
0
Rep
10
Posts

Drives: BMW m140i
Join Date: Dec 2017
Location: Brum

iTrader: (0)

Or the AIOCOAI EWM-BMCP-NBT04X with HDMI (and the rugged looking embossed case)
£197 to UK from China
https://www.aliexpress.com/item/4000...yAdapt=glo2nld
Attached Images
 
Appreciate 0
      01-25-2022, 06:30 AM   #9689
Meza
New Member
0
Rep
10
Posts

Drives: BMW m140i
Join Date: Dec 2017
Location: Brum

iTrader: (0)

I have an aftermarket reversing camera which already has it's own control box taking up space next to the glove box. Can I get rid of this box and plug the aftermarket camera straight into the the MMI box, or do I need to keep both boxes behind the dash now(!)?
Appreciate 0
      01-25-2022, 07:03 AM   #9690
RAAF12
First Lieutenant
Netherlands
61
Rep
385
Posts

Drives: 1 series F20LCI 120i 2016
Join Date: Nov 2020
Location: North

iTrader: (0)

Quote:
Originally Posted by muniz_ri View Post
Correct, the wifi antenna only affects the range. The mmi will work fine without it.

In regard to audio quality...I would disable loudness then try each of the prest EQ settings as a starting point for fine tuning. I believe that I am currently using the Pop preset.

You may also need to adjust your iDrive tone settings, i.e. bass and treble as they also affect music played through the mmi.

The MMI box is made from metal you'll need an external antenna for receiving and transmitting Bluetooth and Wifi signals. Mine has a printed antenna and must be glued and away from metal parts of the car. My BT en Wifi has good strenght and works ftom within 10 meters of the outside car. This version of BT is capable of max 10 meters distance. You have some 'room' for good transmission in hostile environments like places with man made noise and so on. So always use the antenna(s).

Last edited by RAAF12; 01-25-2022 at 03:22 PM..
Appreciate 0
      01-25-2022, 04:28 PM   #9691
40theyears
New Member
2
Rep
6
Posts

Drives: F30
Join Date: Jun 2020
Location: TR

iTrader: (0)

Exclamation Carplay & Jailbreak

Hello, I have been using Carlinkit NBT device in my vehicle for 6 months. Recently I jailbroken my iPhone 11 Pro Max and at the same time I upgraded my NBT device to the latest 9.6.3.yl.b version of Carlinkit. However, after the jailbreak, the Carlinkit module does not switch to Carplay, although the phone appears to be connected (wired or wireless). I wonder if a friend of mine has knowledge and experience about this problem.

Note: When I cancel the jailbreak process on my phone and restore it to the standard ios state, there is no connection problem. But will I never be able to use the jailbroken iPhone on the NBT unit?

Thank you so much…

İlker

Name:  WhatsApp Image 2022-01-26 at 00.04.32.jpeg
Views: 288
Size:  52.7 KB
Appreciate 1
      01-25-2022, 05:05 PM   #9692
RAAF12
First Lieutenant
Netherlands
61
Rep
385
Posts

Drives: 1 series F20LCI 120i 2016
Join Date: Nov 2020
Location: North

iTrader: (0)

Quote:
Never be able to use the jailbroken iPhone on the NBT unit?
Short answer, yes.
Appreciate 0
      01-25-2022, 10:24 PM   #9693
fe7565
Second Lieutenant
United_States
39
Rep
226
Posts

Drives: 2012 BMW 328i
Join Date: Nov 2013
Location: United States

iTrader: (0)

Quote:
Originally Posted by Meza View Post
I'm in the UK and looking to get one of these for my CIC pro headunit
Which, if any, of these would people recommend?


AIOCOAI £189 inc delivery to UK from China
https://www.aliexpress.com/item/4000...yAdapt=glo2fra

EBILAEN £171 inc delivery to UK from China
https://www.aliexpress.com/item/1005...mend-recommend

Navifly £155 inc delivery to UK from China
https://www.aliexpress.com/item/1005...mend-recommend

There are numerus complaints about the NaviFly (non-existing) customer service.
EBILAEN : may not find forum support for this one.

I believe AIOCOAI is Andream, the main topic of this thread.

Last edited by fe7565; 01-25-2022 at 10:32 PM..
Appreciate 0
      01-25-2022, 10:29 PM   #9694
fe7565
Second Lieutenant
United_States
39
Rep
226
Posts

Drives: 2012 BMW 328i
Join Date: Nov 2013
Location: United States

iTrader: (0)

Quote:
Originally Posted by Meza View Post
I have an aftermarket reversing camera which already has it's own control box taking up space next to the glove box. Can I get rid of this box and plug the aftermarket camera straight into the the MMI box, or do I need to keep both boxes behind the dash now(!)?
Depends on your aftermarket camera's operation setup. Does it require the extra box it came with to process the signal? Or it just sends the signals via RCA plugs (or whatever) to anything that is able to process composite video signals? Then you can connect it with the MMI directly. Try to plug it into your TV or VCR or whatever that has composite video input and see if it works without the box it came with. Or post the model number and /or operating manual for the camera and someone may be able to review it and comment.
Appreciate 0
      Yesterday, 12:42 PM   #9695
guafra
New Member
Burkina Faso
2
Rep
12
Posts

Drives: Man
Join Date: Sep 2018
Location: ITALIA

iTrader: (0)

Send a message via AIM to guafra Send a message via Yahoo to guafra
Aiuto non ricordo la password wifi andream b2 grazie
Appreciate 0
      Yesterday, 01:30 PM   #9696
RAAF12
First Lieutenant
Netherlands
61
Rep
385
Posts

Drives: 1 series F20LCI 120i 2016
Join Date: Nov 2020
Location: North

iTrader: (0)

Quote:
Originally Posted by guafra View Post
Aiuto non ricordo la password wifi andream b2 grazie
Only English language forum your lazy b*st*rd. Or use Google Translate!
Appreciate 1
      Yesterday, 02:53 PM   #9697
guafra
New Member
Burkina Faso
2
Rep
12
Posts

Drives: Man
Join Date: Sep 2018
Location: ITALIA

iTrader: (0)

Send a message via AIM to guafra Send a message via Yahoo to guafra
Quote:
Originally Posted by RAAF12 View Post
Only English language forum your lazy b*st*rd. Or use Google Translate!
sorry for gaffe, small panic solved thanks thanks
Appreciate 1
Post Reply

Bookmarks

Tags
andream, android, android auto, apple, carplay, mmi, retrofit

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:49 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST