F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > B58 Turbo Engine / Drivetrain / Exhaust Modifications > B58 Engine: please post your experience, including problems / resolutions
Post Reply
 
Thread Tools Search this Thread
      09-22-2019, 08:59 AM   #507
BMWILUVU
Lieutenant
221
Rep
582
Posts

Drives: 340ix
Join Date: Mar 2017
Location: The Boibs

iTrader: (0)

Quote:
Originally Posted by NormanConquest View Post
As far as I'm aware the only update is
1. A rockguard to protect the radiator
2. Improve fuel delivery system
3. Tweaks to be able and comply with EU standard which reduces the overall engine power.

The core engine is still the same.

The crankshaft barring issue that you mention all occur on manual something that not even an option anymore for the b58
I recall the crankshaft problem happened within 6 months of the B58's release and it was fixed asap. There has been nothing since. Musashi is on opiods.
Appreciate 2
kern4172002.50

      09-22-2019, 09:18 AM   #508
kern417
Cheapskate
United_States
2003
Rep
3,116
Posts

Drives: 2018 440i / 2010 X5
Join Date: Aug 2016
Location: Cincinnati

iTrader: (0)

Quote:
Originally Posted by BMWILUVU View Post
I recall the crankshaft problem happened within 6 months of the B58's release and it was fixed asap. There has been nothing since. Musashi is on opiods.
Like I said before, give the TU1 a year and it'll be full of revisions too, whether it's design or manufacturing/supplier related fixes. If Mr. Sushi had any actual automotive engineering experience, he'd know these recalls and revisions don't stop. Even after EOP, my bulletproof N52 vehicle had a new recall a few years ago.

But nah. Instead he got "inside scoops" from a guy at BMW. K.
__________________
Quote:
Originally Posted by umizoomi View Post
As long as 3-pedals are an option, I will exercise my right to suffer the handicap and indignity of slower shifts and reaction times.
Instagram @kern417
Appreciate 0
      09-22-2019, 02:16 PM   #509
cfm56d7b
Brigadier General
United_States
1554
Rep
4,352
Posts

Drives: 2017 440i Gran Coupe & 2015 X5
Join Date: Nov 2012
Location: Orange County, CA

iTrader: (2)

While (thankfully) 2 miles away from home, "low coolant" warning appeared. Mileage: 24.8K miles. According to the July 2019 inspection report at 22.8K miles or 2K miles prior, coolant levels were OK.

My vehicle - 2017 BMW 440i Gran Coupe - was built in July 2016. Still under warranty for one year.

I haven't checked the coolant level yet but will inspect in a few hours when the car is 100% cold. Will be mixing BMW coolant 50/50 with distilled water. Visiting local dealer on Monday AM.

Based on everyone's input from this thread ...

- If the coolant level is low in the intercooler tank, I will work with dealer and BMW NA to replace the turbocharger. Based on my research, early production B58 engines experienced this problem.

Does anyone have a copy of the repair order stating "coolant leaking into the turbo bearing. turbo replaced?" Will be grateful.

- If the coolant is low in the main tank, will ask the dealer to pressurize the cooling system.

What was replaced if a leak was found? The tank? The cap?

My hope is that the head gasket is OK considering low mileage.
Appreciate 0
      09-22-2019, 03:17 PM   #510
BMWILUVU
Lieutenant
221
Rep
582
Posts

Drives: 340ix
Join Date: Mar 2017
Location: The Boibs

iTrader: (0)

Quote:
Originally Posted by cfm56d7b View Post
While (thankfully) 2 miles away from home, "low coolant" warning appeared. Mileage: 24.8K miles. According to the July 2019 inspection report at 22.8K miles or 2K miles prior, coolant levels were OK.

My vehicle - 2017 BMW 440i Gran Coupe - was built in July 2016. Still under warranty for one year.

I haven't checked the coolant level yet but will inspect in a few hours when the car is 100% cold. Will be mixing BMW coolant 50/50 with distilled water. Visiting local dealer on Monday AM.

Based on everyone's input from this thread ...

- If the coolant level is low in the intercooler tank, I will work with dealer and BMW NA to replace the turbocharger. Based on my research, early production B58 engines experienced this problem.

Does anyone have a copy of the repair order stating "coolant leaking into the turbo bearing. turbo replaced?" Will be grateful.

- If the coolant is low in the main tank, will ask the dealer to pressurize the cooling system.

What was replaced if a leak was found? The tank? The cap?

My hope is that the head gasket is OK considering low mileage.
If Musashi had anything to go on, its the coolant disappearing. My dealer pressure tested my system and it held. I hope its just the cap.
Appreciate 0
      09-22-2019, 03:46 PM   #511
cfm56d7b
Brigadier General
United_States
1554
Rep
4,352
Posts

Drives: 2017 440i Gran Coupe & 2015 X5
Join Date: Nov 2012
Location: Orange County, CA

iTrader: (2)

Sharing an update with 4 pictures.

Main tank - clearly needs coolant. I will add it later today and measure how much was added. The white residue around the reservoir neck suggests that cap could be faulty.

Small tank - nearly full and that's encouraging. I was concerned that coolant was leaking through the turbocharger bearing. I will still ask the dealer to inspect it.

EDIT: Exactly one liter of 50/50 coolant and distilled water was added.
Attached Images
    

Last edited by cfm56d7b; 09-22-2019 at 06:42 PM..
Appreciate 0
      09-22-2019, 05:02 PM   #512
TheBingoBalls
Brigadier General
Canada
916
Rep
3,286
Posts

Drives: BMW
Join Date: Mar 2011
Location: Toronto, Ontario

iTrader: (1)

Garage List
I'm all for people's opinions but damn is there a bunch of BS in here...
Appreciate 1
WolfGTI164.00

      09-23-2019, 01:00 PM   #513
vinzcast21
First Lieutenant
vinzcast21's Avatar
119
Rep
368
Posts

Drives: F30 340i MY2017
Join Date: Jul 2018
Location: canada

iTrader: (0)

Quote:
Originally Posted by cfm56d7b View Post
Sharing an update with 4 pictures.

Main tank - clearly needs coolant. I will add it later today and measure how much was added. The white residue around the reservoir neck suggests that cap could be faulty.

Small tank - nearly full and that's encouraging. I was concerned that coolant was leaking through the turbocharger bearing. I will still ask the dealer to inspect it.

EDIT: Exactly one liter of 50/50 coolant and distilled water was added.
i wouldnt add that and bring to dealer for them to "see" and replace turbos if required


on another note, my car was built on August 2015 and never had coolant warning whatsoever
__________________
=================================
Mod bug will bite you if you buy a BMW
=================================
Appreciate 0
      09-24-2019, 10:02 PM   #514
cfm56d7b
Brigadier General
United_States
1554
Rep
4,352
Posts

Drives: 2017 440i Gran Coupe & 2015 X5
Join Date: Nov 2012
Location: Orange County, CA

iTrader: (2)

Update from the dealer. Main tank reservoir cap was replaced. The dealer determined no coolant has been lost through the turbo charger bearing. Will continue to closely monitor coolant loss in the future.
Appreciate 1
kern4172002.50

      10-02-2019, 06:57 PM   #515
neonnblack
Second Lieutenant
124
Rep
288
Posts

Drives: 335i 6MT/e46 330xi
Join Date: Nov 2018
Location: Reno, NV

iTrader: (0)

Quote:
Originally Posted by Jahjaman View Post
That's 100% pre-ignition detonation. Or pinging.

Low quality fuel.

Test it with higher quality fuel, or if you can't get better fuel - use octane booster.

Are you running stock tune?
Quick update. No dealer as it's not under warranty anymore.

The sound persists, though it's not pinging as logs show almost no timing correction.
Still at a loss as to what it is. I've completely went through the underside of the car when i fixed the bowden cable clip. Nothing loose, no witnesses marks of something touching something else, etc.

And a quick update update.
Though not a b58 problem the clip that holds the bowden cables up broke and caused a 'death rattle' iin the car. 8 dollar part, 2 or so hours of work (exhaust, heat shielding removed and the gas tank needed to be lowered to fix it) and it's better.

Also im starting to smell burn oil on occasion. I haven't even tried to locate from where yet, but I'm guessing, unsurprisingly, it'll be the VCG.
Appreciate 0
      10-14-2019, 08:17 AM   #516
Astute
PsyD
United_States
37
Rep
65
Posts

Drives: 2016 340i M-sport
Join Date: Feb 2019
Location: Atlanta, GA

iTrader: (2)

Garage List
I've had some low coolant problems, as others have mentioned. My local SA told me to just bring it by periodically to top it off in the service lane.

Weird thing happened this morning though. I hadn't driven the car in a day or 2 and when I started the car this morning, the cold start didn't seem to function as it typically does. I also got a "Drivetrain malfunction: cont. driving possible" telling me to take it to a servicer. I let it run for a minute or so without any issues. So I turned it off and left it for a few minutes to reset. I came back, turned it on and the cold start functioned normally and no longer had the drivetrain malfunction. I ended up taking it to work this morning due to traffic being lighter and took it easy - no issues on the drive.

Any thoughts?
Appreciate 0
      10-14-2019, 09:03 AM   #517
cfm56d7b
Brigadier General
United_States
1554
Rep
4,352
Posts

Drives: 2017 440i Gran Coupe & 2015 X5
Join Date: Nov 2012
Location: Orange County, CA

iTrader: (2)

Do you have a code scanner to examine stored fault code?
Appreciate 0
      10-14-2019, 09:09 AM   #518
Astute
PsyD
United_States
37
Rep
65
Posts

Drives: 2016 340i M-sport
Join Date: Feb 2019
Location: Atlanta, GA

iTrader: (2)

Garage List
Quote:
Originally Posted by cfm56d7b View Post
Do you have a code scanner to examine stored fault code?
Nope, sure don't, but on the plus side, I'm still under warranty for the next few months. I'll prob swing it by my SA tomorrow. I just wanted to see if anyone here had a similar experience or any insight.
Appreciate 0
      10-22-2019, 04:50 PM   #519
340iNL
New Member
0
Rep
10
Posts

Drives: F31 BMW 340i, G12 BMW M760Li
Join Date: May 2019
Location: The Netherlands

iTrader: (0)

I got a strange problem. My car (340i xdrive with MPPSK) is rough on idle while the engine is warm. I'm sure it didn't to this the first zero to 10.000 km (now i'm at 34.000 km). The MPPSK was fitted at 20.000 km.

I also started to run bootmod3 stage 1 at 24.000 km.

A few weeks ago I did a Datalog to check if I could find anything off with help from the forums to read the logs. In the beginning, I didn't read my logs. I discovered a few weeks ago on a recent datalog that KNOCK was detected. It turns out even with the first run (at 24.000 km first install) with bootmod3 stage 1 I had KNOCK DETECTED, but I never checked it at that time. So I guess I already experienced knocks without Bootmod3.

I went to my dealership for new tires and asked them if the rough idle (which is happening even without the bootmod3 stage 1, just with stock mppsk map) was a problem, they said it's normal.

I emailed PROTUNINGFREAKS, they suggested me to change my spark plugs and gap them correctly. My dealership told me I shouldn't change my plugs before 50.000 km.
I didn't tell them about Bootmod3 map because I needed a new amplifier that died randomly and got it replaced with warranty with no problems (luckily they didn't discover the DME unlock).

Therefore I'm not sure I understand the logs correctly (i get ''10'' as value with knock detected in CSV export). Maybe someone here can have a look on my logs?

I'm quite worried that the detected knocks will harm my engine in the long run. But besides the rough idle it pulls and drives like before.

Edit: I use ron 98 (shell v power) fuel only
Appreciate 0
      11-13-2019, 08:34 PM   #520
NormanConquest
Colonel
1453
Rep
2,198
Posts

Drives: 340i
Join Date: May 2017
Location: Earth

iTrader: (0)

Minor issue at 65+k

66000
View post on imgur.com
Appreciate 1
kern4172002.50

      11-15-2019, 05:13 AM   #521
vinzcast21
First Lieutenant
vinzcast21's Avatar
119
Rep
368
Posts

Drives: F30 340i MY2017
Join Date: Jul 2018
Location: canada

iTrader: (0)

Quote:
Originally Posted by NormanConquest View Post
Minor issue at 65+k

66000
View post on imgur.com
we had same issue but mine didnt throw CEL. seems like the evap system goes bad AFTER the recall
__________________
=================================
Mod bug will bite you if you buy a BMW
=================================
Appreciate 0
      11-15-2019, 11:24 AM   #522
kern417
Cheapskate
United_States
2003
Rep
3,116
Posts

Drives: 2018 440i / 2010 X5
Join Date: Aug 2016
Location: Cincinnati

iTrader: (0)

I can't tell what actually failed though. It almost reads like a check valve or something in the line broke, so they replaced the whole line?
__________________
Quote:
Originally Posted by umizoomi View Post
As long as 3-pedals are an option, I will exercise my right to suffer the handicap and indignity of slower shifts and reaction times.
Instagram @kern417
Appreciate 0
      11-15-2019, 09:03 PM   #523
G.Newt
First Lieutenant
164
Rep
374
Posts

Drives: 340i xDrive 6MT
Join Date: Feb 2017
Location: Denver, CO

iTrader: (0)

Quote:
Originally Posted by NormanConquest View Post
Minor issue at 65+k

66000
View post on imgur.com
See my thread on the issue: https://f30.bimmerpost.com/forums/sh....php?t=1627387

At first, they replaced the evap line, but the CEL came on as soon as I drove it out from the dealership. It wasn't until they actually replaced my fuel tank breather valve, did the 191C02 code go away.
Appreciate 1
      11-15-2019, 09:06 PM   #524
NormanConquest
Colonel
1453
Rep
2,198
Posts

Drives: 340i
Join Date: May 2017
Location: Earth

iTrader: (0)

Quote:
Originally Posted by G.Newt View Post
See my thread on the issue: https://f30.bimmerpost.com/forums/sh....php?t=1627387

At first, they replaced the evap line, but the CEL came on as soon as I drove it out from the dealership. It wasn't until they actually replaced my fuel tank breather valve, did the 191C02 code go away.
CEL is off at the moment if it pops up again I'll let them know.
Appreciate 0
Post Reply

Bookmarks

Tags
b58

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:21 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST