F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > F30 DIYs and Coding Discussions > DIY: Illuminated LCI AC/radio trim retrofit
Post Reply
 
Thread Tools Search this Thread
      08-13-2019, 01:16 PM   #881
Dante
Enthusiast
Dante's Avatar
Germany
398
Rep
1,784
Posts

Drives: F87 M2 / F31 330d
Join Date: Nov 2005
Location: Bavaria

iTrader: (0)

Garage List
Quote:
Originally Posted by yaksrfr1069 View Post
Ya know, maybe not... I got it from eBay based on an installation link on youtube:

https://www.ebay.com/itm/Illuminated...72.m2749.l2649

I did see a few people mention in other forums that the light was brighter than the rest of the ambients, but maybe it's a knockoff? And yes I did use the Y cable and added the cupholder LED (I made the footwell cable, the cupholder LED wasnt in mine).
Ok, thanks for clearing this up.
So yes, the part is a knock off. The original part has the same brightness as the other ambient lighting and thus doesn't need adjustment.
Appreciate 0
      08-13-2019, 02:16 PM   #882
yaksrfr1069
Registered
0
Rep
3
Posts

Drives: 2016 428i M Sport
Join Date: Aug 2019
Location: Florida

iTrader: (0)

Quote:
Originally Posted by Dante View Post
Ok, thanks for clearing this up.
So yes, the part is a knock off. The original part has the same brightness as the other ambient lighting and thus doesn't need adjustment.

Thanks Dante, I should probably research more before I start buying things...
Appreciate 0
      08-15-2019, 08:23 PM   #883
KL19
Registered
0
Rep
2
Posts

Drives: 2015 435i xdrive M sport
Join Date: Jul 2019
Location: Mississauga, ON

iTrader: (0)

would this mod work on 2015 435i GC?
Appreciate 0
      08-17-2019, 07:12 AM   #884
michaelsiu
Registered
0
Rep
3
Posts

Drives: bmw
Join Date: Sep 2018
Location: uk

iTrader: (0)

Quote:
Originally Posted by paimon.soror View Post
yep, im an idiot, you were right, looks like it WAS the wiring harness. Looks like they joined the middle two wires together !?!. Should have looked closer. They went from 4 pin to 3 pin, but instead of omitting pin2, they joined it with pin 3. smh

fixed the harness and all is well now. phew
Hi, I've got the exact same issue. Can you let me send through some images on what I need to do please? I'm not great when it comes to this sort of stuff so your fix above makes no sense to me haha
Appreciate 0
      08-17-2019, 07:16 AM   #885
michaelsiu
Registered
0
Rep
3
Posts

Drives: bmw
Join Date: Sep 2018
Location: uk

iTrader: (0)

Hi, did you find a fix for this? I fitted mine this morning with the exact same issue. Super annoying as I wanted the white lighting around the trim -however not matter which lighting mode I choose the trim only shows in orange.

When I unplug the Y cable everything is working correctly.

Quote:
Originally Posted by Destrovi View Post
Ive bought the LCI Radio Trim and Y-Cable and proceeded to install it. But I found that the Trim only shows the Classic Lighting, but not the Modern Lighting. I was hoping for both since I would like the option to go back and forth.

I dont have the lighting package "563" but have the LED above the cup holder and the door pillar lighting. Both of which can go both colors. (My car is a May '13 Build)

Has anyone had this issue? Maybe something went wrong during the install?
Maybe thats the only option I get?

https://www.ebay.ca/itm/BMW-Genuine-...72.m2749.l2649

https://www.ebay.ca/itm/LCI-LED-Ligh...72.m2749.l2649
Appreciate 0
      08-29-2019, 04:05 PM   #886
Destrovi
New Member
Canada
2
Rep
18
Posts

Drives: 2013 BMW 320xi
Join Date: Aug 2017
Location: N/A

iTrader: (0)

Garage List
2013 BMW 320xi  [0.00]
Quote:
Originally Posted by michaelsiu View Post
Hi, did you find a fix for this? I fitted mine this morning with the exact same issue. Super annoying as I wanted the white lighting around the trim -however not matter which lighting mode I choose the trim only shows in orange.

When I unplug the Y cable everything is working correctly.

Quote:
Originally Posted by Destrovi View Post
Ive bought the LCI Radio Trim and Y-Cable and proceeded to install it. But I found that the Trim only shows the Classic Lighting, but not the Modern Lighting. I was hoping for both since I would like the option to go back and forth.

I dont have the lighting package "563" but have the LED above the cup holder and the door pillar lighting. Both of which can go both colors. (My car is a May '13 Build)

Has anyone had this issue? Maybe something went wrong during the install?
Maybe thats the only option I get?

https://www.ebay.ca/itm/BMW-Genuine-Trim-cover-for-a-c-control-panel-with-ilumination-F30-LCI-F80-M3-OEM/222374774616?ssPageName=STRK%3AMEBIDX%3AIT&_trksid =p2057872.m2749.l2649

https://www.ebay.ca/itm/LCI-LED-Light-AC-Radio-Y-cable-Wire-Cupholder-Port-Fits-BMW-3-4-Series-F82-F83/283418464376?ssPageName=STRK%3AMEBIDX%3AIT&_trksid =p2057872.m2749.l2649
I found that one of the end had the outer wires in the wrong place so I swapped. I forget which end tho. There is a picture somewhere in this thread that shows the wire orientation. But double check that carefully.

All I did was open up one end. Swapped the outer wires and crimped it again and I got both colours working.
Appreciate 0
      09-03-2019, 08:51 PM   #887
JMatthewK
Private
2
Rep
55
Posts

Drives: F30 328i xDrive
Join Date: Apr 2017
Location: Buffalo, NY

iTrader: (0)

Would anyone know why my temperature display doesn't switch from white to orange at night after completing this mod?
Attached Images
 
Appreciate 0
      09-04-2019, 04:49 AM   #888
laxxen
Registered
0
Rep
2
Posts

Drives: BMW 320d
Join Date: Sep 2019
Location: Sweden

iTrader: (0)

Looks really good! Maybe i will do this to mine aswell.
Appreciate 0
      09-04-2019, 05:04 AM   #889
Dante
Enthusiast
Dante's Avatar
Germany
398
Rep
1,784
Posts

Drives: F87 M2 / F31 330d
Join Date: Nov 2005
Location: Bavaria

iTrader: (0)

Garage List
Quote:
Originally Posted by JMatthewK View Post
Would anyone know why my temperature display doesn't switch from white to orange at night after completing this mod?
Probably a misconnection of the wiring in your adapter. It should not do that.
Re-Check your wiring.
Appreciate 0
      09-04-2019, 08:05 AM   #890
JMatthewK
Private
2
Rep
55
Posts

Drives: F30 328i xDrive
Join Date: Apr 2017
Location: Buffalo, NY

iTrader: (0)

Possible that it's the unit itself? It's definitely a bit beaten up.
Appreciate 0
      09-04-2019, 08:15 AM   #891
Dante
Enthusiast
Dante's Avatar
Germany
398
Rep
1,784
Posts

Drives: F87 M2 / F31 330d
Join Date: Nov 2005
Location: Bavaria

iTrader: (0)

Garage List
Quote:
Originally Posted by JMatthewK View Post
Possible that it's the unit itself? It's definitely a bit beaten up.
As long as we don't know what exactly it is you have done or changed and which build and model year your car is, all is wild speculation.
Appreciate 0
      09-04-2019, 08:32 AM   #892
JMatthewK
Private
2
Rep
55
Posts

Drives: F30 328i xDrive
Join Date: Apr 2017
Location: Buffalo, NY

iTrader: (0)

Quote:
Originally Posted by Dante View Post
Quote:
Originally Posted by JMatthewK View Post
Possible that it's the unit itself? It's definitely a bit beaten up.
As long as we don't know what exactly it is you have done or changed and which build and model year your car is, all is wild speculation.
We've got a 2015 F30 build date 8/14.

I did a straight swap of the entire unit. Radio, temp gauges, etc in addition to the assembly with the goal of LCI ambient light. But I do want the white temp displays too. My previous panel was orange only.
Appreciate 0
      09-04-2019, 10:36 AM   #893
Dante
Enthusiast
Dante's Avatar
Germany
398
Rep
1,784
Posts

Drives: F87 M2 / F31 330d
Join Date: Nov 2005
Location: Bavaria

iTrader: (0)

Garage List
Quote:
Originally Posted by JMatthewK View Post
We've got a 2015 F30 build date 8/14.

I did a straight swap of the entire unit. Radio, temp gauges, etc in addition to the assembly with the goal of LCI ambient light. But I do want the white temp displays too. My previous panel was orange only.
Ok, so you also swapped the climate control display. This requires coding to work properly. Check this thread for information: https://f30.bimmerpost.com/forums/sh....php?t=1233171
Appreciate 0
      09-04-2019, 09:33 PM   #894
JMatthewK
Private
2
Rep
55
Posts

Drives: F30 328i xDrive
Join Date: Apr 2017
Location: Buffalo, NY

iTrader: (0)

Quote:
Originally Posted by Dante View Post
Quote:
Originally Posted by JMatthewK View Post
We've got a 2015 F30 build date 8/14.

I did a straight swap of the entire unit. Radio, temp gauges, etc in addition to the assembly with the goal of LCI ambient light. But I do want the white temp displays too. My previous panel was orange only.
Ok, so you also swapped the climate control display. This requires coding to work properly. Check this thread for information: https://f30.bimmerpost.com/forums/showthread.php?t=1233171
Worked perfectly. Thank you very much, sir.
Appreciate 0
      11-05-2019, 03:50 PM   #895
AlexMC93
Registered
0
Rep
2
Posts

Drives: BMW F30
Join Date: Nov 2019
Location: Bucharest

iTrader: (0)

Congrats for the mod and for the effort put into this whole thing. I was looking forward to it, but turns out I don't have the cup holder LED nor the footwell lights, but I was wondering: could it be possible to draw power from the wiring which sends juice to the instrument cluster? I've seen people fitting lights and wiring them to the dimmer dial, but wouldn't it be better and easier to tap in the power sent to the cluster LEDs?
This may sound dumb, but in my head it makes sense and seems feasible. What do you guys think?
Appreciate 0
      11-10-2019, 12:58 PM   #896
AntF32
Private First Class
United Kingdom
59
Rep
105
Posts

Drives: F36 435D xDrive - With stuff
Join Date: Aug 2018
Location: Hampshire (the original one)

iTrader: (0)

Quote:
Originally Posted by AlexMC93 View Post
Congrats for the mod and for the effort put into this whole thing. I was looking forward to it, but turns out I don't have the cup holder LED nor the footwell lights, but I was wondering: could it be possible to draw power from the wiring which sends juice to the instrument cluster? I've seen people fitting lights and wiring them to the dimmer dial, but wouldn't it be better and easier to tap in the power sent to the cluster LEDs?
This may sound dumb, but in my head it makes sense and seems feasible. What do you guys think?
https://f30.bimmerpost.com/forums/sh...&postcount=324
Appreciate 0
      11-10-2019, 02:55 PM   #897
AlexMC93
Registered
0
Rep
2
Posts

Drives: BMW F30
Join Date: Nov 2019
Location: Bucharest

iTrader: (0)

Quote:
Originally Posted by AntF32 View Post
As I said, I don't have the footwel LEDs. I'll try to get some power from the glovebox LED this week. Let's see if it works.
Appreciate 0
      11-11-2019, 07:55 AM   #898
sylver65
New Member
0
Rep
11
Posts

Drives: 320d xdrive
Join Date: Jul 2018
Location: Sanremo

iTrader: (0)

SORRY, i haven't the footwell light.
how can i go about taking the positive?
Appreciate 0
      11-11-2019, 08:03 AM   #899
sylver65
New Member
0
Rep
11
Posts

Drives: 320d xdrive
Join Date: Jul 2018
Location: Sanremo

iTrader: (0)

Quote:
Originally Posted by Chew View Post
FYI, for those of us who do not have the cupholder LED, and thus can't perform this mod, I've figured out where to get a signaled power source (Orange and White) for the cupholder LED as well as the LCI LED radio cover.

I'm waiting on some parts to arrive before I can validate which wires are needed, but I'll create a DIY once it's done to show you guys.

Anyone have a good source in the USA for the materials of the original MOD? I'm going to need that as well as some additional items for this to work. (and it may not end up being exactly plug and play like the original one, a tapped line or two may be required)

I'll let you know when I have more info.

Chew
hi, do you make an tutorial?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:32 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST