F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > F30 DIYs and Coding Discussions > Coding error. CAFD not found
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      09-22-2017, 06:57 AM   #45
shawnsheridan
General
shawnsheridan's Avatar
United_States
3781
Rep
20,449
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by jaskor View Post
Your response is like the speed of lightning.

Thank.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Appreciate 0
      10-31-2017, 06:13 AM   #46
Okan2630
Registered
0
Rep
1
Posts

Drives: BMW
Join Date: Sep 2017
Location: Copenhagen

iTrader: (0)

Hello I have the same issue with this fem_body cafd. Anyone that could help me ??
This is the cafe: Cafd_00000794_014_040_122
Appreciate 0
      10-31-2017, 10:01 AM   #47
shawnsheridan
General
shawnsheridan's Avatar
United_States
3781
Rep
20,449
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by Okan2630 View Post
Hello I have the same issue with this fem_body cafd. Anyone that could help me ??
This is the cafe: Cafd_00000794_014_040_122
Or, you could just help yourself:



http://f80.bimmerpost.com/forums/sho...&postcount=189
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Appreciate 0
      11-26-2017, 09:09 AM   #48
Barre
Registered
0
Rep
4
Posts

Drives: 320xdT-16
Join Date: Dec 2016
Location: Sweden

iTrader: (0)

Thanks

Thanks, this was very helpful!
Appreciate 0
      12-09-2017, 11:19 PM   #49
cj168
New Member
United_States
0
Rep
8
Posts

Drives: 2013 X3 M Sport
Join Date: Jul 2012
Location: Portland, OR

iTrader: (0)

Coding error. CAFD not found

Hello Shawn,

I had similar issue with several CAFD files not found after dealer’s recall on F25 program US version control units this week…

Looks like I may need to update PSdZData and E-System (3.18.4) as well?

Please advise/PM me once you got a chance.

Many Thanks,
Appreciate 0
      12-09-2017, 11:21 PM   #50
shawnsheridan
General
shawnsheridan's Avatar
United_States
3781
Rep
20,449
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by cj168 View Post
Hello Shawn,

I had similar issue with several CAFD files not found after dealer’s recall on F25 program US version control units this week…

Looks like I may need to update PSdZData and E-System (3.18.4) as well?

Please advise/PM me once you got a chance.

Many Thanks,
PM sent.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Appreciate 0
      12-09-2017, 11:34 PM   #51
cj168
New Member
United_States
0
Rep
8
Posts

Drives: 2013 X3 M Sport
Join Date: Jul 2012
Location: Portland, OR

iTrader: (0)

Thumbs up

Quote:
Originally Posted by shawnsheridan View Post
PM sent.
Awesome!
Thanks for the prompt response.
Appreciate 0
      01-23-2018, 12:54 PM   #52
pasam
New Member
0
Rep
11
Posts

Drives: e90
Join Date: Apr 2016
Location: De

iTrader: (0)

i have the same problem like in the #26. No cafd assignment possible for zgw and champ2 with emulator. Can someone please help me?
Appreciate 0
      01-23-2018, 12:57 PM   #53
shawnsheridan
General
shawnsheridan's Avatar
United_States
3781
Rep
20,449
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by pasam View Post
i have the same problem like in the #26. No cafd assignment possible for zgw and champ2 with emulator. Can someone please help me?
ZGW is not a codeable ECU. It has no CAFD by design.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Appreciate 0
      01-23-2018, 02:01 PM   #54
pasam
New Member
0
Rep
11
Posts

Drives: e90
Join Date: Apr 2016
Location: De

iTrader: (0)

Thank you shawnsheridan. Thank really much!!!!!

One additional question. My Champ2 is a retrofit navi and i try to use a most emulator.

After i plugin the emulator the navi loose the coding values. I check it with E sys and see there is no cafd file assigned to the champ2.

Now im not able to code the navi in Esys. I start CAF to SWE and than try o start a fa coding with following error msg.:

CAF File is: cafd_000000f9-007_001_105

Service WDBI_CPS returned a negative response with code requestOutofRange; ECU: HU_CHAMP_63_Ethernet

i try coding with changing the VIN of the Navi with same error. And with different connection via gateway and direct vin..

(Car is a f10 preLCI without Navi)

After reading the fehlerspeicher i find following errors:


- 0xB7F8A9: Codierereignis datenübertragung fehlgeschlagen

- 0xB7F881: codierungsereignis nicht codiert.
Appreciate 0
      01-23-2018, 03:50 PM   #55
shawnsheridan
General
shawnsheridan's Avatar
United_States
3781
Rep
20,449
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by pasam View Post
Thank you shawnsheridan. Thank really much!!!!!

One additional question. My Champ2 is a retrofit navi and i try to use a most emulator.

After i plugin the emulator the navi loose the coding values. I check it with E sys and see there is no cafd file assigned to the champ2.

Now im not able to code the navi in Esys. I start CAF to SWE and than try o start a fa coding with following error msg.:

CAF File is: cafd_000000f9-007_001_105

Service WDBI_CPS returned a negative response with code requestOutofRange; ECU: HU_CHAMP_63_Ethernet

i try coding with changing the VIN of the Navi with same error. And with different connection via gateway and direct vin..

(Car is a f10 preLCI without Navi)

After reading the fehlerspeicher i find following errors:


- 0xB7F8A9: Codierereignis datenübertragung fehlgeschlagen

- 0xB7F881: codierungsereignis nicht codiert.
Do you try injecting CAFD and VO Coding without Emulator hooked up?

And you need to make sure you have proper FA for CHAMP2.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Appreciate 0
      01-23-2018, 06:06 PM   #56
pasam
New Member
0
Rep
11
Posts

Drives: e90
Join Date: Apr 2016
Location: De

iTrader: (0)

big thanks for the super fast response, Shawn.

At the moment I can start a FA Coding without a emulator and everything works fine. The Navi start with the correct menu and i see the Navigation menu item. After installation of the Emulator, the Navi starts and make during the startup phase a reboot again and i see only the standard menu without all the items like navigation.

My car vin is: C704785
and the retrofit Navi has the vin: C659157

I read the Fa form the car and i add 606: My current FA contain following SALAPA Elements:

1CA 1CB 1CC 1CD 230 2K1 320 423 428 488 494 4AT 508 548 575 606 612 614 615 616 620 633 698 6AA 6AB 6FL 6VC 801 851 863 879 8KA 8KA 8TL 8TN 8V1

I dont know so much of injection and of this stuff.sorry that is new for me..
Appreciate 0
      01-23-2018, 06:18 PM   #57
shawnsheridan
General
shawnsheridan's Avatar
United_States
3781
Rep
20,449
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by pasam View Post
big thanks for the super fast response, Shawn.

At the moment I can start a FA Coding without a emulator and everything works fine. The Navi start with the correct menu and i see the Navigation menu item. After installation of the Emulator, the Navi starts and make during the startup phase a reboot again and i see only the standard menu without all the items like navigation.

My car vin is: C704785
and the retrofit Navi has the vin: C659157

I read the Fa form the car and i add 606: My current FA contain following SALAPA Elements:

1CA 1CB 1CC 1CD 230 2K1 320 423 428 488 494 4AT 508 548 575 606 612 614 615 616 620 633 698 6AA 6AB 6FL 6VC 801 851 863 879 8KA 8KA 8TL 8TN 8V1

I dont know so much of injection and of this stuff.sorry that is new for me..
If you can code CHAMP2 without Emulator, and then hook up Emulator and it is messed up the iDrive Menu, then it seems Emulator is messed up. All it should be doing is handling the VIN mismatch between CHAMP2 and its FSC Codes compared to Car's CAS Module.

I notice 6VC in FA. I trust car has Combox to go with it.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Appreciate 0
      01-23-2018, 06:19 PM   #58
pasam
New Member
0
Rep
11
Posts

Drives: e90
Join Date: Apr 2016
Location: De

iTrader: (0)

i see that i have add 620 voice control and 614 internet my mistake into the FA. Do you think this cause the problem?

Last edited by pasam; 01-23-2018 at 06:24 PM.. Reason: mistake
Appreciate 0
      01-23-2018, 06:26 PM   #59
pasam
New Member
0
Rep
11
Posts

Drives: e90
Join Date: Apr 2016
Location: De

iTrader: (0)

Hello shawn, it is possible to confirm that the emulator is messed up?
Appreciate 0
      01-23-2018, 06:27 PM   #60
shawnsheridan
General
shawnsheridan's Avatar
United_States
3781
Rep
20,449
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by pasam View Post
i see that i have add 620 voice control and 614 internet my mistake into the FA. Do you think this cause the problem?
No idea. CHAMP2 is technically capable of Voice Recognition so long as it FSC Enabling Code AppID 36 (24) Champ2 iSpeech High, but I do not know if in such a case, 620 is used in FA.

But, that is a coding issue. FA has nothing to do with Emulator issue.

Quote:
Originally Posted by pasam View Post
Hello shawn, it is possible to confirm that the emulator is messed up?
No idea. I never used one before.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Appreciate 0
      01-25-2018, 03:41 PM   #61
pasam
New Member
0
Rep
11
Posts

Drives: e90
Join Date: Apr 2016
Location: De

iTrader: (0)

Hello Shawn

do you think the problem come up because of the cafd assignment?
https://ibb.co/dfJsgw
https://ibb.co/jSLf1w

i try followingpoints without a success:

- Change the VIN in the FA xml file and try to code
--> Problem not possible to activate the fa. XML error comes up.

change the VIN of the retrofit champ2 and try to start coding
--> i receive the same error

Shawn do oyu know if the champ has a second coding EEPROM Data (default) which will be activate if the coded VIN is different to the received VIN?

Because i see that my idrive menü and my setting restored again, if i disconnect the emulator and restart the navi....

strange strange strange...

Last edited by pasam; 01-25-2018 at 03:43 PM.. Reason: image
Appreciate 0
      01-25-2018, 03:55 PM   #62
shawnsheridan
General
shawnsheridan's Avatar
United_States
3781
Rep
20,449
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by pasam View Post
Hello Shawn

do you think the problem come up because of the cafd assignment?
https://ibb.co/dfJsgw
https://ibb.co/jSLf1w

i try followingpoints without a success:

- Change the VIN in the FA xml file and try to code
--> Problem not possible to activate the fa. XML error comes up.

change the VIN of the retrofit champ2 and try to start coding
--> i receive the same error

Shawn do oyu know if the champ has a second coding EEPROM Data (default) which will be activate if the coded VIN is different to the received VIN?

Because i see that my idrive menü and my setting restored again, if i disconnect the emulator and restart the navi....

strange strange strange...
You say you have error trying to activate FA, but picture shows FA successfully activated.

What happens when you righti-click on CHAMP2 and select Code after the CAFD was injected?

I have no idea about EEPROM(s).
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Appreciate 0
      01-25-2018, 04:11 PM   #63
pasam
New Member
0
Rep
11
Posts

Drives: e90
Join Date: Apr 2016
Location: De

iTrader: (0)

Thank you Shawn,

i will try it tomorrow.

if i try to code it i receive following msg in E-Sys:

Caf's suchen
Tal wird generiert
Abarbeitung wird gestartet

TAL-Abarbeitung gestartet.
VCM Update: Automatische VCM-Aktualisierung ist deaktiviert. VCM wird nicht aktualisiert. [C197]
ExecutionID=2018/01/25-18:59:08.438
[] "prepareTALExecution" wurde gestartet.
[] "prepareTALExecution" wurde beendet.
[] "prepareVehicleForCoding" wurde gestartet.
[] "prepareVehicleForCoding" wurde beendet.
[HU_CHAMP - 63] "prepareECUforCoding" wurde gestartet.
[HU_CHAMP - 63] "prepareECUforCoding" wurde beendet.
[HU_CHAMP - 63] "authenticateECUforCoding" wurde gestartet.
[HU_CHAMP - 63] "authenticateECUforCoding" wurde beendet.
[HU_CHAMP - 63 - cafd_000000f9-007_001_105] Transaction type: cdDeploy; Message: Transaktion wurde gestartet.
[HU_CHAMP - 63 - cafd_000000f9-007_001_105] Transaction type: cdDeploy; Message: Transaktion wurde beendet.
[HU_CHAMP - 63] "finalizeECUCoding" wurde gestartet.
MCDDiagService<Id: 80649, Jobname: com.bmw.psdz.jobs.uds.MCD3_FinalizeECUCoding, Diagnoseservice: WDBI_CPS - WriteDataByIdentifier Codierpruefstempel, Beschreibung: error: negative response : requestOutOfRange, LogicalLink: HU_CHAMP_63_ETHERNET>
[HU_CHAMP - 63] Bei der Aktion "finalizeECUCoding" ist ein Fehler aufgetreten.
[HU_CHAMP - 63] Während der TAL-Abarbeitung ist ein Fehler aufgetreten, bitte überprüfen Sie die Log-Datei.
[HU_CHAMP - 63] - [Exception - HU_CHAMP - 63] Job-Ausführung ist fehlgeschlagen: negative response error:
code: service returned global negative response
description: Service WDBI_CPS returned a negative response with response code requestOutOfRange; ECU: HU_CHAMP_63_ETHERNET
severity: ERROR

[] "finalizeVehicleCoding" wurde gestartet.
[] "finalizeVehicleCoding" wurde beendet.
[] "finalizeTALExecution" wurde gestartet.
[] "finalizeTALExecution" wurde beendet.
TAL-Abarbeitung beendet.
TAL-Abarbeitung beendet mit Status: "FinishedWithError". [C207]
TAL-Abarbeitung beendet. Dauer: "15s". [C206]
Abarbeitung beendet
Appreciate 0
      01-25-2018, 04:12 PM   #64
pasam
New Member
0
Rep
11
Posts

Drives: e90
Join Date: Apr 2016
Location: De

iTrader: (0)

Thats my Fehlerspeicher:



F E H L E R S P E I C H E R L E S E N
---------------------------------------

Datum: 21.05.2017, 21:28:59
JobStatus: OKAY
Variante: CHAMP2.PRG
Version: 12.001
-------------------------------------------------------------

ERGEBNIS: 6 Fehler im Fehlerspeicher !
----------------------------------------------------

---------

0xB7F881 Codierungsereignis nicht codiert

Testbedingungen erfüllt
Fehler momentan vorhanden und bereits gespeichert
Fehler würde kein Aufleuchten einer Warnlampe verursachen
Dies ist kein Ereignis-DTC. Das SG ist für den Fehlerspeichereintrag (DTC) verantwortlich.

Fehlercode: B7 F8 81 0F
-------------------------------------------------------------

0xB7F882 Codierungsereignis falsches Fahrzeug

Testbedingungen erfüllt
Fehler momentan vorhanden und bereits gespeichert
Fehler würde kein Aufleuchten einer Warnlampe verursachen
Dies ist kein Ereignis-DTC. Das SG ist für den Fehlerspeichereintrag (DTC) verantwortlich.

Fehlercode: B7 F8 82 0F
-------------------------------------------------------------

0xE1C447 MOST: ein Steuergerät hat sich abgemeldet

Testbedingungen erfüllt
Fehler momentan nicht vorhanden, aber bereits gespeichert
Fehler würde kein Aufleuchten einer Warnlampe verursachen
Dies ist ein Ereignis-DTC. Das SG ist somit nicht für den Fehlerspeichereintrag verantwortlich.
(Z.B. falsche oder fehlende Netzwerkinformationen.)

Fehlercode: E1 C4 47 0C
-------------------------------------------------------------

0xE1C440 Reset

Testbedingungen erfüllt
Fehler momentan nicht vorhanden, aber bereits gespeichert
Fehler würde kein Aufleuchten einer Warnlampe verursachen
Dies ist kein Ereignis-DTC. Das SG ist für den Fehlerspeichereintrag (DTC) verantwortlich.

Fehlercode: E1 C4 40 0C
-------------------------------------------------------------

0xB7F80F Verbindung Head-Unit zum GPS-Antennenfuß: Leitungsunterbrechung

Testbedingungen erfüllt
Fehler momentan vorhanden und bereits gespeichert
Fehler würde kein Aufleuchten einer Warnlampe verursachen
Dies ist kein Ereignis-DTC. Das SG ist für den Fehlerspeichereintrag (DTC) verantwortlich.

Fehlercode: B7 F8 0F 0F
-------------------------------------------------------------

0xE1C449 MOST-Knoten: Die gleiche Kombination von FBlockID und InstID wird von zwei unterschiedlichen MOST SG doppelt beim NWM angemeldet

Testbedingungen erfüllt
Fehler momentan nicht vorhanden, aber bereits gespeichert
Fehler würde kein Aufleuchten einer Warnlampe verursachen
Dies ist ein Ereignis-DTC. Das SG ist somit nicht für den Fehlerspeichereintrag verantwortlich.
(Z.B. falsche oder fehlende Netzwerkinformationen.)

Fehlercode: E1 C4 49 0E
================================================== ===========
Appreciate 0
      01-25-2018, 04:15 PM   #65
shawnsheridan
General
shawnsheridan's Avatar
United_States
3781
Rep
20,449
Posts

Drives: 2016 650i GC M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by pasam View Post
Thank you Shawn,

i will try it tomorrow.

if i try to code it i receive following msg in E-Sys:

Caf's suchen
Tal wird generiert
Abarbeitung wird gestartet

TAL-Abarbeitung gestartet.
VCM Update: Automatische VCM-Aktualisierung ist deaktiviert. VCM wird nicht aktualisiert. [C197]
ExecutionID=2018/01/25-18:59:08.438
[] "prepareTALExecution" wurde gestartet.
[] "prepareTALExecution" wurde beendet.
[] "prepareVehicleForCoding" wurde gestartet.
[] "prepareVehicleForCoding" wurde beendet.
[HU_CHAMP - 63] "prepareECUforCoding" wurde gestartet.
[HU_CHAMP - 63] "prepareECUforCoding" wurde beendet.
[HU_CHAMP - 63] "authenticateECUforCoding" wurde gestartet.
[HU_CHAMP - 63] "authenticateECUforCoding" wurde beendet.
[HU_CHAMP - 63 - cafd_000000f9-007_001_105] Transaction type: cdDeploy; Message: Transaktion wurde gestartet.
[HU_CHAMP - 63 - cafd_000000f9-007_001_105] Transaction type: cdDeploy; Message: Transaktion wurde beendet.
[HU_CHAMP - 63] "finalizeECUCoding" wurde gestartet.
MCDDiagService<Id: 80649, Jobname: com.bmw.psdz.jobs.uds.MCD3_FinalizeECUCoding, Diagnoseservice: WDBI_CPS - WriteDataByIdentifier Codierpruefstempel, Beschreibung: error: negative response : requestOutOfRange, LogicalLink: HU_CHAMP_63_ETHERNET>
[HU_CHAMP - 63] Bei der Aktion "finalizeECUCoding" ist ein Fehler aufgetreten.
[HU_CHAMP - 63] Während der TAL-Abarbeitung ist ein Fehler aufgetreten, bitte überprüfen Sie die Log-Datei.
[HU_CHAMP - 63] - [Exception - HU_CHAMP - 63] Job-Ausführung ist fehlgeschlagen: negative response error:
code: service returned global negative response
description: Service WDBI_CPS returned a negative response with response code requestOutOfRange; ECU: HU_CHAMP_63_ETHERNET
severity: ERROR

[] "finalizeVehicleCoding" wurde gestartet.
[] "finalizeVehicleCoding" wurde beendet.
[] "finalizeTALExecution" wurde gestartet.
[] "finalizeTALExecution" wurde beendet.
TAL-Abarbeitung beendet.
TAL-Abarbeitung beendet mit Status: "FinishedWithError". [C207]
TAL-Abarbeitung beendet. Dauer: "15s". [C206]
Abarbeitung beendet
"WDBI_CPS - WriteDataByIdentifier" is VIN issue.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Appreciate 0
      01-25-2018, 04:45 PM   #66
pasam
New Member
0
Rep
11
Posts

Drives: e90
Join Date: Apr 2016
Location: De

iTrader: (0)

Do you have a plan for me? What can i test to?

Sorry for so much questions...
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:55 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST