F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > B58 Turbo Engine / Drivetrain / Exhaust Modifications > MAF sensor plug clip broke
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      09-25-2019, 08:36 PM   #1
maatt
Private
United Kingdom
8
Rep
60
Posts

Drives: '18 340i MPPSK
Join Date: Mar 2019
Location: London

iTrader: (0)

MAF sensor plug clip broke

Installed Agency Power Intake today, however when I was removing the harness from the MAF sensor the clip came out completely, when i tried to push it back in the clip snapped. I've tried searching google and ebay but haven't found anything apart from the whole wiring harness which is $300.

if anyone has any info on where I can source the clip?
Appreciate 0
      09-25-2019, 10:17 PM   #2
j1980mac
Captain
United_States
226
Rep
933
Posts

Drives: 2018 X3 M40i
Join Date: Apr 2018
Location: Austin TX

iTrader: (0)

Quote:
Originally Posted by maatt View Post
Installed Agency Power Intake today, however when I was removing the harness from the MAF sensor the clip came out completely, when i tried to push it back in the clip snapped. I've tried searching google and ebay but haven't found anything apart from the whole wiring harness which is $300.

if anyone has any info on where I can source the clip?
I've broken a few different clips on mine. So fragile they are. As long as they are tight, need not to worry.
Appreciate 0
      09-26-2019, 07:23 AM   #3
maatt
Private
United Kingdom
8
Rep
60
Posts

Drives: '18 340i MPPSK
Join Date: Mar 2019
Location: London

iTrader: (0)

Quote:
Originally Posted by j1980mac View Post
I've broken a few different clips on mine. So fragile they are. As long as they are tight, need not to worry.
Ahh I was really hoping to replace the clip!
Appreciate 0
      09-26-2019, 07:50 AM   #4
j1980mac
Captain
United_States
226
Rep
933
Posts

Drives: 2018 X3 M40i
Join Date: Apr 2018
Location: Austin TX

iTrader: (0)

Quote:
Originally Posted by maatt View Post
Quote:
Originally Posted by j1980mac View Post
I've broken a few different clips on mine. So fragile they are. As long as they are tight, need not to worry.
Ahh I was really hoping to replace the clip!
I feel ya. I'm OCD about things like this, but luckily I forgot. Not anymore! I'm going to have replace mine now.
Appreciate 0
      09-07-2020, 04:40 PM   #5
WhiteLotus
New Member
2
Rep
9
Posts

Drives: 2016 340i
Join Date: Sep 2020
Location: South East Florida

iTrader: (0)

Quote:
Originally Posted by j1980mac View Post
I feel ya. I'm OCD about things like this, but luckily I forgot. Not anymore! I'm going to have replace mine now.
Did you end up finding a replacement? Fortunately where I live there are plenty of totaled B58 BMW so I'll probably buy one from a for-parts bimmer.

I was changing the air filter and cleaning the airbox and the clip flew back fell in the engine bay where it vanished.
Appreciate 0
      09-08-2020, 08:47 AM   #6
Supr3me
Captain
Supr3me's Avatar
United_States
454
Rep
628
Posts

Drives: Your mom crazy
Join Date: Feb 2015
Location: Sioux Falls SD

iTrader: (0)

Garage List
I was able to go through the dealership to get a replacement harness clip and locking mechanism. Initially they said they didn't have one but I pushed them to keep looking. It was like $35 which was outrageous for what it is but it worked. It has the plastic bits and all these tiny plastic barrels you have to thread the wires through. It's pretty delicate surgery to do it correctly but it was worth it for me.
Note: for me it was my wastegate position sensor that was broken but I imagine they could get the MAF one as well.
__________________
2016 340i xDrive M-Sport MPPSK
Pure800; Dorch Stg2 hpfp; VRSF DP; AP intake
MHD; Wedge Performance E50 tune; xHP Stage 3
Forgestar wheels & KW coilovers
10.55 1/4; 2.82 0-60mph

Last edited by Supr3me; 09-08-2020 at 09:06 AM..
Appreciate 0
      09-08-2020, 11:13 AM   #7
WhiteLotus
New Member
2
Rep
9
Posts

Drives: 2016 340i
Join Date: Sep 2020
Location: South East Florida

iTrader: (0)

Quote:
Originally Posted by Supr3me View Post
I was able to go through the dealership to get a replacement harness clip and locking mechanism. Initially they said they didn't have one but I pushed them to keep looking. It was like $35 which was outrageous for what it is but it worked. It has the plastic bits and all these tiny plastic barrels you have to thread the wires through. It's pretty delicate surgery to do it correctly but it was worth it for me.
Note: for me it was my wastegate position sensor that was broken but I imagine they could get the MAF one as well.

Thanks. I just want the little gray locking clip though lol. The actual harness plug connector is fine and clicked in nicely. I don't think I need it. Was willing to spend a few dollars just because I like things done well (to a fault maybe)

Called the dealer and explained but the part number they gave of 12527615491 doesn't come up with much pictures and seems like it's what in one of the plugs.
Appreciate 0
      09-09-2020, 06:26 PM   #8
VipinLJ
Petrolhead
VipinLJ's Avatar
United_States
1091
Rep
2,253
Posts

Drives: 20 330i,16 X3,18 SQ5,17 A7
Join Date: Nov 2019
Location: Illinois

iTrader: (2)

Mine is broken too.

My question is. How easy/difficult is it to replace the plug? I've broken a bit of the black part that holds the grey clip in. It fits in tight and locks and works fine. But I'm OCD and want to replace the plug with no broken tab. I was wondering if it is a DIY or if a local workshop could do it for me.

Edit - Part that is broken is the part I've circled in red. It broke when I used a plier to try to lift up the locking tab beneath the grey clip. But it was dark and I couldn't see it and tried lifting the wrong part. That's how it broke. I'm looking at replacing the entire plug but not sure if its possible.
Attached Images
 
__________________
Current:
2020 BMW 330i xDrive
2018 Audi SQ5 Prestige
2017 Audi A7 Prestige

Last edited by VipinLJ; 09-09-2020 at 06:31 PM..
Appreciate 0
      09-09-2020, 09:43 PM   #9
Supr3me
Captain
Supr3me's Avatar
United_States
454
Rep
628
Posts

Drives: Your mom crazy
Join Date: Feb 2015
Location: Sioux Falls SD

iTrader: (0)

Garage List
I replaced the plug/locking clip assembly. See my post in this thread from a couple of days ago
__________________
2016 340i xDrive M-Sport MPPSK
Pure800; Dorch Stg2 hpfp; VRSF DP; AP intake
MHD; Wedge Performance E50 tune; xHP Stage 3
Forgestar wheels & KW coilovers
10.55 1/4; 2.82 0-60mph
Appreciate 0
      09-11-2020, 11:47 AM   #10
VipinLJ
Petrolhead
VipinLJ's Avatar
United_States
1091
Rep
2,253
Posts

Drives: 20 330i,16 X3,18 SQ5,17 A7
Join Date: Nov 2019
Location: Illinois

iTrader: (2)

Quote:
Originally Posted by Supr3me View Post
I replaced the plug/locking clip assembly. See my post in this thread from a couple of days ago
Ahh. I thought only the grey clip part was broken. How much did they charge for labor? I'm scared to ask my dealer here since they'll want $50 for the plug and $500 for labor
__________________
Current:
2020 BMW 330i xDrive
2018 Audi SQ5 Prestige
2017 Audi A7 Prestige
Appreciate 0
      09-12-2020, 09:27 PM   #11
Supr3me
Captain
Supr3me's Avatar
United_States
454
Rep
628
Posts

Drives: Your mom crazy
Join Date: Feb 2015
Location: Sioux Falls SD

iTrader: (0)

Garage List
Quote:
Originally Posted by VipinLJ View Post
Ahh. I thought only the grey clip part was broken. How much did they charge for labor? I'm scared to ask my dealer here since they'll want $50 for the plug and $500 for labor
I think I paid like $35 for the replacement plug assembly and I did the surgery myself. I was able to disassemble the broken plug part way and then use the new housing without having to fully disassemble every wire, which would have been much more difficult.
__________________
2016 340i xDrive M-Sport MPPSK
Pure800; Dorch Stg2 hpfp; VRSF DP; AP intake
MHD; Wedge Performance E50 tune; xHP Stage 3
Forgestar wheels & KW coilovers
10.55 1/4; 2.82 0-60mph
Appreciate 1
VipinLJ1091.00

      09-12-2020, 11:55 PM   #12
VipinLJ
Petrolhead
VipinLJ's Avatar
United_States
1091
Rep
2,253
Posts

Drives: 20 330i,16 X3,18 SQ5,17 A7
Join Date: Nov 2019
Location: Illinois

iTrader: (2)

Quote:
Originally Posted by Supr3me View Post
I think I paid like $35 for the replacement plug assembly and I did the surgery myself. I was able to disassemble the broken plug part way and then use the new housing without having to fully disassemble every wire, which would have been much more difficult.
Ahhh. I thought of buying a plug from BMS for the 3.5bar sensor since it looks like the same plug and doing it myself. But I'm not sure I'm capable of pulling it off.
__________________
Current:
2020 BMW 330i xDrive
2018 Audi SQ5 Prestige
2017 Audi A7 Prestige
Appreciate 0
      09-20-2020, 08:00 PM   #13
WhiteLotus
New Member
2
Rep
9
Posts

Drives: 2016 340i
Join Date: Sep 2020
Location: South East Florida

iTrader: (0)

Quote:
Originally Posted by VipinLJ View Post
Ahh. I thought only the grey clip part was broken. How much did they charge for labor? I'm scared to ask my dealer here since they'll want $50 for the plug and $500 for labor
If you change it, can you mail me your old gray tab? Lol it seems yours is fine. I'll pay shipping lol.
Appreciate 0
      09-20-2020, 11:11 PM   #14
VipinLJ
Petrolhead
VipinLJ's Avatar
United_States
1091
Rep
2,253
Posts

Drives: 20 330i,16 X3,18 SQ5,17 A7
Join Date: Nov 2019
Location: Illinois

iTrader: (2)

Quote:
Originally Posted by WhiteLotus View Post
If you change it, can you mail me your old gray tab? Lol it seems yours is fine. I'll pay shipping lol.
If I do, I will. I'll check my plug out in a few days. Looks like it'll break off and I won't be able to use the grey tab. If so, I can post it to you.
__________________
Current:
2020 BMW 330i xDrive
2018 Audi SQ5 Prestige
2017 Audi A7 Prestige
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:04 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST