F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > 2012-2019 BMW 3 and 4-Series Forums > General F30 Sedan / F32 Coupe / F36 Gran Coupe Forum > N20 Bad HPFP?
Post Reply
 
Thread Tools Search this Thread
      01-13-2020, 04:20 PM   #1
TaylorL
Registered
United_States
0
Rep
4
Posts

Drives: 2013 328i xDrive
Join Date: Apr 2018
Location: Salt Lake City, UT

iTrader: (0)

N20 Bad HPFP?

Hello everyone,

It seems highly unusual for the high pressure fuel pump to go bad on these N20's, yet somehow I think I've done it.
The car is a 2013 328i w/ xDrive, 86k miles on it. Driven pretty lightly, lots of freeway miles and 85% in Eco Pro. I did put on a BM3 stage 1 tune in September.

I had some oil dripping onto my downpipe and smoking up the cabin. General recommendation was to replace the valve cover, as they get old and tend to crack. Upon putting everything back in place, the car is not running well and throwing a low-pressure code: 11A002 - high-pressure fuel, plausibility: pressure too low (& 11AC02 - cold start version).
It bogs down before climbing when pushing the pedal quickly. It also won't idle below 1k rpm with the engine code. Clearing works for a few seconds until they come back up.

I monitored with the BM3 diagnostics and saw the LPFP is holding constant at 84 psi. HPFP ranged between 115-150 psi, target was between 1100-2800 psi.

I've taken the pump off and inspected it. Nothing seems broken. Is there a way to test these? Feeling very stumped at this point. Thanks in advance.

Link to BM3 datalog: http://www.bootmod3.net/log?id=5e1bc...OfcDUup8xaQjhM
Appreciate 0
      01-13-2020, 05:02 PM   #2
JoeyF30
Private First Class
19
Rep
118
Posts

Drives: BMW 2013 328i xDrive N26
Join Date: Dec 2019
Location: Iselin , NJ

iTrader: (0)

This is why I personally will not tune my N26...
Appreciate 0
      01-13-2020, 08:13 PM   #3
andino
Captain
462
Rep
682
Posts

Drives: F31 328i xdrive
Join Date: Jan 2019
Location: norcal

iTrader: (2)

Link to your log doesn't work. Perhaps repaste the share link again or make sure you didn't delete the one you're trying to share.

If your HPFP is only hitting 115-150 PSI when target is 1100-2800, I'd say you've got a bad HPFP which is the likely culprit to your issues.
__________________
2016 328ix F31 - SOLD!
2006 997.1 C4S
Appreciate 0
      01-20-2020, 05:25 PM   #4
TaylorL
Registered
United_States
0
Rep
4
Posts

Drives: 2013 328i xDrive
Join Date: Apr 2018
Location: Salt Lake City, UT

iTrader: (0)

Apologies for the long delay in getting back to you. I did end up having to replace the fuel pump. It seemed sturdy until I pulled on the plunger, at which point it came right off. Replaced it (and soldered the updated connector on) and we're all good to go now.
Appreciate 0
Post Reply

Bookmarks

Tags
11a0002, 11ac02, f30, high pressure fuel pump, hpfp, n20

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:12 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST