F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Cosmetic and Lighting Modifications (exterior & interior) > BMW F30/F31 Xenon retrofit
Post Reply
 
Thread Tools Search this Thread
      06-14-2018, 04:21 PM   #353
Jhnblckwood
Captain
105
Rep
716
Posts

Drives: F30 2014 320i xdrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by Sam.f30 View Post
I have followed this and there is no high beam or low beam, i only have indicators and parking light, please can you advise where I have gone wrong, thanks
Did u add 522 to ur Fa n vo code?
Appreciate 0
      06-21-2018, 08:27 AM   #354
Sam.f30
Registered
0
Rep
4
Posts

Drives: Bmw f30 2012 318d
Join Date: May 2018
Location: London

iTrader: (0)

Quote:
Originally Posted by Jhnblckwood View Post
Did u add 522 to ur Fa n vo code?
Hi
I didnt do this, please can you advise how I can go about doing this, thank you
Appreciate 0
      06-21-2018, 03:42 PM   #355
Jhnblckwood
Captain
105
Rep
716
Posts

Drives: F30 2014 320i xdrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

There is plenty of info here.
Appreciate 0
      07-05-2018, 08:32 AM   #356
Sam.f30
Registered
0
Rep
4
Posts

Drives: Bmw f30 2012 318d
Join Date: May 2018
Location: London

iTrader: (0)

Quote:
Originally Posted by CazuaLLUK View Post
I got lucky, my FEM from my halogen car accepted Xenons and my high beam shutter works!
Hi I coded 522 but my shutter still doesnt seem to work, can you advise on other coding you used perhaps, thank you
Appreciate 0
      08-30-2018, 05:22 AM   #357
Yaasir007
New Member
0
Rep
6
Posts

Drives: BMW F30
Join Date: Aug 2018
Location: Mauritius

iTrader: (0)

Hi All

I am new to the forum and i did this retrofit. I am based in Mauritius and we are RHD same as UK.

I did everything, checked all the pins, code 522 etc but do not have either the low beam or high beam. While driving i am getting the error of Dipped beam right failure and dipped beam failure left.

The DRL and parking lights are working fine, i checked all the fuze and everything. still no light...

I went to the dealer to have same diagnose today to know if all the modules are working properly but they refuse to do it since it did not originally came with XENON lights...

will be grateful if someone can assist....

Last edited by Yaasir007; 08-30-2018 at 05:35 AM..
Appreciate 0
      09-05-2018, 01:38 AM   #358
Yaasir007
New Member
0
Rep
6
Posts

Drives: BMW F30
Join Date: Aug 2018
Location: Mauritius

iTrader: (0)

Hi all

I am still having the issue with my low and high beam.

I am getting the attached error in Ista D.

Will be very grateful if someone can assist me in solving this...
Attached Images
 
Appreciate 0
      09-17-2018, 06:02 PM   #359
Flro2131
New Member
0
Rep
21
Posts

Drives: 2017 bmw f30 320i
Join Date: Sep 2018
Location: United States

iTrader: (0)

2017 bmw headlight vs 2015

I current own a 2017 bmw 320i with stock halogen light and I want to replace it with retrofit Xenon headlight. The retrofit headlight are for 2015 models, but arenít all bmw headlight unit the same size? So, it should be able to fit fine.
Appreciate 0
      09-18-2018, 07:23 PM   #360
Jhnblckwood
Captain
105
Rep
716
Posts

Drives: F30 2014 320i xdrive
Join Date: Jun 2017
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by Flro2131 View Post
I current own a 2017 bmw 320i with stock halogen light and I want to replace it with retrofit Xenon headlight. The retrofit headlight are for 2015 models, but aren’t all bmw headlight unit the same size? So, it should be able to fit fine.
Not all bmw are the Same but as long as the 2015 is a f30 it will fit. Maybe other models too but definitely f30 15-17 will fit.
Appreciate 0
      10-19-2018, 10:24 AM   #361
diedie
New Member
France
0
Rep
5
Posts

Drives: 335xi F30 2013
Join Date: Oct 2018
Location: France

iTrader: (0)

Hi guys,
I didn't have to do this retrofit, but at least i'm sure you'll all understand my problem :

My Xenon lights are too low. The startup check is done correctly, i can see everything moving, but at the end, the lights are going all the way down.

My height ride sensors seems to be fine, i already did an initialization, but still the same problem..

I could'nt find any default value for the front and rear ride sensors.
Do you think these values are ok?


Appreciate 0
      04-20-2019, 04:47 PM   #362
tonyhhandler
...............
Egypt
3
Rep
16
Posts

Drives: f30 328i
Join Date: Dec 2018
Location: egypt

iTrader: (0)

Quote:
Originally Posted by yoodog View Post
You guys buy new fem from bmw dealer when changing it??? Because it seems that it is not possible to use second hand fem, unless you get t with DME
Hello Friends,

You can retrofit Xenon lights (522) on any FEM (Mid or High).
If the retrofit is done on a MID FEM the shutter will not work if the wiring is done upon the normal Xenon retrofit wiring, You have to let the shutter wiring work on the normal halogen high beam and then code it.

I mean
on the left headlight:
Let pin no.6 on the headlight ---- which is pin no.26 on A173*2B on the FEM the same on both ends (don't remove it).

on the right headlight:
Let pin no.6 on the headlight ---- which is pin no.34 on A173*3B on the FEM the same on both ends (don't remove it).

then code FEM:
MAPPING_FERNL_1_L_OUTPUT (change from 18-bix_l to 7-fl_l)
MAPPING_FERNL_1_R_OUTPUT (change from 18-bix_r to 7-fl_r)

This will change the output channel for the Xenon shutter inside the FEM from BiXenon (which is not supported by the MID FEM) to the output channel of the normal halogen high beam and enjoy your Xenon without replacing the FEM .
Appreciate 0
      07-19-2019, 04:52 PM   #363
badea_cristianmihai
Registered
0
Rep
3
Posts

Drives: BMW F30
Join Date: Jul 2019
Location: ROMANIA

iTrader: (0)

Flickering Issue

Quote:
Originally Posted by kapkanimd View Post
Thanks to shawnsheridan who has helped me out even on Christmas Eve... There is no more flickering!!!!!

The headlights work fine and I took it for the first test drive a few minutes ago! I am still getting a few malfunction errors, but I have still not run the wires for the autolevelers and hopefully that will make the difference. I will certainly report my findings, but for now I am at least happy to report the retrofit is near completion, just have to work out the fine details.

aloo6: I am almost certain now that your problem is likely related to a coding issue. Here is the coding that I have done so far that has eliminated the flickering!!

First add 522 to your VO, and then write the VO to the Car as explained here:

http://www.bimmerfest.com/forums/att...6&d=1338725691

Then VO Code FEM_BODY:

Connect => Read FA (VO) => Activate FA (VO) => Read SVT (VCM) => Right-Click on FEM_BODY (the ECU itself not the underlying CAFD) => Select CODE.

Then go back and FDL Code C_BLC_ENA = F030disable (it is under FEM_BODY, but I forgot what folder, I just used the search feature at the time and put in "C_BLC_ENA and it took me right to the folder)

I will report back any updates as they come and I will hopefully have the autolevelers all wired up by Thursday!

Here is some more retrofit porn from after my test drive (sorry hard to get a good pic from my phone):

Hello there,

Can you tell me how you solved the flickering issue ?

Thanks!
Appreciate 0
      07-19-2019, 05:23 PM   #364
badea_cristianmihai
Registered
0
Rep
3
Posts

Drives: BMW F30
Join Date: Jul 2019
Location: ROMANIA

iTrader: (0)

Hello there,

I have adapt the xenon headlight and do all the necessary coding but I have the flickering issue and also the parking light doesnt work.
Can somebody help me to solve this issue?
Appreciate 0
      07-27-2019, 03:41 AM   #365
vioilio
Enlisted Member
United_States
10
Rep
42
Posts

Drives: 2010 BMW X5M
Join Date: Apr 2017
Location: Delaware

iTrader: (1)

Hello. I have installed adaptive xenon on my USA Halogen F34 car. Everything works (angel eyes, high low turn signals) but i have errors:
8041BA AHL system faulty
8041F0 Right headlight driver module TMS coding error.
8041FF Headlight driver module TMS left coding erorr.

I have adaptive headlight malfunction on the dash. I have made the neccesery pin changes to the headlight connectors and the fem module, added/changed the wires. Did all the coding (add 522 524 to VO) and recoded FEM. Checked everything 10 times and still have this error and the adaptive function of the lights is not working.

Can someone help?

Last edited by vioilio; 07-27-2019 at 10:25 AM..
Appreciate 0
      08-12-2019, 10:37 PM   #366
bm4ok
Registered
0
Rep
1
Posts

Drives: 2013 BMW F34 GT
Join Date: Aug 2019
Location: Australia

iTrader: (0)

Hi, just joined and wonderful to see such a helpful community.

I am looking to upgrade my 2013 F34GT from stock Xenon to Adaptive Xenon or the newer Adaptive LED. I have found several references of people asking about this but not anyone who has explained if other parts are necessary and what needs to be done in wiring - if anything? Is it just a VO 524 code change?

Also, am I correct to believe the EU headlight units for RHD ane LHD are different?

If this has all been covered please guide me - my searches have not yielded anything.

Many thanks in advance!
Appreciate 0
      10-10-2019, 03:32 PM   #367
Cpatel
Private First Class
18
Rep
131
Posts

Drives: N26 328i
Join Date: Oct 2018
Location: USA

iTrader: (0)

Has anyone used LED bulbs in their projectors rather than HIDs?
What are your guys thoughts on using LEDS in these fixtures?
Appreciate 0
      04-30-2020, 07:37 AM   #368
Winstanley1993
Registered
United Kingdom
0
Rep
1
Posts

Drives: BMW 340i Touring
Join Date: Apr 2020
Location: West Yorkshire

iTrader: (0)

Quote:
Originally Posted by A.G View Post
Morning Guys, i have an 2015 F31 LCI the car come with standard LED rear lights but halogen Headlights with LED DRL, i want to upgrade to the LCI LED headlights i have the 2 headlights as complete but what else will i need if anyone can help
Hi,
Just reading through this forum and I have the same model and same issue.

Did you upgrade your headlights to xenon adaptive or to led?
Is it just plug and play with the LCI?

Thanks
Appreciate 0
      10-20-2020, 04:20 PM   #369
Andrew48
New Member
0
Rep
10
Posts

Drives: BMW 320i
Join Date: Jan 2020
Location: US

iTrader: (0)

Hi guys,
I have a little bit different situation.
My car has Halogen in stock. I installed Depo headlights + aftermarket Xenon kit for low beams.
Depo headlights not required coding if you use them with halogen bulbs. However, as I installed Xenon, it should be coded for correct work. Sometimes I have issues when one of my low beam turns off.

I have a BimmerCode for coding.
Can you help me and say what should I code in FEM module with bimmercode to replicate 522 option for low beams?
Appreciate 0
      11-04-2020, 01:20 PM   #370
MicHern7
Registered
United_States
2
Rep
4
Posts

Drives: BMW 328i
Join Date: Aug 2019
Location: San Antonio, TX

iTrader: (0)

Andrew--I have the same setup as you. Bi-xenons in Depo headlight. If you want to code out the bulb checks, it's in FEM under "Voltage monitoring." You can turn the low beam warm and cold monitoring to "Not active." As you haven't done this, the most that should be happening is a bulb-out warning. It shouldn't turn off one light.

I had a similar issue when I installed mine--driver's side came on like 65% of the time. Worked great once it was on--no flickering or cutting out or weird color. I took this to mean it wasn't the bulb. I swapped the ballasts, and the no-start switched once to the passenger's side, then came back to the driver's side and stayed there. Weird. I then put in a harness (and capacitor) thinking it might be an issue with the power, but it persisted. Then I replaced both ballasts (Pro Canbus) with Morimotos and it has been great since then. Hope this is of some help.
Appreciate 0
      11-13-2020, 07:35 PM   #371
XuLeTZ
Private
United Kingdom
14
Rep
60
Posts

Drives: BMW 320d F31 M Sport
Join Date: Jan 2017
Location: Oxford

iTrader: (0)

Hi,

Car in question is F31 2012 EU.
Halogen from factory with KAFAS2 for 8TH.
Adaptive xenons and HBA retrofited, VO code 522, 524, 5AC.
Headlights are working just fine, I don`t see TMS and LHM ecu's in ISTA or e-sys.
I guess if the wiring is wrong, something shouldn't work.
Headlights are moving left and right when driving and steering, only issue is that I don`t see the headlight modules in ISTA.

Thank you,
Alex
Appreciate 0
      11-27-2020, 10:00 AM   #372
seebz098
New Member
0
Rep
8
Posts

Drives: F20 Lci
Join Date: Nov 2020
Location: UK

iTrader: (0)

Hey im trying to do this in the UK - im only doing it on one side to check first and the light still isnt working.

I have spliced wire 2 to connect another wire which leads into pin 4 and 7.
i have removed pin 6 and placed wire 9 in its place.

what do I do with wire 6? do i just leave it out of the plug?

I have done the wiring for the Fem.

The only thing that works is my indicators.

I have coded it up using esys but i am still getting faults and the lights still dont work.

Any Idea?
Appreciate 0
      01-21-2021, 08:07 PM   #373
wings516
Private
6
Rep
70
Posts

Drives: '11 X3 35ix & Turbo M3
Join Date: Dec 2014
Location: Ohio

iTrader: (0)

Was there any conclusive evidence on if the FEM module needed updated to MAX?

I currently have all functions working but the TMS are not coding, and the beams are not straight.

Curious if anyone has had this issue. They will not initialize in ISTA+
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:45 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST