F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Cosmetic and Lighting Modifications (exterior & interior) > DEPO LCI Issues
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      11-22-2020, 02:22 PM   #1
FPJK
Private
FPJK's Avatar
18
Rep
79
Posts

Drives: F30 335 / E92 M3 / Ram Rebel
Join Date: May 2018
Location: DC / SC

iTrader: (0)

DEPO LCI Tail Light Issue

Anyone have any issues with installing these?

I finally ordered a set, was installing today with no issues but the passenger side inner light housing would not fit correctly. On my first install attempt the the bolt that connects the inner side snapped. I can no longer use the lamp. Checked the tab that locks into place, it all was set and lined up.

Reached back out to USR to see if I can have another housing sent out.

Has anyone else had issues with fitment? Drivers side was perfect but the passenger side is a whole other story.

Last edited by FPJK; 11-22-2020 at 08:40 PM..
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:45 AM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST