F30POST
F30POST
2012-2015 BMW 3-Series and 4-Series Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW 3-Series and 4-Series Forum (F30 / F32) | F30POST > Technical Forums > Cosmetic and Lighting Modifications (exterior & interior) > US F30 OEM Adaptive Xenon Retrofit DIY
Extreme Powerhouse
Post Reply
 
Thread Tools Search this Thread
      02-27-2014, 11:16 AM   #23
F30EDR
Private
2
Rep
88
Posts

Drives: Black Sapphire F30
Join Date: Jan 2014
Location: NA

iTrader: (0)

Can't wait to get started on my retrofit. Few more weeks :/
Appreciate 0
      02-27-2014, 12:39 PM   #24
S4NoMore
Captain
S4NoMore's Avatar
United_States
202
Rep
904
Posts

Drives: 11 335i 6MT, 91 318i, 15 X3d
Join Date: Aug 2008
Location: Philly suburbs

iTrader: (1)

Garage List
2015 BMW X3  [0.00]
1991 BMW 318i  [4.33]
2011 BMW 335i  [0.00]
Quote:
Originally Posted by kapkanimd View Post
Yes, everything but the autolevelers are working at the moment. They are adaptive, turn with steering wheel, and I have had them working for months now with no problems. No errors except for the autoleveler malfunction which you can turn off with the coding I put in the DIY. Hopefully I can find a fix soon though..
Without the autoleveling, is the beam pattern correct for the majority of driving situations - where the car isn't loaded?

I've downloaded E-Sys and I'm pursuing a cable and token next. I plan on keeping an eye out for the adaptive parts over time, not in any rush.
Appreciate 0
      02-27-2014, 12:59 PM   #25
menncars
Captain
169
Rep
884
Posts

Drives: F22-228i M Sport
Join Date: Nov 2008
Location: Toronto

iTrader: (0)

Isn't leveling for when the car goes up and down hills or dips in the road?
Appreciate 0
      02-27-2014, 02:32 PM   #26
S4NoMore
Captain
S4NoMore's Avatar
United_States
202
Rep
904
Posts

Drives: 11 335i 6MT, 91 318i, 15 X3d
Join Date: Aug 2008
Location: Philly suburbs

iTrader: (1)

Garage List
2015 BMW X3  [0.00]
1991 BMW 318i  [4.33]
2011 BMW 335i  [0.00]
Quote:
Originally Posted by menncars View Post
Isn't leveling for when the car goes up and down hills or dips in the road?
No, the leveling function is based on the difference in ride height between the front and the rear.

When you have a trunk full of cargo or 3 people in the back seat, or both, the rear of the vehicle sits lower due to the load. Towing is the other example but doesn't apply so often to the F30 as with SUVs etc.

In that situation with static headlights, the light would be projected upward and potentially blind oncoming traffic. The leveler system detects the difference by keeping tabs on suspension travel and adjusts the beam angle to compensate accordingly.

I don't know for sure but I believe the adjustment is not fast enough to account for dips in the road. If you are going up a very steep hill, perhaps there will be enough squat to cause adjustment, but again it just comes down to a difference in front/rear ride height.
Appreciate 0
      03-04-2014, 10:01 PM   #27
S4NoMore
Captain
S4NoMore's Avatar
United_States
202
Rep
904
Posts

Drives: 11 335i 6MT, 91 318i, 15 X3d
Join Date: Aug 2008
Location: Philly suburbs

iTrader: (1)

Garage List
2015 BMW X3  [0.00]
1991 BMW 318i  [4.33]
2011 BMW 335i  [0.00]
kap, I think I saw you mention $700 as being fair value on a set of just the housings? Not many on the market, and I see alot of broken tabs unfortunately. Not sure if I'm willing to delve into plastic repair.. has anyone come across a "BMW tab repair kit" for the F30 yet?
Appreciate 0
      03-05-2014, 08:36 AM   #28
kapkanimd
First Lieutenant
United_States
51
Rep
376
Posts

Drives: 2016 340i
Join Date: Sep 2013
Location: Tampa, FL

iTrader: (2)

Quote:
Originally Posted by S4NoMore View Post
kap, I think I saw you mention $700 as being fair value on a set of just the housings? Not many on the market, and I see alot of broken tabs unfortunately. Not sure if I'm willing to delve into plastic repair.. has anyone come across a "BMW tab repair kit" for the F30 yet?

I got mine with all the tabs intact, but I accidently snapped one of the tabs that one of the modules screws into. Just set it back in place with some jbweld epoxy and it was good as new. It is all a preference, if you want to wait till perfect one comes a long then go for it. Also please check car-parts dot com and look for housings their at an affordable rate, just make sure you clarify what you are getting (with modules or not)
Appreciate 0
      04-15-2014, 11:44 AM   #29
F30EDR
Private
2
Rep
88
Posts

Drives: Black Sapphire F30
Join Date: Jan 2014
Location: NA

iTrader: (0)

@kapkanimd, here are a couple of images showing the bottom screws that need to be removed. These are taken from wheelwell, towards the bumper.




Also, setting LWR_AHL_TYP = ohne removed 'adaptive' feature. Projectors no longer move, even on startup. Other than that, everything is working properly. Thanks to your guide, I just did a very minor modification to suit my needs.
Appreciate 0
      04-15-2014, 12:16 PM   #30
S4NoMore
Captain
S4NoMore's Avatar
United_States
202
Rep
904
Posts

Drives: 11 335i 6MT, 91 318i, 15 X3d
Join Date: Aug 2008
Location: Philly suburbs

iTrader: (1)

Garage List
2015 BMW X3  [0.00]
1991 BMW 318i  [4.33]
2011 BMW 335i  [0.00]
Quote:
Originally Posted by F30EDR View Post
Also, setting LWR_AHL_TYP = ohne removed 'adaptive' feature. Projectors no longer move, even on startup. Other than that, everything is working properly.
Does this mean that in order to run error-free without autoleveling, the adaptive functionality must be sacrificed?
Appreciate 0
      04-15-2014, 01:37 PM   #31
F30EDR
Private
2
Rep
88
Posts

Drives: Black Sapphire F30
Join Date: Jan 2014
Location: NA

iTrader: (0)

Not necessarily, but still a matter of changing the correct parameter. LWR_AHL_TYP has 3 options, it could be one of them or a different one altogether.
Appreciate 0
      04-15-2014, 04:43 PM   #32
kapkanimd
First Lieutenant
United_States
51
Rep
376
Posts

Drives: 2016 340i
Join Date: Sep 2013
Location: Tampa, FL

iTrader: (2)

Quote:
Originally Posted by F30EDR View Post
Not necessarily, but still a matter of changing the correct parameter. LWR_AHL_TYP has 3 options, it could be one of them or a different one altogether.
Awesome, glad to see you completed the retrofit. Everything working? Any issues come up during the install or was it pretty much as I laid it out? Thanks for the pictures. Post a before/after pic with your new lights!

Regarding the coding for the error, I only tried the coding in the DIY to clear the code to take the car in for service and never used it at night. I normally just drive every day with the error as it is just the tiny triangle on the cluster and doesn't bother me at all. Did you find a certain code that will clear the error without affecting the adaptive lighting?

I am still in the process of figuring out the issue with the auto leveling sensors. I have received the software to help diagnose it and am setting it up. Also, I went through my install and cleaned everything up so if I have to end up taking it to the dealer to help diagnose they will likely not be able to tell, but I will save that as a last resort.
Appreciate 0
      04-15-2014, 05:30 PM   #33
S4NoMore
Captain
S4NoMore's Avatar
United_States
202
Rep
904
Posts

Drives: 11 335i 6MT, 91 318i, 15 X3d
Join Date: Aug 2008
Location: Philly suburbs

iTrader: (1)

Garage List
2015 BMW X3  [0.00]
1991 BMW 318i  [4.33]
2011 BMW 335i  [0.00]
Quote:
Originally Posted by kapkanimd View Post
Regarding the coding for the error, I only tried the coding in the DIY to clear the code to take the car in for service and never used it at night. I normally just drive every day with the error as it is just the tiny triangle on the cluster and doesn't bother me at all.
Ahh I see. I will wait eagerly for a solution to this. The triangle, though tiny, would bother me... I'm weird like that.
Appreciate 0
      04-15-2014, 06:16 PM   #34
F30EDR
Private
2
Rep
88
Posts

Drives: Black Sapphire F30
Join Date: Jan 2014
Location: NA

iTrader: (0)

I did it almost exactly as you laid it out in the document. The only thing I did differently is I didn't remove pin #12, instead, I tapped into it like for pins #2. I figured if I am to put the light back, I only need to modify FEM wiring and leave the HL connector as is. Pins 8 and 12 are mutually exclusive between halogen and xenon.

There's one line in the document that confused me but the diagram helped cleared it out. I'll let you know which part later.

Other than the initial error BEFORE coding, I didn't get any after. Everything is working other than not being adaptive before coding LWR_AHL_TYP, I can see it auto adjust on startup. I can even hear the motor.

No before pic but lots after
Appreciate 0
      04-16-2014, 12:06 AM   #35
F30EDR
Private
2
Rep
88
Posts

Drives: Black Sapphire F30
Join Date: Jan 2014
Location: NA

iTrader: (0)

@kapkanimd, here's the line that confused me:
"17. Finally, insert the ground wiring you created in steps 2 & 3. The larger one clearly goes into slot #4 and the smaller into slot #5. "

It should say slot #7.

I have to say that I'm really loving it, even without AHL. Not only does it add to the looks, but the light throw is amazing. I was using Philips DiamondVision 5000k and I really like that bulb for it's pure white light. The Xenon, with a 5000k D1S bulb, adds so much in so many level. It puts a smile on my face every time I see my lights' reflection. That's shallow but whatever.

I bought 4300k D1S with my housing, but were not satisfied with the yellowish tint. 5000k is perfect for me.
Appreciate 0
      04-16-2014, 07:07 PM   #36
kapkanimd
First Lieutenant
United_States
51
Rep
376
Posts

Drives: 2016 340i
Join Date: Sep 2013
Location: Tampa, FL

iTrader: (2)

Quote:
Originally Posted by F30EDR View Post
@kapkanimd, here's the line that confused me:
"17. Finally, insert the ground wiring you created in steps 2 & 3. The larger one clearly goes into slot #4 and the smaller into slot #5. "

It should say slot #7.

I have to say that I'm really loving it, even without AHL. Not only does it add to the looks, but the light throw is amazing. I was using Philips DiamondVision 5000k and I really like that bulb for it's pure white light. The Xenon, with a 5000k D1S bulb, adds so much in so many level. It puts a smile on my face every time I see my lights' reflection. That's shallow but whatever.

I bought 4300k D1S with my housing, but were not satisfied with the yellowish tint. 5000k is perfect for me.
Thanks, I fixed it. I also fixed my wiring diagram which was incomplete (not sure how I missed that).

Glad you like your new lights. So you are driving with the AHL turned off? That's the best part (besides the angel eyes).
Appreciate 0
      04-16-2014, 10:41 PM   #37
F30EDR
Private
2
Rep
88
Posts

Drives: Black Sapphire F30
Join Date: Jan 2014
Location: NA

iTrader: (0)

Apparently so. I rarely drive late afternoon/night so I never noticed until a few days back. Had to drive late and I was looking forward to seeing it follow the road but it never did. I took a video to confirm and I didn't see it move a bit.

I'll try other settings and see what it does, or if I can live with the yellow triangle in the dash. When you tried the other one, I believe it was C_BLC_ENA, did the not prevented the error?
Appreciate 0
      04-16-2014, 11:05 PM   #38
kapkanimd
First Lieutenant
United_States
51
Rep
376
Posts

Drives: 2016 340i
Join Date: Sep 2013
Location: Tampa, FL

iTrader: (2)

Quote:
Originally Posted by F30EDR View Post
Apparently so. I rarely drive late afternoon/night so I never noticed until a few days back. Had to drive late and I was looking forward to seeing it follow the road but it never did. I took a video to confirm and I didn't see it move a bit.

I'll try other settings and see what it does, or if I can live with the yellow triangle in the dash. When you tried the other one, I believe it was C_BLC_ENA, did the not prevented the error?
You will immediately know if the lights are adaptive. If you move the steering wheel more than 1mm the lights will react. They also automatically adjust when you hit 25mph (wide to narrow), when you turn the fog lights on (move a little wider), when you put it in reverse (fog lights automatically come on), when you put your blinker on (the fog light on the side you the blinker is on will turn on, as it will also do when you turn the wheel to that direction with or without the blinker), and when you hit 75mph (widen a little). Also if you didn't read this before, in order for the lights to be adaptive, the headlight switch must be on Auto and not just On. Similarly, if you at a stop, they will not swivel left as to not blind traffic across the light/stop.

As far as the other coding, the c_blc_ena was what I was originally advised to try, but I want to say it did not remove the error (I might have not done it correctly and I was in a hurry so I just did the other code). Feel free to give it a try as well. The main reason I haven't been concerned with clearing the error is because I am still trying to get the autoleveling function to work and the error is the main way I can tell to see if I am making progress.
Appreciate 0
      04-17-2014, 11:19 PM   #39
F30EDR
Private
2
Rep
88
Posts

Drives: Black Sapphire F30
Join Date: Jan 2014
Location: NA

iTrader: (0)

Fog lights are working ok as you described, it's just really the project part that isn't.

I did a little testing today and any other settings besides "ohne" for LWR_AHL_TYP will trigger an error. I haven't tried manual yet and that will be next. There are a few more to try if that doesn't work (C_BLC_ENA, C_AFS_ENA, and maybe even C_MLC_ENA)
Appreciate 0
      04-18-2014, 12:03 PM   #40
F30EDR
Private
2
Rep
88
Posts

Drives: Black Sapphire F30
Join Date: Jan 2014
Location: NA

iTrader: (0)

OK, good news. I finally found it. First, thanks to the uber kool excellent tool created by TokenMaster, the NcdCafdTool. This helped me understand and narrow down the parameters.

Here are the settings:

LWR_AHL_TYP = auto./dyn. LWR+AHL = 03
C_FLC_ENA = F030disable (LWR, Leveling sensor)
C_AFS_ENA = F030enable (Light Distribution)
C_BLC_ENA = F030enable (AHL)
C_CLC_ENA = F030enabl (Cornering light)

BLC and CLC are enabled by default, but double check just in case.

Result: No more warning. AHL works and moves with steering. light focus above 25mph, splits/tunnels/widens below. Left or right fog lights turn on when blinker is on or when wheel is steered. Fog lights turn on on reverse.

Damn, I'm a happy camper. Additional option I did: Corona lits up at 40% brightness when headlamps are on (default is 8%).
Appreciate 0
      04-18-2014, 12:13 PM   #41
kapkanimd
First Lieutenant
United_States
51
Rep
376
Posts

Drives: 2016 340i
Join Date: Sep 2013
Location: Tampa, FL

iTrader: (2)

Quote:
Originally Posted by F30EDR View Post
OK, good news. I finally found it. First, thanks to the uber kool excellent tool created by TokenMaster, the NcdCafdTool. This helped me understand and narrow down the parameters.

Here are the settings:

LWR_AHL_TYP = auto./dyn. LWR+AHL = 03
C_FLC_ENA = F030disable (LWR, Leveling sensor)
C_AFS_ENA = F030enable (Light Distribution)
C_BLC_ENA = F030enable (AHL)
C_CLC_ENA = F030enabl (Cornering light)

BLC and CLC are enabled by default, but double check just in case.

Result: No more warning. AHL works and moves with steering. light focus above 25mph, splits/tunnels/widens below. Left or right fog lights turn on when blinker is on or when wheel is steered. Fog lights turn on on reverse.

Damn, I'm a happy camper. Additional option I did: Corona lits up at 40% brightness when headlamps are on (default is 8%).
Awesome, thanks for the effort. I will add this to the DIY. Just a couple questions:

What do you mean by light distribution regarding the C_AFS_ENA? Was that not already enabled with the VO coding?

Also, just to confirm, you did not install the leveling sensors correct? I am now wondering if there is some coding that we are missing that can enable them to work. Could you PM me more information regarding the NcdCafdTool? I think I have it already, but not sure how to use it.

I am still not going to disable my error just because I still want to get the autoleveling to work properly, but this was certainly a step that will make this retrofit complete. Thanks again.
Appreciate 0
      04-18-2014, 12:46 PM   #42
F30EDR
Private
2
Rep
88
Posts

Drives: Black Sapphire F30
Join Date: Jan 2014
Location: NA

iTrader: (0)

C_AFS_ENA was set to F030disabled and I think it may not be needed at all. What happened is that I disabled C_FLC_ENA and set LWR_AHL_TYP to manual. There was no error but the projector didn't move either. So I enabled C_AFS_ENA and set LWR_AHL_TYP to auto/dyn and that did it for me. Maybe it's enough to turn off C_AFS_ENA and set LWR_AHL_TYP.

No, I didn't install leveling sensors but would want to in the near future. In your case, leaving it as-is is the way to go as it would help with your troubleshooting. And I really hope you'll figure this out as I do want to install leveling sensors as well.

There is a new version that has FA-CAFD. I used that narrow options and then search in the NCD/CAFD. What's nice is that it translates and searches comments and this was a big help. TokenMaster don't seem to be a member here though, but the tool is really great.
Appreciate 0
      04-22-2014, 08:49 PM   #43
kapkanimd
First Lieutenant
United_States
51
Rep
376
Posts

Drives: 2016 340i
Join Date: Sep 2013
Location: Tampa, FL

iTrader: (2)

Just as an update, autoleveling sensors are now working as part of the retrofit. The only thing missing was a calibration with a more technical software. Mine is still not functioning because one of my sensors is not working. I will replace it and everything should be working great and finally the retrofit will be complete!
Appreciate 0
      04-23-2014, 08:09 AM   #44
Tothepoint
Private First Class
10
Rep
139
Posts

Drives: F30
Join Date: Oct 2013
Location: DMV

iTrader: (0)

Great Development. Now I just need someone on the east coast to do my install.
Appreciate 0
Post Reply

Bookmarks

Tags
adaptive, diy, f30, install, xenon

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:44 PM.




f30post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST